インテル® HLS (High Level Synthesis) コンパイラーを使用するには、Linux OS の場合は GCC コンパイラー、Windows® OS の場合には Microsoft Visual Studio が必要です。

GCC と Visual Studio は指定されたバージョンを使用する必要があり、この記事では、インテル® HLS コンパイラーとの対応表を記載します。

対応バージョン一覧

インテル® HLS

コンパイラー

バージョン

エディション

インテル® HLS

コンパイラー

対応デバイス

GCC

(Linux の場合)

Microsoft® Visual Studio

(Windows® の場合)

ver.20.3 Pro Stratix® 10 / Arria® 10 / Cyclone® 10 GX 9.1.0 Microsoft Visual Studio 2017 Professional / Community

Standard / Lite (*1/*2)

ver.20.2 Pro Stratix® 10 / Arria® 10 / Cyclone® 10 GX 9.1.0 Microsoft Visual Studio 2017 Professional / Community
Standard / Lite (*1/*2)
ver.20.1 Pro Stratix® 10 / Arria® 10 / Cyclone® 10 GX 9.1.0 Microsoft Visual Studio 2017 Professional / Community
Standard / Lite (*2)
ver.19.4 Pro Stratix® 10 / Arria® 10 / Cyclone® 10 GX 5.4.0 Microsoft Visual Studio 2017 Professional / Community
Standard / Lite (*1)
ver.19.3 Pro Stratix 10 / Arria 10 / Cyclone 10 GX 5.4.0 Microsoft Visual Studio 2017 Professional / Community
Standard / Lite (*1)
ver.19.2 Pro Stratix 10 / Arria 10 / Cyclone 10 GX 5.4.0 Microsoft Visual Studio 2015 Professional / Community
Standard / Lite (*1)
ver.19.1 Pro Stratix 10 / Arria 10 / Cyclone 10 GX 5.4.0 Microsoft Visual Studio 2015 Professional
Standard / Lite Arria 10 / Cyclone V / Arria V / MAX 10 4.4.7 Microsoft Visual Studio 2010 Professional
ver.18.1 Pro Stratix 10 / Arria 10 / Cyclone 10 GX 5.4.0 Microsoft Visual Studio 2015 Professional
Standard / Lite Arria 10 / Cyclone V / Arria V / MAX 10 4.4.7 Microsoft Visual Studio 2010 Professional
ver.18.0 Pro Stratix 10 / Arria 10 / Cyclone 10 GX 4.4.7 Microsoft Visual Studio 2010 Professional
Standard / Lite Arria 10 / Cyclone V / Arria V / MAX 10 4.4.7 Microsoft Visual Studio 2010 Professional
ver.17.1 Pro Stratix 10 / Arria 10 / Cyclone 10 GX 4.4.7 Microsoft Visual Studio 2010 Professional
Standard / Lite Arria 10 / Cyclone V / Arria V / MAX 10 4.4.7 Microsoft Visual Studio 2010 Professional

*1) Standard / Lite Edition は Quartus® Prime および HLS コンパイラーは未リリースです。
*2) Quartus® Prime Standard / Lite Edition v20.1 以降、HLS コンパイラーは未サポートとなり、リリースはありません。

おすすめ記事/資料はこちら

インテル® FPGA の HLS コンパイラー
HLS 簡易チュートリアル

High Level Synthesis 関連の記事や資料

インテル® FPGA の開発フロー/FPGA トップページ

おすすめ FAQ はこちら

High Level Synthesis 関連の FAQ
インテル® FPGA 関連の FAQ