
www.latticesemi.com 2-1 JUG_D3.ProjectMan_v1.0

2015 年 3 月 Lattice Diamond 日本語ユーザガイ ド

© 2014 Lattice Semiconductor Corp. （註 ： 本 Lattice Diamond 日本語マニュアルは、 日本語によ る理解のため一助と し て提供し ています。 その作成にあたっては各 ト       
ピ ッ クについて、 それぞれ可能な限 り 正確を期し てお り ますが、 必ずし も網羅的ではな く 、 或いは最新でない可能性があ り ます。 また、 意図せずオ リ ジナル英語版
オン ラ イ ンヘルプや リ リ ース ノー ト など と不一致があ る場合も あ り 得ます。 疑義が生じ た場合は、 ラ テ ィ スセ ミ コ ンダ ク ター正規代理店の技術サポー ト 担当にお問
い合わせ頂 く か、 または極力最新の英語オ リ ジナル ・ ソース ド キ ュ メ ン ト を併せて参照する よ う にお願い致し ます。）

プロジ ェ ク ト 管理

第 2 章 　 プロジ ェ ク ト 管理

　 本章では Lattice Diamond のプロ ジェ ク ト ・ ナビゲータ （Project Navigator） 上でのデザイ ンプロ ジェ ク ト   
の管理方法について説明し ます。 Lattice Diamond またはプロジェ ク ト ・ ナビゲータ と記述されている場合は 
どち ら も Lattice Diamond Project Navigator を表すもの と し ます。

2.1 プロ ジェ ク ト の構造

　 本節では Lattice Diamond のプロ ジェ ク ト の構造について説明し ます。Lattice Diamond のプロ ジェ ク ト ・ ナ  
ビゲータでは、 「プロ ジェ ク ト 」 単位でデザイ ンを管理し ます。 プロジェ ク ト は主に 「イ ンプ リ メ ンテーシ ョ
ン （Implementation）」、 「ス ト ラ テジ （Strategy）」 と 「設計制約 （Constraint）」 から構成されます （図 2-1）。

　 *****--------------------
• Lattice Diamond で用いる 「設計制約」 には、 論理合成の際に使用する制約 「Synthesis Constraint」 と
論理合成後のプロセスで使用する制約 「LPF Constraint」 があ り ます。 この ド キ ュ メ ン ト では、 特に指
定の無い場合の 「Constraint」 は、 両方を指すもの と し ます。 Constraint 自体は HDL ア ト リ ビ ュー ト を
含む用語です

• 設計制約と し て全 く 同じ意味で 「Preference」 も用います。 制約フ ァ イル 「Preference File」 と し ては
「LPF （Logical Preference File）」 や 「PRF （Physical pReference File）」 があ り ます

• 「Synthesis Constraint」 については、 論理合成のマニュ アルで説明し ます
　 *****--------------------

図 2-1. プロ ジェ ク ト 構造
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　 論理合成や配置配線と いったプロセスはイ ンプ リ メ ンテーシ ョ ン単位で行われます。 この際に使用される
各プロセスのオプシ ョ ン設定が 「ス ト ラ テジ」、 タ イ ミ ング等の制約設定が 「Constraint」 です。 ス ト ラ テジ
と Constraint はプロジェ ク ト 単位で管理されます。 それぞれ複数作成する こ と ができ、 プロ ジェ ク ト 内のイ
ンプ リ メ ンテーシ ョ ンでこれら を共有し ます。 使用する ス ト ラ テジ と Constraint はイ ンプ リ メ ンテーシ ョ ン
ご と に各 １ つを選択し ます。

　 デザイ ン ソース ・ フ ァ イル （HDL や回路図等） は、 イ ンプ リ メ ンテーシ ョ ンご と に個別に管理されますが、
イ ンポー ト の際に他の イ ンプ リ メ ンテーシ ョ ン と 同じ ソース を参照する設定にすれば複数の イ ンプ リ メ ン
テーシ ョ ン間で共有する こ と も可能です （図 2-2）。 ソース フ ァ イルのイ ンポー ト 方法については、 2.6.2 項 
を参照し て く ださい。

　 *****--------------------
• ラ ンマネージ ャ （Run Manager） を使用する こ と によ り 、 同時に複数のイ ンプ リ メ ンテーシ ョ ンを処
理 ・ 実行する こ と ができ ます。 ラ ンマネージャについては第 5 章を参照し て く ださい

　 *****--------------------

図 2-2. 複数イ ンプ リ メ ンテーシ ョ ンでの各要素の共有例

2.2 プロ ジェ ク ト の管理

2.2.1 新規プロ ジェ ク ト 作成

　 Lattice Diamond ではプロ ジェ ク ト 単位でデザイ ンの管理を行います。 本項では、 プロ ジェ ク ト の作成方法 
について説明し ます。

　 Lattice Diamond のプ ロ ジ ェ ク ト の作成には、 新たに Lattice Diamond プ ロ ジ ェ ク ト を作成する方法 と、  
ispLEVER のプロジェ ク ト を イ ンポー ト し て自動的に Lattice Diamond のプロ ジェ ク ト に変換する方法があ り  
ます。 新たにプロ ジ ェ ク ト を作成する際は、 メ ニ ューバーから [File]=>[New]=>[Project] の順に選択するか、
[Start Page] タブ上で [Project :New] を選択し ます。 これで Project Wizard が起動し ます （図 2-3） ので、 その    
指示に従ってデバイ ス等を選択すればプロ ジェ ク ト が生成されます。

　 起動し た Project Wizard には、 プロジェ ク ト の生成に必要なフ ォルダやデバイ ス を指定する旨の メ ッ セー 
ジが表示されていますので、 そのま ま [Next>] ボタ ンを ク リ ッ ク し ます。次に表示される ウ イ ン ド ウでは、 プ
ロジェ ク ト 名と プロジェ ク ト のフ ォルダパス を設定し ます （図 2-4）。

　 [Project:Name] 欄にプロ ジェ ク ト 名を入力し ます。プロ ジェ ク ト 名と し て使用でき る文字は、 アルフ ァベッ
ト 、 数字と _ （アンダース コ ア） です （先頭の 1 文字目はアルフ ァベッ ト のみ） 使用でき ない文字はキーを
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打って も入力されません。

図 2-3. プロ ジェ ク ト の新規作成 ～ Project Wizard の起動

　 [Project:Location] 欄ではプ ロ ジ ェ ク ト で使用す る フ ォ ル ダ を 指定 し ま す。 直接パ ス を 入力す る か、
[Browse…] ボタ ンを ク リ ッ ク し て立ち上がる ウ イ ン ド ウ上で適当なフ ォルダを選択し ます。 フ ォルダパス を
直接入力し た場合、 指定し たフ ォルダが存在し なければ自動的に新しいフ ォルダが生成されます。

図 2-4. プロ ジェ ク ト の新規作成 ～ プロ ジェ ク ト 名 と フ ォルダパスの設定

　 [Implementation: Name] 欄にはイ ンプ リ メ ンテーシ ョ ン名を入力し ます。 デフ ォル ト では [Project:Name] 欄 
と同じ名前が自動的に入力されます。

　 *****--------------------
• [Implementation: Location] 欄は、 実装処理で使用される ソースやネ ッ ト リ ス ト 、 各種レポー ト が格納
される フ ォルダで、 「プロ ジェ ク ト フ ォルダ／イ ンプ リ メ ンテーシ ョ ン名」 にな り ます

　 *****--------------------

　 [Implementation: Name] 欄は Project 欄を入力すれば自動的に設定されますが、 変更する こ と も でき ます。 
[Implementation: Name] 欄を変更する と [Implementation: Location] 欄のパスが自動的に変更されます。



JUG_D3.3ProjectMan_v1.0 2-4

Lattice Diamond 日本語ユーザガイ ド

　 設定が完了後、[Next＞]ボタ ンを ク リ ッ クする と、次はソースのイ ンポー ト ウ イ ン ド ウが開き ます（図 2-5）。

図 2-5. プロ ジェ ク ト の新規作成 ～ ソース フ ァ イルのイ ンポー ト

　 その後、 [Add Source..] ボタ ンを ク リ ッ クする と起動する ウ イ ン ド ウ上で、 必要なフ ァ イル （既存の HDL 
ソース、 edif フ ァ イルや制約フ ァ イル） を選択し ます。 この際、 ウ イ ン ド ウ左下の [Copy source to …] チェ ッ   
ク ボ ッ ク スにチェ ッ クが入っている と、 選択し たフ ァ イルがプロ ジェ ク ト のフ ォルダへコ ピーされ、 それが
イ ンポー ト されます。 チェ ッ クが入っていない場合は選択し たフ ァ イルがイ ンポー ト されます。

　 ソースのイ ンポー ト はプロジェ ク ト 作成後でもでき るので、 こ こで全ての ソース を イ ンポー ト する必要は
あ り ません。 イ ンポー ト する ソースの選択完了後、 [Next ＞ ] ボタ ンを ク リ ッ クする と、 次は使用するデバイ
ス選択ウ イ ン ド ウが開き ます （図 2-6）。

図 2-6. プロ ジェ ク ト の新規作成 ～ デバイ ス選択

　 このウ イ ン ド ウ上で、 使用するデバイ スやス ピード グレード、 パッ ケージを選択し ます。 ラ イセン スのタ
イプによ って選択でき る フ ァ ミ リ に違いがあ り ます。 有償 （Subscription） ラ イセン スでは全てのフ ァ ミ リ が
選択でき ますが、 無償 （Free） ラ イ セン スでは、 SERDES を内蔵し ているデバイ スは表示されないため選択
でき ません。 デバイ スやパッ ケージはプロ ジェ ク ト 作成後でも変更でき ます。 確定し ていない条件について
は適当な ものを選択し ておき、 確定後に変更し て く ださい
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図 2-7. 論理合成ツールの選択

　 デバイ ス選択完了後、 [Next ＞ ] ボタ ンを ク リ ッ クする と、 論理合成ツールの選択ウ イ ン ド ウが開き ます。
MachXO シ リ ーズ と ECP5 のデフ ォル ト 論理合成ツールは LSE （Lattice Synthesis Engine） です。 Synplify Pro   
を選択する事も可能です。 また、 プロ ジェ ク ト 生成後でも、 メ ニューバーの Project => Synthesis Tool … と辿    
る こ と で、 変更する こ と が可能です。

図 2-8. 新規プロ ジェ ク ト の作成 ～ 設定確認

　 論理合成ツールの指定後 [Next ＞ ] ボタ ンを ク リ ッ クする と、 これまでの設定の確認ウ イ ン ド ウが開き ま
す。 [Finish] ボタ ンを ク リ ッ クすれば、 設定し た内容に従ってプロジェ ク ト が作成されます。 設定内容を変更
する場合は、[ ＜ Back] ボタ ンを ク リ ッ ク し て適当なウ イ ン ド ウ まで戻 り 設定の変更を行って く だ さい。作成
されたプロジェ ク ト 情報 （イ ンプ リ メ ンテーシ ョ ンやイ ンポー ト し たフ ァ イル等） は、 プロ ジェ ク ト フ ォル
ダに 「プロジェ ク ト 名 .ldf」 と い う フ ァ イル名で保存されます。
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2.2.2 ispLEVER プロ ジェ ク ト のイ ンポー ト

　 Lattice Diamond では、Lattice の旧デザイ ンツールであ る ispLEVER のプロ ジェ ク ト を イ ンポー ト し、Lattice 
Diamond 上で処理を行 う こ と もでき ます。 イ ンポー ト し た場合、 デザイ ンフ ァ イルや設定フ ァ イル、 各プロ
セスのオプシ ョ ン設定等が引き継がれます。

図 2-9. ispLEVER プロ ジェ ク ト のイ ンポー ト  ～ イ ンポー ト するプロ ジェ ク ト の選択

　 メ ニューバーから [File] => [Open] => [Import ispLEVER Project..] の順に選択するか、 [Start Page] の [Import       
ispLEVER Project] を ク リ ッ クする と （図 2-9）、 イ ンポー ト する ispLEVER のプロ ジェ ク ト フ ァ イル （*.syn）  
を選択する ウ イ ン ド ウが起動し ます。 このウ イ ン ド ウ上で、 イ ンポー ト する ispLEVER のプロ ジェ ク ト フ ァ
イルを選択する と、 Location やソースのイ ンポー ト 方法の確認ウ イ ン ド ウが開き ます。

図 2-10. ispLEVER プロ ジェ ク ト のイ ンポー ト  ～ ロ ケーシ ョ ン設定

　 ウ イ ン ド ウの下側が Lattice Diamond のプロ ジェ ク ト フ ァ イル名 （＝プロ ジェ ク ト 名） と ロ ケーシ ョ ンの設 
定です。 デフ ォル ト ではプロジェ ク ト フ ァ イル名と ロ ケーシ ョ ンは ispLEVER のプロ ジェ ク ト と同じ ものが
設定されています。 このま ま [OK] ボタ ンを ク リ ッ クする と、 元のプロ ジェ ク ト と同じ フ ォルダ内に Lattice
Diamond のプロ ジェ ク ト が作成されます。プロ ジェ ク ト 名と ロ ケーシ ョ ンは必要に応じ て変更し て く ださい。
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　 *****--------------------
• イ ンプ リ メ ンテーシ ョ ン名は自動的に設定されます （変更でき ません）。 プロ ジェ ク ト 名を変更し な
かった場合は [impl1]、 プロ ジェ ク ト 名を変更し た場合は 「ispLEVER のプロ ジェ ク ト 名」 がイ ンプ リ メ
ンテーシ ョ ン名にな り ます

　 *****--------------------

　 ウ イ ン ド ウ左下の [Copy design source …] チェ ッ ク ボ ッ ク スは、 ソース フ ァ イルのイ ンポー ト 方法に関す   
る設定です。 チェ ッ クが入っていれば、 選択し たフ ァ イルがイ ンプ リ メ ンテーシ ョ ン毎に生成される フ ォル
ダ下にコ ピーされ、 それらがイ ンポー ト されます。 チェ ッ クが入っていない場合は選択し た元々のフ ァ イル
がイ ンポー ト （参照） されます。

ispLEVER プロジ ェ ク ト を イ ンポー ト する際の重要注意事項

　 ispLEVER プロ ジェ ク ト を Lattice Diamond にイ ンポー ト する際に、 ソース フ ァ イルを Lattice Diamond にコ  
ピーする設定を行って も、 コ ピーされるのはデザイ ン ソース と し て ispLEVER にイ ンポー ト されている フ ァ
イルのみです。 このため以下の場合に必要なフ ァ イルがコ ピーされずに処理中にエラーや Warning が発生す
る こ と があ り ます。 ソース フ ァ イルのタ イプご と の対処方法は以下の とお り です。

表 2-1. 使用フ ァ イルタ イプご と の問題と対処方法ま と め

ソースフ ァ イル 発生する問題 　 回避策

プロ ジェ ク ト に IPexpress
で生成し た lpc フ ァ イルを
イ ンポー ト し ている場合

ツールは論理合成時に lpc フ ァ イル と同
じ フ ォルダにあ るはずの HDL ソース を
使用し ますが、 イ ンポー ト の際に HDL
ソースはコ ピーされないためフ ァ イル
が見つからずエラーにな る事があ る

プロ ジェ ク ト フ ォルダ内にあ る HDL
ソース を イ ンプ リ メ ンテーシ ョ ンの
source フ ォルダにコ ピーするか、
Lattice Diamond の IPexpress で lpc
フ ァ イルから ソース を再生成する

プロ ジェ ク ト で
SERDES/PCS を使用し て
いる場合

SERDES/PCS の設定が記述されたテキ
ス ト フ ァ イル （.txt） がコ ピーされない
ため、 フ ァ イルが見つから ない旨の
メ ッ セージが出力される。 その後各プ
ロセスでデフ ォル ト 設定値で処理され
るため、 期待動作し ない

ispLEVER プロ ジェ ク ト のフ ォルダ内
にあ る テキス ト フ ァ イルを イ ンプ リ メ
ンテーシ ョ ンのフ ォルダにコ ピーする
か、 Lattice Diamond の IPexpress で lpc
フ ァ イルから ソース を再生成する

プロ ジェ ク ト で ngo フ ァ
イル形式のネ ッ ト リ ス ト
（IP コ ア） を使用し ている
場合

ngo フ ァ イル形式のネ ッ ト リ ス ト は、
Translate Design プロセスで論理合成結
果と マージ されるが、 イ ンポー ト の際
にこのフ ァ イルはコ ピーされないため
フ ァ イルが見つからずエラーにな る こ
と があ る

プロ ジェ ク ト で使用し ていた ngo フ ァ
イルを イ ンプ リ メ ンテーシ ョ ンのフ ォ
ルダにコ ピーするか、 Lattice Diamond
のス ト ラ テジで、 Translate Design の
[Macro Search Path] オプシ ョ ンに ngo
フ ァ イルのあ るパス を記入する

プロ ジェ ク ト の PAR また
は Map プロセスで NCD 
Guide File オプシ ョ ン と し
て ncd フ ァ イル形式の
ネ ッ ト リ ス ト を参照する
設定を行っている場合

参照されるネ ッ ト リ ス ト がイ ンポー ト
の際にはコ ピーされないため、 フ ァ イ
ルが見つからずエラーにな る こ と があ
る

プロ ジェ ク ト で使用し ていた ncd フ ァ
イルを イ ンプ リ メ ンテーシ ョ ンのフ ォ
ルダにコ ピーするか、 Lattice Diamond
のス ト ラ テジで PAR または Map プロ
セスの [NCD guide file] オプシ ョ ンに
オ リ ジナルの ncd フ ァ イル名をフルパ
スで指定する

プロ ジェ ク ト で、 回路図
内に IPexpress または
ispLEVER で HDL ソース
から生成し たシンボルを
使用し ている場合

スケマテ ィ ッ ク ・ シンボルがコ ピーさ
れないため、 Schematic Editor を開いた
際に該当するシンボルが見つから ない
旨の メ ッ セージが表示される

プロ ジェ ク ト で使用し ていたシンボ
ル ・ フ ァ イル （*.sym） を、 イ ンプ リ
メ ンテーシ ョ ンの source フ ォルダに
コ ピーする

プロ ジェ ク ト で、 プロ
ジェ ク ト にイ ンポー ト さ
れていないフ ァ イルを
verilog HDL ソース内でイ
ン クルード し ている場合

イ ン クルード されているだけのフ ァ イ
ルはコ ピーされないため、 論理合成の
際に該当する フ ァ イルが見つからずエ
ラーにな る こ と があ る

プロ ジェ ク ト で使用し ている Verilog 
HDL ソース内でイ ン クルード し てい
たフ ァ イルを、 イ ンプ リ メ ンテーシ ョ
ンの source フ ォルダにコ ピーする



JUG_D3.3ProjectMan_v1.0 2-8

Lattice Diamond 日本語ユーザガイ ド

2.2.3 既存プロ ジェ ク ト のオープン

　 既存の Lattice Diamond プロ ジェ ク ト を開 く には、 メ ニューバーから [File] => [open] => [Project…] の順に     
選択するか、 Start Page の Project:Open を ク リ ッ ク し ます。 また、 Start Page には、 [Recent Project] と し て最   
近使用し たプロジェ ク ト 名が幾つか表示されています。 開きたいプロ ジェ ク ト がこの中にあれば、 そのプロ
ジェ ク ト 名を ク リ ッ ク し ます。

図 2-11. 既存プロ ジェ ク ト のオープン

　 [Recent Project] と し て表示されるプロジェ ク ト 数は、 プロジェ ク ト ・ ナビゲータのオプシ ョ ン設定で変更 
する こ と ができ ます。

2.2.4 プロ ジェ ク ト の ク ローズ

　 プロジェ ク ト を ク ローズする場合は、 メ ニューバーから [File] => [Close Project] の順に選択し ます。 他の   
プロ ジ ェ ク ト をオープンするか、 Lattice Diamond をシ ャ ッ ト ダ ウ ンする と 自動的に ク ローズ されます。 メ  
ニューの close や close all からではプロ ジェ ク ト はク ローズ されません。

2.2.5 ク ローン ・ プロ ジェ ク ト の生成

　 プロジェ ク ト を複製する機能が 「ク ローン生成」 です （Diamond 3.1 以降）。 File メ ニューから [Save Project  
As...] を選択し て表示される ウ ィ ン ド ウで、 保存フ ォルダ と別名で名称を指定するだけです （図 2-12）。

2.2.6 プロ ジェ ク ト のアーカ イブ作成

　 プロジェ ク ト を保存する場合や何らかの都合でフ ォルダを移動させる場合等に、 プロ ジェ ク ト のアーカ イ
ブを作成する こ と ができ ます。 メ ニューバーから [File] => [Archive Project] を選択する と、 [Archive project]    
ウ イ ン ド ウが開 く のでこのウ イ ン ド ウ上で、 アーカ イブの保存先を選択し ます。

　 この際、 ウ イ ン ド ウ左下にあ る [Archive all files ….] にチェ ッ クが入っている場合は、 プロ ジェ ク ト と の関   
連に関わらずプロジェ ク ト フ ォルダ以下にあ る フ ォルダ と フ ァ イル全てが含まれる アーカ イブが作成されま
す。 チェ ッ クが入っていない場合は、 プロ ジェ ク ト に関連し ている フ ォルダ と フ ァ イルのみのアーカ イブが
作成されます。 

　 ラ テ ィ スのテ ク ニカルサポー ト にプロ ジェ ク ト を送付し て技術支援を受ける場合などに、 本アーカ イブ機
能を用いる と容易にや り と り ができ ます。
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図 2-12. ク ローン ・ プロ ジェ ク ト の生成

　 なお、 アーカ イブ後の .zip されたフ ァ イルを Windows 対応の解凍ツールを用いて解凍する と、 一部のフ ァ
イルが復元できな く な る場合も報告されています。アーカ イブフ ァ イルの復元は [File] => [Open] => [Archived    
Project...] の手順で行 う よ う にし ます。

図 2-13. アーカ イブ ・ プロ ジェ ク ト の復元

2.3 イ ンプ リ メ ンテーシ ョ ンの管理

　 「イ ンプ リ メ ンテーシ ョ ン」 と は、 プロ ジェ ク ト 内で設定 ・ 定義する、 ソース フ ァ イルやモジ ュール、 或い
はオプシ ョ ン設定や各設計制約の組み合わせの呼称です。 Diamond では、 単一プロ ジェ ク ト 内に複数のイ ン
プ リ メ ンテーシ ョ ンを定義する こ と ができ ます。 それぞれのイ ンプ リ メ ンテーシ ョ ンでは異なる ソース フ ァ
イルや制約フ ァ イル、 あ るいはオプシ ョ ンを用いて論理合成や配置配線を行 う こ と ができ ます。 従来複数プ
ロジェ ク ト を生成し て行っていた、実装に係わる ト ラ イ アル ・ アン ド ・ エラーを、Diamond では単一プロ ジェ
ク ト 内で行 う 事が可能です。 このため最適な実装の 「推敲」 が容易にな り ます。

　 本節ではイ ンプ リ メ ンテーシ ョ ンの追加方法や切 り 替え方法について説明し ます。 イ ンプ リ メ ンテーシ ョ
ン内でのス ト ラ テジや制約の指定 ・ 選択方法等については、 3.5.4 項または 3.6.3 項を参照し て く ださい。

2.3.1 新規イ ンプ リ メ ンテーシ ョ ンの作成

　 イ ンプ リ メ ンテーシ ョ ンはプロジェ ク ト を作成し た際に必ず １ つ作成されます。 2 つ以上のイ ンプ リ メ ン
テーシ ョ ンが必要な場合、 メ ニューバーから [File] => [New] => [Implementation] の順に選択するか、 [File list]     
ウ イ ン ド ウの一番上に表示されているプロ ジェ ク ト 名を右ク リ ッ ク し [Add] => [new Implementation] の順に選   
択し ます （図 2-14）。
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図 2-14. イ ンプ リ メ ンテーシ ョ ンの追加

　 これで New Implementation Wizard が立ちあが り ます （図 2-15） 。 [Name] 欄は追加する イ ンプ リ メ ンテー   
シ ョ ンの名前、 [Directory] 欄はイ ンプ リ メ ンテーシ ョ ンで使用する フ ァ イルを格納する フ ォルダ名を入力し
ます。 名前を先に入力する と フ ォルダ名も自動的に同じ ものが入力されますが、 変更する こ と もでき ます。

　 [Default Strategy] 欄はイ ンプ リ メ ンテーシ ョ ンで使用する ス ト ラ テジを選択し ます。 右側の▼ア イ コ ンを 
ク リ ッ クする と、 プロジェ ク ト に登録されている ス ト ラ テジの一覧が表示されるので、 適当な ものを選択し
て く ださい （イ ンプ リ メ ンテーシ ョ ン作成後に変更する こ と も可能です）。

図 2-15. New Implementation Wizard

　 イ ンプ リ メ ンテーシ ョ ン作成時にソース フ ァ イルのイ ンポー ト を行 う こ と もでき ます。 [Add Source] ボタ 
ンを ク リ ッ クする と プルダウ ン メ ニューで [Browser…] と [From Existing …] が表示されます。 ブラ ウザを使  
用し て既存のフ ァ イルを選択する場合は [Browser…] を選択し ます。 既存のイ ンプ リ メ ンテーシ ョ ンにイ ン
ポー ト されている ソース を選択する場合は、[From Existing..] を選択する と既存のイ ンプ リ メ ンテーシ ョ ン名 
が全て リ ス ト されますので、 その中から １ つを選択し ます （図 2-16。 この図では一つしかない）。

右クリック
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　 この際、 ウ イ ン ド ウ左下の [Copy source to …] にチェ ッ クが入っている と、 選択し た ソースは新規に作成   
し た イ ンプ リ メ ンテーシ ョ ンのフ ォルダにコ ピーされ、 そち らがイ ンポー ト されます。 チェ ッ ク が入ってい
ない と選択し たフ ァ イルがイ ンポー ト されます。

図 2-16. 既存イ ンプ リ メ ンテーシ ョ ンからのソースのイ ンポー ト

　 *****--------------------
• コ ピーし た場合、 ソース を変更し て も他のイ ンプ リ メ ンテーシ ョ ンの ソースには反映されません

• コ ピーし なかった場合、 複数のイ ンプ リ メ ンテーシ ョ ン間で同一の ソース を使用でき ます
　 *****--------------------

　 必要な ソース を選択後、 OK ボタ ンを ク リ ッ クする と新しいイ ンプ リ メ ンテーシ ョ ンが追加されます。

2.3.2 ア ク テ ィ ブな イ ンプ リ メ ンテーシ ョ ンの選択

　 プロジェ ク ト ・ナビゲータ上では、基本的に １ つのイ ンプ リ メ ンテーシ ョ ンで操作 （オプシ ョ ン設定やフ ァ
イルのイ ンポー ト 等） ができ ます。 このため複数のイ ンプ リ メ ンテーシ ョ ンを持つプロ ジェ ク ト では、 ア ク
テ ィ ブにし て操作する イ ンプ リ メ ンテーシ ョ ンの選択を行 う 必要があ り ます。

　 File Lists ウ イ ン ド ウで、 ア ク テ ィ ブに し たい イ ンプ リ メ ンテーシ ョ ン名を右ク リ ッ ク し、 メ ニ ューか ら 
[Set as Active Implementation] を選択する と イ ンプ リ メ ンテーシ ョ ンがア ク テ ィ ブにな り ます。

図 2-17. ア ク テ ィ ブにする イ ンプ リ メ ンテーシ ョ ンの選択

2.3.3 イ ンプ リ メ ンテーシ ョ ンの削除

　 不要な イ ンプ リ メ ンテーシ ョ ンをプロ ジェ ク ト から削除するには、 まずそのイ ンプ リ メ ンテーシ ョ ンを非
ア ク テ ィ ブ化 （他のイ ンプ リ メ ンテーシ ョ ンをア ク テ ィ ブ化） し ます。次に削除し たいイ ンプ リ メ ンテーシ ョ

右クリック
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ン名を右ク リ ッ ク し、 [Remove] を選択するか、 選択し た状態でキーボード の [Delete] キーを押すと イ ンプ リ  
メ ンテーシ ョ ンがプロジェ ク ト から削除されます。

　 *****--------------------
• ア ク テ ィ ブな イ ンプ リ メ ンテーシ ョ ンは削除でき ません

• 「削除」 は 「イ ンポー ト 情報の削除」 であ り 、 フ ァ イルやフ ォルダの削除ではあ り ません
　 *****--------------------

図 2-18. イ ンプ リ メ ンテーシ ョ ンの削除

2.3.4 イ ンプ リ メ ンテーシ ョ ンのプロパテ ィ

　 プロパテ ィ 設定は図 2-19 のよ う に行います。

図 2-19. イ ンプ リ メ ンテーシ ョ ンのプロパテ ィ 設定

　 イ ンプ リ メ ンテーシ ョ ンはプロパテ ィ と し て、 以下の設定を行 う こ と ができ ます。

• 最上位モジ ュール名

• HDL のパラ メ ータ

右クリック

右クリック
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• VHDL フ ァ イルのコ ンパイルラ イブラ リ 名

• Verilog HDL ソースでイ ン クルード されている フ ァ イルがあ る フ ォルダ指定

　 これらの設定を行 う 場合は、 メ ニ ューバーから [Project] => [Property Pages] の順に選択するか、File List ウ    
イ ン ド ウでイ ンプ リ メ ンテーシ ョ ン名を右ク リ ッ ク し て [Properties] を選択し ます（図 2-19）。これで、Project 
Properties ウ イ ン ド ウが立ち上が り ます。

図 2-20. Project Properties ウ イ ン ド ウ ～ イ ンプ リ メ ンテーシ ョ ン

　 Project Properties ウ イ ン ド ウでは、 左側にプロ ジェ ク ト に登録されている イ ンプ リ メ ンテーシ ョ ンやイ ン 
ポー ト されている ソースが表示されています。 こ こ で現在ア ク テ ィ ブな イ ンプ リ メ ンテーシ ョ ンを選択する
と、 ウ イ ン ド ウ右側に設定項目が表示されます。

　 非ア ク テ ィ ブな イ ンプ リ メ ンテーシ ョ ンを選択し た場合は、 何も表示されません。 イ ンプ リ メ ンテーシ ョ
ンのプロパテ ィ と し て設定でき るのは以下の 4 つの項目です。

　 Top Level Unit

イ ンポー ト し たデザイ ン ソースの最上位階層の entity/module 名を入力し ます。 論理合成ツール と し
て Synplify Pro が選択されていれば、ほ と んどの場合で最上位階層の entity/module 名はイ ンポー ト され 
た ソースから自動的に検出されます。 しかし VHDL/Verilog HDL 混在の場合には、最上位階層が自動検 
出されない場合があ るので、 その際にはこの欄に最上位階層の entity/module 名を入力し て く ださい。

論理合成ツール と し て LSE を選択し ている場合は、 設定が必要です。

　 HDL Parameter

HDL ソースにグ ローバルで作用するパラ メ ータ （VHDL の generic、 Verilog HDL の parameter やコ ン 
パイ ラ指示子） を指定する こ と ができ ます。 これ以外のパラ メ ータは HDL ソース内の値が適用されま
す。 設定は以下の様に記述し ます。 複数定義する場合はセ ミ コ ロ ンで分離し ます。

-- 記述ルール

　 　 　 パラ メ ータ = 設定値 [; パラ メ ータ = 設定値 ]

-- 記述例

　 　 　 g_bus_width=16; comm_id=8;

　 VHDL Library Name

イ ンプ リ メ ンテーシ ョ ンで、デフ ォル ト で使用する VHDL ソースのコ ンパイル先ラ イブラ リ 名の設定
です。 デフ ォル ト では VHDL ソースは work ラ イブラ リ にコ ンパイルされます。 VHDL ソース単位でコ
ンパイル先の ラ イブ ラ リ 名が異な る場合は、 デザイ ン ソースのプロパテ ィ で設定し て く だ さ い （2.6.6
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項参照）

　 Verilog Include Search Path

Verilog HDL ソース内でイ ン クルード し ている フ ァ イルを検索するパスの設定です。 イ ン クルード さ 
れる フ ァ イルが、 ソース内にフルパスでフ ァ イル名が記述されていた り 、プロ ジェ ク ト 内の適当なフ ォ
ルダに保存されていた り する場合は、 設定する必要はあ り ません。

2.3.5 イ ンプ リ メ ンテーシ ョ ンの複製 （ク ローン）

　 イ ンプ リ メ ンテーシ ョ ンの複製を生成する機能が 「ク ローン生成」 です。 意図する イ ンプ リ メ ンテーシ ョ
ンを選択後、 右ク リ ッ ク で [Clone Implementation...] を選びます （図 2-21） 。 その後表示される ウ ィ ン ド ウ  
（図 2-22） で名称を入力し ます。 ソース フ ァ イルを参照するか、 コ ピーするかの指定も行います。

図 2-21. イ ンプ リ メ ンテーシ ョ ンの複製

図 2-22. ク ローン ・ イ ンプ リ メ ンテーシ ョ ンの設定

2.4 ス ト ラ テジの管理

　 ス ト ラ テジ と は各プロセスに対し て与え る設計制約・オプシ ョ ン全てを集約し た ものの呼称です。Diamond
では、単一プロ ジェ ク ト 内に複数のス ト ラ テジを持つこ と ができ、それぞれのス ト ラ テジでは異なるオプシ ョ
ン設定を定義する こ と ができ ます。 本項ではス ト ラ テジの追加方法や切 り 替え方法について説明し ます。

右クリック
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2.4.1 デフ ォル ト で作成される ス ト ラ テジ

　 プロジェ ク ト を作成し た際に、 必ず以下の 5 つのス ト ラ テジが作成されます。

　 　 Area : 必要な リ ソース （SLICE） 数が最小になる よ う に設定されたス ト ラ テジ

　 　 I/O Assistant : I/O Assitant 機能 （IO の配置ルールチェ ッ ク） を実行するためのス ト ラ テジ

　 　 Quick : プロセスの処理時間を優先する よ う に設定されたス ト ラ テジ

　 　 Timing : タ イ ミ ング要求を優先する よ う 設定されたス ト ラ テジ （全てデフ ォル ト ）

　 　 Strategy1 : Timing と同じ

　 *****--------------------
• Strategy1 以外は設定を変更する こ と ができ ません

• I/O Assistant は IO のルールチェ ッ クだけのプロセスで、 配線処理は行われません
　 *****--------------------

2.4.2 新規ス ト ラ テジの作成

　 ス ト ラ テジを追加するには、 新たに作成する方法と、 既存のス ト ラ テジの clone （コ ピー） を作成する方法
があ り ます。 本項では、 新たに作成する方法について説明し ます。

　 ス ト ラ テジを作成する場合は、 メ ニ ューバーから [File] => [New] => [Strategy…] の順に選択するか、File list     
ウ イ ン ド ウのス ト ラ テジシンボルを右ク リ ッ ク し、 [Add] => [New Strategy…] の順に選択し ます （図 2-23）。    
これで、 New Strategy Wizard が立ち上が り ます （図 2-24）。

図 2-23. ス ト ラ テジの追加

　 New Strategy Wizard の Strategy ID: 欄にはス ト ラ テジ名を入力し ます。 Lattice Diamond 上にはこの名前で    
表示されます。 File name: 欄にはデフ ォル ト でス ト ラ テジ ID と同じ名前が設定されますが、 変更する こ と も  
でき ます。 Save to Location: 欄はフ ァ イルを保存する フ ォルダです。 デフ ォル ト ではプロ ジェ ク ト フ ォルダ  
が設定されていますが、 変更する こ と も可能です。

右クリック
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図 2-24. New Strategy Wizard

　 全ての設定完了後、 OK ボタ ンを ク リ ッ クする と、 新規ス ト ラ テジ （設定は全てデフ ォル ト ） が作成され
ます。 作成し たス ト ラ テジは 「strategy 名 .sty」 と い う フ ァ イル名で指定し たフ ォルダに保存されます。

2.4.3 ス ト ラ テジの複製

　 Lattice Diamond では既存のス ト ラ テジの複製を作成する機能が 「ク ローン （Clone） 生成」 です。 複製し た 
いス ト ラ テジを右ク リ ッ ク し、 メ ニューから [Clone Strategy...] を選択し ます （図 2-25）。 これで、 図 2-24 と    
同様の 『Clone *** Wizard』 （”***” は複製元のス ト ラ テジ名） が立ち上が り ますので、 新ス ト ラ テジ名を入  
力し ます。

図 2-25. Clone Strategy の作成

　 New Strategy Wizard の設定は、 新規にス ト ラ テジを追加する場合と同じですが、 作成される ス ト ラ テジの  
設定値は、 デフ ォル ト ではな く 複製元と同じになっています。 プロ ジェ ク ト 作成時にデフ ォル ト で生成され
る設定変更できないス ト ラ テジでも、 Clone は設定を変更でき ます。

2.4.4 使用する ス ト ラ テジの選択

　 イ ンプ リ メ ンテーシ ョ ンでは、 プロジェ ク ト に複数あ る ス ト ラ テジの内、 ア ク テ ィ ブ化されている １ つが
使用されます。 このため 「ス ト ラ テジのア ク テ ィ ブ化」 が 「使用する ス ト ラ テジの選択」 にな り ます。

右クリック



2-17 JUG_D3.3ProjectMan_v1.0

プロジ ェ ク ト 管理

　 ス ト ラ テジをア ク テ ィ ブ化するには、File List ウ イ ン ド ウでス ト ラ テジを右ク リ ッ ク し、 メ ニューから [Set 
as Active Strategy] を選択し ます。 これでそのス ト ラ テジがア ク テ ィ ブ化され、 以後その イ ンプ リ メ ンテー  
シ ョ ンで使用されます （図 2-26）。 ア ク テ ィ ブ化されたス ト ラ テジは太字で表示されます。

図 2-26. ス ト ラ テジのア ク テ ィ ブ化

2.4.5 ス ト ラ テジの削除

　 プロ ジェ ク ト で不要になったス ト ラ テジは削除する こ と もでき ます。 File List ウ イ ン ド ウで削除し たいス 
ト ラ テジを右ク リ ッ ク し [remove] を選択するか、 キーボード の [Delete] キーを押すと、 ス ト ラ テジがプロ
ジェ ク ト から削除されます （図 2-27）。

図 2-27. ス ト ラ テジの削除

　 なお、 非ア ク テ ィ ブな イ ンプ リ メ ンテーシ ョ ンでも ア ク テ ィ ブなス ト ラ テジは削除でき ません。 また、 プ
ロジェ ク ト 作成時に自動生成される ものは、 [Strategy1] を含めて、 全て削除でき ません。 「プロ ジェ ク ト から
削除」 する こ と は 「イ ンポー ト 情報の削除」 であ り 、 フ ァ イルの削除ではあ り ません。

右クリック

右クリック
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2.4.6 ス ト ラ テジの設定変更

　 File List ウ イ ン ド ウでス ト ラ テジ名をダブルク リ ッ クするか、 右ク リ ッ ク し て メ ニ ューから [Edit] を選択 
する と、 ス ト ラ テジの設定ウ イ ン ド ウが立ち上が り ます （図 2-28）。

図 2-28. ス ト ラ テジの設定ウ イ ン ド ウ （LSE の例、 一部）

　 このウ イ ン ド ウで各プロセスのオプシ ョ ン設定を変更する こ と ができ ます。 なお、 オプシ ョ ン設定の詳細
については、 各プロセスのマニュ アルを参照し て く ださい。

2.5 LPF 制約フ ァ イルの管理

　 LPF （Logical Preference File） 制約フ ァ イル （”LPF Constraint”） は設計制約を記述する フ ァ イルで、 拡張   
子が lpf です。 プ ロ ジ ェ ク ト と し て配置配線に係わる全ての制約を書き出し た制約フ ァ イル .prf （Physical
Preference File） と区別されます。 テキス ト フ ァ イルですので、 ユーザが任意に編集でき ます。

　 １ つのプロジェ ク ト は 1 つ以上の LPF 制約フ ァ イルを持ち、それぞれの制約フ ァ イルでは異なる制約の設
定を行 う こ と ができ ます。 本項では LPF 制約フ ァ イルの追加方法や切 り 替え方法について説明し ます。

2.5.1 新規 LPF 制約フ ァ イルの作成

　 プロジェ ク ト 作成時には、 自動的に LPF 制約フ ァ イルが １ つ生成されます。 内容は基本的な BLOCK 制約
が二つ記載し てあ るのみです。 名前は 「プロ ジェ ク ト 名 .lpf」 にな り ます。 これ以外に制約フ ァ イルを追加
する場合は、 メ ニューバーから [File] => [New] => [File…] の順に選択するか、 File List ウ イ ン ド ウでフ ォルダ     
シ ンボル （ス ト ラ テジ以外） を右 ク リ ッ ク し、 [Add]=> [New File...] の順に選択し ます。 こ れで、 New File   
Wizard が起動し ます。
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図 2-29. LPF 制約フ ァ イルの追加

　 LPF 制約フ ァ イルを追加する場合は、 Categories 欄で [Source Files]、 Source Files 欄で [Preference Files] を   
選択し、 Name 欄にフ ァ イル名を入力し ます。 Ext. 欄 （丸印） で拡張子を選択する こ と もでき ますが、 基本
的には [lpf] を選択し て く ださい。 設定完了後に New ボタ ンを ク リ ッ クする と、 新しい LPF 制約フ ァ イルが
作成されテキス ト エデ ィ タが立ち上が り 、 編集後に自動的にイ ンプ リ メ ンテーシ ョ ンに取 り こ まれます。

　 *****--------------------
• 新たに作成し た LPF 制約フ ァ イルは、 完全なブラ ン ク フ ァ イルです。 プロ ジェ ク ト 作成時に自動で生
成される LPF 制約フ ァ イルに記述されているデフ ォル ト の BLOCK 設定も記述されていません

• 「LPF 制約フ ァ イルのコ ピー」 機能はないので、 必要な部分は他の LPF 制約フ ァ イルを開き、 マニュ
アルで記述のコ ピーを行って く ださい

• LPF 制約フ ァ イルを追加する場合、 新規に作成する よ り 既存のものを別名で保存し、 それを イ ンポー
ト し た方が、 手間がかから ない場合があ り ます

　 *****--------------------

図 2-30. New File Wizard （LPF 制約フ ァ イルの追加）

右クリック
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2.5.2 既存 LPF 制約フ ァ イルのイ ンポー ト

　 既存の LPF 制約フ ァ イルを イ ンポー ト する場合は、 メ ニューバーから [File] => [Add] => [Existing File…] の     
順に選択するか、 File List ウ イ ン ド ウ上で＊ Files のフ ォルダシンボルを右ク リ ッ ク し、 [Add] => [Existing   
File…] の順に選択し ます （図 2-31）。

　 これで、 イ ンポー ト する フ ァ イルの選択ウ イ ン ド ウ （図 2-32） が立ち上がるので、 まず File of Type と し     
て [LPF Constraint Files （*.lpf） ] を選択し ます。 これで リ ス ト に LPF 制約フ ァ イルフ ァ イルが表示されるの  
で、 適当なフ ァ イルを選択し [Add] ボタ ンを ク リ ッ ク し ます。

図 2-31. 既存 LPF 制約フ ァ イルのイ ンポー ト

図 2-32. イ ンポー ト する LPF 制約フ ァ イルの選択

　 この際、 ウ イ ン ド ウ左下の [Copy file to ….] にチェ ッ クが入っている と、 イ ンプ リ メ ンテーシ ョ ンフ ォル   
ダにコ ピーが作成され、 そち らがイ ンポー ト されます。 チェ ッ クが入っていない場合は、 選択し たフ ァ イル
がイ ンポー ト されます。

2.5.3 使用する LPF 制約フ ァ イルの選択

　 イ ンプ リ メ ンテーシ ョ ンでは、 プロ ジェ ク ト に複数あ る LPF 制約フ ァ イルの内、 ア ク テ ィ ブ化されている
１ つが使用されます。 このため 「LPF 制約フ ァ イルのア ク テ ィ ブ化」 が 「使用する LPF 制約フ ァ イルの選択」

右クリック
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にな り ます。 ア ク テ ィ ブ化するには、 File List ウ イ ン ド ウでア ク テ ィ ブでない LPF 制約フ ァ イルを右ク リ ッ 
ク し、 [Set as Active Preference File] を選択し ます （図 2-33）。 以後そのイ ンプ リ メ ンテーシ ョ ンで使用され     
ます。 ア ク テ ィ ブ化された LPF 制約フ ァ イルは太字で表示されます。

図 2-33. LPF 制約フ ァ イルのア ク テ ィ ブ化

2.5.4 LPF 制約フ ァ イルの削除

　 不要になった LPF 制約フ ァ イルは、 プロ ジェ ク ト から削除する こ と もでき ます。

図 2-34. LPF 制約フ ァ イルの削除

　 File List ウ イ ン ド ウで削除し たい LPF 制約フ ァ イルを右ク リ ッ ク し [remove] を選択するか、 選択し た状態 
でキーボード の [Delete] キーを押し ます （図 2-34）。イ ンプ リ メ ンテーシ ョ ンでア ク テ ィ ブになっている LPF 
制約フ ァ イルは削除でき ません。

　 なお、非ア ク テ ィ ブな イ ンプ リ メ ンテーシ ョ ンでも ア ク テ ィ ブな LPF 制約フ ァ イルは削除でき ません。LPF
制約フ ァ イルが １ つしかイ ンポー ト されていない場合は削除でき ません。 「プロ ジェ ク ト から削除」 は 「イ ン
ポー ト 情報の削除」 であ り 、 フ ァ イル自体の削除ではあ り ません。

右クリック

右クリック
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2.6 デザイ ンフ ァ イルの管理

　 本項ではプロジェ ク ト 内でデザイ ンフ ァ イル （HDL ソースや回路図等） を作成し た り イ ンポー ト し た り す
る方法について説明し ます。 なお、 RAM、 PLL、 SERDES と いったマ ク ロの作成方法については、 別の ド キ ュ
メ ン ト で説明し ます。

2.6.1 新規デザイ ンフ ァ イルの作成

　 新規デザイ ンフ ァ イルを作成する場合、 メ ニューバーから [File] => [New] => [File…] の順に選択するか、 も    
し く は File List ウ イ ン ド ウでフ ォルダシンボル （ス ト ラ テジ以外） を右ク リ ッ ク し、 [Add]=> [New File...] の   
順に選択し ます。 これで、 New File Wizard が起動し ます。

図 2-35. 新規デザイ ンフ ァ イルの作成

　 デザイ ンフ ァ イルを追加する場合は、Categories 欄で [Source Files]、Source Files 欄で [VHDL Files]、[Verilog   
Files] または 「Schematic Files」 を選択し、 Name 欄にフ ァ イル名を入力し ます。 Ext. 欄 （丸印） で拡張子を選 
択する こ と もでき ます （選択し たフ ァ イルに応じ て適当な ものが幾つか表示されます）。

図 2-36. デザイ ンフ ァ イルの追加 （New File Wizard）

右クリック
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　 設定完了後に [New] ボタ ンを ク リ ッ クする と、 フ ァ イルが作成され適当なエデ ィ タ （テキス ト エデ ィ タか
回路図エデ ィ タ） が立ち上が り ます。 なお、 [Add to Implementation] ボ ッ ク スにチェ ッ ク が入ってい る と、  
フ ァ イルは作成し た時点でプロジェ ク ト にイ ンポー ト されます。

2.6.2 既存のデザイ ンフ ァ イルのイ ンポー ト

　 既に作成済みのデザ イ ン フ ァ イルをプ ロ ジ ェ ク ト に イ ンポー ト する場合は、 メ ニ ューバーか ら [File] => 
[Add] => [Existing File…] の順に選択するか、 も し く は File List ウ イ ン ド ウでフ ォルダシンボル （ス ト ラ テジ     
以外） を右ク リ ッ ク し、 [Add]=> [Existing File...] の順に選択し ます （図 2-37）。 これで、 フ ァ イルの選択ウ イ   
ン ド ウが起動し ます。

図 2-37. 既存のデザイ ンフ ァ イルのイ ンポー ト

図 2-38. イ ンポー ト するデザイ ンフ ァ イルの選択

　 イ ンポー ト する フ ァ イルの選択ウ イ ン ド ウ （図 2-38） が立ち上がるので、 まず Files of Type と し て [Input     
Files （*.vhd *.v …） ] を選択し ます。 これで リ ス ト にデザイ ンフ ァ イルが表示されるので、 適当なフ ァ イル  
を選択し [Add] ボタ ンを ク リ ッ ク し ます。

右クリック
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　 この際、ウ イ ン ド ウ左下の [Copy file to ….] にチェ ッ ク が入っている と、 イ ンプ リ メ ンテーシ ョ ンの source   
フ ォルダにコ ピーが作成され、そち らがイ ンポー ト されます。チェ ッ クが入っていない場合は、選択し たフ ァ
イルがイ ンポー ト されます。

2.6.3 対象プロセスの選択

　 イ ンポー ト し たデザイ ンフ ァ イルを使用するプロセス （シ ミ ュ レーシ ョ ン、 論理合成、 または両方） を選
択する こ と ができ ます。

　 *****--------------------
• イ ンポー ト し た際のデフ ォル ト 設定は、 シ ミ ュ レーシ ョ ンおよび論理合成の対象と し て設定されてい
ます

　 *****--------------------

　 デザイ ンフ ァ イルを右ク リ ッ ク し、 [Include For] を選択する と対象プロセスの リ ス ト が表示されます。 こ 
の中から １ つを選択し ます。

　 [Synthesis] または [Synthesis and Simulation] を選択し た ソースは、 論理合成の対象と な り ます。 [Simulation]  
または [Synthesis and Simulation] を選択し た ソースは、 Simulation Wizard でシ ミ ュ レーシ ョ ン用コ ンパイルス   
ク リ プ ト 作成時に、 デフ ォル ト でコ ンパイル対象と し て リ ス ト ア ッ プされます。

　 　 使用例

・ テス ト ベンチを イ ンポー ト し て [Simulation] に設定

・ IP コ アを使用する場合に、シ ミ ュ レーシ ョ ン用のビヘイ ビアモデル と合成用のブラ ッ ク ボ ッ ク ス
モデル両方を イ ンポー ト し てそれぞれ [Simulation]、 [Synthesis] に設定

図 2-39. 対象プロセスの選択

2.6.4 使用し ないデザイ ンフ ァ イルの選択

　 イ ンポー ト し たデザイ ンフ ァ イルは、 イ ンプ リ メ ンテーシ ョ ンご と に特定のフ ァ イルを処理の対象から除
外こ と もでき ます。

　 *****--------------------
• 例えば （内部の記述が異な るが） 同じ entity/module 名のフ ァ イルを複数イ ンポー ト し ておき、 イ ン
プ リ メ ンテーシ ョ ン毎に使用する フ ァ イルを切 り 替え る場合などに使用する機能です

• remove と違い、 イ ンポー ト 情報が削除されません
　 *****--------------------

右クリック
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　 File List ウ イ ン ド ウで処理の対象から外し たいフ ァ イルを右ク リ ッ ク し、 [Exclude from Implementation] を   
選択する と、 そのフ ァ イルは現在のイ ンプ リ メ ンテーシ ョ ンの処理対象から除外されます （図 2-40）。 

　 対象から除外されたフ ァ イルは、 薄い文字で表示されます。

　 *****--------------------
• この設定は選択されている イ ンプ リ メ ンテーシ ョ ンでのみ有効です。 他のイ ンプ リ メ ンテーシ ョ ンに
は反映されません

　 *****--------------------

　 なお、 一度除外 し た フ ァ イ ル を 再び処理対処に戻す場合は、 フ ァ イ ル を 右 ク リ ッ ク し て [Include in 
Implementation] を選択し ます。

図 2-40. デザイ ンフ ァ イルの除外 （Exclude）

2.6.5 デザイ ンフ ァ イルの削除

　 不要になったデザイ ンフ ァ イルは、 プロ ジェ ク ト から削除する こ と もでき ます。 File List ウ イ ン ド ウで削 
除し たいデザイ ンフ ァ イルを右ク リ ッ ク し [remove] を選択するか、選択し た状態でキーボード の[Delete] キー
を押すと、デザイ ンフ ァ イルがプロ ジェ ク ト から削除されます。 フ ァ イル自体は削除されません。 図 2-40 で 
『Remove』 を選択し ます。

2.6.6 デザイ ン ソースのプロパテ ィ 設定

　 イ ンポー ト されている HDL ソースのプロパテ ィ と し て、 個別に以下の設定を行 う こ と ができ ます。

• VHDL ソースのコ ンパイル先ラ イブラ リ 名

• Verilog HDL ソース内でイ ン クルード されている フ ァ イルの検索パス

　 これらの設定を行 う 場合は、 メ ニ ューバーから [Project] => [Property Pages] の順に選択するか、File List ウ    
イ ン ド ウでデザイ ンフ ァ イルを右ク リ ッ ク し て [Properties] を選択し ます（図 2-41）。これで、Project Properties  
ウ イ ン ド ウが立ち上が り ます。

　 このウ イ ン ド ウの左側でプロパテ ィ を設定し たいデザイ ンフ ァ イルを選択する と、 ウ イ ン ド ウ右側に設定
可能な項目が表示されます。

　 なお、 イ ンプ リ メ ンテーシ ョ ン作成時に既存のイ ンプ リ メ ンテーシ ョ ンにイ ンポー ト されている ソース を
参照し た場合、 これらのプロパテ ィ 設定も反映されます。 従って イ ンプ リ メ ンテーシ ョ ン毎に設定し なおす
必要はあ り ません。

右クリック
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図 2-41. デザイ ンフ ァ イルのプロパテ ィ 設定

図 2-42. プロパテ ィ ・ ウ イ ン ド ウ ～ デザイ ンの設定

2.6.7 デザイ ン （フ ァ イル） の階層構造表示

　 イ ンポー ト し たフ ァ イルは File List ウ イ ン ド ウではフ ラ ッ ト に表示されるため、 フ ァ イルの過不足が直感 
的には分か り ません。

図 2-43. Hierarchy ビ ューによ るモジュールの階層構造表示

Ｚ 右クリック
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　 Diamond 3.2 以降はグ ラ フ ィ カル表示ツールの HDL Diagram があ り ませんので、 図 2-43 のよ う にハイ ア   
ラーキ （Hierarchy） ビ ューでモジ ュールの階層構造が期待通 り かど う かを確認でき ます。

　 ハイ ア ラーキ ・ ビ ューは論理合成前後で表示内容が変わ り ます。 論理合成後は LUT、 FF など各 リ ソース
の使用数が各モジ ュール毎、 階層ご と に表示されます （図 2-44） 。 RTL 既述の想定する規模に合致するか、 
大凡の判断が可能です。 また、 回路規模を目標に収めるための方策を検討するデータ と な り ます。

　 図 2-44 のよ う にモジ ュールを選択し て右ク リ ッ クする と、 種々 メ ニ ューが表示されます。 『Goto Source  
Definition / Instantiation』 等を選択する と、 設定し ているエデ ィ タが開き、 モジュール既述やイ ン ス タ ン ス箇  
所にジ ャ ンプし て表示し ます。 『Export Resource to ASCII / CSV File』 ではハイ ア ラーキビ ューの表示内容が      
テキス ト フ ァ イル と し て書き出すこ と ができ ます。

図 2-44. ソース と の リ ン ク、 エ ク スポー ト など

2.7 プロ ジェ ク ト 管理の注意点

2.7.1 Windows と Linux 間のデータ移転

　 Windows マシンで作成し たプロジェ ク ト を Linux マシンにコ ピーし た場合、 HDL ソースや制約フ ァ イル等
のイ ンポー ト 情報が Linux 上の Lattice Diamond 上で正し く 認識されない場合があ り ます。 これは、 Windows 
上で作成し たフ ァ イルを （そのま ま） Linux 上へコ ピーし た際に、 フ ォ ン ト や文字コード の変換が原因でフ ァ
イル名の大文字／小文字が変更されて し ま う こ と があ るためです。 Linux は大文字小文字を区別し ますので、
フ ァ イル名の大文字／小文字が変換される と正し く 認識でき な く な り ます。

　 回避策は 2 つあ り ます。

１ ． Linux にコ ピーし た ソース フ ァ イル名を全て変更する （拡張子は小文字のま ま）

２ ． Windows から コ ピーする フ ァ イルを tar と gzip で圧縮 （拡張子が tgz or tar.gz） し、 コ ピーし た圧  
縮フ ァ イルを Linux 上で展開する

2.7.2 自動生成マ ク ロのパラ メ ータ フ ァ イル

　 SERDES や一部のマ ク ロの HDL ソースは、 GUI ツール IPexpress で生成し ますが、 この際に HDL ソース と
共に動作モード設定等のパラ メ ータ を記述し たテキス ト フ ァ イルも生成し ます。 配置配線やタ イ ミ ング解析
プロセス、 或いは書き込みデータ生成時には、 このフ ァ イルを読み込んでパラ メ ータ を抽出し ます。 これら
のパラ メ ータ フ ァ イルは、 イ ンプ リ メ ンテーシ ョ ン ・ フ ォルダに置いてお く 必要があ り ます。 書き込みデー
タ生成プロセスでは、 プロジェ ク ト フ ォルダにあって も適用されますが、 フ ァ イル管理の観点から イ ンプ リ
メ ンテーシ ョ ン ・ フ ォルダに置 く こ と を推奨し ます （IPexpress のデフ ォル ト 設定では、 フ ァ イルの出力先は
イ ンプ リ メ ンテーシ ョ ン ・ フ ォルダではな く プロ ジェ ク ト フ ォルダです）。

　 プロセス実行時にイ ンプ リ メ ンテーシ ョ ンフ ォルダにテキス ト フ ァ イルが無い場合、 ツールは以下の様な
メ ッ セージを出力し、 マ ク ロはデフ ォル ト のパラ メ ータで処理が行われます。
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WARNING - Cannot open configure file: [ モジュール名 ].txt. Use the default setting ! 

　 この メ ッ セージが表示された場合、IPexpress で設定し たフ ァ イルの出力先から該当する テキス ト フ ィ ルを
イ ンプ リ メ ンテーシ ョ ン ・ フ ォルダにコ ピーし て く ださい。 テキス ト フ ァ イルを Lattice Diamond にイ ンポー 
ト し て も適用されませんので、 注意し て く ださい。

2.8 改訂履歴

--- *** ---

Ver. page 内容

3.1

2-9 2.2.5 ク ローン ・ プロ ジェ ク ト の生成、 追加

2-10 2.2.6 プロ ジェ ク ト ・ アーカ イブ項、 復元について追記

2-16 2.3.5 ク ローン ・ イ ンプ リ メ ンテーシ ョ ンの生成、 追加

3.3 -- バージ ョ ン 3.3 (3.2) 用に GUI キ ャプチャ を全面的に更新

2-26 HDL Diagram 既述を削除し、 Hierarchy ビ ューによ る既述に更新
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