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1 ispVM System(基本編) 
1.1 概要 

ispLEVER を使用してプロジェクトをコンパイルした後、Lattice のデバイスをプログラムまた
は、コンフィグレーションします。 デバイスへのプログラムまたはコンフィグレーションは、
ispVM Systemを用います。ispVM Systemは ispLEVERイントール時に ispVM Systemのみ単
体でインストールすることも可能です。 

ispVM Systemを単体で使用する場合は、弊社HP【http://www.latticesemi.com/】からダウンロ
ードしてご利用ください。ispVM Systemは無料でご使用頂けます。 

 
1.2 ispVM Systemの主な機能・特徴 

(1) ラティス全 ispデバイスのプログラミング・コンフィグレーション 
(2) 他メーカ混在チェーンの書き込みが可能 
(3) デバイスチェーンの自動スキャン 
(4) シリアル/ターボダウンロードをサポート 
(5) ユーザーコード/UESエディタ 
(6) ボード診断機能 
(7) プログラミング中の I/Oステート指定 
(8) VMEファイルの生成/VME-Processor 
(9) ATEプログラミング・ベクタジェネレータ 

・ HP, Genrad, Teradyne及びMarconi ATE装置をサポート 
・ 先進的 AETベクタ生成機能  

(10) ビルトイン SVFエディタ 
(11) SVFファイルのインタープリタとデバッガ 
(12) IEEE1532(ISC)データ・ジェネレータ 
(13) FPGAローダー 
(14) コマンドラインモードを用意 
(15) XMLベースの新しいチェーン 

・ フォーマット(.XCF ファイル) 
・ パッケージ・タイプを含むデバイスのフル・ネーム 
・ TDIと TDOのチェーン接続•デバイス毎に選択されたオペレーション•ヒューズ 
・ チェックサム値やファイルのタイム・スタンプを含む JEDECファイル名 
・ デバイスのインストラクション・レジスタ長•デバイスの BYPASSオペコード(オール 1で
ない場合) 

・ SVFファイルのファイル名とタイム・スタンプ 
・ /ispEN、/ENABLE、/TRST、/BSCAN 、/EPEN ピンとケーブルとの接続 
・ プリロード BSCANベクタをサポート(デフォルト I/O値は HiZ) 
・ その他プロジェクト設定 

 4

http://www.latticesemi.com/


ispVM System  
ユーザーマニュアル  

Mar.2007    Ver1.1 

1.3 ispVM systemの起動方法 

① Windowsのスタートメニューから起動する 
[スタート]→[プログラム]→[Lattice Semiconductor]→[ispVM System]で起動します。 
 

② ispLEVER Project Navigatorから起動する 
ispLEVER Project Navigatorのアイコンをクリックすることで起動します。 

 

 
 
 
 

このアイコンをクリック 

図 1-1 ispVM Systemアイコン 

 
  上記何れかの方法により、ispVMを起動しますと図 1-2のような画面が立ち上がります。 
 

 
図 1-2  ispLEVER起動時の画面 
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1.4 ダウンロードケーブルの種類 

 Latticeのダウンロードケーブルには、PCとの接続ポートが USBタイプの物と、25pinパラレルポ
ートタイプの物があります。 
 以下に、ダウンロードケーブルの外観図を示します。 

 
 

コネクタ部の色がベージ 
 

 

コネクタ部の色がグレー
 
 

図 1-3 ダウンロードケーブル外観 

 
ダウンロードケーブルの詳細および、旧式のダウンロードケーブルおよび旧 Vantis 製ケーブルにつ
いての詳細は、データシート【http://www.latticesemi.com/lit/docs/devtools/dlcable.pdf】をご参照く
ださい。 
 
1.5 ダウンロードケーブル接続時の注意事項 

PCと基板をダウンロードケーブルで接続する際は、以下の点にご注意ください。 
 
１．ダウンロードケーブルの抜き差しは、書き込み対象のボードの電源を切ってから行ってください。

電源が供給された状態での抜き差しは、デバイスを破損する恐れがあります。 
２．書き込みが終り次第、ダウンロードケーブルを基板から外して下さい。パラレルポートもしくは

USBポートから何かしらの信号が出力されデバイスを誤動作させる恐れがあります。 
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1.6 デバイスのスキャン 

 
基板と PCをダウンロードケーブルで接続後、基板の電源を投入し、デバイスのスキャンを行います。 
 デバイスのスキャンは、以下の 3通りの方法で可能です。 

 
① ツールバー上のアイコンをクリック 
② メニューの[ispTools]→[Device Scan]で起動 
③ F2キーを押す。 

 
尚、ラティス ISPチェーンと JTAG－ISPチェーンを混在したチェーンの場合には、Mix Scanボタ

ンを押します。 
 

 

チェーンに接続されているデバイスのリスト 

図 1-4  SCAN実行後の画面 

 
SCAN が正常に行われますと、図 1-4のようにチェーンに接続されているデバイス名が表示されま
す。 
 尚、他社デバイスは全て JTAG-NOPと表示されます。 
 
 
1.7 ダウンロードケーブルと I/Oポートの設定 

上記でデバイスの SCANが上手くいかない場合、ダウンロードケーブルの設定がされていない可能性
があります。その場合、以下の手順により、設定を行うことができます。 

 
ispVM Systemのメニューから[Options]→[Cable and I/O Setup]を選択します。 
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I/Oポートの自動検出 

図 1-5 ダウンロードケーブルと I/Oポートの設定画面 

 
各項目の内容および設定内容は、表 1-1を参照ください。 
 

表 1-1 ダウンロードケーブルと I/Oポートの設定項目とその内容 

項目 内容 設定内容 
Cable Type 使用するダウンロードケーブルのタイプ Lattice：パラレルポートケーブル 

Vantis：旧 Vantis製ケーブル 
USB  ：USBポートケーブル 

Port Setting ケーブルが繋がっているポートの指定。 Auto Detectにより設定可能。 
(旧 Vantis製は自動検出不可) 

Custom Port 0x ケーブルが接続されているポートをカス

タム指定 
繋がっているポートを指定 

TRST/Reset  
Pin Connected 

ダウンロードケーブルに TRST ピンを接
続するか、接続しないかの設定 

ON：接続する 
  Set High：Active High 
    Set Low ：Active Low 
OFF:接続しない。 

Done Pin 
Connected 

ダウンロードケーブルにDONEピンを接
続するか、接続しないかの設定 

ON：接続する 
OFF:接続しない。 

ispEN/BSCAN 
 Pin Connected 

ダウンロードケーブルに ispEN/BSCAN
ピンを接続するか、接続しないかの設定 

ON：接続する 
  Set High：Active High 
    Set Low ：Active Low 
OFF:接続しない。 

Prog Pin 
Connected 

ダウンロードケーブルに Prog ピンを接
続するか、接続しないかの設定 

ON：接続する 
OFF:接続しない。 

INIT Pin 
Connected 

ダウンロードケーブルに INIT ピンを接
続するか、接続しないかの設定 

ON：接続する 
OFF:接続しない。 

 
※Windows XPで USBダウンロードケーブルを使用する場合、上記方法による自動検出が上手くいか
ない場合があります。その場合は、次頁に示します手順にてドライバをインストールしてください。 

 8



ispVM System  
ユーザーマニュアル  

Mar.2007    Ver1.1 

1.8  USBダウンロードケーブルドライバのインストール 

本作業は必ず Admin権限で行ってください。 
まず、準備として ispVMsystemを正常にインストールしてください。 
インストール後、図 1-6のような USBドライバのインストール確認画面が起動しますので、「はい」を
押します。 
 

 
図 1-6 USBドライバのインストール確認画面 

 
インストールが完了しますと、図 1-7のような画面が起動します。 
 

 
図 1-7 USBドライバインストール完了画面 

 
インストールが完了しましたら、USB ダウンロードケーブルを PC に接続します。自動でのような

Wizard画面が起動します（Wizard画面が起動しない場合は、自動で認識しておりますので、以降の作
業は不要です）。 

 
図 1-8 新しいハードウェアの検索ウィザードの開始画面 

 
上記画面が起動しましたら、「一覧または特定の場所からインストールする」を選択し、「次へ」をク

リックします。 
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続いて図 1-9のような画面が起動しますので、「次の場所で最適のドライバを検索する」内の「次の

場所を含める」を選択し、「C:¥WINDOWS¥Sysytem32」を指定します。 
 

 
図 1-9 ハードウェアの更新ウィザード 

 
「次へ」をクリックしますと、図  1-10のような画面が起動します。表示に「Lattice USB ISP 
Programmer」と記載されていることを確認し、「続行」をクリックしてください。 
「Lattice USB ISP Programmer」と記載されていない場合は、ispVMsystemインストール時にドライ
バが正常にインストールされていないか、インストールしていない可能性がございます。 
 

 
図 1-10 ハードウェアのインストール 
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「続行」をクリックした後、図 1-11のような画面が起動すればインストールは正常に終了しております。 
「完了」をクリックして、画面を閉じます。 
 

 
図 1-11 ハードウェアの更新ウィザードの完了 

 
インストールが完了しましたら、念のため、次に示します手順により確認を行ってください。 
 
確認手順 
① Windowsのスタートメニューから「設定」→「コントロールパネル」を選択します。 
② コントロールパネル内の「システム」をクリックします。 
③ システムからハードウェアを選択し、デバイスマネージャを開きます。 
④ デバイスマネージャ内の USBコントローラを開いて、「Lattice USB ISP Programmer」が表

示されていることを確認します。 
 

 
図 1-12 USBドライバインストール完了の確認 
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1.9 デバイス情報の編集 

 図 1-4のように SCAN が成功した画面にて、編集したデバイスの行をダブルクリックしますと、図 
1-13のようなデバイス情報の編集画面が開きます。 
 

 

書き込みファイルの指定 

オペレーションの指定 

図 1-13 デバイス情報の編集画面 

 
上記画面にて、最初に書き込みファイルに指定を行います。書き込みファイルの指定は、Data File

設定欄の「Browse」ボタンを押し、ファイルの指定を行います。 
 EC/ECP/ECP2/SCファミリの場合は、拡張子が bitもしくは rbfを、XP/XOファミリの場合は、拡張
子が iscもしくは jedのファイルを指定します。 
 書き込みファイルの指定が完了しましたら、オペレーション項目の設定を行います。 
主なオペレーションの項目とその内容について表 1-2に示します。 

 

表 1-2 オペレーション項目と内容 

オペレーション項目 内容 
Fast Program 
Erase,Programming,Verify 

消去、書き込み、ベリファイを実行します 

Erase,Programming,Verify,Secure 消去、書き込み、ベリファイを実行後、セキュリティをかけ

ます。(*1) 
Verify Only ベリファイのみ実行します。 
Verify ID デバイスコードをベリファイします。 
Erase Only 消去のみ実行します。 
Display ID デバイスからデバイスコードを読み出し、表示します。 
Bypass 何も実行しません。 
Calculate Checksum チェックサム値を計算し、表示します。 
Verify USERCODE デバイス内のユーザコードをベリファイします。 
Display USERCODE デバイス内のユーザコードを読み出し、表示します。 
Read and Save JEDEC デバイス内のデータを読み出し、保存します。 
Read DONE bit DONE bitの値を読み出し、表示します。 

*1 セキュリティをかけた場合、読み出しデータにセキュリティがかけられます。これにより、
Verify,Checksumの確認ができなくなりますので、ご注意ください。 
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 次に、Device Access Optionsの設定を行います。設定内容に対する実行内容は、表 1-3～表 1-5の通
りとなります。 
 

表 1-3 Device Access Optionsの設定内容(EC/ECP/ECP2ファミリ) 

項目 内容 
JTAG 1532 Mode デバイスがプログラムモード時に JTAGポートを使用 
Static RAM Cell Background デバイスがユーザーモード時に、リードまたはベリファイ

を可能とする 
SPI Flash Programming JTAG経由で SPIフラッシュメモリの書き込みを実行 
Advanced SPI Flash Programming FPGAローダ機能を使用して、SPIフラッシュメモリの書

き込みを実行 
Serial Mode デバイスのシリアルコンフィグレーションを実行 

 

表 1-4 Device Access Optionsの設定内容(SCファミリ) 

項目 内容 
JTAG Mode JTAGポートを使用 
Serial Mode シリアル・コンフィグレーションポートを使用 

 

表 1-5 Device Access Optionsの設定内容(XP/XOファミリ) 

項目 内容 
Flash Programing Mode 内蔵フラッシュメモリのプログラムグを実行 
Flash Background Mode デバイスがユーザーモード時に、内臓フラッシュメモ

リのバックグラウンドプログラム、再プログラムを可

能とする 
Static RAM Cell Mode SRAMにアクセス 
Static RAM Cell Backgournd Mode デバイスがユーザーモード時に、SRAM セルのバック

グラウンドリード、確認を実行 
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1.10 プログラミング(オペレーションの実行) 

 チェーンの設定、デバイスの設定が完了した状態で、メニューアイコンの「GO」ボタンをクリック
しますと、プログラミング(設定したオペレーション)が開始されます。 
 

 
 

 

 

 オペレーション実行中 

プログラムステータスを表します。 
本ステートが、PASS もしくは DONE
になれば、Operationは成功です。 
FAILとなった場合は、何らかの理由に
より、失敗しています。 

プログラム(オペレーション)の実行 

ログファイルの表示 

図 1-14 オペレーションの実行 

 
 「ＧＯ」ボタンをクリック後、ステータス欄に PASS もしくは DONE と表示されれば、プログラミ
ング(オペレーション)が正常に完了しています。FAILと表示された場合には、何らかの理由により、オ
ペレーションが失敗しています。 
 オペレーション失敗の原因が不明の場合には、次章 ispVM(応用編)のトラブルシューティングの項を
参照ください。 
 オペレーション終了後、「LOG」ボタンをクリックしますと、ログファイルを参照することができま
す。また、[Edit]→[Clear Log File]でログをクリアすることができます。 
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1.11  チェーン情報の保存 

 作成した、JTAGチェーンの情報は、以下の２つの方法により保存することができます。 
 
⑤ ispVM Systemuのメニューから[File]→[Save]を選択する。 
⑥ Saveアイコンをクリックする。 

 

 
図 1-15 チェーン情報の保存 

 
 上記何れかを実行後、ファイル名をつけて保存します。尚、拡張子は xcfとなります。 

 

 
 
 
 

保存ボタン ファイル名 

 
 保存したチェーンファイルは、spVM Systemu のメニューから[File]→[Save]を選択することで、次
回以降同じ設定で使用することが可能となります。 

 
これで、ispVM System使用ガイド(基本編)は終了です。 
ここに記載されていない、応用機能に関しては、次項の ispVM System使用ガイド(応用編)を参照く
ださい。 
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2 ispVM System(応用編) 
2.1 概要 

本節は、ispVM機能の応用機能について説明いたします。 
 

2.2  Dual Boot 
Lattice ECP2/ECP2Mファミリでは、SPI Flashを利用した Dual Boot機能の使用が可能です。本節
では、ispVM Systemを使用したデュアルブート用書き込みファイルの設定方法、書き込み方法につい
て説明致します。 
  
 ボードに電源を供給し、ダウンロードケーブルを接続した状態で ispVM を起動し、SCAN ボタンを
クリックしますと、 図 2-1のようにボードに実装されている ECP2/Mデバイスが Device Listに表示
されます。 
  

 
図 2-1 ispVM Systemメイン画面 

 
デバイスが正常に表示されている状態で該当行をダブルクリックしますと、図 2-2のような画面が起
動します。 
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② 
① 

 
図 2-2 デバイス情報画面 

 
上記画面が起動しましたら、Device Access Optionsのプルダウンメニューから「Dual Boot SPI Flash 

Programming」を選択し、「SPI Flash Options」ボタンをクリックします。 
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① 

② 

③ 

⑤ 

⑥ 

④ 

 
図 2-3 SPI Flash設定画面 

 
上記画面が開きましたら、下記 6つの設定を行います。 
① Flash Device欄の Selectボタンをクリックし、書き込みを行う SPI Flashの型名を選択します。 
② Data File欄の Browseボタンをクリックし、書き込みファイルの生成場所、ファイル名を設定し
ます。 

③ Operationを「SPI Flash Erase,Program,Verify」に設定します。 
④ Golden Boot Fileおよび Primary Boot Fileを選択します。 

Golden Boot File ：Primary boot fileによるコンフィグレーションエラー時に読み込まれる、コ
ンフィグレーションファイル 

Primary Boot File：優先的に読み込まれるコンフィグレーションファイル  
⑤ Generateボタンをクリックし、書き込みファイルを生成します。 
⑥ 生成が正常に完了した旨のメッセージが表示されましたら OKボタンをクリックします。 
 
以上で書き込みファイルの設定は完了です。 
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2.2.1 Primary Image fileの書き換え 

 
 本節では、ispVMを使用して Primary Image Fileのみを書き換える方法を示します。 
前ページに記載の方法で、Dual Boot 用書き込みファイルを生成しますと、Log ファイルに Primary 
Imageと Golden Imageのアドレスが記載されます。 
 

 
図 2-4 LOGファイルの表示 

書き込みファイル生成後、ispVM メイン画面にて「LOG」ボタンをクリックしますと、図 2-5のよ
うにログファイルが表示されます。 
 

 

ログファイルの表示 

図 2-5 ログファイル 

 
上図のように Golden および Primary の Start アドレスおよび Enc アドレスがレポートされます。

Primaryのみ書き換えるには、上記アドレスを指定して書き込みを行いますので、Primaryのアドレス
を記録しておきます。 

2.2節と同様の手順にて SPI Flashの設定画面を開きます。 
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⑤ 
① 

② 

③ 

④ 

図 2-6 SPI Flash設定画面 

 
上記画面が開きましたら、下記 6つの設定を行います。 
 

① Flash Device欄の Selectボタンをクリックし、書き込みを行う SPI Flashの型名を選択し
ます。 

② Data File欄の Browse ボタンをクリックし、書き込みファイルの生成場所、ファイル名を
設定します。 

③ Operationを「SPI Flash Erase,Program,Verify」に設定します。 
④ ログファイルの情報をもとに、Staring Addressおよび Ending Addressを指定します。 
⑤ OKボタンをクリックします。 

 
以上で設定は完了です。 
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2.3 USERCODE/UES設定 

ラティス FPGA では、デバイス内にユーザー固有のコード、USERCODE を格納することが可能
です。USERCODEの設定は、下記手順により行います。 

 
１．ispVM Systemを起動し、メニューの[Option]→[Dsiplay USERCODE/UES Options]で、

基数を設定します。 
2. Device Information 画面を起動し、 [Advanced]をクリックし、 [Advanced Device 

Information]画面を開きます。 
3. [USERCODE/UES Field]に①で設定したフォーマットで、UESを記述し、[Apply UES]
をクリックします。 

4. [Auto-Increment After Program by]を 1以上の数に設定しますと、プログラムごとに設
定した数が自動でインクリメントされます（0の場合は毎回同じです）。 

 

 
図 2-7  USERCODE/UESのフォーマット設定画面 

 
 

USECODEを設定したフォーマ
ットで入力します。 
USERCODE/UES Field in __ 
の__の部分に設定されているフ
ォーマットが表示されます。 

自動インクリメント数の設定 

図 2-8 Advanced Device Information 画面 
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2.4 プログラミング中の I/Oステートの設定 

 下記手順により、プログラミング中の I/Oの指定が可能です。 
 

1. ispVM Systemを起動し、[Device Information]画面を開きます。 
2. [Expand]をクリックします。 
3. [Device Information]画面が拡張しましたら、[I/O Status]をクリックし、 
プルダウンから、プログラミング中の I/O状態を設定します。 
 

プルダウンメニューから 
I/Oステートを選択します。

 

「Custom」もしくは「Dynamic IO」
に設定した場合、BSDLファイルを
指定します。指定後、Editボタンを
押します。 

 
 

図 2-9 Device Information画面 

 各設定項目に対する、I/O状態を表 2-1に示します。 
 

表 2-1 Device Access Optionsの設定内容(EC/ECP/ECP2ファミリ) 

項目 内容 
High-Z(Default) 全てのピンを Hi-Z状態にします。 
All 1’s 全てのピンを Highにします。 
All 0’s 全てのピンを Lowにします。 
Leave Alone ピンの状態をサンプルし、プログラム中はその状態を保持

します。 
Custom プログラム前にベクタを作成し、選択したピンごとに I/O

状態を指定します(未設定ピンは High-Zになります)。 
詳細は、下記を参照ください。 

Dynamic IO “Leave Alone”と ”Custom”を混在させたモードで
す。”Leave Alone”に設定したピンは、サンプル値を保持
し、値を指定したピンは、その値となります。 

Caputure ダウンロード前に、Editウインドからの I/Oの値をキャプ
チャし、その後 Dynamicモードになります。 

 22



ispVM System  
ユーザーマニュアル  

Mar.2007    Ver1.1 

I/O ステートを、「Custom」もしくは「Dynamic IO」に設定した場合、BSDL ファイルが必要とな
ります。BSDLは、ラティスの HPからダウンロードできますので、ダウンロードして使用ください。 
＊ 初めて、ダウンロードする場合はユーザー登録(無料)が必要となります。 
 

BSDLファイルを指定後、EDITボタンを押しますと、のような[IO Vector Editor]画面が開きます。 
 

 
図 2-10 I/O Vector Editor 画面 

 
 [IO Vector Editor]画面上で、各ピンに対してクリックを繰り返すことで、I/Oピンの状態を設定する
ことができます(色のついているピンは設定不可です)。設定内容に対するピンの状態は、左下の表に示
されます。 
 設定が完了しましたら、[Apply]ボタンを押すことで、設定が反映されます。また、[Save As]ボタン
を押すことで、I/Oベクタファイル(*.iov)として保存することができます。 
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2.5 書き込み設定の変更 

 
 ispVM Systemのメニュー画面の[Project]→[Project Setting]により、書き込みに関する設定を変更
することができます。 
 
 

 
図 2-11 書き込みに関する設定画面 

 
各設定項目に対する、設定内容を図 2-11に示します。 
 

表 2-2 書き込みに関する設定内容 

項目 内容 
Sequential Program 同一チェーン上のデバイス１個ずつ書き込みを実施

(JTAGアルゴリズム)。 
Turbo Program デバイスに同時に書き込みます。これにより書き込み時間

が短縮できます(Latticeオリジナルアルゴリズム/特許)。 
Entire Chain チェーン上全てのオペレーションを実施します。 
Selected Device チェーンの中で、選択されたデバイスに対してのみオペレ

ーションを実施します。 
Operation Override プルダウンメニューからオペレーションを選択できます。 
Disable Board Setup Checking 書き込み前ボード構成のチェックを実施しません。 
Avoid Test Logic Reset State ダウンロード中に、JTAGの Test Logic Reset状態を回避

します。 
Continue Download Even on Error ダウンロード中に、エラーが発生してもソフト上で無視し

ます。 
Starting/Ending TAP State ダウンロード時、最初の JTAGの状態を指定します。 
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 また、[Advance]ボタンをクリックすると以下のような画面が開きます。 
 

 
図 2-12 書き込みに関する設定画面(拡張設定) 

 
ここでは、以下のような設定が可能です。 

表 2-3 書き込みに関する設定内容(拡張設定) 

項目 内容 
TCK Low Pulse Width Delay TCK のクロック幅を調整します。数字を大きくすれば、

クロック幅が大きくなり、書き込み時間が増大します。 
Comment チェーンファイルにコメントを記入することができます。 
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2.6 ATEプログラミング・ベクタの生成 

 
 基板テスター(ATE : Automatic Test Equipment)用にプログラミング・ベクタを生成することができ
ます。プログラミング・ベクタを使用すると、製造時に基板のテストとプログラミングを同時に行うこ

とができます。 
 
 対応している ATEは次になります。 

・ Gen Rad  
・ HP 3070 
・ HP 3065 
・ Teradyne 1800 
・ Teradyne L200/300 

 
また、上記以外でも SVF(Serial Vector Format)に対応している ATEであれば、SVFファイルを生成
することで、ATEでのプログラミングが可能です。 
 
SVFのスペックについては、下記ＵＲＬから参照できます。 
http://www.asset-intertech.com
もしくは、:¥ispTOOLS¥ispvmsystem¥documents¥svf_standard.pdf 
からも参照可能です。 
 
ATEプログラミング・ベクタ生成画面は、以下の何れかの方法で起動します。 
 
① Project→Generate ATE Vectorを選択 
② ATEアイコンをクリック 
 

 
図 2-13 ATE プログラミング・ベクタ生成画面の起動 

 26

http://www.asset-intertech.com/


ispVM System  
ユーザーマニュアル  

Mar.2007    Ver1.1 

 
図 2-14  ATE生成画面 

 
図 2-14のような、ATE生成画面が起動しましたら、まず Tester Typeを指定します。 

続いて、生成基チェーンファイルの指定、出力ファイルの指定を行います。また、Header Fileには、
各種ピン情報などを含む、ヘッダーファイルを指定します。ブランクとした場合は、自動的にヘッダー

ファイルは生成されます。 
 
 続いて、「Advanced」ボタンをクリックし、起動した画面の「More」ボタンをクリックすると、の
ような画面が起動します。 

 

生成元 
チェーンファイルの指定

出力ファイルの指定 

ヘッダーファイルの指定

拡張設定 

Tester Typeの指定 

図 2-15 ATE Advanced Options画面 
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 ここでは、必要に応じて設定を行います。 
 各設定の内容をに示します。 
 

表 2-4 書き込みに関する設定内容 

項目 内容 
Split File ファイルサイズを削減するために、ベクタファイルを分割

します。 
Maximum number of vectors per 
file 

各ベクタファイルの、許容するベクタの最大数を指定しま

す。この値は、ATEベンダーから得ることができます。 
Split File without initialization ファイルサイズを削減するために、ベクタファイルを分割

します。このオプションを有効にするためには、

ispEN,MODE および SCLK にプルダウン抵抗が必須で
す。 

Program Vectors Only ベリファイ動作をスキップします。 
Erase Vectors Only 消去動作のみの ATE ファイルを生成します。これは、チ

ェーンファイル上の個々のデバイスに対する設定を無視

します。 
Vector Signal Order 各ベクタの信号オーダを指定します。 
HP-PFC Data More ボタンを押した時のみ、この設定は可能です。プロ

グラミングピンの名前、リードおよびライトのディレイ値

を設定できます。 
 
 設定後、「OK」ボタンをクリックして ATE Advanced Options 画面を閉じ、ATE 生成画面の
「Generate」ボタンをクリックすると、指定したフォルダに ATEプログラミング・ベクタファイルが生
成されます。 
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2.7 SVFファイルの生成 

 
SVFファイル生成画面は、以下の何れかの方法で起動します。 
 
① Project→Generate SVF Fileを選択 
② SVFアイコンをクリック 

 

 
図 2-16 SVF ファイル生成画面の起動 

2.7.1 デバイス単体の SVFファイルの生成 

 デバイス単体の SVF ファイルを生成する場合は、図 2-17のような SVF ファイル生成画面が起動し
ましたら、Optionsで「Build SVF File For Single Device」を選択します。続いて、出力ファイルの指
定、生成元ファイルの設定を行います。チェーン上に複数個のデバイスがある場合は、何番目のデバイ

スに対して生成を行うのかを入力してから、同様の設定を行います。設定が完了しましたら、

「Generate」ボタンをクリックすることで、指定したフォルダに SVFファイルが生成されます。 
 

  
図 2-17  SVFファイル生成画面(デバイス単体) 

生成元ファイルの設定 

設定対象のデバイスナンバー 

出力ファイルの指定 
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2.7.2 チェーン全体の SVFファイルの生成 

チェーン全体の SVF ファイルを生成する場合は、図 2-18のような SVF ファイル生成画面が起動し
ましたら、Optionsで「Build Sequential Chain SVF File」を選択します。続いて、出力ファイルの指
定、生成元ファイルの設定を行います。設定が完了しましたら、「Generate」ボタンをクリックするこ
とで、指定したフォルダに SVFファイルが生成されます。 
 

 

生成元ファイルの指定 

出力ファイルの指定 

図 2-18 SVFファイル生成画面(チェーン全体) 
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2.8 VMEファイルの生成 

2.8.1 VMEファイルの生成 

 VMEファイルは、エンベデッドプログラム用に生成されるバイナリファイルになります。VMEファ
イルはチェーンおよびデータ情報をもったファイルになります。 
 
VMEファイル生成画面は、以下の何れかの方法で起動します。 
 
① Project→Generate SVF Fileを選択 
② VMEアイコンをクリック 

 

 
図 2-19 VMEファイル生成画面の起動 

 
上記何れかの方法で、VMEファイル生成画面を起動しますと、以下のような画面が開きます。 
ここで、タブの VME12、VME11等の VME**の**部はバージョンを示します。 
VMEファイルの生成には、最新のバージョンをご使用ください。 
 

 
図 2-20  VMEファイル生成画面 
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 生成元ファイル、出力ファイルを設定しましたら、オプションの設定を行います。オプションの設定

内容を表 2-5に示します。 

表 2-5  Programing Mode設定内容 

項目 内容 
Continue If Fail プログラムまたはベリファイ前に、デバイスのユーザーコ

ードとVMEファイルのユーザーコードが一致するかどう
かをチェックします。 

Turbo VME File Program Setting..で設定したモードを無視して、Turbo
モード設定となります。 

Compress VME File VMEファイルを圧縮します。 
Loop VME FIle ループによって、生成される VMEファイルサイズを削減

します。 
Commnet コメント付の VMEファイルを生成します。 

 
 オプション設定完了後、「Generate」ボタンをクリックしますと、指定したフォルダに VME ファイ
ルが生成されます。 
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2.8.2 エンベデッド用 Cソースファイルの生成 

 図 2-20の VME ファイル生成画面にて、「VME2HEX」ボタンを押すと、図 2-21のような VME フ
ァイルを HEXファイルに変換するための画面が起動します。 
 

 
図 2-21 VMEファイルから HEXファイルへの変換 

 
 ここで、変換元ファイルと、出力先ファイルを指定し、「Generate」ボタンをクリックしますと、図 
2-22のようなコマンドプロンプト画面が起動します。「続行するには何かキーを押して下さい」とメッ
セージがでますので、キーを何か押して下さい。キーを押しますと、Ｃ言語ファイル(拡張子 c)とヘッダ
ファイル(拡張子 h)が生成されます。Ｃ言語ファイルは、デバイスの容量に応じていくつかに分割して
生成されます。 

 
図 2-22 C言語ファイル生成中画面 
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ispVMにインストールされているＣ言語の公開ソースをもとに、各プラットフォーム用にカスタマイ
ズを行い、CPUからのエンベデッドコマンドを完成させます。 
公開ソースは下記フォルダに保存されています。 

 
 インストールフォルダ¥ispvmsystem¥ispVMEmbedded¥SoureCode 
 
詳細説明は、readme.txtを参照願います。 
 
2.9 CPU エンベデッド ビットストリームの生成 

 
複数または単体の FPGAチェーン用に CPU エンベデッド ビットストリームを生成します。 
CPUエンベデッド ビットストリーム生成画面は、以下の何れかの方法で起動します。 

 
① Project→Generate SVF Fileを選択 
② CPUアイコンをクリック 
 

 
図 2-23  CPUエンベデッド ビットストリーム生成画面の起動 

 
上記何れかの方法で、CPU エンベデッド・ビットストリーム生成画面を起動しますと、以下のよう

な画面が開きます。 
 

 
図 2-24  CPUエンベデッド ビットストリーム生成画面 

 
続いて、フォーマット等の設定を行います。 
設定項目と内容について、表 2-6に示します。 
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表 2-6  オプション設定内容 

項目 内容 
Format 出力ファイルのフォーマットを設定します。 

Binary：バイナリフォーマット 
C-CODE：Ｃコードのファイル 
Intel-HEX：インテル HEXフォーマット 
Text：テキストフォーマット(デバック用) 

Comment コメントを入れるか否かを設定します。 
コメントを入れる場合は、ONに設定します。 

Output File 出力ファイルを設定します。Browse をクリックし、出力
フォルダ、ファイル名を設定します。 

Advanced  
Configuration Mode 各 CFGピンのコンフィグレーションを有効にします。 
Byte Wide Bit Mirror インテル HEXファイルのMSBと LSBを反転します。 

 
 オプション設定完了後、「Generate」ボタンをクリックしますと、指定したフォルダに CPU エンベ
デッドビットストリームが生成されます。 
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2.10  コマンドラインモード 

 isvVM Systemは、コマンドラインで起動することが可能です。 
製造段階で、コマンドをバッチファイル化し、マウスオペレーションを排除することで、書き込みに要

する時間を短縮することが可能となります。 
 
・コマンドのシンタックス 
 
 コマンドの基本文型は以下のようになります。 
 
ドライブ:¥ispVMディレクトリ¥ispVM.exe –infile”<入力ファイルパス>” /-processtype<プロセスタイ
プ>/-cabletype<ケーブルタイプ>/-portaddress<ポートアドレス>/-processmode<プロセスモード> 
 

表 2-7  コマンドラインの設定内容 

項目 内容 
入力ファイルパス(必須) 拡張子が xcfもしくは dldのチェーンファイル名を指定します。パ

スにスペースが含まれる場合には” “で囲んでください。 
プロセスタイプ(オプション) 
 

ターボモード(turbo)もしくはシーケンシャルモード(sequetial)を
指定します。何も指定しない場合は、シーケンシャルモードにな

ります。 
ケーブルタイプ(オプション) ラティス製パラレルケーブル(lattice)、バンティス製ケーブル

(vantis)、ラティス製 USBケーブル(usb)を指定します。何も指定
しない場合は、ラティス製パラレルケーブルになります。 

ポートアドレス(オプション) 
※パラレルケーブルの場合 

LPT1(0x0378)、 LPT2(0x0278)、 LPT3(0x03BC)、カスタム
(0xXXXX)を指定します。何も指定しない場合は、LPT1(0x0378)
になります。 

ポートアドレス(オプション) 
※USBケーブルの場合 

0～15の間でポートアドレスを指定します。15の場合 Ezusb-15
と指定します。何も指定しない場合は、Ezusb-0となります。 

プロセスモード(オプション) サイレントモード(-h)、メッセージモード(-o)、ウインドウモード
(-w)を指定します。何も指定しない場合、サイレントモードとなり
ます。 

 
以下に、コマンド例を示します。 
 
C:¥ispTOOLS¥ispvmsystem¥ispVM.exe -infile “C:¥demo¥demo.xcf” -processtype turbo -cabletype  
lattice -portaddress 0x0278 
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2.11  Universal File Writer 

 
  Universal File Writer(以下 UFW)は、データフォーマットの変換や、ファイルの圧縮。分割等をする
ためのツールです。 
  

UFWは、以下の何れかの方法で起動します。 
 
① ispTOOLS→Universal File Writerを選択 
② UFWアイコンをクリック 

 

 
図 2-25 VMEファイル生成画面の起動 

 
上記何れかの方法で、UFWを起動しますと、以下のような画面が開きます。 
 

 

入力・出力ファイルの指定

出力ファイル形式の選択 
変換の実行 

図 2-26 Universal File Writer(UFW)起動時の画面 

 
 UFWの画面が開きましたら、以下の手順でファイルのフォーマット変換を実施します。 
 
① 出力ファイルの形式を選択します。 
② 入力ファイルおよび出力ファイルを指定します。 
③ アイコンをクリックし、変換の実行 
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2.12  データの圧縮 

EC/ECP/ECP2 ファミリでは、UFW を用いてコンフィグレーション・ビットストリームの圧縮を
行うことができます。 
データ圧縮の手順は以下のとおりです。 
 
① UFWを起動する。 
② 出力ファイル形式を Bitstreamにする。 
③ 入力ファイル・出力ファイルを設定する。 
④ Bitstream Settingsで[Compression]を ONに設定する。 

 

 
図 2-27 ビットストリームデータ圧縮オプションの設定 

 
 上記手順により、出力されるビットストリームファイルは圧縮されます。 
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2.13  Application Specific BSDL File Generator 

 
  Application Specific BSDL File Generatorは、ユーザーデザインの信号名を使用して、アプリケー
ション特定の BSDL(Boundary Scan Description Language)ファイルを生成するためのツールです。 
 VREFまたは LVDS ペアをサポートし、配置されている I/Oに対して、変換された BSDLファイル
は VREF または LVDS ペアの振る舞いを正確に反映しています。このファイルを生成するには、汎用
の BSDLと、JEDECまたは ISCファイルが入力データとして必要となります。汎用の BSDLファイ
ルは、ラティスのWEBサイトから入手可能です。 
 
 Application Specific BSDL File Generatorは ispVM Systemsのメニュー画面から 
 ispTOOLS→Application Specifig BSDL File Generatorを選択することで、起動できます。 
 

 

デザインファイルの指定 

汎用 BSDLファイルの指定 

出力ファイルの指定 

図 2-28  Application Specific BSDL File Generator起動時の画面 

BSDL ファイル
の生成 

 
起動しましたら、下記手順により BSDLファイルの生成を行います。 
 
① 特定のデザインファイルを指定 
② 汎用 BLDLファイルを指定 
③ 出力ファイルを指定 
④ Generateボタンをクリック 
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2.14  Model300の使用方法 

 
Model300は、Lattice社でリリースしている簡易的な ISP/JTAGプログラマです。Model300を使っ
てプログラミングを行うには、本体の他にデバイス毎、パッケージ毎に専用のソケットが必要になりま

す。 
 Model300では、Vccのレベルが、1.8V,2.5V,3.3Vおよび 5.0Vのデバイスをサポートしており、ispVM
ソフトウェアで書き込みを行うことができます。 

 
Model300 には、本体、AC アダプタおよびダウンロードケーブルが付属しています。デバイス毎の
ソケットは別途購入の必要があります。ソケットの型式はラティス社の Web ページから確認すること
ができます。 

 

 
図 2-29 Model300外観図 
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  Model300は以下の手順にて使用します。 
 
① Model300の Programmerに電源を入れ、ダウンロードケーブルを接続します。 
② ispVM System を起動し、メニューから ispTools→Model300 Programmer を選択します(または

M300アイコンをクリックします)。 
 

 

デバイスの指定 
オペレーションの実行 

オペレーションの指定 

書き込みファイルの指定

電源電圧の確認 

図 2-30 Model300 Programmer画面 

 
③ Model300 Programmer画面から、デバイスを選択します。 

実行結果の確認 

④ 書き込みファイルを選択します。 
⑤ オペレーションを指定します。 
⑥ Auto-Detectを実行し、ケーブルを検出します(個別に指定することも可能です)。 
⑦ デバイスに対応する電源電圧の LED が点灯していることを確認します(ソフト上および Model300
上)。 

⑧ Goボタンをクリックし、オペレーションを実行します。 
⑨ 実施結果は、Status欄に表示されます。 
 
以上で ispVM System(応用編)は終了です。 
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3 トラブルシューティング(プログラミング関連) 
  
 本節では、プログラミングに関するトラブルシューティング法について説明いたします。 
 
3.1 ボード診断機能 

 ボード上での JTAG信号のオープン/ショートの可能性がある個所の暗示、デバイスの IDCODEのチ
ェックなどを行うことができます。 
 
 問題が発生した場合、JTAGケーブルを接続し、ボードへ電源を供給した状態で ispVM Systemのメ
ニューより ispTools→Board Diagonostics を選択することで、ボード診断機能を実行することができ
ます。図 3-1の図のように問題が無い場合は、デバイス型名、ＩＤ等が正常に表示されますが、問題あ
る場合は、期待値と違う値が検出されます。 
 また、JTAG信号のオープン/ショートの可能性がある個所は？が表示されます。 
 

 
図 3-1 ボード診断機能 

 
IDCODEに異常が発生している場合、以下のような事が考えられます。 
 
① 検出した IDCODEがオール１もしくはオール０の場合、JTAG信号の接続性に問題がある場合があ
ります。また、非ラティスデバイスが混在している場合は、そのインストラクション・レジスタ長

をチェックする必要があります。 
② 検出した IDCODEが 1と 0の組み合わせで、かつ再現性が悪い場合は、TCKと TMS信号の終端
やバッファリングに問題がある可能性があります。 
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3.2 反復ダウンロード 

 
 反復ダウンロード機能を用いることで、ケーブルの接続性のチェックを行うことができます。 
 反復ダウンロード機能は ispVM Systemのメニューから ispTools→Repetitive Downloadを選択する
ことで起動します。 
 

 
図 3-2 反復ダウンロード機能 

 
上記のような画面が起動しましたら、プログラミングを繰り返す回数(Number of)と反復ダウンロー
ド・プロセスを終了するまでのエラー回数(Stop on Error Number)を設定し、OKボタンをクリックす
ることで、反復ダウンロードを開始します。 

 
3.3 ケーブルデバッグ機能 

  
 ケーブルデバッグ機能は、テスト信号を出力しケーブルの接続性をチェックする機能です。 
ケーブルデバッグ機能は、ispVM Systemのメニューから Options→Cable and I/O Port Setupを選
択して、Cable and I/O Setting画面を起動し、Debug Modeボタンをクリックすることで起動します。 

 

 

ケーブルデバッグ機能

図 3-3 ケーブルデバッグ機能の起動 
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 上記手順にて、ケーブルデバッグ機能を起動するとのような画面が起動します。 

 
図 3-4 ケーブルデバッグ機能起動時の画面 

 
上記画面にて、出力する信号、出力パターンにチェックを入れ、Loopで繰り返し出力し、ESCで終了
となります。Power Checkを実行するとケーブルに、電源が供給されているかを確認することができま
す。 
各設定内容の詳細は、以下のとおりです。 
 
① Test Setting 

Toggle   ：1-0-1を交互に出力 
Hold High ：１を出力 
Hold Low  ：0を出力 
Read(TDO Only) TDOからデータをリードバックします。 

② Apply 
選択したピンに対して、設定内容を有効にします。特にトグル設定を行っているピンに対しては、

トグル出力を開始します。 
③ Loop 
連続テストを実行します。 

④ View Log 
Cable Signal Test operationsの結果を要約したテキストファイルを開きます。 

⑤ Power Check 
ケーブルとパワーコネクトのチェックを行います。ケーブルに正しく電源が供給されている場合は、

緑色に点滅します。 
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3.4 SVFデバッガ 

  
 SVF デバッガは、ダウンロードケーブルに繋がれた実際のデバイスを動作させながら、SVF ファイ
ルをデバッグする為のものです。 
 何らかの理由で、ISP/JTAGプログラミングが失敗する場合、いったん JEDECもしくはチェーンフ
ァイルを SVFファイルに変換し、それをデバッグすることで原因を究明できる場合があります。 
 SVFデバッガは、主な SVFシンタックスをサポートしていますが、あくまで CPLDプログラミング
用の SVFのデバッグを意図しており、16ビット・メモリ・サイズのみのサポートとなります。 
 

SVFデバッガを使用するには、まず SVFインタープリタを起動します。 
SVFインタープリタは、ispVM Systemのメニューから ispTools→SVF Interpreterを選択すること
で起動できます。 

 

 

SVFファイルの指定 

インストラクションレジスタのビット数を指定 

図 3-5 SVFインタープリタ 

上記画面が開きましたら、次の手順で SVFデバッガを起動します。 
 
① 生成した SVFファイルを指定する。 
② Advancedボタンをクリックする。 
③ 必要に応じて、インストラクションレジスタのビット数を設定します。 
※デバイス毎に異なります。 

④ Debugボタンをクリックし、SVFデバッガを起動します。 
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SVFデバッガを起動しますと、図 3-6のような画面が開きます。 
 ここで、メニューの Configuration→SVF Optionsを選択します(または SVF Optionsアイコンをク
リックします)。 
 

 
図 3-6 SVFデバッガ起動時の画面 

 
SVF Optionsを起動しますと、図 3-7のような画面が起動します。 
ここで、JTAGチェーン上の単一デバイスをデバッグする場合、チェーン上にある前後のデバイスの命
令レジスタ長を考慮した、ヘッダ長・トレイラ長を指定します。 
 

 

SVF Optionsの起動 

図 3-7 SVF Options画面 
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 図 3-8にヘッダ長・トレイラ長の設定例を示します。 

 
図 3-8 ヘッダ長・トレイラ長の設定例 

 
 続いて、メニューから Configuration→SVF Outputを選択しますと、のような画面が開きます。 
この画面では、デバッグしながら JTAG ピンや TAP コントローラのステートを確認することができま
す。 
 

 
図 3-9 SVF Output画面 

 
以上でトラブルシューティング(プログラミング関連)は終了です。 
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