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Section 1 : 

iCEcube2によるデザイン設計フロー 
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iCEcube2の起動 新規プロジェクトの作成 

■スタートメニューより、プログラム > SiliconBlue iCEcube2 > iCEcube2 を起動します。 
  新規プロジェクトを作成するには、File > New Project を選択するか、Create a new Projectアイコンをクリックします。 

File > New Projectを選択 

Create a new projectアイコン
からでもスタートできます 
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新規プロジェクトの作成 

任意のプロジェクト名を直接入力します。 

任意のプロジェクト保存先フォルダを直接入力または 

右のブラウズアイコンからフォルダを指定します。 

※新規プロジェクトを作成する場合はプロジェクト毎に 

 新規プロジェクトフォルダを作成し、そのフォルダを 

 保存先に指定することを推奨します。 

※プロジェクト名、プロジェクトフォルダは半角英数のみを 

 使用し、日本語やスペースは使用しないで下さい。 

プルダウンメニューから設計するデバイスファミリー、 

デバイス型番、パッケージを選択します。 

温度条件を選択します。 

コア電圧マージンを選択します。±5%を選択して下さい。 

各I/Oバンクの電源電圧を指定します。各I/Oバンクで使用
するスタンダードに合わせて設定して下さい。 

タイミング解析時にデバイススペックとしてBest, Typical, 

Worstのいずれのパラメータを算出するかを指定します。 

タイミング解析時に別途設定できます。 

Start From Synthesis : 

 バンドル版Synplifyを使用して論理合成する段階から設計開始します。通常はこれを選択します。 

Start From BackEnd : 

 有償版Synplify等で予め合成されたネットリストを用いて設計開始します。 

IP Generation : 

 ユーザーオリジナルIPを生成する際に選択します。 
設定完了後クリック 
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新規プロジェクトの作成 

■ソースや制約ファイルが用意されている場合は、次のウィンドウでインポートすることができます。 
  プロジェクト作成後にインポートすることも可能です。 

①Verilog, VHDL, EDIF, SDCファイル等を選択します。 

(本資料ではプロジェクト作成後にVerilogファイルをインポートします。) 

③インポート完了後クリック。 

以上新規プロジェクトが作成され、iCEcube2のメインウィンドウが表示されます。 

②クリックして右のウィンドウ
にインポート。 
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既存プロジェクトのオープン 

■既存のプロジェクトをオープンする場合は、File > Open Project より既存のプロジェクトファイル(_sbt.project)を 
  選択します。Open an existing projectアイコンからでもオープンすることができます。 

File > Open Projectを選択。 

Open an existing projectアイコンか
らでもオープンできます。 
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iCEcube2メインウィンドウ 

インポート済みのソースファイル(Verilog, VHDL等)とSynopsys

形式の制約ファイル(.sdc)が表示されます。 

論理合成後のネットリスト(.edf)と,sdcが変換されたiCEcube2で
使用される制約ファイル(.scf)が表示されます。 

フィッティング後のレポートファイル(.rpt)とログ(.log)が表示されます。 

生成されたビットマップファイル(書込みファイル)が表示されます。
バイナリ(.bin)、HEXファイル(.hex)、インテルHEX(_int.hex)の3つの
形式で生成されます。 

設計中のデバイス情報が表示されます。設計中に変更可能です。 

コア電圧、ジャンクション温度設定が表示されます。設計中に 

変更可能です。 

Timing Simulation用の遅延データとソースファイルが表示されます。 
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ソースファイルのインポート 

①Design Filesを右クリック
し、Add Fileを選択します。 

②予め用意したソースファイルからイン
ポートするファイルを選択し、Addボタン
(“>>”)でFile to addボックスに移動させます。 

③選択完了後、クリックします。 

■iCEcube2上では新規デザインソースの設計はできません。予めソースファイルを作成し、インポートする 
  必要があります。 
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■ソースファイルがインポートされるとRun Synplify Pro Synthesisが実行可能になります。Run Synplify Pro Synthesisを 
  実行すると、バックグラウンドでSynplify Proが起動し、論理合成を実行します。 

論理合成の実行 

Run Synplify Pro Synthesisを 

実行して論理合成。 
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(参考)作成したデザインの確認 

■Synplify Proを単体起動して論理合成を行うと、Synplify Pro上のツールを用いて作成したデザインの確認が行えます。 
  （※このフローは確認が必要な場合のみ行います。必ず実施する必要はありません。） 

①Tool -> Tool Optionsと選択。 

②Synplify ProタブにてClick ”here”を
クリックし、Symplify Proを起動。 

③Runをクリックして論理合成を実行。 

③0 errorsであれば論理合成完了です。 
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(参考)作成したデザインの確認 

Design Hierarchyタブに切り替えると 

デザインの階層設計がツリー形式で 

確認できます。 

■論理合成後、Design Hierarchyタブにてデザインの階層構造が確認できます。 
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■論理合成後、Synplify Pro上のRTL Viewを実行すると論理展開されたブロック図が確認でき、  
  Technology Viewを実行するとより詳細な内部構成図が確認できます。 

RTL View Technology View 

(参考)作成したデザインの確認 
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デザインコンパイル 

■論理合成が完了すると、生成されたネットリスト(.edf)  が自動でプロジェクトに追加されています。 
  この状態でRun Allを実行し、コンパイルを行います。 

Run Allをダブルクリックしてコンパイル 

を行います。段階毎にコンパイルを行いたい
場合はRun Allを実行せずに、 

- Import P&R Input Files 

- Run Placer (配置) 

- Pun Router (配線) 

- Generate Bitmap (書込みデータ生成) 

のうち実施したいプロセスをダブル 

クリックして実行することも可能です。 

レポートファイル、ログファイル、 

ビットマップファイル3種、 

Timing Simulation用遅延ファイル 

が生成されます。 

Run All実行後、全プロセスに 

チェックが付けばコンパイル 

完了です。 
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Timing Constraints Editorによるタイミング制約設定 

■iCEcube2からTiming Constraints Editorを起動します。P&R FlowでImport P&R Input Filesまで実行すると、 
  Timing Constraints Editorが起動できるようになります。 

①Import P&R input Filesまで実行。 

③制約設定タブが開きます。 

②Timing Constraints Editorを起動。 
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クロック信号定義と最大動作周波数（Fmax）制約の設定 

②設定を有効にする行に
チェックを入れます。 

③プルダウンメニューから 

クロック信号を選択。 

④動作周波数制約として 

クロック周期を設定します。 

①Clocksタブを選択。 

■Clockタブにてクロック信号を設定します。ここで設定された信号がクロックとして認識され、Input DelayやOutput Delay 
  制約でクロック信号として設定できるようになります。また、ここで設定しなかったクロックは、Setup/Holdタイミング 
  解析時にもクロック信号として認識されずに、誤ったクロック信号での解析がされるケースがありますので、デザイン上の 
  クロック信号は必ずここで設定しておくことを推奨します。 
  また、最大動作周波数(Fmax)の設定もClocksタブにて同時に行います。 

【オプション】 

クロックの立ち上がりポイ
ントと立下りポイントを設
定します。この例では10ns

の周期のクロックの0nsで
立ち上がり、5nsで立ち下
がる(Duty 50:50)設定にな
ります。 
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Setup Time (Input Delay)制約の設定 

■Setup Time制約はInput Delayタブで設定します。Input Delayとは下図のように入力データのクロックに対する遅延量の 
  設定で、前段デバイスのClock to Output Timeに相当します。iCEcube2ではこの値から以下のようにSetup Timeを 
  計算して制約に用います。 

Setup Time = T - Input Delay 

Hold Time = Input Delay 

①Input Delayタブを選択。 

②設定を有効にする行に
チェックを入れます。 

③プルダウンメニューから 

データ信号を選択。 

④プルダウンメニューから 

クロック信号を選択。 

※Clockタブで制約設定され
ているクロックのみ有効。 

⑤Input Delay量を入力。 

【オプション】 

立下りエッジからのDelayを設
定する場合、Clock FallとAdd 

Delayにチェックを入れます。 
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■Clock to Output Time制約はOutput Delayタブで設定します。Output Delayとは下図のように出力データを 
  ラッチするクロックエッジのデータに対する遅延の設定で、後段デバイスのSetup Timeに相当します。 
  iCEcube2ではこの値から以下のようにClock to Output Timeを計算して制約に用います。 

Clock to Output Time (Output Delay)制約の設定 

Clock to Output Time = T - Output Delay 

①Output Delayタブを選択。 

②設定を有効にする行に
チェックを入れます。 

③プルダウンメニューから 

データ信号を選択。 

④プルダウンメニューから 

クロック信号を選択。 

※Clockタブで制約設定され
ているクロックのみ有効。 

⑤Output Delay量を入力。 

【オプション】 

立下りエッジからのDelayを設
定する場合、Clock FallとAdd 

Delayにチェックを入れます。 
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Max Delay制約の設定 

■Max Delay制約はMax-delayタブで設定します。Max Delay制約はあるピンから入力されたデータが別のピンから出力される 
  までの遅延制約になります。 

①Output Delayタブを選択。 

②設定を有効にする行に
チェックを入れます。 

③遅延量を設定します。 ④プルダウンメニューから 

データ入力ピンを選択。 
⑤プルダウンメニューから
データ出力ピンを選択。 
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Timing Constraints Editorの再起動 

設定した制約はConstraint Fileの下に 

sdcファイルとしてインポートされます。 

Import PAR Input Filesまで実行した後、 

このsdcファイルをダブルクリックする
ことで再度Timng Constraints Editorの
GUIを起動でき、編集可能です。 
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Pin Constraint Editorによるピンアサイメント 

■Pin Constraints Editorでピンアサイメントを行うことができます。 

①Pin Constraints Editor

を起動。 【重要】 

Lockedには必ずチェックを入れて下
さい。チェックを入れていないと
Saveを行ってもRun Allを実行する
と設定が消えてしまいます。 

②ピン番号、IOスタンダード、
Pullモードを設定します。 

EditorをSaveするとメッセージが出て制約ファ
イルがプロジェクトに追加されますので、追加
後に再度Run Allを実施して下さい。 

再編集はPin Constraints Editorを再起動すれば
実施できます。 
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■Package ViewでGUIにてピンアサイメントを行うことができます。 

Package Viewによるピンアサイメント 

①Package View

をクリック 

②GUI上でドラッグ&ドロップによりピン配置
を行います。 

【重要】 

配置後は必ず右クリックのメニューからLock

を選択して下さい。LockせずにRun Allを実行
すると、設定が消えてしまいます。 

IOスタンダードやPullモードを設定する 

には、GUIまたはPortリストで信号を 

右クリックし、Edit Pin Constraintを選択
して以下のWindowを開き、設定します。 

Package ViewをSaveするとメッセージが
出て制約ファイルがプロジェクトに追加さ
れますので、追加後に再度Run Allを実施
して下さい。 

再編集はPackage Viewを再起動すれば実
施できます。 
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タイミング結果の確認 

■タイミング制約に対して、コンパイル後の結果がどのようになっているかレポートファイル(.rpt)またはTiming Analyzer 
  にて確認が行えます。ここではTiming Analyzerによる確認方法を説明します。 

Timing Analyzerを起動。 

Timing Analyzerタブが開きます。 
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最大動作周波数（Fmax）の確認 

②制約設定されているクロックに対して、コンパイル 

結果が表示されます。任意のクロックをクリックすると、
下にそのクロックドメイン内でのワーストパスが表示 

されます。 

②上に表示されているリストのうち、クリック 

したクロックドメイン内でのワーストパスが表示 

されます。 

タイミング結果 制約値 

■最大動作周波数の確認はClock Summaryにて行います。 

※Slack = データ遅延要求(Required Time) －実際のワーストデータ遅延(Arrival Time) 

 この値がプラスであれば制約をミートしています。また値が大きい程、制約に対して 

  タイミングマージンが多いことを意味します。 

①Clock Summaryを選択。 

③詳細表示ボタンをクリックすると、 

Detailウィンドウが展開し、ワースト
パスの詳細が確認できます。 
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最大動作周波数（Fmax）の確認 

■Path Detailの見方は以下の通りです。 

ワーストパスの起点(前段FF)と終点(後段FF)の情報 

後段FFまでのクロック遅延と、後段FFのSetup Time 

前段FFまでのクロック遅延、前段FFのTco、データパス遅延 

[Fmax 計算式] 

1 / {FF_Tco + Routing + FF_Tsu - (後段Clock Path Delay - 前段Clock Path Delay)} 

前段FFから出力される
データが後段FFに到達す

るタイミング 

この立上がりで前段
FFからデータ出力 

FF Tco 
+ Data Path Delay 

+ FF Tsu  

後段FFでデータを
叩ける限界ライン 

Clock SkewはSetupマージンの増減に関係 

レポート内容を計算式にあてはめると、 

364 + 6111 + 440 - (1877 – 1877)  = 6915 ps = 6.915 ns 

1 / 6.915 ns ≒ 144.61 MHz 
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最大動作周波数（Fmax）の確認 

■Output Delay制約がかかっており、最終段レジスタから出力ピンまでの遅延がワーストパスになる場合、 
  クロック周期からOutput Delay設定値を引いた遅延量が最大動作周波数制約となり、結果に反映されます。 

例えば最大動作周波数周波数制約100MHzでOutput Delay制約 

3nsの場合、100MHzクロックの周期10nsから次段デバイスの 

Setup Time 3nsを引いた7nsと最終段レジスタからピンまでの 

遅延が評価されます。 

許容される遅延量 

 = クロック周波数 - 次段デバイスのSetup Time (Output Delay) 

 

最大動作周波数制約100MHz(10ns)で、Output Delay制約3ns 

をかけている場合、最終段レジスタからピンまでの遅延が 

10 -3 = 7ns以上発生すると次段デバイスの初段レジスタで 

データをラッチできないため、タイミング違反となります。 



Xxxxxx_revxx.ppt 

Page 26 

Setup Time / Hold Timeの確認 

■Setup Time / Hold TimeはDatasheetタブにて確認できます。 

②Input Pad to FFを選択して、
Setup Time / Hold Timeの確認し
たい方のタブを選択します。 

タイミング結果 

①Datasheetタブを選択。 

Timing Cornerをクリックすると、PVTバラつきが
Best/Typical/Worstのそれぞれのケースを選択でき
ます。Setup Time/ Hold TimeはBest / Worstのど
ちらでワースト値になるかケースバイケースなの
で両方とも確認するようにしてください。 
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Clock to Output Delay (Tco)の確認 

■Clock to Output Delay (Tco)はDatasheetタブにて確認できます。 

タイミング結果 

①Datasheetタブを選択。 

②FF to Output Padを選択して、
Min Tco/ Max Tcoの確認したい
方のタブを選択します。 

Timing Cornerをクリックすると、PVTバラつきが
Best/Typical/Worstのそれぞれのケースを選択でき
ます。TcoはBest / Worstのどちらでワースト値に
なるかケースバイケースなので両方とも確認する
ようにしてください。 
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ピン間Max Delay / Min Delayの確認 

■ピン間のMax Delay/Min DelayはDatasheetタブにて確認できます。 

タイミング結果 

①Datasheetタブを選択。 

②Pad to Padを選択して 

Min Delay/ Max Delayの 

確認したい方のタブを 

選択します。 

Timing Cornerをクリックすると、PVTバラつきが
Best/Typical/Worstのそれぞれのケースを選択でき
ます。PVTバラつきを考慮して確認を行うために
も、Best/Worstの両方のケースでの確認をお勧め
します。 
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Multi Cycle Pathの確認 

■Multi Cycle Pathの確認はAnalyze Pathesタブで該当パスをサーチして確認します。 

③Clock to Clockタブで制約をかけ
たクロックドメインを選択。 

④立上り/立下りを選択します。 

⑤Searchをクリックして
Path Summaryウィンドウ
に該当パスを表示します。 

Path Summaryウィンドウで該当パス
を選択し、詳細表示ボタンをクリッ
クしてPath Detailを表示し、タイミ
ングを確認します。 

タイミング結果を確認 

①Analyze Pathを選択。 

②By Slackを選択。 
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Multi Cycle Pathの確認 

■Analyze Pathで該当パスをサーチする方法以外に、Clock Relationship Summaryにて制約設定を行った 
  クロックドメインの項目を探し、Path Detailにて確認することもできます。 

②制約設定を行ったクロックドメイン
の項目を探し、Path Detailを表示。 

タイミング結果を確認 

①Clock Relationship Summaryを選択。 
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消費電力の見積もり 

■消費電力の見積もりはPower Estimatorで行います。 

①Power Estimatorを起動します。 

②Core Voltage, IO Voltageを設定します。 

③解析デバイス条件をTypical/Worstから
選択します。 

④ジャンクション温度（Tj）を設定します。 
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消費電力の見積もり 

■動作クロック周波数と、内部ロジックセルのスイッチングレート、I/Oスイッチングレートを入力します。 

①動作クロック周波数を設定。 

③I/Oのスイッチングレートを設定します。 

※デフォルトでクロック周波数の12.5%が設定されます。 

④出力先デバイスの負荷容量を設定します。 

※デフォルトで10pfが設定されています。 

②内部ロジックのスイッチングレートを設定します。 

※デフォルトでクロック周波数の6.25%が設定されます。 
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消費電力の見積もり 

■設定完了後、Calculateをクリックして消費電力見積もり結果を表示します。 

①Calculateをクリック。 

②消費電力見積もり結果が 

表示されます。 
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iCEcableを用いたデザインの書込み 

■オンボードにコンフィグレーション用のSPIフラッシュを用意している場合、以下のフローで書込みを行います。 

③使用するROMを選択。 

※選択可能なROMは動作確認が取れている以下の5種類です。 

 M25P20 (ST-Micro製) 

 M25P16 (ST-Micro製) 

 M25P32 (ST-Micro製) 

 M25P80 (ST-Micro製) 

 PMOD (3rdベンダー製 SPI Flash ROMモジュール) 

④Image Typeを選択します。 
■Single Image 

 ⇒ SPI FlashにConfig Dataを1種類のみ書き込みます。 

■Multiple Image 

 ⇒ SPI FlashにConfig Dataを複数(最大4つ)書き込みます。 

   どのデータでコンフィグするかはツールでスタティックに 

   選択する方法と、専用ピン(CBSEL[1:0])からダイナミック 

   に選択する方法があります。 

②iCE Cableを選択。 

①Programmerを起動。 

⑤Image File Settingsから書込みデータ 

に関する設定を入力します。 

詳細は次ページ以降で説明します。 
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iCEcableを用いたデザインの書込み 

■Image TypeでSingle Imageを選択している場合の操作は以下の通りです。 

①プロジェクト内で既にConfig Fileが生成されて 

いる場合はデフォルトでそのデータが設定されて 

います。別のデータを選択する場合はブラウズ 

ボタンからファイル(.hex)を選択しなおします。 

②ファイルフォーマットは 

Raw HexadecimalのままでOKです。 

③OKをクリックし、設定を完了。 

④Executeをクリックすると 

書き込みが実行されます。 
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④Executeをクリックすると 

書き込みが実行されます。 

■Image TypeでMultiple Imageを選択している場合の操作は以下の通りです。 

iCEcableを用いたデザインの書込み 

①Enable Cold Bootにチェックを入れると、専用 

ピンからダイナミックにコンフィグデータを選択 

する設定になります。チェックを外した場合は 

下のボックスで0-3番目のどのデータでコンフィグ 

するかを選択します。 

②Config Dataを4つまで選択します(データは予め用意
しておく必要があります)。ブラウズボタンからデータ
を選択して下さい。各データを書き込むStart Address

の設定はデフォルトのままで構いません。 

※SPI Flashの容量を超える分のデータ数をセットした
場合、そのデータでのコンフィグはできません。 

③OKをクリックし、設定を完了。 



Xxxxxx_revxx.ppt 

Page 37 

Section 2 : 

専用モジュールの作成 
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■RAMモジュール等の生成はSynplify PROにて行います。論理合成時の手順でSynplify PROを起動し、SYNCoreを 
  立ち上げて、作成したいモジュールを選択し、パラメータを設定して生成します。 

RAMモジュールの生成 

①SYNCoreを起動。 

②生成したいRAMモジュールを選択。 

③各種パラメータを設定。 

④Generateをクリック。 
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PLLの生成 

■PLLの生成は PLL Module Generatorにて行います。 

②新規作成の場合はCreate a new PLL configuration 

を選択し、PLLモジュール名を入力します。 

既存のPLLモジュールの設定変更を行う場合は
Modify an existing PLL configurationを選択し、 

PLLソースを選択します。 

③OKをクリックすると次ページ以降に
記載のPLL設定画面が開きます。 

①Tool > Configure PLL Moduleから 

PLL Module Generatorを起動。 
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PLLの生成 

PLL出力を何ポートGlobal Clock Network

に接続するか選択します。（1 or 2） 

■General Purpose IO Pad or Core Logic 

 ⇒ PLL入力クロックが汎用I/O からの入力クロック、または内部ロジックで生成 

  したゲートクロックの場合に選択します。 

■Dedicated Clock Pad (Single Ended) 

 ⇒ PLL入力クロックがクロック入力専用ピンからの入力クロックの場合に 選択 

  します。こちらを選択した場合、入力クロックを分岐させてFPGA内部で使用 

  することはできません。そのため、入力クロックをFPGA内で使用したい場合 

  はGlobal Clock Networkを2本ドライブする設定にし、下のチェックボックスに 

  チェックを入れることで、Port Aより入力クロックがそのまま出力されるので、 

  このクロックを使用します。 

■Dedicated Clock Pad (TMDS) 

 ⇒ PLL入力クロックがクロック入力専用ピンから作動信号で入力される場合に 

   選択します。 
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PLL出力クロックの生成方法についての設定です。 

■Using a feedback path internal to the PLL (PLL内部フィードバックパス使用） 

 - No Compensation  

 ⇒ 周波数設定のみ有効。 

 - Delay Compensation using only the Fine Delay Adjustment Block 

 ⇒ 周波数設定と遅延微調整が有効。 

 - Delay Compensation using the Phase Shifter and the Fine Delay Adjustment Block 

 ⇒ 周波数設定、遅延微調整、位相シフト機能が有効 

■Using a feedback path external to the PLL (PLLの外からのフィードバックを使用） 

PLLの生成 
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遅延微調整機能のコントロール方法をダイナミックかスタティックか選択します。 

遅延微調整機能が有効なPLLモードの場合にのみ設定できます。 

■Yes 

 ⇒ デバイス動作中にダイナミックに遅延調整を行います。遅延調整用のポートが   

   PLLに追加されます。 

■No 

 ⇒ 本設定画面で設定した遅延設定値で固定します。設定値は0～15で選択でき、 

   (n+1) x 165ps(TYP) で遅延します。  

PLLの生成 
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PLL位相シフト量の設定です。 

 - 1ポートGlobal Clock Networkに接続されるPLLタイプ 

 - 2ポートGlobal Clock Networkに接続される設定で、入力クロックを遅延調整、位相シフト無効で 

 出力するチェックボックス（P32参照）にチェックが入っているタイプ 

に対して、0deg or 90deg から選びます。位相シフトはPort Bに反映され、Port Aに対して  

0degまたは90degシフトします。 

PLLの生成 

上記以外のPLLタイプの場合、位相シフト設定がターゲットアプリケーション設定に変化します。 

■LVDS Display Panel 

 ⇒ x7、x3.5逓倍モードが使用できるようになります。Port Bの周波数を 

   Port Aの周波数のx7 または x3.5のいずれにするか選択します。 

■DDR Application 

 ⇒ Port Bの位相をPort Aに対して0degまたは90degシフトのいずれにするか 選択します。 
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PLLの生成 

Port Aに対しての追加遅延微調整の設定をします。P34に記載の遅延調整に追加でPort A 

に対してのみ、さらに(n+1) x 165ps(TYP) の遅延を加えます。Port A設定が不可のPLL 

タイプ（入力クロックを遅延調整、位相シフト無効で出力するタイプ）に関してはこの 

設定はできません。 
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PLLの生成 

■PLL Input/Output Frequency 

 ⇒ PLL入力クロック周波数と出力クロック周波数を設定します。 

■Others 

- Create a LOCK output port 

 ⇒PLLのロックステータス出力ポートを追加します。 

- Create a BYPASS port that will bypass the PLL reference clock to the PLL output port 

 ⇒ PLLをパワーダウンモードにし、入力クロックをそのまま出力クロックに出力 

   するBypass制御ポートを追加します。 

- Low Power Mode 

 ⇒ iCEGateの制御ポートの有無を設定します。iCEGate有効時、出力クロックは 

   前値保持し、トグルを抑えることで電力消費を抑えます。 
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Section 3 : 

論理シミュレーション 
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Active-HDLを使用したFunction Simulation 

■Lattice社ではシミュレーションツールとしてActive-HDLがバンドルされています。 
  iCEcube2上からSimulation Wizardを使用してActive-HDLプロジェクトを生成します。 

①Simulation Wizardを起動。 

②プロジェクト名を入力。 

③Nextをクリック。 
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①RTLを選択。 

②Nextをクリック。 

④テストベンチを選択して 

“開く”をクリック。 

⑤テストベンチインポート後、
Nextをクリック。 

■以下の手順でActive-HDLプロジェクトを作成します。 

Active-HDLを使用したFunction Simulation 

⑥Finishをクリックして
Active-HDLを起動。 

③Add Fileアイコンをクリック 

してテストベンチをインポート 
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Active-HDLを使用したFunction Simulation 

■Active-HDL起動後、Design > Compile Allでコンパイルを実行します。 

Compile All を実行。 

インポートした全てのファイルに緑のチェック
マークが付けばコンパイル完了です。 
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③Waveform Windowを開きます。 

①Structureタブを選択。 

②Top-Level Selectionでテスト
ベンチを選択します。 

■シミュレーショントップモジュールを選択し、Waveform Windowを開きます。 

Active-HDLを使用したFunction Simulation 
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■Simulation > Initialize Simulation を実行します。 

Active-HDLを使用したFunction Simulation 
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Active-HDLを使用したFunction Simulation 

■観測する信号をWaveform Windowにドラッグ＆ドロップし、シミュレーションを実行します。 

①観測する信号が含まれるモジュール
をハイライトします。 

②観測する信号をWaveform Window

にドラッグ＆ドロップします。 

③Runアイコンでシミュレーションを
開始し、Stopアイコンで停止します。 
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波形拡大、縮小、Zoom to Fit(波形全体表示) 

ツールで希望の倍率に変更できます。 

任意拡大ツールで拡大したい 

場所を選択して拡大できます。 

右クリックから”Add Cursor”でカーソ
ルを追加し、カーソル間の時間を確認
することができます。 

Active-HDLを使用したFunction Simulation 
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■シミュレーション完了後、プロジェクトを保存して終了します。 

Active-HDLを使用したFunction Simulation 

①Saveをクリック 

②”はい”をクリック 

③Noをクリック 

④Saveをクリック 
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Active-HDLを使用したFunction Simulation 

■次回以降再度プロジェクトを開く場合は、スタートメニューより、プログラム > Lattice iCEcube2 201x_xx > avhdl  
  を起動し、File > Open Workspace/Design Explorer からプロジェクトを開きます。 

①Open Workspace/Design Explorerを選択。 

②Attach and Openを選択。 

③該当のawsファイルを開きます。 
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（参考）Active-HDLを使用したTiming Simulation 

■Timing Simulationも基本操作はFunction Simulationの場合と同じですが、Simulation Wizardにて 
  “Post-Route Cell-Level+Timing”を選択する箇所と、Active-HDL上で遅延情報の有効化を行う箇所が異なります。 

P46に記載のフロー中で”Post-Route Cell-Level+Timing”を 

選択します。ソースファイルのインポート画面にて自動で 

遅延情報ファイル（SDF）がインポートされます。 

なお、ここでもテストベンチは手動でインポートして下さい。 

Post-Route Cell-Level+Timingを
選択し、設計言語を選択します。 

テストベンチは手動で 

インポートします。 

SDFファイルは自動で
インポートされます。 

Active-HDL起動後は、All Compileを実行し、Top-Level Selection 

でテストベンチ選択後、Design > Setting > SDF と進み、遅延情報 

の有効化を行います。 

LoadをYesに設定します。 
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■シミュレーション開始前に、Synplify PROでFunction Simulation Model（ vmファイル、vhmファイル）を生成する 
  必要があります。Synplify PROを起動し、以下の手順で を生成します。 
  vmファイルはVelilogソースでのシミュレーション、vhmファイルはVHDLソースでのシミュレーションに使用します。 
 
  ※本マニュアルではVerilogソースでのシミュレーションについて説明を行います。 

①Symplify PROを起動。 

②Inplementation Options

を起動。 

④”Write Mapped Verilog Netlist”と 

“Write Mapped VHDL Netlist”に 

チェックを入れる。 

⑤OKをクリックし、
Synplify PROトップ画面
でRUNを実行する。 

③Implementation Result

タブを選択 

vmファイル、vhmファイルはプロジェクトフォルダ内の 

<プロジェクト名>_Inplmnt/ に生成されます。 

※Model SimはLattice社から無償提供されておりません。予め別途Mentor Graphics社より購入して 
  下さい。また、PLLのライブラリはVerilog用のみ用意されておりますので、VHDLでシミュレーション 
  を行う場合はMixed Signal対応バージョンのModel Simをご用意下さい。 

（参考）Model Simを使用したFunction Simulation 
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（参考）Model Simを使用したFunction Simulation 

■Model Simを起動し、File > New > Project から新規プロジェクトを作成します。 

①Projectを選択。 

②プロジェクト名を入力。 

③Browseからプロジェクト
フォルダを選択。 

④OKをクリック。 
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■テストベンチ、iCEライブラリ、シミュレーション用モジュール（vm、vhmファイル）をインポートします。 

①Add Existing Fileをクリック。 
②Browseをクリックし、ファイル
選択ウィンドウを開きます。 

③テストベンチ、iCEライブラリ、vmファイルをインポートします。 
 

※iCEライブラリは以下のフォルダに用意されています。 

 Verilog用 : <iCEcube2インストールディレクトリ>/Verilog 

 VHDL用 : <iCEcube2インストールディレクトリ>/VHDL 

※vm、vhmファイルの生成方法、生成場所に関してはP53を 

 参照して下さい。 

※PLLを使用しているデザインの場合、追加でPLLライブラリ 

 ”ABIPTBS8.v “, “ABIWTCZ4.v”をインポートする必要があります。 

 <iCEcube2インストールディレクトリ>/Verilog 

 に用意されています。 

④インポート完了後、Closeをクリック。 

※All Filesを選択しないとvm、vhmファイルが 

 表示されないのでご注意下さい。 

（参考）Model Simを使用したFunction Simulation 
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■ファイルインポート後、Compile > Compile All を実行します。 

Compile All を実行。 

全てのファイルに緑のチェックマーク
が付けばコンパイル完了です。 

（参考）Model Simを使用したFunction Simulation 
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①Start Simulationを実行。 

②テストベンチを選択。 

■Simulate > Start Simulationを実行し、テストベンチを選択します。 

（参考）Model Simを使用したFunction Simulation 
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■観測する信号をWaveウィンドウにドラッグ＆ドロップし、シミュレーションを実行します。 

①観測する信号が含まれるモジュール
をハイライトします。 

②Objectsウィンドウから観測する
信号をWave Windowにドラッグ＆
ドロップします。 

③Run、Run-All、Breakを使用して 

シミュレーションを実行します。 

※各種ウィンドウが表示されていない
場合は、Viewから開くことができます。 

（参考）Model Simを使用したFunction Simulation 
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