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はじめに

◼ 本マニュアルはLattice社FPGAデバイス設計ツールRadiantのオペレーションフローマニュアルです

◼ 新規プロジェクトの作成からデバイスへのフィッティングまでの一連のフローを解説したものです

◼ 各項目の詳細については、別途LatticeのユーザーマニュアルもしくはツールのHelpをご参照頂くか
弊社技術サポートまでお問い合わせ下さい

◼ 本マニュアルとLattice社マニュアルに差異があった場合、Lattice社マニュアルを正として扱うよう
お願い致します
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1. プロジェクト作成～デザインエントリー



Lattice Radiant Softwareの起動～新規Project作成

◼ Windowsのスタート > 全てのプログラム> Lattice Radiant Software x.x > Radiant 
Softwareまたは、デスクトップやタスクバーに配置したショートカットアイコン からRadiantを起動します。

◼ 画面上のNew Projectアイコン をクリック、またはFile > New > Projectでプロジェクト作成
Windowを開きます。
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Lattice Radiant Softwareの起動～新規Project作成

①NextをクリックしてProject作成

◼ 以下のフローに従い新規プロジェクトを作成します
◼ フォルダ名は半角英数のみで入力し、フォルダパスに全角やスペースが入らないようにして下さい

②Projectフォルダ名とProjectフォルダのロケーションを入力
 ロケーションはBrowseで選択することが可能です

③Implementationフォルダ名を入力
（*Implementationについては後述）

④Nextをクリック



◼ 以下のフローに従い新規プロジェクトを作成します
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Lattice Radiant Softwareの起動～新規Project作成

⑤プロジェクトにインポートするソースファイルを選択
（プロジェクト作成後でもインポート可能です）

⑥Nextをクリック

⑦設計対象のデバイスファミリー、デバイス型名を選択

⑧温度グレード、パッケージ、スピードグレードを選択

⑨Nextをクリック



◼ 以下のフローに従い新規プロジェクトを作成します
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⑩論理合成ツールを選択

Simplify Pro :
Synopsys社の論理合成ツールを使用します

Lattice LSE :
Lattice社のオリジナル論理合成ツールを使用します

*LSEはLattice社デバイスへの最適なフィッティングを目指して
開発されていますが、市場での使用実績、安定性を重視
される場合、Simplify Proの使用をお勧めします

⑪Nextをクリック

Lattice Radiant Softwareの起動～新規Project作成

⑫Finishをクリック



（参考）Implementationについて

◼ Radiantは作成したProject単位で管理を行います
◼ Projectの下にさらに複数のサブProjectを構成でき、サブProjectごとに違う設計データを持たせて

デザインの管理を行うことができます。このサブProjectをImplementationと呼びます
◼ Implementation毎にStrategy（コンパイルオプション）や制約を持たせることができ、全ての

Implementationを並列にコンパイルさせ、それぞれのコンパイル結果を比較することもできます

Implementation = サブProject

プロジェクト作成時はデフォルトの
Implementationを作成します
作成後に他のImplementationを
追加することが可能です
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既存プロジェクトのオープン

◼ 画面上のOpen Projectアイコン をクリック、またはFile > Open > Projectで既存プロジェクトの
拡張子.rdfファイルを開きます

拡張子.rdfファイルを開きます



Project Navigator

◼ プロジェクトを新規作成、または既存プロジェクトをオープンすると以下のProject Navigatorの
GUIが開きます
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*各ビュー右上のDetach Viewボタン  でビューを別ウィンドウに切り離して大きく表示できます

Project Navigator
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■Toolbar
ファイル追加、制約設定、消費電力見積もり、シミュレーション等を実行する各種ツールのアイコン

■Process Toolbar
論理合成、マッピング、配置配線、ファイル出力の
プロセスはここで実行します

■Message View
プロセス進行状況、エラー、ワーニングメッセージ等表示されます
確認したいメッセージをタブで切り替えます

■Tool View
制約設定ツール、配置配線状況確認ツール、レポートビューワ等
各種ツールが開きます。複数ツールの表示をタブで切替えます■Project View

・インポート済みファイルリスト/ソース階層表示
・ソーステンプレートの表示
・専用モジュール/IPの生成画面表示
をタブで切り替えて表示します



◼ New Fileウィンドウを以下のいずれかの方法で開きます

A) File > New > File を選択

B) Newアイコン をクリック

C) Implementation名を右クリック > Add > New File
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新規デザインエントリー



◼ New Fileウィンドウが開いたら以下の手順で新規ソースコードを作成します
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①Source Filesの一覧から使用
する言語に応じてVerilog Files

 またはVHDL Filesを選択します

②ファイル名を入力します

③Newをクリックします

新規デザインエントリー
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新規デザインエントリー

◼ 新規ソースコードは自動でプロジェクトにインポートされます
◼ 同時にSource Editorが開き、そのままソースコード編集が可能です



◼ 既存のソースコードはFile > Add > Existing FileもしくはImplementation名を右クリックして   
Add > Existing Fileを選択します

◼ Add Existing Fileウィンドウが開きますので、インポートしたいソースコードを選択します
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既存デザインエントリー



◼ Project View下部のタブからIP Catalogを選択、もしくはToolbarからIP Catalogアイコン を
クリックします

◼ 生成したいモジュールをダブルクリック（ここでは例としてPLLを選択）

専用モジュールの生成

16

①IP Catalogタブ、もしくはアイコンをクリックして開く

②生成したいモジュールをダブルクリック



*モジュールのパラメータ内容の詳細に関しては Lattice社HPに掲載されている
各デバイスの専用モジュール向けに用意されたApplication Noteや
Project Navigator上部のHelpからLattice Radiant Software Helpを
ご参照下さい

◼ Module/IP Block Wizardが開きますので、以下の手順でモジュールを生成します

専用モジュールの生成
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③モジュール名を入力

④Nextをクリック

⑤モジュールの各種パラメータを設定

⑥Calculateボタンがある場合、クリックして
 デザインルールチェックを実行

⑦Generateをクリック
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専用モジュールの生成

⑧Finishをクリック

左図のInsert to Projectにチェックが入っている
場合、生成したモジュールが自動でプロジェクトに
インポートされます



（参考）専用モジュールのファイル構成
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xxx.ipx
→ 生成したモジュールの管理ファイルです。ダブルクリックするとモジュールの

編集画面が開きます。このファイルがインポートされている場合のみ
以下の構成ファイルがプロジェクトビューに同時表示されます

xxx.v
→ モジュールのソースファイルです。このソースファイルかipxファイルの

いずれかがプロジェクトにインポートされている必要があります

xxx.Ldc
→ モジュールに付帯する制約ファイルです

xxx.tb_top.v
→ 生成したモジュールのシミュレーション用テストベンチファイルです

xxx.cfg
→ モジュールのコンフィグレーションファイルです。モジュール構成の概要を

示しています
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（参考）Source Template

◼ Project View下部のSource Templateを開くと各デバイスに用意されたコンポーネント（専用モ
ジュールやFF、I/Oバッファ等）のプリミティブ記述を参照したり、ユーザーがよく使うソース記述をテンプ
レートとして記憶させることができます

◼ 主ににユーザーのテンプレート記憶用途として使用して下さい。こちらに用意されているプリミティブ記述
をソースファイルに記述して使用することは特定の場合を除き基本的に推奨致しません。必要な専用
モジュールはIP Catalogから生成して使用して下さい。

Source Templateからプリミティブ
記述を参照できますが、特定用途を
除き、基本的に使用を推奨しており
ません。専用マクロはIP Catalogから
生成して下さい

User Templateに新規テンプレート
を追加し、Copy & Pasteで使用
することは問題ありません



デザインエントリー確認
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◼ デザインエントリーが正しく行われた場合、ツールがTopモジュールを自動認識し、太字で表示します
◼ 同時にProject View下部のモジュール階層構造が正しく表示されます

デザインの階層構造が表示されます

Topモジュールが太字で表示されます



論理合成の実行
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◼ Process ToolbarのSynthesize Designをクリックして論理合成を実行します
◼ 論理合成が成功すると緑のチェックマークが表示されます
◼ 各プロセス実行時に出力するファイルはExport Files右側のアイコンをクリックすることで設定可能です

ダブルクリックで論理合成実行
成功すると緑のチェックマークが表示されます

失敗した場合は赤色のチェックマークが表示
されますので、ソース記述やデザインエントリー
が正しいか確認して下さい

各プロセスの出力ファイルの設定が可能です



◼ Synplify Proに付属のRTL Viewで論理合成後の回路がシンボル接続で表示できます
◼ Process ToolbarのSynplify Proアイコン をクリックして立ち上げ、論理合成を実行します
◼ Synplify Pro上のRTL Vewアイコンをクリックします

（参考）Synplify ProによるRTL Viewの確認
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①Synplify Proを起動

②論理合成を実行

③RTL Viewを表示



24

2. タイミング制約の設定



Timing Constraint Editor
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◼ タイミング制約の設定はTiming Constraint Editorで行います
◼ Synthesize Designが完了している状態でTools > Timing Constraint Editor > Post 

Synthesis Timing Constraint Editorもしくは、ToolbarのTiming Constraint Editor
アイコン からPost Synthesis Timing Constraint Editorを開きます



◼ Fmax制約の設定はClockタブもしくはGenerated Clockタブで行います
◼ Object Clockセルをダブルクリックすると、クロックタイプの選択画面を表示させることができます
◼ 下図を参照してクロックタイプを選択し、その他のパラメータを設定します
◼ 制約を削除する場合は右クリックでRemove Rowを選択するか、Disableにチェックを入れることで設定

そのものは残したまま制約を外すことができます

Fmax（最大動作周波数）制約
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■Object Type

・CLOCKPORT : ピンからの入力クロック信号
・CLOCKPIN : インスタンスまたはピンからのクロック信号
・CLOCKNET : 内部クロック信号

*ピン入力クロックに制約をかける場合は、CLOCKPIN
  ではなくCLOCKPORTを選択して下さい

■Clock Name
クロック名。Object Clockを選択すると自動で入力さ
れます

■Waveform (ns)
クロックデューティを設定できます。例えば周期50nsのク
ロックに対し、0;25と設定した場合、0nsで立ち上がり、
25nsで立ち下がる設定になり、デューティ比50:50の
制約になります。空欄の場合、デューティ比は50:50に
なります

■Period (ns) / Frequency (ns)
クロックの周期 / 周波数を入力します。どちらか片方を
入力すると他方は自動入力されます



◼ Generated Clockタブでは内部生成クロックに対して制約を設定できます
◼ Object Clockセルをダブルクリックすると、クロックタイプの選択画面を表示させることができます
◼ 内部PLLで生成するクロック等はここに自動で制約が入力されます

Fmax（最大動作周波数）制約
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■Object Clock
制約対象の内部生成クロック信号を選択します

■Source
その内部生成クロックの元となるソースクロックを選択します

■Name
Object Clockを選択すると自動で入力されます

■Divide Factor / Multiply Factor
ソースクロックから見た分周率 or 低倍率を入力します

■Duty Cycle
Duty比を設定します。入力無しは50%設定です



Input Delayの設定
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◼ Input Delayとは入力データのクロックに対する遅延設定で、クロック周期からSetup Timeを
引いた値、つまり前段デバイスのClock to Output Timeに相当します

◼ 下図を参照して制約を与えるポートと基準クロック、パラメータを設定します

■Constraint Type
ここではInput Delay制約を選択します

■Port
制約対象となるデータ入力ポートを選択します

■Clock
制約の基準クロックを選択します

■Clock Fall
クロックの立下りエッジを基準として制約をかける場合にチェックを入
れます

■Max / Min
制約が最大遅延（Max）に対するものか、最小遅延（Min）に
対するものかを選択します

■Value
遅延量を設定します。デバイスのMin Setup Timeの値が T -
Input Delay(Max)より小さくならないように設定します。また、デ
バイスのMin Hold TimeがInput Delay (Min)より小さくならな
いように設定します

■Add Delay
同一データパスに複数の制約をかける際にチェックします。例えば同
一のデータパスに同じクロックの立上がりと立下りの両方に対して制
約をかける場合、Add Delayにチェックを入れないと前の制約が後
に追加されている制約に上書きされます

Setup Time = T - Input Delay
Hold Time = Input Delay



Output Delayの設定
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◼ Output Delayとは出力データをラッチするクロックエッジのデータに対する遅延の設定で、クロック
周期からClock To Output Timeを引いた値、つまり後段デバイスのSetup Timeに相当します

◼ 下図を参照して制約を与えるポートと基準クロック、パラメータを設定します

■Constraint Type
ここではOutput Delay制約を選択します

■Port
制約対象となるデータ出力ポートを選択します

■Clock
制約の基準クロックを選択します

■Clock Fall
クロックの立下りエッジを基準として制約をかける場合にチェックを入
れます

■Max / Min
制約が最大遅延（Max）に対するものか、最小遅延（Min）に
対するものかを選択します

■Value
遅延量を設定します。後段デバイスのMin Setup Timeの値がよ
りもOutput Delay(Min)が小さくならないように設定します。また、
後段デバイスのMin Hold TimeよりもT - Output 
Delay(Max)が小さくならないように設定します

■Add Delay
前ページを参照して下さい

Clock to Output Time
= T - Output Delay
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その他のタイミング制約(Min/Max Delay, Multicycle, False Path)

◼ 詳細なパス間の最大・最小遅延制約、マルチサイクル制約、False Path制約はTiming 
Exceptionタブから設定可能です

◼ 非同期クロックドメインのデータ受け渡しの際のタイミング制約や、解析対象から外したいパス等は
ここから設定します

■Constraint Type
set_max_delay : 指定パス間の最大遅延制約設定
set_min_delay : 指定パス間の最小遅延制約設定
set_multicycle_path : マルチサイクルパス設定
set_false_path : 解析対象外パスの設定

■From / To
制約の起点と終点を設定します

■Max / Min delay
Max Delay制約、Min Delay制約の制約値を設定します

■Setup / Hold
マルチサイクル制約において、サイクル数Nを増すエッジをSetup
側解析エッジにするかHold側解析エッジにするか選択します
（左図の解析エッジ参照）Setup側に制約をかけると、同時に
Hold側に自動で制約がかかり、タイミングエラーとなる場合があり
ます。この場合Hold側にも個別に制約をかける必要があります

■Start / End
マルチサイクル制約のサイクル数を送信側クロックでカウントする
(start)か、受信側クロックでカウントするか(end)を選択します

■Multiplier
マルチサイクル制約のサイクル数Nを設定します

*タイミング解析における解析エッジ

Setup側 Hold側
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その他の制約(Load Capacitance)

◼ 出力ポートに対して、接続先の負荷容量の設定が可能です。出力タイミング解析時に負荷容量を
加味した解析が行われるようになります

◼ タイミング解析の他に、SSOアナライザを使用した同時スイッチングノイズの影響度解析にもここで設
定された負荷容量が使用されます

■Port
負荷容量設定を与えるポートを選択します

■Load
負荷容量値（pf）を設定します
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3. I/Oアサイメント、デバイス全般の設定



Device Constraint Editor
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◼ 入出力信号のI/OへのアサイメントDevice Constraint Editorで行います
◼ Synthesize Designが完了している状態でTools > Device Constraint Editorもしくは、

ToolbarのDevice Constraint Editorアイコン から開きます
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Device Constraint Editor

◼ Device Constraint EditorのGUIは以下のようになっています

■Package View
デバイスパッケージをそのまま可視化したも
のです。Netlist Viewからドラッグ＆ドロッ
プでピンアサインできます

■Spreadsheet View
表形式のピンアサイン含むI/O設定および
デバイス全般の設定ビューです

■Device View
Package Viewに表示する
ピンの選択ができます

■Netlist View
デザインに存在するポート、
内部信号、内部コンポーネン
トの一覧です

このアイコンで各ビューの
表示、非表示を選択で
きます



Spreadsheet View
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◼ Spreadsheet ViewのPortタブではピンアサインやI/O Type（電圧スタンダード）等を表形式の
シートで細かく設定できます

各設定項目の内容は以下の通りです

*デバイス及びI/Oバンクや入出力設定によって設定可否が変わります

PIN  : 配置したいピン番号を入力します
BANK  : 配置したいI/Oバンクを入力します(PINを設定すると、こちらも自動的に設定されます)
IO_TYPE  : I/Oスタンダードを設定します
CLAMP  : クランプダイオードのON/OFF設定です
DIFFDRIVE  : 差動出力のドライブ電流です
DIFFRESISTER : 差動入力の内部終端の使用・不使用を選択します
DRIVE  : ドライブ電流値を設定します。出力ピンにのみ設定可能です
HYSTERISYS  : 入力ピンのヒステリシス設定です
OPENDRAIN  : 出力ピンをオープンドレインにします（High出力がHi-z出力になります）
PULLMODE  : 内部プルモードを設定します
SLEWRATE  : 各デバイスに用意された出力スルーレートを設定できます。設定の差はIBISモデルで確認できます
VREF  : 参照電圧が必要な入力の参照先設定。参照先はGlobal Preferenceで設定します



Spreadsheet View
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◼ Spreadsheet ViewのPinタブではI/OのDual Functionを確認しながらピンアサインが可能です
◼ I/O TYPE等の細かい設定はPortタブで行う必要があります

①Signal Nameの欄
 をダブルクリック

②アサインしたい信号
 をドラッグ＆ドロップ

③Assignをクリック



Spreadsheet View
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◼ Spreadsheet ViewのGrobalタブではデバイスのコンフィグレーション関連ピンの有効・無効設定
等の全般的な設定を行うことができます



Package View
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◼ Package ViewではNetlist Viewに表示されているPortの信号をドラッグ&ドラッグによって
グラフィカルにピンアサインが行えます

◼ ViewでTop View/Bottom Viewの切り替えや、差動ペアの表示も可能です

アサインしたいポート
をドラッグ&ドロップ

差動ペアの表示

Top View（デバイスを表側から見た配
置）とBottom View（デバイスを裏側
から見た配置）の切り替え



（参考）SSO解析
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◼ Spreadsheet ViewのSSOタブでSSO（同時スイッチング出力）の影響確認用の設定を行い、
Package View上で影響度の確認を行うことができます

◼ 予めTiming Constraint EditorのLoad Capacitance設定で出力先の負荷容量の制約をか
けておく必要があります

①Spreadsheet ViewのSSOタブで必要な設定を行います

Outload(pf) : 出力先の負荷容量制約。Timing Constraint Editorで設定
Ground plane PCB noise (mV) : PCB上でGNDプレーンに想定されるノイズ量
Switching ID : 同時スイッチングする出力グループに同じグループ名を設定
SSO Allowance (%) : デバイスの許容値の何％を超えるとエラー表示するか設定
Power plane PCB noise (mV) : PCB上で電源プレーンに想定されるノイズ量

②Package Viewを表示し、
 Show SSO Viewを選択

③パッドにカーソルを合わせると
 解析結果が表示されます
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4. デザインコンパイル～レポート確認



配置配線の実行

41

◼ Process ToolbarのPlace & Route Designをクリックして配置配線を実行します
◼ Map Design（論理回路の実リソースへのマッピング）から順番に行っても良いですが、Place & Route 

Designを実行すれば自動的にMap Designも実行されます
◼ Map Design, Prace & Route Designが成功すると緑のチェックマークが表示されます

ダブルクリックで実行
成功すると緑のチェックマークが表示されます

失敗した場合は赤色のチェックマークが表示
されますので、リソース使用量や配線ルール
等に問題が無いか確認が必要です



Map Reportの確認
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◼ Map Reportではリソース使用状況の確認ができます
◼ Reportsアイコン をクリックし、レポート画面を表示します
◼ Reportsの項目でMap Reportsを選択します



Map (Map Report) の確認
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◼ デバイスの基本的なリソース（LUT、SLICE、Register、EBR、DSP、PLL、OSC、I/O Logic等）の
使用状況の確認はMapのDesign Summaryで行います

◼ 右上のContentsボタンにカーソルを合わせると、レポートコンテンツが表示されます
◼ 確認したいコンテンツをクリックすると、その記載箇所にジャンプします



Place & Route Reportの確認
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◼ Place & Route Reportではリソース使用状況の確認ができます
◼ Reportsの項目でPlace & Route Reportsを選択します



45

◼ Place＆Routeではデザインが使用しているリソースの使用率が確認できます
◼ リソースの使用率確認は基本的にはMap Reportで確認しますが、Place & RouteではMap Report

で確認できないクロック関連リソースの使用状況やクロック専用配線のアサイン状況が確認できます

Place & Route (Place & Route Report) の確認
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◼ Signal/Padでは配置配線後の実際のピン配置結果、Buffer Typeやその他I/O設定の反映
結果が確認できます

Signal/Pad (Place & Route Report) の確認



Place & Route Timing Analysis (Place & Route Report) の確認
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◼ Place & Route Timing Analysisでは配置配線後の静的タイミング解析（STA）結果を
確認できます

◼ 右上のContentsボタンから確認したいレポートを選択します



Place & Route Timing Analysis (Place & Route Report) の確認
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◼ 以下はCLOCK SUMMARY（Fmax解析結果）の表示例です

← 同一クロックドメイン内でのFmax解析結果

← クロックドメインを跨ぐ（非同期パス）Fmax解析結果

制約値(Target)と実際(Actual)の結果

パスが存在しない場合”No path”, False Path制約がかかっている場合
“False path“, パスが存在している場合はSlackが表示されます
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◼ 以下はTIMING ANALYSIS SUMMARYの ”3.1 Overall (Setup and Hold)” の表示例です

Place & Route Timing Analysis (Place & Route Report) の確認

← タイミング解析のカバレッジ（解析率）

← Setup側、Hold側両方の合計エラー数

← Setup側、Hold側両方のNegative Slackの合計

*Slack = 制約値に対するマージン（ns）
Negative Slack（値がマイナス表示のもの）は
タイミングマージンがマイナスであることを示しています



◼ 以下はTIMING ANALYSIS SUMMARYの ”3.2 Setup Summary Report” と
“3.3 Hold Summary Report” の表示例です
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Place & Route Timing Analysis (Place & Route Report) の確認

← Negative Slack (タイミングエラー) パスの合計

Setup側の解析に対して、Slackが
最小のパス（マージンが最小のパス）
からワースト10までが表示されます

← Negative Slack (タイミングエラー) パスの合計

Hold側の解析に対して、Slackが
最小のパス（マージンが最小のパス）
からワースト10までが表示されます



◼ 以下はTIMING ANALYSIS SUMMARYの ”3.4 Unconstrainted Report” の表示例です
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Place & Route Timing Analysis (Place & Route Report) の確認

制約がかかっておらずタイミング解析されていない
パスが表示されます



◼ 以下はTIMING ANALYSIS SUMMARYの ”4 DETAILED REPORT” の表示例です
◼ この例では同期クロック間でのFmax解析の詳細を示しています
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Place & Route Timing Analysis (Place & Route Report) の確認

解析パスの起点と終点

起点のクロックソースと終点のクロックソース（同じであれば同期パス）

← 設定されているタイミング制約

解析起点までのクロック遅延詳細

解析終点までのクロック遅延詳細

データバス間遅延詳細

Floor PlannerやPhysical Viewで
視覚的にパスの確認も可能



I/O Timing Analysis (Place & Route Report) の確認
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◼ I/O Timing Analysisでは配置配線後のI/Oタイミング解析（STA）結果を確認できます
◼ 入力ポートのワーストSetup/Hold Timeと解析クロックエッジ、出力ポートのワーストTcoと解析

クロックエッジを以下のように確認できます



（参考）Strategy設定
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◼ タイミングエラーが出た場合の対処として、Strategy(コンパイルオプション)を変更することができます
◼ Strategyを変更してPlace & Route Designを実行することで配置配線結果に変化を与えます
◼ デフォルトで “Area”, “Timing”, “Strategy1”が用意されており、Strategy1がアクティブになっています
◼ Project ViewのStrategiesの下にあるStrategy1をダブルクリックするか右クリックからEditを選択すると

設定画面が開きます
◼ 配置配線時に与えるコンパイルオプションはPlace & Route Designを選択します

各種設定の詳細はHelpから
確認できます

Strategyをダブルクリックか
右クリックでEditを選択
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◼ Strategiesを右クリック > Add > New Strategyで新しいStrategyを作成することができます
◼ 設定の異なるStrategyを複数用意し、切り替えてコンパイル結果を比較することができます

①Strategiesを右クリック

②Add > New Strategyを選択

③Strategy ID（Projectに表示される
 Strategy名）を入力
 File NameはStrategy IDがコピーされます

④OKをクリックするとProjectに
 インポートされます

（参考）Strategyの追加



◼ アクティブなStrategyを切り替えるにはStrategy名を右クリックし、”Set as Active Strategy”
を選択します
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①Strategy名を右クリック

②Set as Active Strategyを選択 アクティブになったStrategyは
太字で表示されます

（参考）Strategyの追加



◼ 複数のImplementation（サブProject）を作成し、それぞれに異なるStrategyや制約を設定し、
同時にコンパイルを回すことができます

◼ まず、File > New > Implementationから新しいImplementationを作成します

（参考）Run Manager
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①Implementation名を入力
 Directory名はImplementation名がコピーされます

②Add Sourceでソースコード、制約ファイル等
 を追加します（Implementation作成後
 でも追加可能）

③OKをクリック



◼ 作成したImplementationがProject Viewにインポートされます
◼ アクティブなImplementationを切り替えてImplementation毎にStrategyやソースコード、

制約設定を変更することができます

（参考）Run Manager

58
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◼ Tools > Run Manager またはToolbarのRun Managerアイコン からRun Managerを
起動します

◼ コンパイルを実行するImplementationにチェックを入れ、Runボタンをクリックします
◼ レポートはImplementationを切り替えて確認します

（参考）Run Manager

①Run Managerを起動

②コンパイルするImplementationにチェック

③Runを実行
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5. 消費電力の見積もり



◼ 消費電力の見積もりはPower Calculatorを使用します
◼ Power Calculatorには実際のデザインコンパイル結果を用いるCalculationモードと、使用リソースを

概算で入力して見積もるEstimationモードが用意されていますが、ここではCalculationモードについ
て説明します

◼ Tool > Power Calculator もしくはToolbarのPower Calculatorアイコン から起動します

Power Calculator

61



◼ Power CalculatorのGUIは以下のようになっています

Power Calculator

62

■Device
見積もり対象デバイスの情報、
設定入力

■Environment
周囲温度、実装条件等の入力及び
ジャンクション温度、最大周囲温度等の表示

■見積もりモード表示

■Current by Power Supply
電源電圧毎の消費電流

■Power by Power Supply
電源電圧毎の消費電力

■Power by Block (W) /
Peak Startup

ブロック毎の消費電力 / 起動時ピーク電流

■Voltage/Dynamic Power Multiplier
電源電圧設定とマージン設定



◼ 以下のフローで動作周波数設定を行います

Power Calculator
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①Edit > Frequency Settingを選択

②動作周波数を設定

■Frequency Default
全てのクロックに一律で設定した周波数を与えます

■Use Frequency TWR
Place & Routeまで完了している場合に使用します（推奨）
- Minimum of Constraint and Timing

制約設定と実際の最大動作周波数のうち小さいものを適用（推奨）
- Always use Constraint

制約設定で与えた周波数を適用
- Always use Timing

最大動作周波数を適用

③OKをクリック



◼ 以下のフローでActivity Factorを設定します

Power Calculator
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①Edit > Activity Factor Settingを選択

②Activity Factorを設定

*Activity Factor = 内部ロジックのスイッチングレート
内部ロジックがクロックエッジに対してどの程度の頻度でスイッチするかを示すレート
毎エッジ遷移する場合を100％と考えます。デフォルトで10%が入力されています

③OKをクリック



◼ 以下のフローで周囲環境を設定します

Power Calculator

65

①Thermal Profileをクリック

⑤デバイス周囲温度を設定

②Boardサイズを選択

③Heat Sinkの有無、Airflowの強度を選択

④OKをクリック



◼ デバイスプロセス条件のTypical / Worstを設定し、見積もり結果を確認します

Power Calculator

66

①Typical or Worstを選択

ジャンクション温度の見積もり結果
最大周囲温度見積もり結果

電源毎の消費電流見積もり結果

トータル消費電流見積もり結果 トータル消費電力見積もり結果

電源毎の消費電力見積もり結果
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6. Functionシミュレーション



Simulation Wizardの実行
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◼ RadiantではActive-HDLでのシミュレーションをSimulation Wizardを使用して実行することが
出来ます

◼ Tool > Simulation Wizard またはToolbarからSimulation Wizardアイコン をクリックして
Simulation Wizardを起動します
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◼ 以下のフローに従い、シミュレーションプロジェクトを作成します

①Nextをクリック

②シミュレーションプロジェクト名を入力

③Functionシミュレーションの場合はRTLを選択

④Nextをクリック

Simulation Projectの作成

⑤Yesをクリック
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⑨エラーが無ければNextをクリック
 エラーがある場合はソースコード
 を修正して下さい

Simulation Projectの作成

⑥Radiantのプロジェクトにインポートされている
 ソースファイルは自動でインポートされます

⑦追加のテストベンチやソースコードはAddボタン
 から追加します

⑧Nextをクリック
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Simulation Projectの作成

⑩Finishをクリック

◼ FinishをクリックするとActive-HDLが立ち上がります
◼ 作成したシミュレーションプロジェクトはRadiantのProject View内のScript Fileにインポートされ、

このファイルをダブルクリックすることでいつでもシミュレーションプロジェクトを起動できます

シミュレーション起動ファイル(.spf)
がインポートされます
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Active-HDLでの波形確認

①確認したい信号が存在する
 インスタンスを選択

②インスタンス内の信号が表示されるので
 確認したい信号をWaveformウィンドウに
 ドラッグ&ドロップ

③Runボタンをクリックして
 Simulation実行

④Simulation停止は
 Breakをクリック



73

Active-HDLでの波形確認

波形拡大、縮小、Zoom to Fit（波形全体表示）
ツールで希望の倍率に変更できます

任意拡大ツールで拡大したい
場所を選択して拡大できます

右クリックから”Add Cursor”でカーソル
を追加し、カーソル間の時間を確認する
ことができます
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7. デザイン書き込み



デザイン書き込み
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◼ RADIANTでは、コンフィグレーションデータの生成から書き込みまで同ツール内で行うことが可能です
◼ ここでは、コンフィグレーションデータの生成と書き込みフローについて説明します

Process ToolbarのExport Filesをダブルクリックして、
コンフィグレーションデータ(.bit)を生成します。
コンフィグレーションデータ(.bit)はプロジェクトフォルダ内の
インプリメンテーションフォルダ（デフォルトは”impl_1”）の
中に生成されます

マークに表示となるとコンフィグレーションデータの生成が完了します
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デザイン書き込み

◼ PCとデバイスが実装されたボードを接続します
◼ ここでは、Lattice評価ボードを使用した場合を紹介していますが、お客様ボードでの書き込みフローも

操作方法は共通となります

お客様ボードの場合、USBダウンロードケーブル
HW-USBN-2B（JTAG/SPI/I2C対応）を使用します
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デザイン書き込み

◼ Tools > Programmer もしくはToolbarからProgrammer アイコンをクリックし、
Programmerを起動します
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デザイン書き込み

Programmerを起動すると自動で接続されているデバ
イスがスキャンされますが、正しくデバイスのスキャンが完了
していない場合は、”Scan Device”をクリックします

デバイスのスキャンが正常に完了すると、”Device Family”,
”Device”に接続されているデバイス型番が反映されます

デバイスへの書き込みオペレーションを設定します。書き込み
オペレーション詳細については、次ページに記載しています
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デザイン書き込み

書き込みオペレーションの詳細設定は、青枠部分をダブル
クリックします

コンフィグレーションメモリの書き込み先を選択します。外部
SPI-FLASH、内部NVCM、SRAMから選択可能です

書き込む際のI/Fを選択します。JTAG、又はSPIから選択可
能です。デバイスとケーブルを接続しているI/Fに合わせて設定
してください

アクセスモードを選択します。通常のコンフィグレーションデータ
書き込みであれば、”Direct Programming”を選択します

書き込み時のオペレーション、その他実施したいオペレーション
メニューから選択します。通常、外部SPI-FLASHに書き込む
際は、”Erase Program Verify”を選択します

書き込むコンフィグレーションデータを選択します

SPI-FLASHへ書き込む際は、型番に合わせて各種設定し
ます。設定が誤っていると書き込みエラーが発生します

すべての設定が完了したらOKをクリックします
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デザイン書き込み

書き込みは”Program Device”をクリックして開始します

書き込みには数十秒ほどかかります。

書き込みが正常に完了すると、”PASS”と表示されます
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8. 実機上での内部波形観測
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実機上での内部波形観測

HW-USBN-2 B

◼ RADIANTでは、デバイス内部の実機波形を観測できるデバッグ用機能、Revealが用意されています
◼ Revealを使用した実機上での波形観測は、下図のようにPCと、デバイスが実装されたボードを接続します
◼ ここでは、Revealを使用した内部波形観測フローを紹介します
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実機上での内部波形観測

Reveal Inserterをクリック

◼ Revealを使用するには、デバイス内部にRevealコアを生成＆実装する必要がある為、Reveal 
InserterでRevealコアを生成します

◼ Tools > Reveal Inserter もしくはToolbarからReveal Inserterアイコン をクリックします
◼ Reveal Inserter Wizard上でRTL(Pre-Synthesis)を選択します

Reveal Inserterが起動したら、”Add”から
Add Logic Analyzerをクリックします

RTL(Pre-Synthesis)を選択

Finishをクリック
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実機上での内部波形観測

観測可能な信号がリストで表示されます。これらの信号から観測した信号を選択し、
Traceの下にドラッグ&ドロップします

サンプリングクロックを選択します。必ず10MHz以上のクロックを選択してください

Buffer Depthを決定します。Buffer Depthの値を高くすることによって、観測
したい信号の数を増やすことが可能ですが、実デザインで使用しているEBR、又
はDistributed RAM容量によってRevealで使用可能な上限値が決まります

内部信号をバッファする為のメモリタイプを選択します
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実機上での内部波形観測

下タブをTrigger Signal Setupに切り替えます

Trigger Unitでは、トリガー信号と条件を設定します。Addボタンをクリックして、
トリガー信号と条件、信号観測時の表示方法をBin/Oct/Dec/Hexから設定
します。この例では、”en_signal”がHighになったらトリガーがかかる設定となって
います
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実機上での内部波形観測

Trigger Expressionでは、Trigger unitで設定した複数のトリガーを組み合わせて論理を組むことが可能です
この例では、”en_signal”がHighかつ、”RST”がLowの時にトリガーがかかる設定となっています
論理はExpressionのセルに直接記述します。論理の記述方法は次ページを参照ください
尚、Trigger Expressionでは、論理の組み合わせが不要な場合もExpressionのセルにTrigger Unitで設定したトリガー条件
を入力する必要があります。この例では、TU1又はTU2のいずれかを記述します
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実機上での内部波形観測

演算子 演算子の意味

& 前後のTUの and 論理

| 前後のTUの or 論理

^ 前後のTUの xor 論理

! 後に続くTUの not 論理

() 括弧内の論理式を優先

next 前のTU成立後、次のサンプルで後のTUが成立

then 前のTU成立後、後のTUが成立

# 前に指定されたTUが、後に指定された回数成立

## 前に指定されたTUが、後指定された回数連続して成立

■Trigger Expression記述例

TU1 & TU2 : TU1とTU2が同時にTrueの場合にトリガ生成
TU1 | TU2 : TU1もしくはTU2がTrueの場合にトリガ生成
!TU3 : TU3がTrueでない場合にトリガ生成
TU1 & !TU4 : TU1がTrueかつTU4がTrueでない場合にトリガ生成
TU3 ^ TU1 : TU3もしくはTU1のどちらか一方がTrueの場合にトリガ生成
TU1 next TU2 : TU1がTrueになった次のサンプリングでTU2がTrueの場合にトリガ生成
TU1 then TU2 : TU1がTrueになった次のサンプリング以降にTU2がTrueの場合にトリガ生成
TU5 #2 : TU5が2回Trueになった場合にトリガ生成
TU5 ##2 : TU5が2回連続してTrueになった場合にトリガ生成

* #および##演算子で繰り返し回数を指定する場合は“Max Event Counter“セルの設定が必要
* thenおよびnext演算子でシーケンシャル・トリガを生成する場合は”Max Sequence Depth”セルの設定が必要
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実機上での内部波形観測

すべての設定が完了したら、Design Rule Checkアイコンをクリックします

すべての設定において問題が無ければ、
”Design Rule Check PASSED”と表示されます
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実機上での内部波形観測

Insert Debugアイコンをクリックします

ポップアップが表示されたら、例の様に2
つのチェックが入っているを確認らして、
OKをクリックします

Revealコアの名称を記述し、
保存ボタンをクリックします
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実機上での内部波形観測

File ListタブにRevealコア
ファイル(.rvl)が追加されて
いる事を確認します

Export Filesプロセスまで完了させ、Revealコアが実装
されたコンフィグレーションデータを生成します



91

実機上での内部波形観測

Revealコアが実装されたコンフィグレーションデータをProgrammerを使用して書き込みます
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実機上での内部波形観測

書き込みが完了したら、Tools > Reveal 
Analyzer/Controller もしくはToolbarから
Reveal Analyzer/Controllerアイコン  を
クリックします

ポップアップ画面が出てきたら、Create a new file
にチェックを入れます。以降、デバイスとPCは接続した
状態で作業を行う必要があります

Detectボタンをクリックし、PCと接続されているケーブル
を認証させます

Scanボタンを押して対象
デバイスを認識させます

Browseボタンを押して、Reveal Inserterで作成
した、Revealコアファイル(.rvl)を選択します

上記設定が完了したらOKボタンをクリックします
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実機上での内部波形観測

Reveal Analyzerが起動したら、Ready表示に
なっていることを確認して、    アイコンをクリックします

トリガーがかかると、下図のように内部信号が表示されます
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実機上での内部波形観測

初回移行、再度Reveal Analyzerを起動するときは、File 
ListのReveal Analyzer起動ファイル(.rva)をダブルクリックする
だけで、起動させることが可能です Revealコアは、File ListのRevealコアファイル(.rvl)を右クリック後、

Set as Inactiveを選択することによって無効にすることが可能です。
Revealコアを実装すると、メモリリソース、内部ロジック、配線、リソース
を消費し、消費電力も高くなる為、ご量産のコンフィグレーションデータ
を生成する際は、Revealコアを無効にして頂く事をお勧め致します
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9. 実機上での内部波形観測（Post-PAR Reveal）
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実機上での内部波形観測（Post-PAR Reveal）

【概要】
◼ Reveal Inserter起動時に3つのDebug Stageが選択可能です

◼ RTL(Pre-Synthesis)：通常のデバッグオプション
◼ Post-Synthesis：論理合成結果を保持したままデRevealを挿入するオプション
◼ Post-Place&Route：配置配線結果を保持したままRevealを挿入するオプション

◼ 次ページ以降はPost-Place&Routeのフローを紹介します



97

実機上での内部波形観測（Post-PAR Reveal）

◼ Revealを入れていない状態でPlace & Route Designをクリックして配置配線を実行します

②Place & Route Designをクリック

①*.rvlが有効に
なっていなことを確認
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実機上での内部波形観測（Post-PAR Reveal）

Reveal Inserterをクリック

◼ Tools > Reveal Inserter もしくはToolbarからReveal Inserterアイコン をクリックします
◼ Reveal Inserter Wizard上でPost-Place&Routeを選択します

Reveal Inserterが起動したら、”Add”から
Add Logic Analyzerをクリックします

Post-Place&Routeを選択

Finishをクリック
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実機上での内部波形観測（Post-PAR Reveal）

◼ 7章と同手順でRevealのセットアップを行いInsert Debugまでを実施（詳細割愛）

詳細は7章参照
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実機上での内部波形観測（Post-PAR Reveal）

①File ListタブにRevealコ
アファイル(.rvl)が追加され
ている事を確認します

②Place & Route Designアイコン内に
白抜きの□が表示されていることを確認します

③Task Detail View内に
Place & Route Revealが
追加されていることを確認します

④Export Fileをクリック
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実機上での内部波形観測（Post-PAR Reveal）

詳細は7章参照

◼ 7章と同手順で波形確認を行います（詳細割愛）
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実機上での内部波形観測（Post-PAR Reveal）

【注意点①】
◼ Post-PAR Revealはタイミングエラーが出やすいです

（既存配置配線を保持したままデバッグコアを挿入するため）
◼ デバッグはRTL(Pre-Synthesis)を基本と捉えてください
◼ Post-PARは観測信号を最小限にする、低速のサンプリングクロックを選定する等の工夫が必要です

【注意点②】
◼ Post-PAR Revealの観測信号はネットリスト形式で表示されます
◼ ソースファイルに予め/*synthesis syn_rvl_debug=1 */アトリビュートを記述しておくと該当信号

がハイライトされます

観測信号にアトリビュートを記述します
/*synthesis syn_rvl_debug=1 */

アトリビュート記述した
信号がハイライトされます
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実機上での内部波形観測（Post-PAR Reveal）

【注意点③】
◼ 既にRevealが挿入されているProjectに、新たに別のPost-PAR Revealを追加挿入することは出

来ません
◼ 基本的にRevealはInactiveにしておき、問題発生時に都度Revealを追加することがお奨めと考え

られます
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