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2024 年 5 月 Lattice Radiant 日本語ユーザーガイ ド

註 ： 本 Lattice Radiant 日本語マニュアルは、 日本語によ る理解のため一助と して提供しています。 作成にあたっては各 ト ピ ッ クについて可能な限 り 正確を期してお
り ますが、 必ずし も網羅的あるいは最新でない可能性や、 オ リ ジナル英語版オン ラ イ ンヘルプや各種ド キュ メ ン ト と不一致がある可能性があ り 得ます。 疑義が生じ
た場合は技術サポー ト 担当者にお問い合わせ頂 く か、 または最新の英語オ リ ジナル ・ ソース を参照する よ う にお願い致し ます。

　

第 2 章 　 プロジ ェ ク ト 構造

2.1 プロ ジェ ク ト 構造と特長
　 Lattice Radiant のプロ ジェ ク ト 構造 と し て、 以下のよ う な特長があ り ます。

１ ． 単一ラ イセン スで複数のデザイ ン ・ プロ ジェ ク ト を同時実行する こ と ができ ます

• 同一プロ ジェ ク ト を対象にし た複数実行は除き ます

• Synplify-Pro も同様に GUI を複数立ち上げて実行する こ と ができ ます

• Radiant に付属する ModelSim Lattice Edition は、 異なる シ ミ ュ レーシ ョ ン ・ プロ ジェ ク ト に対し
て GUI を複数立ち上げる こ と はでき ますが、 シ ミ ュ レーシ ョ ンの複数実行はでき ません

２ ． デザイ ン ・ プロ ジェ ク ト は大き く は ” ス ト ラ テジー ” および ” イ ンプ リ メ ンテーシ ョ ン ” と い う
二つの構成要素で管理されます。 本章で詳細に記述し ます

３ ． 本ユーザーガイ ド のカバーし ていない項目やよ り 詳細については以下をご参照 く ださい

• ス ター ト ページ ・ ビ ューから リ ン ク されている ド キ ュ メ ン ト 類

• オン ラ イ ンヘルプ （ メ ニュー [Help] → [Lattice Radiant Software Help]）

• ラ テ ィ スセ ミ コ ンダ ク ターのウ ェブサイ ト （https://www.latticesemi.com）

• 特定の ト ピ ッ ク スについて知 り たい場合、 GUI 上でマウ スポイ ン ターを当該ア イ テムに移動し
た状態でフ ァ ン ク シ ョ ンキー 『F1』 を押し ます。 当該項目についてのオン ラ イ ンヘルプ ・ ペー
ジを直接表示する こ と ができ ます （” コ ンテキス ト ・ センシテ ィ ブ ・ ヘルプ ”）

　 Lattice Radiant では、 ” プロ ジェ ク ト ” ご と にデザイ ンを構成し ますが、 主な管理機構は ” ス ト ラ テジー
（Strategy） ” と ” イ ンプ リ メ ンテーシ ョ ン （Implementation） ” と い う 考え方です。 プロ ジェ ク ト には必ず一
つの ”LPF 制約フ ァ イル ” が存在し、 ユーザーが用意する RTL ソース フ ァ イルがプロ ジェ ク ト の入力にな り
ます （図 2-1）。

　 イ ンプ リ メ ンテーシ ョ ンはデザイ ンの管理単位であ り 、 デザイ ン実装に関わる全てのフ ァ イルを含んだも
のです。 論理合成や配置配線と いった処理プロセスはイ ンプ リ メ ンテーシ ョ ン単位で行われます。 図 2-1 の
表示構成で RTL ソース フ ァ イルは [Input Files] セ ク シ ョ ン、 設計制約フ ァ イルは [Pre-Synthesis Constraint
Files] および [Post-Synthesis Constraint Files] セ ク シ ョ ン、 これ以外にオンチッ プ ・ デバッ ガー Reveal 用は
[Debug Files] セ ク シ ョ ン、 書き込み用フ ァ イルは [Programming Files] セ ク シ ョ ンに、 などそれぞれ表示され
ます。 イ ンプ リ メ ンテーシ ョ ンは複数作成する こ と ができ ます。

　 ス ト ラ テジーは各プロ セスの制約設定 （Constraints、 Preferences） やオプシ ョ ン設定を一元管理する機構
です。 定義済みス ト ラ テジーは三種類あ り 、 プロ ジェ ク ト と し て管理されます。 有効なス ト ラ テジーはイ ン
プ リ メ ンテーシ ョ ンご と に １ つです。複数のイ ンプ リ メ ンテーシ ョ ンで同じ ス ト ラ テジーを共用する こ と も、
或いはイ ンプ リ メ ンテーシ ョ ンご と に異なる ス ト ラ テジーを割 り 当てる こ と も可能です （図 2-2）。 ス ト ラ テ
ジー ・ オプシ ョ ン個々の詳細についてはプロセス各章の記述をご参照 く ださい。

　 デザイ ンエン ト リ ーは RTL ソース フ ァ イル （VHDL/Verilog HDL/System Verilog 記述） で、 イ ンプ リ メ ン
テーシ ョ ンご と に登録 （イ ンポー ト ） し ます。 複数のイ ンプ リ メ ンテーシ ョ ンで同じ ソース フ ァ イルを参照
し て共用する こ と が可能です （図 2-2）。 モジュール生成 （第 4 章参照） し た場合は、 RTL ソース フ ァ イルの
代わ り に、 自動生成される定義フ ァ イル （*.ipx） を イ ンポー ト し ます。

　 なお、 デザイ ンエン ト リ ーと し て SynplifyPro の出力であ る ”*.vm” も使用する こ と ができ ます。
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図 2-1. プロ ジェ ク ト 構造

　 各プロセスの処理において、デザイ ン ソース・フ ァ イル（と設計制約フ ァ イル）以外は必須ではあ り ません。

図 2-2. 複数イ ンプ リ メ ンテーシ ョ ン と制約設定やソース ・ フ ァ イルの適用例

　 プロ ジェ ク ト を構成する [File List] ビ ューの各フ ァ イルについて、 ボール ド字体表示の意味する こ と には
二通 り あ り ます。 [Input Files] セ ク シ ョ ンのソース フ ァ イルについては、 ト ッ プモジュール と し て認識された
フ ァ イルがボール ド表示にな り ます。 ボール ド表示が二つ以上あった り 、 或いは一つも ない場合は、 その状
態を解消する必要があ り ます。

　 イ ンプ リ メ ンテーシ ョ ン下の [Input Files] 以外の各セ ク シ ョ ン と、 [Strategies] セ ク シ ョ ンについては ” ア
ク テ ィ ブ （有効） ” なフ ァ イルがボール ド字体表示にな り ます。 これらは複数のフ ァ イルがイ ンポー ト （登
録） される こ と が可能ですが、各プロセスに適用される ア ク テ ィ ブな設定フ ァ イルはそれぞれ一つのみです。

2.2 プロ ジェ ク ト 管理

2.2.1 新規プロ ジェ ク ト の作成

　 新規プロ ジェ ク ト の作成は、 メ ニューバーから [File] → [New] → [Project...] の順に選択するか、 ス ター ト

ページ ・ ビ ュー上部の Project セ ク シ ョ ンで大き な ”New Project” ア イ コ ン を ク リ ッ ク し ます （図 2-3）。
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これで ”New Project” ウ ィ ン ド ウが表示されますので、 その指示に従ってデバイ ス等を選択すればプロ ジェ
ク ト が生成されます。

　 プロ ジェ ク ト 生成に伴って ” プロ ジェ ク ト ・ フ ォルダ ” は自動作成されませんので、 フ ィ ッ テ ィ ング用の
作業フ ォルダを事前に作成し てお く 事を推奨し ます。

図 2-3. プロ ジェ ク ト の新規作成開始

　 ”New Project” ウ ィ ン ド ウの始めは、プロ ジェ ク ト の生成に必要なフ ォルダやデバイ ス を指定する旨の メ ッ
セージが表示されています。 そのま ま 『Next>』 ボタ ンを ク リ ッ ク し、 次に表示される ウ ィ ン ド ウでプロ ジェ
ク ト 名と プロ ジェ ク ト のフ ォルダパス を設定し ます （図 2-4）。

　 Project セ ク シ ョ ンの 「Name」 セルにプロ ジ ェ ク ト 名を入力し ます。 プロ ジ ェ ク ト 名 と し て使用でき る文
字は、 アルフ ァベッ ト 、 数字と ”_” （アンダース コ ア） です （先頭の 1 文字目はアルフ ァベッ ト のみ）。

図 2-4. プロ ジェ ク ト の新規作成～プロ ジェ ク ト 名と フ ォルダパスの設定

　 「Location」 セルにはプロ ジェ ク ト で使用する フ ォルダーを指定し ます。直接パス を入力するか、『Browse...』
ボタ ンを ク リ ッ ク し て立ち上がる ウ ィ ン ド ウ上で適切なフ ォルダを選択し ます。 フ ォルダーパス と し て存在
し ないフ ォルダー名を直接入力する と、 自動的にその名称の新しいフ ォルダーが生成されます。
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　 Implementation セ ク シ ョ ンの 「Name」 セルにはイ ンプ リ メ ンテーシ ョ ン名を入力し ます。 デフ ォル ト 名の
”impl_1” が自動的に入力されていますが、 変更でき ます。 「Name」 を変更する と 「Location」 セルのパス表示
も自動的に更新されます。 設定が完了後、 『Next >』 ボタ ンを ク リ ッ クする と、 次はソース を イ ンポー ト する
ウ ィ ン ド ウ [Add Source] が表示されます （図 2-4）。

図 2-5. プロ ジェ ク ト の新規作成～ソース フ ァ イルのイ ンポー ト

　 『Add Source...』 ボタ ンを ク リ ッ クする と起動する フ ァ イル ・ ブラ ウザーで、 必要なフ ァ イル （既存の RTL
ソースや制約フ ァ イル sdc/ldc/fdc/pdc） を選択し て取 り 込みます。 この際、 ウ ィ ン ド ウ左下の 「Copy source
to...」チェ ッ ク ボ ッ ク スにチェ ッ ク が入っている と、選択し たフ ァ イルがプロ ジェ ク ト のフ ォルダーへコ ピー
され、それがイ ンポー ト されます。チェ ッ ク が入っていない場合は選択し たフ ァ イルがイ ンポー ト されます。

図 2-6. プロ ジェ ク ト の新規作成～デバイ ス選択

　 各ソース フ ァ イルはプロ ジェ ク ト 作成後でも イ ンポー ト でき ますので、 このステ ッ プで全てを イ ンポー ト
する必要はあ り ません。 完了後 『Next >』 ボタ ンを ク リ ッ クする と、 次はターゲ ッ ト ・ デバイ スの選択ウ ィ
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ン ド ウが表示されます （図 2-6）。

　 このウ ィ ン ド ウで、使用するデバイ スやス ピード グレード、パッ ケージを選択し ます。デバイ スやパッ ケー
ジはプロ ジェ ク ト 作成後でも変更でき ますので、 確定し ていない条件については暫定的に適当な ものを選択
し ておき、 確定後に変更する よ う にし ます。

　 次に 『Next >』 ボタ ンを ク リ ッ クする と、論理合成ツールの選択ウ ィ ン ド ウが開き ます。2023.2 でのデフ ォ
ル ト 論理合成ツールは Synplify Pro ですが、 LSE （Lattice Synthesis Engine） を選択する事が可能です。 また、
プロ ジェ ク ト 生成後でも、 変更する こ と が可能です （第 2.2.4.2 項参照）。

図 2-7. 論理合成ツールの選択 （ウ ィ ン ド ウの一部）

図 2-8. 新規プロ ジェ ク ト の作成～設定確認

　 次に 『Next >』 ボ タ ンを ク リ ッ クする と、 これまでの設定の確認ウ ィ ン ド ウが開き ます。 『Finish』 ボ タ ン
を ク リ ッ クすれば、 設定は完了です。 設定内容を変更する場合は、 『< Back』 ボ タ ン を ク リ ッ ク し て適切な
ウ ィ ン ド ウ まで戻 り 、 設定変更を行って く ださい。 作成されたプロ ジェ ク ト 情報 （イ ンプ リ メ ンテーシ ョ ン
名やイ ンポー ト し たフ ァ イル等） は、 プロ ジェ ク ト ・ フ ォルダに ”< プロ ジェ ク ト 名 >.rdf” と い う フ ァ イル名
で保存されます。

2.2.2 既存プロ ジェ ク ト のオープン

　 既存の Lattice Radiant プロ ジェ ク ト を開 く には、メ ニューバーから [File] → [open] → [Project…] の順に選択

するか、 ス ター ト ページ ・ ビ ュー上部の Project セ ク シ ョ ンで大き な ”Open...” ア イ コ ン を ク リ ッ ク し

ます。 ”Recent Project List” セ ク シ ョ ンには直近に作業し たプロ ジェ ク ト 名が表示されています （図 2-9 の右
枠） ので、 開きたいプロ ジェ ク ト がこの中にあれば、 そのプロ ジェ ク ト 名を ク リ ッ ク し て もオープンでき ま
す。 表示するプロ ジェ ク ト 履歴数は、 オプシ ョ ン設定で指定する こ と ができ ます （第 3.5.1 項参照）。 ア イ コ



Rev.2023.2.1

2-6 Lattice Radiant プロジ ェ ク ト 構造
©2024 Macnica, Inc.

ンを ク リ ッ ク し た場合は、 立ち上がる フ ァ イルブラ ウザーで *.rdf フ ァ イルを指定し ます。

図 2-9. 直近プロ ジェ ク ト のオープン

2.2.3 プロ ジェ ク ト のク ローズ

　 プロ ジェ ク ト を ク ローズする場合は、 メ ニューバーから [File] → [Close Project] を選択し ます。 他のプロ
ジェ ク ト をオープンするか、 Lattice Radiant を終了し て も自動的にク ローズ されます。 メ ニューの [File] →
[Close] や [File] → [Close All] ではプロ ジェ ク ト はク ローズ されません。

2.2.4 プロ ジェ ク ト 生成後の設定変更

2.2.4.1 ターゲッ ト ・ デバイスの変更

図 2-10. ターゲ ッ ト デバイ スの変更方法 1

　 ターゲ ッ ト とするデバイ スや、デバイ スの論理規模 （バルク）、或いはパッ ケージやス ピード グレード （SG）
など、 このよ う な変更の必要があ る場合の操作方法は二通 り あ り ます。
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　 第一の方法はフ ァ イル リ ス ト ・ ビ ュー内でプ ロ ジ ェ ク ト 名の下に表示さ れているデバイ ス名をダブル ク
リ ッ クする こ と です （図 2-10）。 これでプロ ジェ ク ト 作成時のデバイ ス選択と同じ ”Select Device” ウ ィ ン ド
ウ を表示させて変更し ます。 第二の方法は Radiant の メ ニューから [Project] → [Device...] と選択する こ と で
同じ ウ ィ ン ド ウ を表示させます。

　 ターゲ ッ ト ・ デバイ ス / パッ ケージ /SG はプロ ジェ ク ト で一つのみ指定可能です。 イ ンプ リ メ ンテーシ ョ
ン毎に異なる設定はでき ません。 変更する と、 論理合成プロセスからの再実行にな り ます。 また、 モジュー
ル生成ツール （IP Catalog） で生成し たマ ク ロや IP がイ ンポー ト されている場合、 再生成を求められる ケー
スがあ り ます。

2.2.4.2 プロジ ェ ク ト 属性の変更

　 　 ” ア ク テ ィ ブ ” な イ ンプ リ メ ンテーシ ョ ンについては、 プロ ジェ ク ト 生成時に選択し た論理合成ツール
などの属性を変更する こ と ができ ます。 Radiant の メ ニューから [Project] → [Property Pages] と選択する、 或
いはイ ンプ リ メ ンテーシ ョ ン名を選択し て右ク リ ッ クする と 表示される メ ニ ューか ら ”Properties” を選択
し、”Project Properties” ウ ィ ン ド ウ を表示させます。「Top-Level Unit」は ト ッ プレベルの指定、「Verilog Include
Search Path」 は Verilog RTL 記述内の ”‘include” 指定し ている フ ァ イルの所在の設定、 「HDL Parameter」 は
RTL 記述内のパラ メ ータ指定、 「Verilog Directive」 は ”‘define” デ ィ レ ク テ ィ ブで定義する キーワード の指定
と同等のこ と がそれぞれ可能です。

　 論理合成ツールの変更は、 「Synthesis Tool」 セルを二回ク リ ッ クする と 現れるプルダ ウ ンか ら選択し ます
（図 2-11 右）。 また、 Radiant の メ ニューから [Project] → [Active Implementation] → [Select Synthesis Tool...] と
選択するか、 イ ンプ リ メ ンテーシ ョ ン名の右ク リ ッ ク表示 メ ニューから [Select Synthesis Tool...] を選択し て
も同様です （図 2-11 左）。

図 2-11. 論理合成ツールの変更

　 論理合成ツールはイ ンプ リ メ ンテーシ ョ ン毎に異なる指定ができ ます。 また、 変更する と論理合成プロセ
スからの再実行にな り ます。 また、 モジュール生成ツール （IP Catalog） で生成し たマ ク ロや IP がイ ンポー
ト されている場合、 再生成を求められる ケースがあ り ます。

2.2.5 プロ ジェ ク ト の複製

　 プロ ジェ ク ト を複製するためには、メ ニューから [File] → [Save Project As...] を選択し て表示される ウ ィ ン
ド ウで、 保存フ ォルダ と別名のプロ ジェ ク ト 名称を指定し ます。

2.2.6 アーカ イブ ・ プロ ジェ ク ト の作成

　 プロ ジェ ク ト を保存する場合や何らかの都合でフ ォルダを移動させる場合等に、 プロ ジェ ク ト のアーカ イ
ブを作成する こ と ができ ます。メ ニューバーから [File] → [Archive Project...] を選択する と、”Archive Project”
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ウ ィ ン ド ウが開き ます。 このウ ィ ン ド ウでアーカ イブ ・ フ ァ イル （.zip） の保存先 と名称を指定し ます。 アー
カ イブ ・ フ ァ イルであ る こ と が容易に判別でき る よ う な名称、 例えば ”_archv.zip” のよ う にする こ と を推奨
し ます。

　 Radiant の環境設定オ プ シ ョ ン の一つで あ る 「Archive all files under the Project directory when archving
project」 がデフ ォル ト で イ ネーブル さ れています （図 3-13、 および第 3.5.1 項参照） 。 こ の状態、 ま たは
”Archive Project” ウ ィ ン ド ウ左下にあ る 「Archive all files under the Project directory.」 にチェ ッ ク が入れる と、
プロ ジェ ク ト と の関連に関わらずプロ ジェ ク ト ・ フ ォルダ下にあ る フ ォルダ と フ ァ イル全てが含まれる アー
カ イブが作成されます。 チェ ッ ク が入っていない場合で、 環境設定オプシ ョ ンがデフ ォル ト からデ ィ セーブ
ルに変更された場合は、 プロ ジェ ク ト の復元に必要な関連フ ォルダ と フ ァ イルのみの、 サイ ズの小さいアー
カ イブ ・ フ ァ イルが作成されます。 FAE のテ ク ニカルサポー ト にプロ ジェ ク ト を送付し て技術支援を受ける
場合などに、 後者のアーカ イブ機能を用いる と、 小さいフ ァ イルサイ ズでや り と り が容易にな り ます。

　 なお、 予期し ない ト ラブルを防ぐため、 アーカ イブ後の .zip フ ァ イルは Windows 対応の解凍ツールを用い
て unzip するのではな く 、 メ ニューから [File] → [Open] → [Archived Project...] を選択し て （図 2-12） 復元す
る よ う に し ます。 立ち上が る ウ ィ ン ド ウ で （図 2-13） 、 アーカ イ ブ ・ フ ァ イ ル と 復元先の フ ォ ルダーを
「Destination directory」 セルにブラ ウズ後指定し て 『OK』 を ク リ ッ ク し ます。

図 2-12. アーカ イブ ・ プロ ジェ ク ト の復元操作 １

　 復元先のフ ァ イル / フ ォルダ構造は、アーカ イブ元のそれ と は異な り 、 ツール所定の様式で展開されます。

図 2-13. アーカ イブ ・ プロ ジェ ク ト の復元操作 ２

　 なお、 当該デザイ ンにモジュール生成ツールで作成し た ”ROM モジュール ” が含まれている場合は注意が
必要です。 ROM 生成には必ず メ モ リ 初期化用のテキス ト ・ フ ァ イル ”.mem” が必要です （第 4.6.1 項参照）。
元々のプロ ジェ ク ト ・ フ ォルダー下に *.mem が存在し、 かつ全フ ァ イルを全てアーカ イブに含める設定以外
では、 アーカ イブ zip には含まれないこ と にご留意 く ださい。

2.3 イ ンプ リ メ ンテーシ ョ ンの管理
　 「イ ンプ リ メ ンテーシ ョ ン」 と は、 前述の とお り デザイ ンの管理単位であ り 、 デザイ ン実装に関わる全ての
フ ァ イルを含んだものです。 Radiant では、 単一プロ ジェ ク ト 内に複数のイ ンプ リ メ ンテーシ ョ ンを定義する
こ と ができ ます。 それぞれのイ ンプ リ メ ンテーシ ョ ンで異なる ソース フ ァ イルや制約フ ァ イル、 あ るいはオ
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プシ ョ ンを用いて論理合成や配置配線を行 う こ と ができ ます。Radiant では単一プロ ジェ ク ト 内で最適な実装
の推敲を行 う こ と が容易です。

2.3.1 新規イ ンプ リ メ ンテーシ ョ ンの追加

　 イ ンプ リ メ ンテーシ ョ ンは新規プロ ジェ ク ト を作成し た際に必ず １ つ作成されます （ユーザーが命名）。追
加の新規イ ンプ リ メ ンテーシ ョ ンが必要な場合、 メ ニューバーから [File] → [New] → [Implementation...] の順
に選択するか、 フ ァ イル リ ス ト ・ ビ ューの一番上に表示されているプロ ジェ ク ト 名を右ク リ ッ ク し [Add] →
[New Implementation...] の順に選択し ます （図 2-14 左）。 これで ”New Implementation” ウ ィ ン ド ウが表示され
ます （図 2-14 右）。

図 2-14. イ ンプ リ メ ンテーシ ョ ンの追加

　 「Name:」 セルは追加する イ ンプ リ メ ンテーシ ョ ンの名称、 「Directory:」 セルはイ ンプ リ メ ンテーシ ョ ンで
使用する フ ァ イルを格納する フ ォルダ名です。 名称を先に入力する と フ ォルダ名も自動的に同じ ものが入力
されますが、 変更する こ と もでき ます。

　 「Synthesis Tool」 セル と 「Default Strategy:」 セルは、 それぞれ右側の▼ア イ コ ン を ク リ ッ ク し て適切な も
のを選択し ます。 イ ンプ リ メ ンテーシ ョ ン作成後に変更する こ と も可能です。

図 2-15. 既存イ ンプ リ メ ンテーシ ョ ンからのソースのイ ンポー ト 例

　 イ ンプ リ メ ンテーシ ョ ン作成時に 『Add Source』 ボタ ンを ク リ ッ ク し て ソース フ ァ イルのイ ンポー ト がで
き ます。 プルダウ ン メ ニューで [Browser...] と [From Existing Implementation] が表示されます。 ブラ ウザを使
用し て既存のフ ァ イルを選択する場合は前者を選択し ます。 既存のイ ンプ リ メ ンテーシ ョ ンにイ ンポー ト さ
れている ソース を選択する場合は、 後者を選択し ますが、 する と既存のイ ンプ リ メ ンテーシ ョ ン名が全て候
補と し て リ ス ト されますので、 その中から １ つを選択し ます （図 2-15。 この図では一つのみ）。

　 この際、 ウ ィ ン ド ウ左下の 「Copy source to implementation directory」 にチェ ッ ク が入っている と、 選択し
た ソースは新規に作成し た イ ンプ リ メ ンテーシ ョ ンのフ ォルダにコ ピーされ、 それがイ ンポー ト されます。
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チェ ッ ク が入っていない と選択し たオ リ ジナルのソース フ ァ イルがイ ンポー ト されます。 コ ピーし た ものを
イ ンポー ト する場合、 オ リ ジナルのソース フ ァ イルは変更されませんので、 他のイ ンプ リ メ ンテーシ ョ ンの
ソースには影響し ません。逆にオ リ ジナルのソース フ ァ イルを イ ンポー ト する場合、複数のイ ンプ リ メ ンテー
シ ョ ンが同一ソース を参照し ていれば、 更新された際に全てが影響されます。

　 必要な ソース を選択後、 『OK』 ボタ ンを ク リ ッ ク し て設定は完了です。 ” イ ンプ リ メ ンテーシ ョ ン ・ フ ォ
ルダ ” が自動作成され、 各種フ ァ イル / サブフ ォルダがその下に置かれます。

2.3.2 イ ンプ リ メ ンテーシ ョ ンの複製 （ク ローン）

　 Radiant にはイ ンプ リ メ ンテーシ ョ ンの複製 （” ク ローン ・ イ ンプ リ メ ンテーシ ョ ン ”） を容易に生成する
機能があ り ます。

図 2-16. イ ンプ リ メ ンテーシ ョ ンの複製

　 複製の元になる イ ンプ リ メ ンテーシ ョ ンを選択後、右ク リ ッ ク で[Clone Implementation...]を選びます（図 2-
16 左）。 ” ア ク テ ィ ブ ” （次項で記述） でないイ ンプ リ メ ンテーシ ョ ンでも選択は有効です。 その後表示され
る ウ ィ ン ド ウ （図 2-16 右） で複製後の名称を 「Name:」 セルに入力し ます。 下部でソース フ ァ イルを参照す
るか、 コ ピーするかの指定も行います。 イ ンプ リ メ ンテーシ ョ ンがフ ォルダ一括で複製され、 付与し た名称
にな り ます。

2.3.3 イ ンプ リ メ ンテーシ ョ ンのア ク テ ィ ブ化

図 2-17. イ ンプ リ メ ンテーシ ョ ンのア ク テ ィ ブ化
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　 複数のイ ンプ リ メ ンテーシ ョ ンを持つプロ ジェ ク ト では、 ” ア ク テ ィ ブ ” な イ ンプ リ メ ンテーシ ョ ンは一
つだけです。 ア ク テ ィ ブ と は、 論理合成以下各処理プロセスの対象と い う こ と です。 従って意図する処理対
象のイ ンプ リ メ ンテーシ ョ ンは、 初めにア ク テ ィ ブ化し てから、 またはア ク テ ィ ブであ る こ と を確認し てか
らすべての操作を行 う 必要があ り ます。

　 フ ァ イル リ ス ト ・ ビ ューで、 ア ク テ ィ ブ化し たいイ ンプ リ メ ンテーシ ョ ン名を選択後に右ク リ ッ ク し、 メ
ニューから [Set as Active Implementation] を選択し ます。 イ ンプ リ メ ンテーシ ョ ンがア ク テ ィ ブになった こ と
を示すボール ド字体にな り ます。

2.3.4 イ ンプ リ メ ンテーシ ョ ンの削除

　 不要な イ ンプ リ メ ンテーシ ョ ンをプロ ジェ ク ト から削除するには、 まずそのイ ンプ リ メ ンテーシ ョ ンを非
ア ク テ ィ ブ化 （他のイ ンプ リ メ ンテーシ ョ ンをア ク テ ィ ブ化） し ます。 次にそのイ ンプ リ メ ンテーシ ョ ン名
を右ク リ ッ ク し、 [Remove] を選択するか （図 2-17 で赤枠の下）、 またはイ ンプ リ メ ンテーシ ョ ンを選択し た
状態でキーボード の [Delete] キーを押し ます。

　 ア ク テ ィ ブな イ ンプ リ メ ンテーシ ョ ンは削除でき ません。 なお、 ” 削除 ” はイ ンポー ト 情報の削除であ り 、
フ ァ イルやフ ォルダ自体は削除されません。

2.3.5 イ ンプ リ メ ンテーシ ョ ンのプロパテ ィ 設定

　 プ ロパテ ィ 設定は メ ニ ューバーか ら [Project] → [Property Pages] の順に選択する か、 フ ァ イ ル リ ス ト ・
ビ ューでイ ンプ リ メ ンテーシ ョ ン名を右ク リ ッ ク し て [Properties] を選択し ます （図 2-18 左）。 これによ り
”Project Properties” ウ ィ ン ド ウが立ち上が り ます （図 2-18 右）。

図 2-18. イ ンプ リ メ ンテーシ ョ ンのプロパテ ィ 設定

　 プロパテ ィ 項目の意味は以下の通 り です。 イ ンプ リ メ ンテーシ ョ ン名が左枠で選択された状態で、 右枠内
でそれぞれ確認 ・ 変更し ます。 なお、 非ア ク テ ィ ブな イ ンプ リ メ ンテーシ ョ ンを選択し た場合は、 何も表示
されませんので、 変更は一切でき ません。

　 Top Level Unit

デザイ ン ソースの最上位階層のエンテ ィ テ ィ （VHDL） / モジュール （Verilog） 名を入力でき ます。 ほ
と んどの場合、 最上位階層名はイ ンポー ト し た ソースか ら自動的に検出し ます。 し か し VHDL/Verilog
HDL 混在の場合など、 最上位階層が認識されないケースがあ り ます。 そのよ う な場合にこ こ で指定し ま
す。 セルを ク リ ッ クする と、 右端に▼印が現れ、 プルダウ ンでその候補が表示されます。
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　 Synthesis Tool

選択されている論理合成ツールが表示されますが、 変更する こ と ができ ます。

　 Automaticly Compile Order

2023.2 から追加されま し た。 デフ ォル ト は ’on’ で、 ソース フ ァ イルのコ ンパイル順序を自動的に設定
し ます。 このウ ィ ン ド ウで ’off’ にする こ と もでき ますが、 Input Files セ ク シ ョ ンでフ ァ イルを上下に ド
ラ ッ グ し て順序を変え る操作をする と、 オフにするかど う かの メ ッ セージがポ ッ プア ッ プし ます。

　 VHDL Library Name

イ ンプ リ メ ンテーシ ョ ンで、 デフ ォル ト で使用する VHDL ソースのコ ンパイル先ラ イブラ リ ー名の設
定です。 デフ ォル ト では work ラ イブラ リ ーと し てコ ンパイルされます。 VHDL ソース単位でコ ンパイル
先のラ イブラ リ ー名が異なる場合は、 デザイ ン ソースのプロパテ ィ で設定し ます （第 2.6.6 項参照）

　 Verilog Standard

デフ ォル ト は Verilog 2001 で、 Verilog 95 と SystemVerilog が選択でき ます。

　 Preservation Level

2023.1 から追加されたブロ ッ クベース ・ デザイ ン （Block Based Design） に関する ものですが、 2023.2.1
時点では何も設定でき ません。

　 Verilog Include Search Path

Verilog HDL ソース内で相対パス記述でイ ン クルード し ている フ ァ イルを検索するパスの設定です。 イ
ン クルード される フ ァ イルが、 ソース内にフルパスでフ ァ イル名が記述されていた り 、 プロ ジェ ク ト 内
の適切なフ ォルダに保存されていた り する場合は、 設定する必要はあ り ません。

　 HDL Parameters

HDL ソースにグ ローバルで作用するパラ メ ータ （generic/VHDL、 parameter/Verilog） を指定する こ と が
でき ます。 VHDL ソースによ るプロ ジェ ク ト で Reveal デバッ ガを使用する場合、 generic 宣言し ているパ
ラ メ ータがあれば、 全て こ こに列記する必要があ り ます （第 11.2.1 項参照）。 複数定義する場合は以下の
よ う にセ ミ コ ロ ンで分離し ます （改行はでき ません）。

-- 記述例 　 　 　 g_bus_width=16;comm_id=8;

　 Verilog Directives

Verilog HDL の ”define” に相当する コ ンパイ ラ指示子を指定でき ます。 複数定義する場合はセ ミ コ ロ ン
で分離し ます （改行はでき ません）。

2.4 ス ト ラ テジーの管理
　 ス ト ラ テジーは前述のよ う に各プロ セスの制約設定 （Constraints、 Preferences） やオプシ ョ ン設定を一元
管理する機構です。 Radiant では、 プロ ジェ ク ト 内に複数のス ト ラ テジーを持ち、 それぞれのス ト ラ テジーで
は異なるオプシ ョ ン設定を定義する こ と ができ ます。 イ ンプ リ メ ンテーシ ョ ンご と に ” ア ク テ ィ ブ ” な （有
効な） ス ト ラ テジーは一つだけです。

2.4.1 デフ ォル ト ・ ス ト ラ テジー

　 プロ ジェ ク ト を作成し た際に、 以下の ３ つのス ト ラ テジーが作成されています。 Strategy1 以外は編集する
こ と ができ ません。
　 　 Area : 必要な リ ソース （ス ラ イ ス） 数が最小になる よ う に設定されたス ト ラ テジー

　 　 Timing : タ イ ミ ング要求を優先する よ う 設定されたス ト ラ テジー （全てデフ ォル ト ）

　 　 Strategy1 : Timing と同じ （ユーザーが編集可能）

　 ス ト ラ テジーを追加するには、 新たに作成する方法と、 既存のス ト ラ テジーを複製する方法があ り ます。
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2.4.2 新規ス ト ラ テジーの作成

　 新規作成する場合は、 メ ニューバーから [File] → [New] → [Strategy...] の順に選択するか、 フ ァ イル リ ス

ト ・ ビ ュー内の [Strategies] 表記を選択し て右ク リ ッ ク し、 [Add] → [New Strategy...] と選択し ます （図 2-19
左）。 これで、 ”New Strategy” ウ ィ ン ド ウが表示されます （図 2-19 右）。

　 New Strategy ウ ィ ン ド ウの 「Strategy ID:」 セルにス ト ラ テジー名を入力し ます。 Radiant 上にはこの名称で
表示されます。 「File name:」 セルにはデフ ォル ト でス ト ラ テジー ID と同じ ものが自動入力されますが、 変更
でき ます。 「Save to Location:」 セルはス ト ラ テジー設定フ ァ イルを保存する フ ォルダです。 デフ ォル ト でプ
ロ ジェ ク ト フ ォルダが設定されていますが、 変更する こ と も可能です。

　 全ての設定完了後、 OK ボタ ンを ク リ ッ クする と、 新規ス ト ラ テジー （設定は全てデフ ォル ト ） が作成さ

れ、 ”< ス ト ラ テジー名 >.sty” と い う フ ァ イル名で指定フ ォルダに保存されます。

図 2-19. 新規ス ト ラ テジーの追加

2.4.3 ス ト ラ テジーの複製

　 Lattice Radiant には既存ス ト ラ テジーの複製 ” ク ローン （Clone） ” を作成する機能があ り ます。 複製し た
いス ト ラ テジーを選択し て右ク リ ッ ク し、 表示される メ ニューから [Clone Strategy...] を選択し ます （図 2-
20 左）。 これで、 ”Clone *** Strategy” ウ ィ ン ド ウ （’***’ は複製元のス ト ラ テジー名） が立ち上が り ますの
で、 新ス ト ラ テジー名を入力し ます （図 2-20 右）。

図 2-20. ス ト ラ テジーの複製

　 Clone Strategy ウ ィ ン ド ウの設定は、新規ス ト ラ テジーを追加する場合 と同じですが、作成される ス ト ラ テ
ジーの設定値が複製元と同じになっています。 プロ ジェ ク ト 作成時にデフ ォル ト で生成される設定変更でき
ないス ト ラ テジーであ る ”Area” や ”Timing” の場合でも、 複製版は変更が可能です。
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図 2-21. ス ト ラ テジーのア ク テ ィ ブ化

2.4.4 適用する ス ト ラ テジーの選択 （ア ク テ ィ ブ化）

　 イ ンプ リ メ ンテーシ ョ ンでは、 ” ア ク テ ィ ブ化 ” されている １ つのス ト ラ テジーのみが有効です。 このた
め ” ス ト ラ テジーのア ク テ ィ ブ化 ” がすなわち適用する ス ト ラ テジーの選択にな り ます。

　 ス ト ラ テジーをア ク テ ィ ブ化するには、 フ ァ イル リ ス ト ・ ビ ューで当該ス ト ラ テジーを ク リ ッ ク し て選択
後、 右ク リ ッ クする と表示される メ ニューから [Set as Active Strategy] を選択し ます （図 2-21）。 ア ク テ ィ ブ
化されたス ト ラ テジーは太字で表示され、 以後のプロセス処理に適用されます。

2.4.5 ス ト ラ テジーの削除

　 プロ ジェ ク ト で不要になったス ト ラ テジーは削除でき ます。 フ ァ イル リ ス ト ・ ビ ューで削除し たいス ト ラ
テジーを右ク リ ッ ク し て選択後、 表示 メ ニューから [Remove] を選択するか、 キーボード の [Delete] キーを押
すと、 ス ト ラ テジーがプロ ジェ ク ト から削除されます。 ” プロ ジェ ク ト から削除 ” する こ と はイ ンポー ト 情
報の削除であ り 、 ス ト ラ テジー ・ フ ァ イルの削除ではあ り ません。

　 なお、 非ア ク テ ィ ブな イ ンプ リ メ ンテーシ ョ ンで も ア ク テ ィ ブなス ト ラ テジーは削除でき ません。 また、
プロ ジェ ク ト 作成時に自動生成されている ものは、 全て削除でき ません。

2.4.6 ス ト ラ テジー ・ オプシ ョ ンの編集

　 ス ト ラ テジー ・ オプシ ョ ン項目を変更 ・ 編集するためには、 まずフ ァ イル リ ス ト ・ ビ ューでス ト ラ テジー
名をダブルク リ ッ クするか、 または意図する ス ト ラ テジーを右ク リ ッ ク し て選択後、 表示される メ ニューか
ら [Edit] を選択し ます。 ス ト ラ テジー ・ オプシ ョ ンの設定ウ ィ ン ド ウが立ち上が り ます （図 2-22）。
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図 2-22. ス ト ラ テジー ・ オプシ ョ ン設定ウ ィ ン ド ウ （PAR）

　 このウ ィ ン ド ウで各プロセスの定義済みオプシ ョ ン設定を変更する こ と ができ ます。 左枠で意図するプロ
セスかサブプロセス を選択し ます。 オプシ ョ ン項目の詳細については、 各プロセス章の記述をご参照 く ださ
い。

2.5 設計制約フ ァ イルの管理
　 Radiant の制約フ ァ イルに三つのタ イプがあ り ます。 Radiant プロ ジェ ク ト ではイ ンプ リ メ ンテーシ ョ ンご
と に 1 つ以上の sdc/pdc 制約フ ァ イルが存在でき ますが、" ア ク テ ィ ブ " な ものは一つです。或いは制約フ ァ
イルが一切な く て も処理プロセスに問題はあ り ませんが、 実デザイ ンの実装ではピン配置指定や動作ク ロ ッ
ク に対する タ イ ミ ング制約は必要ですので、実質的に最低限 *.sdc/*.pdc 各一つはイ ンポー ト し て適用するの
が通常です。

　 ・ Pre-Synthesis Design Constraints (*.sdc)

論理合成に適用される業界標準の Synopsys 設計制約書式の制約です。 論理合成ツール と し て Synplify
Pro を選択し ている場合、 *.fdc を指定する こ と もでき ます。

　 ・ Post-Synthesis Design Constraints (*.pdc)

論理合成後の処理に適用される タ イ ミ ング制約や、ピン配置し ていなどの Radiant 固有の設計制約です。

　 ・ Lattice Design Constraints (*.ldc)

Lattice 独自の制約で sdc (ver.2.0) と論理合成ア ト リ ビ ュー ト の組み合わせた ものです。 IP などを生成
する と 付随し て生成されます。 それらに含まれる ピン配置やピン属性指定、 一部のタ イ ミ ング制約につ
いてはプロ ジェ ク ト と し ての制約に自動的に反映されます。

　 それぞれの作成方法等については、 第 15 章、 第 16 章をご参照 く ださい。
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2.5.1 既存の制約フ ァ イルのイ ンポー ト

　 既存の制約フ ァ イルを イ ンポー ト する場合は、 メ ニューバーから [File] → [Add] → [Existing File...] と選択
するか、 フ ァ イル リ ス ト ・ ビ ューでイ ンプ リ メ ンテーシ ョ ン ・ セ ク シ ョ ン下 [Pre-Synthesis Constraint Files]
や[Post-Synthesis Constraint Files]行を選択後右ク リ ッ ク し、表示される メ ニューから [Add] → [Existing File...]
の順に選択し ます。 図 2-23 は sdc のイ ンポー ト 例ですが、 他も同様です。

図 2-23. 既存 sdc 制約フ ァ イルのイ ンポー ト 例

　 ”Add Existing File” ウ ィ ン ド ウ （図 2-24） が表示されます。 ”Files of Type” と し て [Pre-Synthesis Constraint
Files （*.sdc） ] が選択されて立ち上が り ますので （必要に応じ て タ イプを変更し た後）、 ブラ ウズ し て適切な
フ ァ イルを選択し、 『Add』 ボタ ンを ク リ ッ ク し ます。

　 こ こ で、 ウ ィ ン ド ウ左下の [Copy file to Implementation’s Source directory] にチェ ッ ク が入っている と、 イ
ンプ リ メ ンテーシ ョ ン ・ フ ォルダにコ ピーが作成され、 これがイ ンポー ト されます。 チェ ッ ク が入っていな
い場合は、 選択し たフ ァ イルがイ ンポー ト されます。

　 なお、 *.fdc を イ ンポー ト する場合は、 [Pre-Synthesis Constraint Files] セ ク シ ョ ン下にあ る [Synplify Pro] を
選択後右ク リ ッ ク し て同様に指定し ます。

図 2-24. イ ンポー ト する制約フ ァ イルの選択
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2.5.2 適用する制約フ ァ イルの選択 （ア ク テ ィ ブ化）

　 イ ンプ リ メ ンテーシ ョ ンに複数の制約フ ァ イルが Pre-/Post- それぞれにイ ンポー ト されている場合でも、
有効 （ア ク テ ィ ブ） な ものは一つです。 ア ク テ ィ ブ化するためには、 フ ァ イル リ ス ト ・ ビ ューでア ク テ ィ ブ
でない制約フ ァ イルを選択後右ク リ ッ ク し、表示される メ ニュから [Set as Active Preference File] を選択し ま
す。 ア ク テ ィ ブ化された制約フ ァ イルは太字で表示され、 以後のプロセス処理に適用されます。

　 複数のフ ァ イルがイ ンポー ト されていて も、 すべて非ア ク テ ィ ブにでき ます。

2.5.3 制約フ ァ イルの削除

　 不要になった制約フ ァ イルは、 プロ ジェ ク ト から削除する こ と ができ ます。 フ ァ イル リ ス ト ・ ビ ューで削
除し たい制約フ ァ イルを選択後右ク リ ッ ク し、表示される メ ニューから [Remove] を選択するか、選択し た状
態でキーボード の [Delete] キーを押し ます。” プロ ジェ ク ト から削除 ” はイ ンポー ト 情報の削除であ り 、フ ァ
イル自体は削除されません。

　 ア ク テ ィ ブな制約フ ァ イルでも削除でき ますので、 ご注意 く ださい。

2.6 RTL ソース フ ァ イルの管理

2.6.1 新規 RTL ソース フ ァ イルの作成

　 新規 RTL ソース フ ァ イルを作成する場合、 メ ニューバーから [File] → [New] → [File...] と選択するか、 も
し く はフ ァ イル リ ス ト ・ ビ ューでイ ンプ リ メ ンテーシ ョ ン ・セ ク シ ョ ン下の [Input Files] 行を選択後右ク リ ッ
ク し、表示される メ ニューから [Add] → [New File...] の順に選択し ます。”New File” ウ ィ ン ド ウが起動し ます
ので、 適宜意図する タ イプを選択し て作業を開始し ます。

　 一般的には、 RTL ソース フ ァ イルを Radiant のよ う なフ ィ ッ テ ィ ング ・ ツール上で新規作成するのは非常
にまれですので、 こ こでの詳細説明は割愛し ます。

2.6.2 既存の RTL ソース フ ァ イルのイ ンポー ト

図 2-25. 既存のソース フ ァ イルのイ ンポー ト

　 作成済みの RTL ソース フ ァ イルを イ ンプ リ メ ンテーシ ョ ンにイ ンポー ト する場合は、 メ ニ ューバーから
[File] → [Add] → [Existing File...] の順に選択するか、 も し く はフ ァ イル リ ス ト ・ ビ ューでイ ンプ リ メ ンテー
シ ョ ン ・ セ ク シ ョ ン下の [Input Files] 行を選択後右ク リ ッ ク し、 表示される メ ニューから、 [Add] → [Existing
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File...] の順に選択し ます （図 2-25）。 ”Add Exiting File” ウ ィ ン ド ウが表示されますので、 ブラ ウズ し て指定
し ます。

　 ”Add Exiting File” ウ ィ ン ド ウでは、 必要に応じ て適宜 ”Files of Type” を選択し直し ます。 同ウ ィ ン ド ウ左
下の 「Copy file to Implementation’s Source directory」 にチェ ッ ク が入っている と、 イ ンプ リ メ ンテーシ ョ ン
下の ”source フ ォルダ ” にコ ピーが作成され、 これがイ ンポー ト されます。 チェ ッ ク が入っていない場合は、
選択し たフ ァ イルがイ ンポー ト されます。

　 なお、 モジュール生成ツール IP Catalog （参照） で生成済のモジュールを イ ンポー ト する場合は、 RTL 記
述の ト ッ プフ ァ イル （.v） ではな く 、 それらの定義フ ァ イル （拡張子 ”.ipx”） を指定し ます。

2.6.3 対象プロセスの指定

　 イ ンポー ト し た RTL ソース フ ァ イルは、デフ ォル ト で ” シ ミ ュ レーシ ョ ンおよび論理合成 ” の対象と し て
設定されますが、 これをシ ミ ュ レーシ ョ ンのみや論理合成のみの対象に変更でき ます。

図 2-26. RTL ソース フ ァ イルの対象プロセス を指定

　 当該 RTL ソース フ ァ イルを選択後、右ク リ ッ ク し て表示される メ ニューから [Include For] を選択する と リ
ス ト が表示されますので、 この中から １ つを選択し ます。

　 [Synthesis] または [Synthesis and Simulation] を選択し た ソースは、 論理合成の対象と な り ます。 [Simulation]
または [Synthesis and Simulation] を選択し た ソースは、 ”Simulation Wizard” （第 10 章参照） で論理シ ミ ュ レー
シ ョ ン用のコ ンパイルス ク リ プ ト が自動作成される時に、 デフ ォル ト でコ ンパイル対象 と し て含まれます。

　 　 使用例

・ テス ト ベンチを イ ンポー ト し て [Simulation] に設定

・ 論理合成用のブラ ッ ク ボ ッ ク ス ・ モデル （フ ァ イル） を イ ンポー ト し て [Synthesis] に設定

2.6.4 使用し ないソース フ ァ イルの扱い

　 RTL ソース フ ァ イルは、 イ ンポー ト し ていて も イ ンプ リ メ ンテーシ ョ ンご と に処理の対象から除外する こ
と ができ ます。 例えば （内部の記述が異な るが） 同じ entity/module 名のフ ァ イルを複数イ ンポー ト し てお
き、 イ ンプ リ メ ンテーシ ョ ン毎に使用する フ ァ イルを切 り 替えて使用する こ と ができ ます。

　 フ ァ イル リ ス ト ・ ビ ューの [Input Files] セ ク シ ョ ンで、 処理対象から外し たいフ ァ イルを選択し た後、 右
ク リ ッ ク し て表示される メ ニューから [Exclude from Implementation] を選択する と、 そのフ ァ イルは処理対象
から除外されます。 対象から除外されたフ ァ イルは、 薄い文字で表示されます。
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　 この設定は選択されている イ ンプ リ メ ンテーシ ョ ンでのみ有効で、 他のイ ンプ リ メ ンテーシ ョ ンには反映
されません。 また ”Remove” と は異な り 、 イ ンポー ト 自体は解除されません。

　 一度除外し た フ ァ イ ルを再び処理対処に戻す場合は、 同様に右 ク リ ッ ク し て表示 さ れ る メ ニ ューか ら
[Include in Implementation] を選択し ます。

2.6.5 RTL ソース フ ァ イルの削除

　 不要になった RTL ソース フ ァ イルは、 プロ ジェ ク ト から削除でき ます。 [Input Files] セ ク シ ョ ンで削除し
たいソース フ ァ イルを選択後、右ク リ ッ ク し て表示される メ ニューから [Remove] を選択するか、選択し た状
態でキーボード の [Delete] キーを押すと、 プロ ジェ ク ト から削除されます。 フ ァ イル自体は削除されません。

　 また、 イ ンポー ト 済みの RTL ソース フ ァ イルを移動し た場合など、 ツールが見つから ない と判断する と、
当該フ ァ イル名を取 り 消し線で表示し ます。 削除するか、 移動し た ものを元に複製するか戻すなどの対処を
し ます （任意）。

2.6.6 RTL ソース フ ァ イルのプロパテ ィ 設定

　 イ ンポー ト 済み RTL ソース フ ァ イルのプロパテ ィ と し て、 個別に以下の設定を行 う こ と ができ ます。

• VHDL ソースのコ ンパイル先ラ イブラ リ ー名

• Verilog HDL ソース内でイ ン クルード されている フ ァ イルの検索パス

図 2-27. Project Property ウ ィ ン ド ウ～ RTL ソース フ ァ イルの設定

　 第 2.3.5 項と同様の手順で ”Project Properties” ウ ィ ン ド ウ を表示し ます。 ソース フ ァ イルを選択し てから
表示し て も同様です。 ウ ィ ン ド ウ左枠でプロパテ ィ を設定し たいソース フ ァ イルを選択する と、 ウ ィ ン ド ウ
右側に設定可能な項目が表示されます。 図 2-27 は VHDL ソース を選択し た場合の表示例です。

　 なお、 イ ンプ リ メ ンテーシ ョ ン作成時に既存のイ ンプ リ メ ンテーシ ョ ンにイ ンポー ト されている ソース を
参照し た場合、 これらのプロパテ ィ 設定も反映されます。 従って イ ンプ リ メ ンテーシ ョ ン毎に設定し直す必
要はあ り ません。

2.6.7 RTL ソース フ ァ イルの暗号化

　 Radiant はイ ンプ リ メ ンテーシ ョ ンにエン ト リ ーする RTL ソース フ ァ イルのモジュール （エンテ ィ テ ィ ） 単
位での暗号化に対応し ています。

　 ラ テ ィ スの公開鍵を用いる場合を Verilog を例にし た手順は次の通 り です。Verilog の ”pragma” は VHDL で
は ”protect” が相当し ます。

１ ． RTL ソース先頭に次のよ う な pragma （Verilog） /protect （VHDL） 属性の宣言文を入れます。

`pragma protect version=1

`pragma protect encoding=(enctype=”base64”)

　 テンプレー ト にあ る次の宣言は任意です。
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`pragma protect author="<Your Name>"

`pragma protect author_info="<Your info>"

２ ． 以下を RTL ソース内に記述するか、 またはテキス ト フ ァ イル ”key.txt” と し て用意し ます。

`pragma protect key_keyowner= "Lattice Semiconductor"

`pragma protect key_keyname= "LSCC_RADIANT_2"

`pragma protect key_method="rsa"

`pragma protect key_public_key

MIIBIjANBgkqhkiG9w0BAQEFAAOCAQ8AMIIBCgKCAQEA0EZKUUhbuB6vSsc7OhQJiNAWJR5unW/OW
p/LFI71eAl3s9bOYE2OlKdxbai+ndIeo8xFt2btxetUzuR6SrvhxR2Sj9BbW1QToo2u8JfzD3X7AmRvlwKRX870
8DPo4LDHZMA3qh0kfDDWkp2EausfLzE2cVxgq7fy/bDhUeN8xKQCSKJ7aguG6kOI6ROoZz21ljzDLUQzhm
2qYF8SpU1otD8/uw53wLfSuhR3MBOB++xcn2imvSLqdgHWuhX6CtZIx5CD4y8inCbcLy/0Qrf6sdTN5SAg2
OZhjeNdzmqSWqhL2JTDw+Ou2fWzhEd0i/HN0y4NMr6h9fNn8nqxRyE7IwIDAQAB

図 2-28. 暗号化記述テンプレー ト （Lattice Semiconductor）

３ ． その後に RTL ソース内に一行空けて使用する アルゴ リ ズムを宣言し ます。 対応するのは標準的な
AES の CBC モード で、 キーワード は "aes256-cbc" （デフ ォル ト ） または "aes128-cbc" です。

`pragma protect data_method="aes256-cbc"

４ ． RTL ソース内で暗号化する対象の記述範囲の前後に次のよ う なキーワード を記述し ます。
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`pragma protect begin

　 <your code>

`pragma protect end

５ ． TCL コ ン ソールで以下のよ う なコマン ド を実行し ます （<> 内は実際のフ ァ イル名や言語を記述）。
上ステ ッ プ ２ でキーフ ァ イルを用意し ている場合はこのよ う に ”-k” オプシ ョ ンで指定し ます。 RTL
内に記述し ている場合は不要です。

encrypt_hdl -k <keyfile> -l <verilog | vhdl> -o <output_file> <input_file>

　 出力フ ァ イル名の指定は任意です。 その場合は ”<input_file>_enc.v” のよ う な名称で生成されます。

　 暗号化された RTL ソース フ ァ イルは、 も ちろんイ ンプ リ メ ンテーシ ョ ンにイ ンポー ト し て使用でき ます。

　 RTL ソース フ ァ イルにコ ピー＆ペース ト でき る テンプレー ト は Radiant GUI 操作で容易に入手でき ます。ま
ず GUI 左枠のウ ィ ン ド ウ下部にあ る三つのタブから、 [Source Template] を選択し ます。 表示されるセ ク シ ョ
ンから [Verilog] か [VHDL] を展開し、 [Encryption Templates] を展開する と、 Radiant の対応し ているベンダー
を含めた ８ つのテンプレー ト が用意されている こ と がわか り ます （図 2-28）。

　 なお、RTL ソースの暗号化では、Radiant フ ロー以外で論理合成 と し て Synplify Pro 対応にする場合は、RTL
ソース内に ”key_keyowner” と し ては ”Synplicity”、”key_keyname” と し て ”SYNP15_1” および ”SYNP05_001” の
二つについてそれぞれの ”key_public_key” を RTL ソース フ ァ イルの冒頭に追加し てお く よ う にし ます。

　 関連情報についてはオン ラ イ ンヘルプで [User Guides]→[Securing the Design]→[HDL File Encryption Steps]
をご参照 く ださい。

更 　 新 　 履 　 歴

--- *** ---

リビジョン ページ 　　　　　内　　　容

2022.1 6  Rev.3.2.1 からバージョン・アップに伴い、図2-9を更新

19  RTL暗号化について、LSEのみの対応の注記を追加

(r1) 1  デザインエントリーとして*.vmが可能なことを追記

7  2.2.4.2項を”プロジェクト属性の変更”に変更し、論理合成ツールの変更以外につ
いても追記

2023.2.1  バージョンアップに伴い見直し・更新

12  VHDLでのHDL Parameters属性入力について追記
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