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本ドキュメントの内容はマクニカにて確認した参考情報としての扱いであり、マクニカがその内容を保証するものではございません。

また、本ドキュメントの内容は全て現状有姿にて提供され、これに対する改版や技術サポートのご依頼に関しては理由の如何を問わず

お控え頂くようお願いしております。お客様ご用途における使用可否の判断、使用の際の動作確認、お客様製品への実装における

適合性や安全性の確認、法的要件の確認はお客様にて実施頂きますようお願いいたします。これらに対してもマクニカは一切の責任を

負うことが難しく、いかなる保証もいたしかねます。また、本ドキュメントはマクニカの所有物であり、予告なしに変更を加えることが

ございますので予めご了承ください。

免責事項
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1. はじめに

4

◼ Lattice Propel での作業にはライセンス・ファイルが必要です（P.45 を参照）

• Propel SDK はライセンスが無くても起動しますが、Propel Builder は起動しません

• インストール後、“license” フォルダーに入手したライセンス・ファイルを保存します

• Windows 環境変数 “LM_LICENSE_FILE” が適切に設定されていることを確認します

◼ 本 RISC-V チュートリアルは Windows 環境で主に “Hello World” テンプレート・プロジェクトを例として
実装する手順の紹介です

• MachXO2/3 ターゲットの場合は『Propel 2022.1 Tutorial』をご参照ください

◼ RISC-V の実装には Lattice Propel および Radiant を使用します

• Nexus シリーズ、Avant ファミリーが対象の場合 2024.1 を予めインストールしておきます

• Radiant の無償版で設計できます（SERDES 搭載品は有償版のみ）

• MachXO2/3 ターゲットの場合は Radiant ではなく Diamond を使用します

◼ Lattice Propel をインストール後 Eclipse IDE ベースの統合フレームワークで開発作業を行います

• Propel SDK C/C++ プロジェクトの作成とビルド、およびデバッグ（”Debug Perspective”）

• Propel Builder FPGA に構成する RISC-V を含む “SoC プラットフォーム”の設計と生成（SoC 

プロジェクト）
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RISC-V / Propel 実装手順の概要
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実装ステップは以下の通りです：

（事前準備）Propel Builder を起動し、各 IP モジュールをインストールしておきます（p.7）

✓ 一度更新しておけば、それ以降は必要に応じてインストールするのみです

1. Lattice Propel を起動します

✓ 作業フォルダ（workspace）を事前に作成しておきます

2. SoC プラットフォーム（FPGA 実装回路）を作成します

✓ Propel Builder で ”SoC プロジェクト”を作成し、プラットフォーム（回路設計と構成）を生成します

➢ ステップ３で必要な ”sys_env.xml” などが生成されますので、必ず SoC 作成が先になります

3. C/C++ プログラム（ユーザ・アプリケーション）を作成します

3-1. Propel SDK でソフトウェア・プロジェクトを作成します

➢ C/C++ ソースコードは別途作成してインポートするか、この環境で作成・編集します

3-2. C/C++ ソースコード一式をビルドします

➢ アプリケーション実行ファイル *.elf と、これを FPGA 用に変換した *.mem ファイルが生成されます

4. Propel Builder に戻り SoC プラットフォームを更新します

✓ ビルドで生成した *.mem ファイルを RISC-V 用プログラムメモリー sysmem の初期化に指定します

➢ sysmem コンポーネント初期化指定しないでデバッグ作業を繰り返す方法もあります（p.30 参照）

5. （Propel から）Radiant を起動してフィッティングします

6. プログラマーでデバイスをプログラミングした後に動作確認（HW/SW デバッグ）します
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Propel Builder の起動
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◼ Windows スタートメニューで Lattice Propel Builder 2024.1 をクリックして起動します

✓ ライセンス・ファイルが見つからないと “License checkout failed” のメッセージが出ます（p.45 参照）

クリック

Propel Builder 単独起動時の
初期画面

ライセンス・エラー表示
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Propel Builder：IP のインストール
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◼ “IP on Server” タブを選択し、各コンポーネントをインストールします

◼ まず アイコンをクリックして Lattice Server にアクセスできるかどうかをチェックします

◼ アクセスできないと下のようなメッセージが表示されますので、次ページのネットワーク設定を確認・変更します

✓ 問題なければ右図のように入手可能なコンポーネントとそのバージョン、インストール済かどうか
がリストされます

✓ インストールするコンポーネントを選択し、 アイコンのどちらかをクリックします

☞ “License Agreement” を求める表示が出ますので、”Accept” して作業を進めます

☞ RISC-V コアは SM と MC、および RX の三つがありますが、全てインストールしておきます

☞ 各コンポーネントは最新バージョンのインストールを推奨します（古いバージョンは必要な場合
にのみインストールします）

◼ インストールが完了したら、いったん Propel Builder は終了します

✓ その後は IP が更新され次第、単独起動することなく、逐次インストールできます

✓ Propel Builder で作成した SoC プロジェクト（プラットフォーム）は、GUI 単独
起動ではなくても、SDK からオープンできます（p.22、p.28、p.31）
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Propel Builder：ネットワーク設定
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◼ Lattice Server アクセスに問題がある場合、ネットワーク設定を確認します

◼ メニューバーの Tools → Options.. を選択します

◼ 社内ネットワーク接続環境などでプロキシ・サーバーを介する場合は “Use a Proxy Server” にチェックしてホスト名、
ポート名などを適切に設定します

◼ Apply → OK をクリックします

proxy 設定例
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Propel SDK の起動
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◼ Propel の起動は Windows スタートメニューで Lattice Propel 2024.1 をクリックします

✓ Launcher 窓が立ち上がり workspace を訊いてきます

✓ デフォルトのディレクトリは後々の作業でやや煩雑なので、予め専用の作業ディレクトリを作成しておき、ブラウズして
指定先にします

☞ 以降ステップの SoC プロジェクト、C/C++ プロジェクトのフォルダは全てこのディレクトリ下に生成されます

☞ 開発案件ごとに作成して使い分けるなど、プロジェクト管理が容易になります

☞ 『Browse...』ボタンで指定、または下部 “Recent Workspaces” を展開し作成済フォルダをクリックすることで起動時の指定を
変更できます

☞ P.62 に関連記述

クリック

Launcher: デフォルトの
workspace 設定Recent Workspace 展開後の

表示・選択例
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Propel SDK の初期画面

10

◼ Propel SDK が起動したら（下）、File → New → Lattice SoC Design Project を選択して SoC ハードウェア・プ
ラットフォームを作成します（右）

☞ p.5 に明記した通り SoC 作成後の生成ファイル “sys_env.xml” がないと、C/C++ プロジェクトは作成できません

☞ Propel Builder GUI を起動して作成しても、Project Explorer に表示（登録）されませんので、関連する C/C++ プロジェクトと
連携したプロジェクト管理ができません。必ず SDK から作成するようにします（別途インポートする場合は pp.54-57）

Propel 初期表示

✓ 初期表示の状態でのみ、ここをクリックしても同様です
✓ 一つでもプロジェクトを作成すると、Project Explorer 

枠内の表示は変わります
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SoC プロジェクトの作成（1）
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◼ “Create SoC project” が表示されますので、プロジェクト名を入力し、その他を指定します

✓ “Template Design” はチュートリアルでは Hello World Project を選択します（Finish で終了）

☞ “Project name” は SoC プロジェクトであること、およびターゲットデバイスが容易に識別できる名称にします

☞ “Project name” 入力と同じ名称のフォルダが workspace (p.9) の下に生成されます

☞ RISC-V RX は RTOS 用です

SoC プロジェクト名を入力

チュートリアルは
テンプレートから選択

(RISC-V タイプで異なる）

（Family 選択後に指定）

Speed Grade、温度グレード

Family

RISC-V コアの選択

テンプレート・プロジェクトの内容

重要：Device Select 部各指定は、この後に変更する
ことができません。特に Family は生成 RTL に作用し
ますので注意します。Device / Package / Speed 
の設定は厳密でなくても構いません（p.19 参照）

言語を選択
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SoC プロジェクトの作成（2）
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◼ Project Explorer 枠に生成された SoC プロジェクトとファイルが表示されます

◼ 同時に Propel Builder が立ち上がり、テンプレートで選択した プロジェクトの回路が表示されます

Propel Builder 起動後の
テンプレート・デザインの表示例

[IP Catalog] タブでは PC にインストール済みで、かつ選択
デバイスで使用できるコアとペリフェラル名が表示されます
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SoC プロジェクトの作成（3）
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◼ テンプレートで選択した Crosslink-NX 用 Hello World の回路図トップが表示されます

✓ RISC-V コアは、ここではインスタンス “cpu0_inst” です

✓ “osc” と “pll” コンポーネントがクロックソースとしてインスタンスされています

✓ 実行プログラムを格納するオンチップメモリ・コンポーネントは “sysmem0_inst” です

✓ ペリフェラル・インスタンスとして GPIO（gpio0_inst）、UART（uart0_inst）が APB で接続されています

• 通常どのようなハードウェアにも存在するペリフェラルです。割り込み信号が直接コアに与えられます

ペリフェラル・
コンポーネント

AHBL / APB インター
コネクト・コンポーネント

RISC-V CPU

プログラムメモリー

osc コンポーネントの構成 pll コンポーネントの構成
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SoC プロジェクトの作成（4-1）
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◼ 各コンポーネントのバージョン確認・更新

✓ テンプレートや既存の Schematic が表示される際に、含まれるコンポーネント（IP）がインストールされていないと左下
メッセージ１のような表示が出る場合があります

• Propel Builder が立ち上がった状態で “IP Catalog” タブを選択し、当該 IP をインストールします（p.7）

✓ Schematic 内の各コンポーネントをダブルクリックして、左下メッセージ２のような表示が出ないことを確認します

• “replace” の必要がなければ pp.15～17 のような “Configure IP” ウィンドウが立ち上がりますので、“Generate” をクリックします

• メッセージ２の場合に “replace” に問題なければ “Yes” をクリックして先に進みます

“Open IP” メッセージ２ “IP Catalog” タブを選択後
p.7 のようにインストール

“Open IP” メッセージ１
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SoC プロジェクトの作成（4-2）
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◼ 各インスタンスをダブルクリックするとその構成（Configuration）ができます

✓ pp.15-17 の図・バージョンは Propel 2024.1 を元にしています

✓ 下図は RISC-V MC ですが、構成を変更したら必ず Generate をクリックします（他も同様）

✓ P.14 に示した通りバージョンが古いとメッセージが出ますので更新します

RISC-V MC 2.6.0
のデフォルト Property 

RISC-V MC/SM
のシンボル例
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SoC プロジェクトの作成（4-3）
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◼ sysmem と AHBL/APB インターコネクト・コンポーネントです
プログラムサイズによって変更します

（デバイスに搭載されている EBR 数が許容限度です。
8kW（8,192）で EBR の場合 16 個を消費します）

pp.29-30、p.47 に関連説明
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SoC プロジェクトの作成（4-4）
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◼ GPIO と UART コンポーネントです

I/O ポートの本数

双方向バッファをなしにするオプション

出力の初期値（各ビットごとに設定）

方向：1=出力、0=入力（各ビットごとに設定）

ボーレートの精度が +/-1% 以内＊ に
なる除数（整数）が存在し、かつ PCB 
/ Device が生成できる周波数にします

（＊：一般的には <1.5~2% 
程度のデバイスが多い）
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SoC プロジェクトの作成（4-5）
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◼ Propel Builder の Address タブでアドレスマップが確認できます

✓ 下図はデータ（ペリフェラル）バス選択時の表示例です

① sysmem など、アドレスを固定したいコンポーネントの ”Base Address” を入力後に”Lock” をチェックし、 を
クリックして自動アサインする、または

②各コンポーネントの ”Base Address” を適宜編集します（Lock をチェックしておきます）

データバスのメモリマップ表示例

アドレス範囲がオーバーラップしていると赤色
表示になりますの（DRC エラー）で、問題

の有無が容易に判別できます

アドレスを固定（ロック）する際にチェックします
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SoC プロジェクトの作成（4-6）
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◼ Propel Builder の Design View タブから、ターゲット・デバイスの属性が確認できます

☞ Propel 2024.1 からは Family のみでなく、Device/Package/Speed/Operating... も全て変更できなくなりました

全てグレイアウトになり、変更ができません

(CertusPro-NX の場合の例)
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SoC プロジェクトの作成（5）
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◼ 新規にコンポーネントやポートを追加した場合など、それらを結線する方法について記述します

✓ ワイヤ（1bit 幅の信号やポート）：下

a. マウスをピン上に移動して アイコンが表示されたらクリックし、クリックした状態で、結線先のピンにドラッグ（移動）します

b. 結線可能だと信号線がボールドに変化し、また緑色のマーク が現れれますのでクリックします。結線されると赤色になります

c. 連続してこの状態で他にも結線できるように アイコンと配線が表示されたままになっていますので、全て結線するまで継続します

d. 結線する作業を終了する場合は、この状態で何もないところでマウス右クリックするか『Esc』 キーをヒットします

✓ バス信号の接続：右

1. ワイヤの a ~ b は同じ操作です

2. 結線されると、配線が赤色になり、これで結線操作は終了します

a & b. ピンでクリックしたままドラッグして再クリックすると
信号線がボールドになり、緑のマークが出る

c. クリックが有効だと赤色になります。アイコンと配線のマーク
は表示されたままで、連続して他と結線できる

1. バスの場合、始めはワイヤ
の a & b と操作は同じ

2. 結線先でクリックする
と赤色になり、これで
自動終了

クリックして開始

有効な結線先
（クリック前）

結線後も表示された
まま（Esc で終了）

有効な結線先には
緑マークが表示される

クリックして
開始
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SoC プロジェクトの作成（6）
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◼ 各コンポーネントの配置と接続、構成（パラメータ）、およびアドレス配置を完了します

✓ アドレス配置は “Auto Assign” しても良いです

◼ メニューバーかアイコンで次を行います

1. DRC (Validate Design)必須です！

2. Generate

◼ Tcl Console はエラーがなければ右下のようになります

✓ 保存後 Propel SDK GUI に戻ります（次ページ）

☞ SoC の属性を全て含む二つのファイル “sys_platform.h” と “sys_env.xml”、

および各コンポーネントのドライバーが C/C++ プロジェクトにコピーされます

✓ Warning は極力解消しておくようにします

☞ 本例 “cpu0_inst_TIMER_IRQ_M0 remains unconnected...” はこのまま残って

いても Generate できます

“Validate” (DRC)

（Address) Auto Assign

Generate

SoC プロジェクト名

“Generate” 後の
コンソール表示例

生成されるファイル
とサブフォルダ例

RTL

“Generate” 後の Project 
Explorer ウィンドウ表示例
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SoC プロジェクトの確認
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◼ Propel Builder で問題なく Generate が実行されると “sge” サブフォルダと各ファイルが生成されています

✓ Project Explorer 枠で確認できます

✓ ダブルクリックして、各ファイルの内容を確認することができます

ダブルクリック

各モジュール / コンポーネント
のドライバーが参照する属性
情報の定義ファイル（例）

ダブルクリック

SoC プロジェクトを選択してメニュー

バー下部のアイコン列から を

クリックすれば Propel Builder が起動
し、回路図が表示されます
（右クリックメニュー Open Design In 

→ Propel Builder でも同様）

SoC プロジェクトの構成を定義
する情報（例）
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ソフトウェア・プロジェクトの作成（1）
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◼ SoC プロジェクトの次に C/C++ ソフトウェア・プロジェクトを生成します

1. File → New → Lattice C/C++ Project を選択

2. 立ち上がる “C/C++ Project” 設定 GUI で：

① System env: セルには SoC プラットフォーム作成時に生成された

“sys_env.xml” を指定します（確認します）

（或いはブラウズ・ボタンかプルダウンから意図するものを指定）

②ソフトウェア・プロジェクトの名称を入力し、Project Type（C/C++）を

確認し、Next をクリックします

☞ プロジェクト名を入力しないと『Next』ボタンはアクティブになりません

☞ ソフトウェア・プロジェクトであることが容易に識別できる名称にします
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ソフトウェア・プロジェクトの作成（2）
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◼ “C/C++ Project” 設定 GUI（つづき）

③ “Configuration:” で Debug / Release を選択して “Finish” します

☞ この後、右に示すような確認を促すウィンドウが表示されることがありますが、適宜クリックして進みます

☞ [Lib Setting]、[C/C++ Compiler]、[C/C++ Linker] 各タブがありますが、ここでは全てデフォルトのままにします

☞ 入力したソフトウェア・プロジェクト名のフォルダが自動生成されます（事前にフォルダを作成しておく必要はありません）

☞ プロジェクト作成後の Debug / Release 切り替え方法は p.61 をご参照ください

確認のウィンドウ表示
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ソフトウェア・プロジェクトのビルド（1）
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◼ 生成されたプロジェクトとファイル一式は下図例のようになります

☞ Project Explorer 枠の表示は workspace 下に自動作成される C/C++ プロジェクト・フォルダです

☞ 右ソース・ウィンドウは main.c を示しています

生成チュートリアル・プロジェクト
下のファイルとサブフォルダを

展開した状態

ダブルクリック

自動的に取り込まれ
たドライバー群

本チュートリアル用の
ソースファイル
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ソフトウェア・プロジェクトのビルド（2）
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◼ ソフトウェア・プロジェクトをビルドします

1. プロジェクトを選択して右クリックし、”Build Project” を選択します

2. 問題がなければコンソールに <project_name>.mem がビルドされて
“Build Finished” というメッセージが表示されます

☞ エラーが無くなるまでソースを編集など、デバッグします

☞ Warning も（極力）解消するようにします

☞ 左下は “sysmem” サイズが小さすぎるための Fail 例です

3. 次に Propel Builder で作業して（次ページから）、再度 SDK GUI に
戻ります

選択して右クリック

Builder で設定した sysmem サイズがオーバーフローした
（メモリサイズが小さすぎる）ためのエラー例
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ソフトウェア・プロジェクトの更新
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◼ Propel Builder で SoC プラットフォームに何らかの変更を行った場合の操作です

どちらの方法でも、
始めに C/C++ 

プロジェクトを選択します

右クリック

方法１

方法２

 適宜チェック

確認

✓ アドレスマップなどのマイナーな変更の場合は手動
で C/C++ プロジェクト下の sys_env.xml、
sys_platform.h を SoC プロジェクトの最新の
同名ファイルに差し替え（コピー＆ペーストし）て
も更新できます

✓ 周辺コンポーネントの追加・削除などの変更では
左図のように “Update Lattice C/C++ 
Project...” を選択後の表示ウィンドウで
『Update BSP package』 ボックスをチェックし
『Update』 ボタンをクリックすることで一括して自動
更新できます

✓ CPU の構成やメモリーに変更がある場合などは、
『Re-generate toolchain parameters and 
linker script』 ボックスをチェックしてから
『Update』 します

✓ その後どの方法でも “Clean Project” を実行し
てから “Build Project” を行います

（Propel 2023.2 以前に作成された SoC に
対する 2024.1 での本操作はできませんので
ご注意下さい）
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Propel Builder：プログラムメモリーの設定（1）
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◼ ソフトウェア・プロジェクトのビルドで生成した mem ファイルをプログラムメモリの初期化に使用する
ための設定を行います

1. SoC プロジェクトを選択します（ソフトウェア・プロジェクトではありません）

2. 次のいずれかの方法で Propel Builder を立ち上げます（次ページ）

✓ アイコン をクリック（下図赤丸）、または

✓ メニューから [LatticeTools] → [Open Design in Propel Builder] を選択、または

✓ SoC プロジェクト行を右クリックして表示されるメニューから [Open Design In] →[Propel Builder] を選択

始めに SoC プロジェクトを選択
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Propel Builder：プログラムメモリーの設定（2）
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◼ Propel Builder で mem ファイルをシステム
メモリ（プログラムメモリ）の初期化ファイル
に指定します

1. sysmem インスタンスをダブルクリック

2. “Initialize Memory” のボックスをチェック

3. “Initialize File” セルの右端のブラウズ・ボタ
ンをクリックし、mem ファイルをブラウズ
して選択（ソフトウェア・プロジェクト・
フォルダ下 Debug/Release サブフォルダの
下に生成されています）

4. 当該 mem であることを確認して Generate

5. （次ページ）

③ セルをクリックするとブラウズボタンがアクティブに
なるので、ブラウズして *.mem ファイルを指定

② チェック

① sysmem インスタンスをダブル
クリック

④ mem ファイル指定後、 Generate
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Propel Builder：プログラムメモリーの設定（3）
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５．最後にメニューバーかアイコンで Generate し、保存後 Propel SDK GUI に戻ります

◼ Generate 時に Tcl Console でエラーがないことを確認します

◼ 必ず保存します

☞ この .mem 指定ステップに限り、Generate 後にソフトウェア・プロジェクトを再ビルドする必要はありません

☞ システムデバッグ段階でソフトウェア・プロジェクトを再ビルドして *.mem を更新する度に、sysmem コンポー
ネントをダブルクリックして再度 Generate した後に、SoC プラットフォームを保存するか再 Generate する必要が
あります

☞ sysmem の Generate のみでは、更新された *.mem が反映されません

☞ この場合、Radiant / Diamond では論理合成からのやり直しになります

☞ 処理時間を短縮する方法が ECO Editor で（pp.47-48）、両方の Generate を省くことができます

☞ なお、sysmem の初期化ファイルを指定せずにブランクのままにしておくことで、p.35 の OpenOCD 設定 GUI か
ら起動するデバッガーでのデバッグが可能です。この場合はフィッティングも ECO Editor も不要ですので、
C/C++ 記述が確定できずにOpenOCD ベースのデバッグを繰り返す場合の手法の一つとして有効な選択肢です

☞ いずれかのコンポーネントの何らかの構成（パラメーター）を変更した場合は Generate 後に P/F ビルダー下の
sys_env.xml、 sys_platform.h を SoC プロジェクト下に手動でコピー＆ペーストしてから再ビルドする必要があり
ます（Clean Project→ Build Project 操作のみでは自動更新されません。P.27 関連記述）

Generate
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Radiant フィッティング（1）
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◼ ターゲットデバイスが Nexus シリーズの場合は Radiant を
選択します

1. SoC プロジェクトを選択して右クリック（ソフトウェア・プロ
ジェクトではありません）

2. Open Design In → Radiant を選択

（Radiant 2024.1 が立ち上がります：次ページ）

☞ Diamond はグレイアウトします

☞ SoC プロジェクトを選択した後、メニューバー下部のアイコン

列から をクリックしても同等です

☞ SoC プロジェクトを選択してメニューバー下部のアイコン列から

をクリックすれば Propel Builder が起動し、回路図が表示されます

（右クリックメニュー Open Design In → Propel Builder でも同様）

選択して右クリック
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Radiant フィッティング（2）

32

◼ Radiant がプロジェクトをオープンした状態で起動します

☞ インポートされるのは RTL トップ（*.v）と下位コンポーネントの *.ipx です

☞ オンチップ・オシレータの周波数は自動認識されますが、仮に認識されないネットがあれば、Post-Synthesis Timing 
Constraint Editor（または *.pdc ファイルを編集すること）で手動で与えます（下右図、一部）

☞ ポート配置指定も基本的には手動で与えます

トップ・モジュール
（ボールド表示）

下位モジュール / 
各コンポーネント

“Post-Synthesis Timing Constraint Editor“
でクロックネットを指定するウィンドウでの選択例
（p.13 に示す回路図における PLL 出力相当）
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SDK デバッグ設定（1）
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◼ Programmer でデバイスをプログラミングしておきます

◼ デバッガー設定を起動しますが、これには二通りの方法があります

1. デバッグ・アイコン をクリックします

（下図：アイコン右側の▼部をクリックすると表示される “Debug Configurations...” を選択しても同じです）

2. メニューバーで Run → Debug Configurations... を選択します（右図）

以前に立ち上げたデバッグ・セッションが
あればここにリスト表示されます
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SDK デバッグ設定（2）
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◼ デバッグ設定用のウィンドウ（Debug Configurations）が表示されます

◼ “GDB OpenOCD Debugging” 行をダブルクリックするか、本行を選択して右クリックすると表示されるメニュー
から “New Configuration” を選択します

New Configuration を選択
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SDK デバッグ設定（3）
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◼ “Name” は作業プロジェクトに対して “<Project-name> Debug” になります

◼ “Project:” セルと “C/C++ Application:” セルが意図するものであることを確認し、”Name セル”のデバッグ
セッション名をチェックします

クリックしてデバッグ作業を開始
（または次ページ）
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SDK デバッグ設定（4）
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◼ 前ページで『Debug』ボタンをクリックする前の、作業が確実に開始できるかどうかがわかるステップです

✓ [CableConn] タブを選択し、『Detect Cable』、『Scan Device』ボタンを順にクリックします

✓ “Port” セルが本タブを選択時に “FTUSB-0” のように表示されていれば『Detect Cable』は省略可です

✓ 『Scan Device』後、“Device” セルが下図例のようになっていればデバッグ開始できます

☞ “Device” セルがブランクのままや

“+” 表示などの場合は何か問題があり

ますので、解消する必要があります

PC の C ドライブ直下に “Data” という名称の
フォルダがあると、『Scan Device』 後にこの
セルが “+” 表示になることが報告されています

クリックしてデバッグ作業を開始
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Info : clock speed 4000 kHz
Error: JTAG scan chain interrogation failed: all zeroes
Error: Check JTAG interface, timings, target power, etc.
Error: Trying to use configured scan chain anyway...
Error: fpga_spinal.bridge: IR capture error; saw 0x00 not 0x01
Warn : Bypassing JTAG setup events due to errors
Info : Listening on port 3333 for gdb connections
Started by GNU MCU Eclipse
Info : Listening on port 6666 for tcl connections
Info : Listening on port 4444 for telnet connections
Info : accepting 'gdb' connection on tcp/3333
Info : Halt timed out, wake up GDB.
Error: timed out while waiting for target halted

Error: JTAG scan chain interrogation failed: all zeroes

SDK デバッグ設定（5）
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◼ まれにデバッガー動作を開始後、左下のようなエラーがコンソールに表示される場合があります

✓ 少なくとも MachXO3 Starter ボードが該当します

◼ この場合の対処方法の一つを示します：

✓ [Debugger] タブを選択し、Config options セル内のオプション “set channel” と “set cmdlength” の値を下図のように編集します

✓ 以下 FAQ に記述があります

https://www.latticesemi.com/support/answerdatabase/7/2/6/7268

コンソールのメッセージ例

FAQ ページから引用

https://www.latticesemi.com/support/answerdatabase/7/2/6/7268
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SDK デバッグ（1）
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① ファイアーウォールのウォーニングが出ますが、許可して進みます

② Perspective 切り替えのメッセージが表示されますので、”Switch” をクリックします

③ 起動に問題があるとメッセージが出ますので解消してやり直します

④ 起動には比較的長い時間がかかりますが、GUI 右下のステータスバーが表示されていれば正常です

⑤ デバッガーが起動すると Console にログが表示されます（下に一部のみを例示）

☞ 赤字は GDB のログメッセージであり、必ずしもエラーを意味する訳ではありません

③の表示例：デバイス接続の問題や
コンフィグされていない時などのエラー例

②の表示

⑤の表示例
（一部）

④の表示例
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SDK デバッグ（2）

39

◼ 起動に成功すると、表示が Debug Perspective に切り替わります

✓ main() 先頭で自動的に停止します

✓ アイコン（Open a terminal）をクリックし、ターミナル（UART）設定をします

➔ “Serial Terminal” にプルダウンを変更し、”Serial port” を候補から選択します

Debug Perspective に
切り替わります

Serial port は適切な選択をします（候補
がリストされますが Windows のデバイス
マネージャで念のため確認しておきます）

初期表示

Serial Terminal はデバッガーを用いない
時でも、ターミナル・ソフトとして利用できます
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SDK デバッグ（3）
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◼ 前ページの操作でコンソール部に新たに Terminal タブが現れますので、これを選択します

✓ アイコン（resume）をクリックして、プログラムを実行します

◼ ”printf” 文でメッセージを出力する記述があれば Terminal に表示されます

✓ 実行停止は アイコン（suspend）です

✓ ブレークポイント設定（次ページ）、ステップ実行（右）などでデバッグ作業を進めます

✓ メモリ内やレジスタ値を表示させる機能もあります

◼ デバッガー（GDB セッション）の終了は GUI 上部のアイコン列にある か、右下
“Console” タブを選択すると右側にある アイコン（terminate）をクリックします

→注意事項：p.43

step into

step over

step return

step into 下位関数が呼ばれれば、その行に進む
step over 下位関数が呼ばれても、そこに飛ばずに次の行に進む
step return 下位関数に飛んだ後、飛んだ元の次の行に進む
等々、、、
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SDK デバッグ（4）
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◼ ブレークポイントの設定はデバッガー実行中に一旦停止して以下を操作します

✓ ブレークするソース行を選択→行頭の行数表示箇所で右クリックして “Add Breakpoint...” をクリックします

✓ プロパティ・ウィンドウで “Apply and Close”（”Ignore count” 0 で毎回ブレーク）します

✓ 右上ウィンドウ枠の “Break” ビューで設定されているブレーク・ポイント一覧が表示されます

✓ 実行（Resume）してブレークポイントに達すると、そのソースコード行が緑色表示になり停止します

◼ 解除は同様にして “Toggle Breakpoint” するか、Break ビュー内リストの

チェックボックスをクリック（disable）します

◼ 設定済ブレークポイントのプロパティ変更は Break ビュー内で選択して

右クリック→ “Breakpoint Properties...” をクリックして再設定します

行数表示の
上でクリック

✔印ありで Enable
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SDK デバッグ（5）
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◼ デバッガー GUI デフォルトで右上には種々 View がタブで選択できます

✓ Variables / Breakpoints / Peripherals / Modules ...

➢ [Variables] タブではグローバル / ローカル変数のその時点の値を確認および編集できます

➢ [Breakpoints] タブではブレークポイントの確認やイネーブル / ディセーブル設定ができます

◼ 次の操作をすることで逆アセンブル・コードを表示すると、ステップ実行の様子を確認することができます

✓ Window → Show View → Disassembly
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SDK デバッグ（6）

43

◼ デバッガーを Terminate しただけでは元の SDK Perspective 表示には戻りません

1. GUI 左上の『Project Explorer』タブをクリック、または

2. GUI 右上の アイコン（Open Perspective）をクリック、または

3. メニューバーで次の操作をします：Window→ Perspective → Open Perspective → Propel SDK

重要：デバッガーを終了する前に Propel を終了したり、ボードを取り外すと Programmer が誤動作する状態になる可能性があり
ます（PC を再起動しても復帰しない）。必ず p.40 に示すとおり アイコンで通常終了してから次の作業をするようにします

１の操作

２の操作

３の操作
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➢ 補足１ 無償ライセンス・ファイルの生成・入手

➢ 補足２ What’s New in Propel 2024.1 

➢ 補足３ ECO Editor

➢ 補足４ GPIO コンポーネントの多ビットポート

➢ 補足５ ユーザーモジュールの組み込み

➢ 補足６ 内部バス引き出しでユーザー回路とインターフェイス

➢ 補足７ SoC/C プロジェクトのインポート

➢ 補足８ SoC プラットフォームのインポート

➢ 補足９ C/C++ プロジェクトのインポート

➢ 補足10 SDK ビルド設定

➢ 補足11 Propel 起動後のワークスペースの切り替え

補 足

44
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1. ラティスのホームページから Propel のページに移動し、”Licensing” をクリックします

2. 移動先で “Request a Free License” をクリックします

3. 移動先で “Name”, “Email” を確認し Host NIC セルに入力します

4. “I verify ...” の内容を確認し文頭をチェックします

5. ”Generate Licensing” をクリックします

補足１：無償ライセンス・ファイルの生成・入手

45

registered name

registered email address

registered email
address

2. 移動先で Propel のセクションにあるリンク
“Request a Free License をクリックします

（事前にユーザー登録している
必要があります）
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◼ What’s New in Propel 2024.1 (Rel.Notes) ➔

◼ なお、本ドキュメントで参照した関連文書
は以下の通りです：

• FPGA-UG-02211-1-0-Lattice-Propel-2024-1-SDK-
User-Guide

• fpga-ug-02212-1-0-lattice-propel-2024-1-builder-
user-guide

補足２：Propel 2024.1

46
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◼ プログラムメモリー sysmem の初期化ファイルのみを変更するツールが ECO エディターです

✓ ユーザー・アプリケーションのデバッグ完了までは、C/C++ コードの記述を修正・編集して確認する、繰り返し作業になるこ
とが一般的です

☞ その都度、実行コード *.elf を変換した *.mem ファイルが更新されます

✓ この更新された *.mem を反映するためには sysmem コンポーネントをダブルクリックして再度 Generate した後、SoC プラット
フォームを保存して再 Generate する必要があります

☞ sysmem の Generate のみでは更新された *.mem が反映されません

☞ この場合、Radiant / Diamond では論理合成からのやり直しになります

☞ 全てのデバッグが完了した後、デザインのリリース段階では少なくとも再 Generate が必要です

✓ Radiant / Diamond には sysmem の初期化ファイル *.mem のみの変更が可能なツール “ECO Editor” があります。

☞ これは PAR 完了後のネットリストに対する操作であり、SoC プラットフォーム自体が変更されていなければ、PAR までのフィッ
ティング処理は一切不要になり、繰り返し処理の時間を大幅に節約できます

☞ sysmem コンポーネントや SoC プラットフォームの再 Generate は不要です

✓ SoC プラットフォームに含まれる各コンポーネントの構成（パラメータ）や回路の変更があれば、フィッティングは論理合成
から再実行する必要があります。sysmem のサイズやアドレスマッピングの変更もこれに含まれます

☞ OpenOCD ベースのデバッグを繰り返す場合、sysmem の初期化ファイルを指定せずにブランクのままにしておく方法があります
（フィッティングも ECO Editor も不要です）。ビルド後に P.33 のデバッグ設定から作業します

補足３：ECO Editor（Radiant）

47
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④hex にしてブラウズ
➔ *.mem 指定

◼ プログラムメモリー sysmem の初期化ファイル更新手順は以下のとおりです

① PAR まで完了後 アイコンをクリックします

② ECO Editor 下部の “Memory Initialization” タブを選択します

③ “Memory Instance” 名の中から “sysmem0” のようなインスタンス名に相当するものを特定します（デザインに依っては他にも
メモリ・インスタンスがある場合がありますので、間違えないようにします）

④ Attribute セルにある “Choose File ...” をダブルクリックすると表示される “Update Initial Memory” GUI で “File Format” を
“Hexadecimal” に変更後 “Memory file” セル右端のブラウズボタンをクリックして、意図する .mem ファイルを指定（絶対パス
表記）し、OK ボタンをクリックします

⑤ Output 枠に “Success to ...” が出れば成功です

⑥保存アイコン をクリックすると表示されるメッセージで“Save” をクリックして ECO Editor を終了します

⑦ Export Files プロセスを再実行します

補足３：ECO Editor（Radiant、つづき）
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①

②

③ ダブルクリック

⑤

sysmem インスタンス

⑥
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◼ SoC ビルダーで回路図作成時に多ビット幅外部ポートを追加する際の例です

✓ Bus Options のボックスをチェックし、MSB と LSB のビット位置を明示的に入力します

✓ その後 Schematic で結線します

補足４：GPIO 外部ポートの多ビットポート
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ビット幅を決める
ので必要

ブランク領域でマウスを右クリック
して Create Port を選択 8b 出力の

GPIO 例
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◼ ユーザー論理は RTL トップで SoC と統合（編集）しますが、その際は以下に留意します

✓ 下図に示す通り “Remove Tri-State Buffer” をチェックします（P.17 に関連記述）

➢ 双方向バッファがないため、I/O ポートは “gpio_i”、”gpio_o”、“gpio_en_o” になります

➢ 出力設定時 “gpio_en_o” はトライステート・バッファ制御用です。双方向バッファを制御しない場合はオープンでも構いません

補足５：GPIO ポートをユーザー論理と接続する際の注意

50
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◼ APB バスを引き出す方法を示します
✓ RTL トップで APB バス I/F をもつユーザー回路と Propel 生成 SoC RTL とを統合する場合です

1. “APB Interconnect” コンポーネントをダブルクリックし、マスター（M）ポート数を一つ増やしておきます

2. Module → “Processors...” → “APB Feedthrough” コンポーネントを追加し、その S ポートを “APB Interconnect” コンポーネントの M ポー
トに接続します

3. APB Feedthrough コンポーネントの設定は “Completer” を指定します（アドレスマッピングの対象になります）

4. バス引き出しはコンポーネントを選択して右クリック後のメニューから Export を選択します

5. 『DRC』 実行後『Generate』 します（必要に応じてアドレスを編集したり “Lock” します）

補足６：内部バス引き出しでユーザー回路と I/F（1）

51

APB Feedthrough

コンポーネントの設定例

バスを接続

アドレスマップされていることを確認

APB Interconnect

コンポーネント

バスが引き出される
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◼ AHBL バスを引き出す方法を示します
✓ RTL トップで AHBL バス I/F をもつユーザー回路と Propel 生成 SoC RTL とを統合する場合です

1. “AHBL Interconnect” コンポーネントをダブルクリックし、マスター（M）ポート数を一つ増やしておきます

2. Module → “Processors...” → “AHB-Lite Feedthrough” コンポーネントを追加し、その S ポートを “AHBL Interconnect” コンポーネントの M 

ポートに接続します

3. AHBL Feedthrough コンポーネントの設定は “Slave” を指定します（アドレスマッピングの対象になります）

4. バス引き出しはコンポーネントを選択して右クリック後のメニューから Export を選択します

5. 『DRC』 実行後『Generate』 します（必要に応じてアドレスを編集したり “Lock” します）

補足６：内部バス引き出しでユーザー回路と I/F（2）
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AHB-Lite Feedthrough

コンポーネントの設定例

バスを接続

アドレスマップされていることを確認AHB-Lite 
Interconnect

コンポーネント

バスが引き出される



© Macnica, Inc.

◼ AXI4 バスを引き出す方法を示します

✓ RTL トップで AXI4 バス I/F をもつユーザー回路と Propel 生成 SoC RTL とを統合する場合です

1. “AHBL Interconnect” コンポーネントをダブルクリックし、マスター（M）ポート数を一つ増やしておきます

2. IP → “Processors...” → “AHB-Lite to AXI4 Bridge” コンポーネントを追加し、その S ポートを“AHBL Interconnect” コンポーネント の M 

ポートに接続します

3. IP → “Processors...” → “AXI4 Feedthrough” コンポーネントを追加し、その S ポートを “AHB-Lite to AXI4 Bridge” コンポーネントの M 

ポートに接続します

4. AXI4 Feedthrough コンポーネントの設定は “Subordinate” を指定します（アドレスマッピングの対象になります）

5. バス引き出しはコンポーネントを選択して右クリック後のメニューから Export を選択します

6. 『DRC』 実行後『Generate』 します（必要に応じてアドレスを編集したり “Lock” します）

補足６：内部バス引き出しでユーザー回路と I/F（3）
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バスが引き出される

AHB-Lite to AXI4

Bridge の設定例

バスを接続

アドレスマップされていることを確認

（Mem.Map Width=16b の場合）

AHB-Lite to 
AXI4 Bridge

AXI4 Feedthrough 
コンポーネントの設定例

タイプ以外に特に ID 幅や
メモリマップ幅などの設定に

も注意します

注：現状 2024.1 でこの構成で DRC を実行すると Propel 
Builder が強制終了します。原因は不明です。
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◼ SoC と C/C++ プロジェクトを複製しないでインポートする手順です

1. 作業フォルダを作成し、その下にパッケージ zip ファイルを解凍しておきます

➢ デスクトップや日本語名フォルダの下は避けるようにします

2. Propel SDK を起動し、”workspace” の場所を当該作業フォルダにして立ち上げます（重要）

3. SDK GUI で File メニューから “Open Projects from File System...” を選択

4. 『Directory』をクリックしてインポート元のディレクトリを指定します

➢ “.settings” フォルダの見えるディレクトリです

➢ SoC or C/C++ プロジェクトそれぞれについて、この作業を行います

5. Project Explorer 内にインポート元と同名のプロジェクトが表示されます

（インポート先に同名の新規フォルダは作成されません）

補足７：SoC/C プロジェクトのインポート

54

“.settings” 
フォルダの見える
ディレクトリを選択

C/C++ プロジェクトの場合の例

SoC プロジェクトの場合の例
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◼ 既存の SoC プロジェクトを複製して再利用する場合 “Propel SDK からインポート” します

✓ ワークスペースの直下に新たにオリジナルと同名の SoC プロジェクトが複製されて、インポートされます

✓ これによってその後の再利用が可能になります

補足８：SoC プロジェクトのインポート（1）
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または、トップメニューから
File → Import... を選択
します

クリック

“Lattice Propel” を展開
して選択、クリックします

ブラウズ時、SoC プロジェクトを作成時に
自動生成された SoC フォルダーを指定
して 『フォルダーの選択』 をクリックします

有効なプロジェクトが認識されると、候補が
表示されますので 『Finish』 をクリックします
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◼ 問題なくインポートされると「Project Explorer」枠に SoC プロジェクトとサブフォルダー/ファイル一式が表示
されます（下左）

☞ Propel SDK の Project Explorer にリストされないと、それ以降の一貫性のある作業ができません

補足８：SoC プロジェクトのインポート（2）

56

 プロジェクト名先頭の > 印をクリック
して展開した場合の表示例

これ以降はプロジェクト名を選択 → 右クリック → Open Design In → Propel Builder を選択
すると、Propel Builder が立ち上がり回路図が表示され、確認・編集作業が可能になります
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◼ インポートした SoC プロジェクトを再現するためには以下のポイントを押さえておきます

✓ 事前に各コンポーネントの最新バージョンをインストールしておきます（”IP on Local” タブで表示されるバージョンが最新か
どうかを “IP on Server” タブでの表示で確認しておきます）

✓ 回路図で各コンポーネントをダブルクリックすると、問題がなければコンフィグレーション・ウィンドウが表示されます。
エラーメッセージが表示されないことを確認します（バージョンを更新するかどうかの確認メッセージの場合は任意です）

◼ 上の確認・設定が全て問題なければ『Generate』アイコンをクリックして SoC プラットフォームを再生成します

✓ 複数ある GPIO コンポーネントの “アドレス重複“ のエラーになる場合は、手動でアドレスを再配置し直してから生成します

✓ オリジナルの SoC プロジェクトのターゲットデバイス・ファミリーを変更することはできません

◼ この後、この SoC プラットフォームをターゲットとして、C/C++  プロジェクトでユーザー・アプリケーション
を作成・ビルドすることができます

✓ プラットフォーム設定を書き出したファイルの一つ “sys_env.xml” が C/C++ プロジェクト作成時に必要です

✓ ビルドに成功すると Debug / Release フォルダ下にプログラムメモリー初期化ファイル *.mem が生成されます

◼ ビルド後、再び SoC ビルダーにもどり、プログラムメモリー初期化ファイルを指定します

✓ プロブラムメモリー（sysmem_inst0）コンポーネントをダブルクリックすると表示される設定ウィンドウで、「Initialize 

Memory」カラムのボックスをチェックし、「File Format」を “hex” にし、「Initialization File」セルにはビルドし直したソフト
ウェア・プロジェクト下 Debug/Release フォルダにブラウスし、当該 *.mem ファイルを指定します

✓ その後、DRC → Generate を再度行います

補足８：SoC プロジェクトのインポート（3）

57
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◼ 既存の C/C++（SDK）プロジェクトを複製して再利用する場合は、インポート・メニューから行います

1. File→ Import... を選択

2. 立ち上がる “Import” ウィンドウで General Existing Projects into Workspace を選択

3. 『Select root directory』をブラウズしてインポートする C/C++ プロジェクト・フォルダを指定します

4. Projects 枠に有効なプロジェクト名が表示されますので、チェックされていることを確認して『Finish』

5. SDK の Project Explorer 窓枠内にインポート元と同じ名称の C/C++ プロジェクトが複製されてインポートされます

補足９：C/C++ プロジェクトのインポート
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インポートした C/C++ 
プロジェクト表示例

選択

クリック

ブラウズして指定

確認

クリック
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◼ C/C++ プロジェクトを選択して File Properties... を選択します

◼ インクルード・ディレクトリの指定（既存ソースファイルを再利用する場合など）

✓ C/C++ Build → Settings → GNU RISC-V Cross C Compiler → Includes

補足10：SDK ビルド設定 ～ インクルード・ディレクトリ
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追加・削除時にクリックして
適宜操作・編集
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◼ 条件付きビルドなどの用途にユーザー定義のシンボルをここに記述しておきます

✓ C/C++ Build → Settings → GNU RISC-V Cross C Compiler → Preprocessor

補足10：SDK ビルド設定 ～ プリプロセッサ
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ビルド時に参照する
ユーザー定義のシンボル
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◼ ビルド・コンフィグレーションの変更ステップを示します（C/C++ Build → Settings）

✓ Debug → Release を示す（逆も全く同様の操作。⑦～⑨を忘れないようにします）

補足10：SDK ビルド設定 ～ Debug vs. Release
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① クリック

② 非アクティブ側の行をクリック
③ 『Set Active』 をクリック

④ 変更した側の Status が Active 
になるので 『OK』 をクリック

⑧ バー表示が “[Active]” 表示で意図するビルドに
なっていることを確認

⑨ 右下の 『Apply and Close』 をクリック

⑤ 『OK』 で元に戻る
⑥ バーをクリック

⑦ 変更した側が Active に変わって
いるので、それをクリック
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◼ 起動時に選択する workspace（p.9）は起動後でも SDK GUI から切り替えができます

✓ File → Switch Workspace → (選択)

補足11：Propel 起動後のワークスペースの切り替え

62

切り替え操作の例
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更新履歴

63

Date Rev. New Page# Contents By

2024/10/22 1.0

--

(p.20)

(p.37)

(pp.51-53)

(p.54)

旧版用から Propel 2024.1 用にスクリーンショットなど全般的に更新
＊Builder、配線時の操作方法について追加
＊OpenOCD Debugger のエラー例と解消方法を追加
＊補足 “内部バス引き出しでユーザー回路と I/F” を追加
＊補足 ”SoC/C プロジェクトのインポート” を追加

S.S.

2024/10/28 1.1 p.9, 11, 20, 29 フィードバックを反映してマイナーな更新 S.S.
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