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GUI カス タ マイズ
註 ： 本 Lattice Diamond 日本語マニュ アルは、 日本語によ る理解のため一助と し て提供し ています。 作成にあたっては各 ト ピ ッ クについて可能な限 り 正確を期し てお 

第 23 章 　 GUI カス タ マイズ

23.1 GUI の構成と各部の機能

23.1.1 デフ ォル ト 表示

　 Diamond GUI のデフ ォル ト 表示は大き く 4 つのエ リ アに分け られます （図 23-1）。

図 23-1. Lattice Diamond のデフ ォル ト ・ ウ ィ ン ド ウ表示

23.1.2 メ ニュー / ツールア イ コ ン ・ エ リ ア

　 GUI 最上段のエ リ アで、 各種操作のための メ ニューバーや、 各種ポイ ン ト ツールを起動するためのア イ コ
ンが配置されています。

23.1.3 プロセス ビ ュー / フ ァ イル リ ス ト ・ ビ ュー ・ エ リ ア

　 GUI の中段左側のエ リ アで、主にプロ ジェ ク ト 管理に関わる ウ ィ ン ド ウが配置されます。図 23-1 では三つ 
のビ ューが下部にあ る タブで切 り 替え る よ う に重なっています。

プロセスビ ュー

論理合成から フ ァ イル出力までの各プロセス ・ ステ ッ プ と、その実行状況を表示する ウ ィ ン ド ウです

フ ァ イルリ ス ト ・ ビ ュー

プロジェ ク ト にイ ンポー ト し た RTL ソース フ ァ イルや制約フ ァ イル等を表示する ウ ィ ン ド ウです
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り ますが、 必ずし も網羅的あ るいは最新でない可能性や、 オ リ ジナル英語版オン ラ イ ンヘルプや各種ド キ ュ メ ン ト と不一致があ る可能性があ り 得ます。 疑義が生じ
た場合は技術サポー ト 担当者にお問い合わせ頂 く か、 または最新の英語オ リ ジナル ・ ソース を参照する よ う にお願い致し ます。
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Hierarchy - Post Map Resources

マ ッ ピング後のデザイ ンの階層構造と それぞれの使用 リ ソース数を表示する ウ ィ ン ド ウです

23.1.4 レポー ト ビ ュー / ス ター ト ページ ・ ビ ュー ・ エ リ ア

　 GUI 中段右側のエ リ アで、 デフ ォル ト では Lattice Diamond 起動時の基本情報を ま と めた ” ス ター ト ペー 
ジ ・ ビ ュー ” （図 23-2） と、 各種プロセスのレポー ト 等を表示する ” レポー ト ビ ュー ” を ウ ィ ン ド ウ上部の 
タブで切 り 替え る よ う に重なっています。 このエ リ ア右側の領域は HTML 各種レポー ト の閲覧用にも使われ
ます。

　 このほかにも、 起動する各種ポイ ン ト ツール （テキス ト エデ ィ ターや消費電力見積も り など） がデフ ォル
ト でこのエ リ アに表示されます。 

レポー ト ビ ュー

図 23-1 のよ う に ”Design Summary” 内で ”Project Summary” が選択されている と、 プロジェ ク ト （実際は   
後述する ” イ ンプ リ メ ンテーシ ョ ン ”） のサマ リ ーが表示されます。 ”Design Summary” 内で ”Process 
Reports” セ ク シ ョ ンのいずれかを選択する と、 実行し た当該プロセスのレポー ト が表示されます。

ス ター ト ページ ・ ビ ュー

Lattice Diamond 起動する と表示されます。 左側は上部に基本操作 リ ス ト 、 その下に作業し たプロジェ ク 
ト の履歴一覧が表示され、 また最下部にはア ッ プデー右側には各種主要ド キ ュ メ ン ト への リ ン ク がま と
められています。

• 左上 ： プロジェ ク ト の基本操作 メ ニュー プロ ジェ ク ト 作成やオープン

• 左下 ： ア ッ プデー ト 情報 ツールバージ ョ ン と ア ッ プデー ト 情報

• 右 ； ド キ ュ メ ン ト への リ ン ク ユーザーガイ ドやチュー ト リ アルなど

図 23-2. ス ター ト ページ ・ ビ ュー

23.1.5 出力ビ ュー /Tcl コ ン ソール ・ エ リ ア

　 GUI 下部は各種ロ グの表示出力のエ リ アで、 Tcl コマン ド を実行する際に使用する ”Tcl コ ン ソール ” など
を六つのタブで切 り 替えます。
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23.2 各エ リ アのカ ス タマイ ズ

23.2.1 メ ニュー / ツールア イ コ ン ・ エ リ アのカ ス タマイ ズ

　 メ ニュー / ツールア イ コ ン ・ エ リ アは、 デフ ォル ト では全てのア イ コ ンが表示されていますが、 不要なア
イ コ ンはグループ単位で非表示にでき ます。 メ ニューバーから [View] → [Toolbar] の順に選択する と表示さ  
れる リ ス ト から、 グループ名を選択する と表示／非表示が交互に切 り 替わ り ます ( 図 23-3)。デフ ォル ト では 
全てチェ ッ ク （イ ネーブル） されています。

図 23-3. ツールア イ コ ンの表示／非表示切 り 替え

　 [Toolbars] メ ニューのグループ名と対応する ア イ コ ンは図 23-4 および表 23-1 をご参照 く ださい。

図 23-4. メ ニューバーのグループ名と ア イ コ ンの対応

表 23-1. ア イ コ ン ・ グループの主な処理内容

グループ名 内 　 　 容

File フ ァ イルやプロジ ェ ク ト のオープン / ク ローズや保存関連のアイ コ ン

Edit テキス ト エデ ィ ターや各種 GUI ツールの編集作業に使用するアイ コ ン （undo, redo 等）

View
ト ッ プビ ューの特定ウ ィ ン ド ウの選択や、 GUI ツールの表示制御 （拡大、 縮小等） に使
用するアイ コ ン

Project プロパテ ィ （Property） ウ ィ ン ド ウのオープンやデバイス選択に使用するアイ コ ン

Process プロセスの実行や停止に使用するアイ コ ン

Tools 各種ポイ ン ト ツールを起動するアイ コ ン

Window ト ッ プビ ューのウ ィ ン ド ウ表示カス タ マイズに使用するアイ コ ン

Help Lattice Diamond のア ッ プデー ト 有無を確認するアイ コ ン

23.2.2 各ビ ュー / エ リ アのカス タマイ ズ

　 各ビ ューはデフ ォル ト で図 23-1 のよ う に三つのエ リ アに分かれていますが、 以下のカ ス タマイ ズができ 
ます。
Lattice Diamond GUI カス タ マイズ 23-3
©2021 Macnica, Inc.



Rev.3.12
• ウ ィ ン ド ウの表示／非表示切 り 替え

• ウ ィ ン ド ウのア タ ッチ とデタ ッチ

• ウ ィ ン ド ウの多重／独立表示

　 エ リ アそれぞれで操作と し ては共通ですので、 基本操作について記述し ます。

23.2.2.1 ウ ィ ン ド ウの表示／非表示切り替え

　 メ ニューバーから [View] → [Show Views] の順に選択する と現れる メ ニュー （図 23-5） で、 表示／非表示    
を切 り 替え る こ と ができ ます。 リ ス ト にはプロセス ビ ュー / フ ァ イル リ ス ト ・ ビ ュー ・ エ リ ア と出力ビ ュー
/Tcl コ ン ソ ール ・ エ リ アの ウ ィ ン ド ウ名が表示 さ れてい ます。 デフ ォ ル ト では各ウ ィ ン ド ウ名の左側に 
チェ ッ ク マークがあ り 、 有効になっています。

　 どのウ ィ ン ド ウでも、 各ウ ィ ン ド ウ右上の ボタ ンを ク リ ッ クする こ と で非表示にでき ます。

図 23-5. 各ビ ューの表示／非表示切 り 替え

　 ス ター ト ページ ・ ビ ューと レポー ト ビ ューは、 プロ ジェ ク ト 作成時に重ねて表示されます。 ウ ィ ン ド ウ名

表記タブの右側の ボタ ンを ク リ ッ クする こ と で非表示にでき ます。 非表示にし たウ ィ ン ド ウ を再度表示

させるには、 メ ニューバーから [View] → [Start Page] （または [Report]） の順に選択するか、 ツールバーから

Start Page か Report ア イ コ ンを ク リ ッ ク し ます。

23.2.2.2 ウ ィ ン ド ウのア タ ッ チ とデタ ッ チ

　 デフ ォル ト で各エ リ アの各ビ ュー （ウ ィ ン ド ウ） は Diamond GUI に ” 組み込まれて （ア タ ッチ ： attach） ” 
いますが、 独立し たウ ィ ン ド ウ と し て表示 （デタ ッチ ： detach） する こ と ができ ます。

図 23-6. プロセス ビ ューのア タ ッチ （左） と デタ ッチ （右） 例
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　 ア タ ッチ状態のウ ィ ン ド ウ をデタ ッチするには、ウ イ ン ド ウ右上の  ア イ コ ンを ク リ ッ クするか、ウ ィ

ン ド ウのタ イ ト ルバーをつかんでエ リ ア外に ド ラ ッ グ し ます。 デタ ッチ状態のウ ィ ン ド ウ をア タ ッチ状態に
戻す場合は、 ウ ィ ン ド ウのタ イ ト ルバーをつかんで ド ラ ッ グ＆ド ロ ッ プし ますが、 この際の ド ロ ッ プ操作の
方法で事項に示す多重 （重ねた） 表示か、 単独表示かが変わ り ます （次項を参照）。

　 スプレ ッ ド シー ト ・ ビ ューやパワー ・ カ リ キ ュ レーターなど、 個別に起動し たポ イ ン ト ツールの場合も、
デタ ッチは同様です。デタ ッチ状態のウ ィ ン ド ウ をア タ ッチ状態に戻す場合は、若干異な り 、デタ ッチされて

いる ウ ィ ン ド ウ右上の ア イ コ ンを ク リ ッ ク し ます。 ウ ィ ン ド ウの ド ラ ッ グ＆ド ロ ッ プは無効です。

23.2.2.3 ウ ィ ン ド ウの多重表示と単独表示

　 各エ リ アのビ ュー （ウ ィ ン ド ウ） は、 デフ ォル ト では図 23-6 例の左のよ う に重ねて表示されています。 こ 
れをエ リ ア内で単独のウ ィ ン ド ウ と し て表示でき ます。 ウ ィ ン ド ウ をデタ ッチし た後のア タ ッチ操作の方法 
で多重表示か単独表示かの差が出ます。

図 23-7. 単独表示する ド ラ ッ グ＆ ド ロ ッ プ操作の例

　 ア タ ッチする ウ ィ ン ド ウのタ イ ト ルバーをつかんで ” ド ラ ッ グ＆ド ロ ッ プ ” する際に、 以下の二通 り があ
り 得ます ：

　 ①マウ スポイ ン ターを重ねて表示する ウ ィ ン ド ウ上のど こかに位置する と こ ろで ド ロ ッ プする、 または

　 ②マウ スポイ ン ターが二つのウ ィ ン ド ウの境界付近に位置する と こ ろで ド ロ ッ プする （図 23-7）

　 ①の場合、 移動し たウ ィ ン ド ウは ド ロ ッ プ先のウ ィ ン ド ウに重ねて表示されます （多重表示）。 そのエ リ ア
の下部にタブができ ますので、 これで表示の切 り 替えに使用し ます。

　 ②の場合、 移動し たウ ィ ン ド ウは二つのウ ィ ン ド ウに割 り 込んで ド ロ ッ プされ、 個別に表示されます （単
独表示）。 その後に表示幅を適宜調整し ます。 なお、 『境界』 と は厳密ではな く 、 ” おおよその感覚 ” で操作
し てかまいません。 期待通 り にな ら ない場合は再度デタ ッチ と ア タ ッチをや り 直し ます。

23.2.2.4 ポイ ン ト ツールの分割表示と多重表示

　 スプレ ッ ド シー ト ・ ビ ューやパワー ・ カ リ キ ュ レーター、 タ イ ミ ング解析ビ ューなど、 個別に起動するポ
イ ン ト ツールは、 ス ター ト ページ ・ ビ ューと レポー ト ビ ューの表示されている右上の メ イ ンエ リ アに重ねて
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表示された状態 （多重表示） で立ち上が り ます。

　 複数のポイ ン ト ツールが起動されている状態で分割表示にする場合は、 分割し たいウ ィ ン ド ウのタブを選
択し た状態で、 メ ニ ューバーから [Window] → [Split Tab Group] の順に選択するか、 またはツールバーのア イ

コ ン を ク リ ッ ク し ます。 分割されたそれぞれは ” タブグループ ” と呼び、 二つまで作られます。

　 個別表示し たウ ィ ン ド ウ を再度重ねるには、 メ ニューバーから [Window] → [Merge Tab Group] の順に選択

するか、 も し く はツールバーの ア イ コ ンを ク リ ッ ク し ます。

図 23-8. タブグループ化 と配置入れ替え操作

　 2 つのタブグループの配置を入れ替え る場合は、 メ ニ ューバーから [Window] → [Switch Tab Group position]

の順に選択するか、 ツールバーの ア イ コ ンを ク リ ッ ク し ます。

　 3 つ以上のポイ ン ト ツールが起動し ていて タブグループに分かれている場合、 多重表示される タブグルー
プ間を移動させる こ と もでき ます。 移動させたいウ ィ ン ド ウのタブを選択し た状態で、 メ ニューバーから

[Window] → [Move to Another Tab Group] の順に選択するか、 ツールバーの ア イ コ ンを ク リ ッ ク し ます。

また、 ウ ィ ン ド ウの他の Tab Group に ド ラ ッ グする こ と でも移動させる こ と ができ ます。

23.2.3 レ イ アウ ト の保存と呼び出し

　 カ ス タマイ ズ し たウ ィ ン ド ウのレ イ アウ ト を保存し、 必要に応じ て呼び出すこ と ができ ます。 保存する場
合は適切なウ ィ ン ド ウ ・ レ イ ア ウ ト にし た状態で、 メ ニューバーから [Window] → [Save Layout] を選択し ま   
す。 する と、 レ イ ア ウ ト 保存の設定ウ ィ ン ド ウが起動し ます （図 23-9）。

　 「Name」 セルには保存する レ イ ア ウ ト 名を入力し ます。 こ の名称は、 後で呼び出す際に使用し ます。 ウ ィ
ン ド ウの左下には [Launch view when loaded] チェ ッ ク ボ ッ ク スがあ り ます。 これにチェ ッ クが入っている と、   
レ イ ア ウ ト を呼び出し た際に起動し ていないツールやウ ィ ン ド ウがあった場合、 それら を自動的に起動し て
レ イ ア ウ ト を再現し ます。 チェ ッ クが入っていない場合は、 起動し ている ツールやウ ィ ン ド ウだけでレ イ ア
ウ ト が再現されます。

　 必要な部分の入力が完了し た ら ウ ィ ン ド ウ右下の 『OK』 を ク リ ッ ク し ます。 保存し たレ イ ア ウ ト を呼び出
すには、 メ ニューバーから [Window] → [Manage Layout...] の順に選択し ます。する と、レ イ ア ウ ト の選択ウ ィ   
ン ド ウが起動し ます （図 23-10） 。 ウ ィ ン ド ウ左上に保存されている レ イ ア ウ ト 名の一覧が表示されていま 
す。 こ の中か らいずれかを選択する と、 ウ ィ ン ド ウ左下にはレ イ ア ウ ト に含まれる ウ ィ ン ド ウ名の一覧が、
ウ ィ ン ド ウ右下にはレ イ ア ウ ト のイ メ ージが表示されます。
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図 23-9. レ イ ア ウ ト 保存の設定ウ ィ ン ド ウ

　 レ イ ア ウ ト 名を選択し てウ ィ ン ド ウ右上の 『Load』 ボタ ンを ク リ ッ クする と、 保存し たレ イ ア ウ ト が再現
されます。なお、 レ イ ア ウ ト を ロードする際に起動し ている レ イ ア ウ ト に含まれないツールは閉じ られずに、
そのま ま残 り ます。

図 23-10. レ イ ア ウ ト 選択ウ ィ ン ド ウ

　 また、 レ イ ア ウ ト 名を選択し て ウ ィ ン ド ウ右上の 『Set as Default』 ボタ ンを ク リ ッ クする と、 そのレ イ ア  
ウ ト が次回起動時のデフ ォル ト と し て表示に使用されます。 デフ ォル ト 指定されている レ イ ア ウ ト 名が太字
で表示されます。

23.2.4 ステータ スバーの表示／非表示切 り 替え

　 ウ ィ ン ド ウ最下部にあ る ステータ スバーには、現在実行中のプロセスや メ モ リ ーの使用量が表示されます。
ステータ スバーはデフ ォル ト で表示されていますが、 これを非表示にする場合は メ ニ ューバーで [View] → 
[Status Bar] の順に選択し ます。 非表示の状態で再度同じ操作を行えば、 ステータ スバーが表示されます。

図 23-11. ステータ スバー
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23.3 環境設定オプシ ョ ン
　 Lattice Diamond では、 ユーザーが好みに合わせて環境設定ができ る よ う になっています。 メ ニューバーの 
[Tool] → [Options…] の順に選択する と開 く ウ ィ ン ド ウの、”Environment” 以下の項目が環境設定です ( 図 23-   
12)。 このウ ィ ン ド ウでは各ポイ ン ト ・ ツールの設定 （フ ォ ン ト や色設定） もでき ます （詳細はオン ラ イ ンヘ
ルプをご参照下さい）。

図 23-12. 環境設定オプシ ョ ン （一部）

　 環境設定は、 大き く 以下の 5 項目に分かれています。

　 General : 全般的な設定

　 Startup : 起動し た際の動作に関する設定

　 File Association : フ ァ イルの拡張子と、 それを開 く ツール （テキス ト エデ ィ ター等） の関連付け設定

　 Directories : 合成ツール と シ ミ ュ レータのフ ォルダー設定

　 Network Setting : ネ ッ ト ワーク接続 （プロ キシーサーバー） の設定

23.3.1 General

　 本セ ク シ ョ ンでは主に動作に関わる設定ができ ます。

Copy file to Implementation's Source Directory when adding existing file

既存のソース フ ァ イルをプロ ジェ ク ト にイ ンポー ト する方法のデフ ォル ト 値設定です（イ ンポー ト の
際に個別に選択する こ と もでき ます）。 チェ ッ クが入っている と、 デフ ォル ト が 「選択し たフ ァ イルを
イ ンプ リ メ ンテーシ ョ ン ・ フ ォルダーにコ ピーし、 それを イ ンポー ト する」 設定にな り ます。 チェ ッ
クが入っていない と ” 選択し たフ ァ イルを イ ンポー ト する ” 設定にな り ます。

Archive all files under the Project Directory when archiving Project

フ ァ イル メ ニューから [Achieve Project] を実行し、 プロ ジェ ク ト を圧縮保存する場合の対象フ ァ イル 
の選択設定です。 チェ ッ ク が入っている と、 当該プロ ジ ェ ク ト と の関連を問わずプロ ジ ェ ク ト フ ォル
ダー以下の全てのフ ァ イルおよびフ ォルダーが圧縮されます。 チェ ッ ク が入っていない と、 当該プロ
ジェ ク ト に関連する フ ァ イルのみが圧縮されます。

Clear Output/Error/Warning window before running process

プロセス実行時の Output/Error/Warning ウ ィ ン ド ウに関する設定です。 チェ ッ ク が入っている と プ
ロセス実行のたびに、以前の結果はク リ ア され新しい メ ッ セージのみが表示されます。チェ ッ ク が入っ
ていない と プロセス実行のたびに メ ッ セージが追記されていき ます。

Maximum items shown in Recent item lists （0~20）

ス ター ト ページ ・ ビ ューに表示する直近に開いたプロ ジェ ク ト （Recent Project） の数の設定です。
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Maximum number of implementation processes in run manager （1~32）

ラ ンマネージ ャーで並列処理させる最大イ ンプ リ メ ンテーシ ョ ン数の設定です。使用する コ ンピ ュー
タの CPU コ ア数以下の値を設定する こ と が推奨です。

Maximum number of multi-par processes in run manager （1~32）

配置配線プロセスのス ト ラ テジー設定でマルチシード （Placement Iteration 値が 2 以上） 処理にし た 
場合、 ラ ンマネージャーで並列処理させる最大数の設定です。 使用する コ ンピ ュータの CPU コ ア数以
下の値を設定する こ と を推奨し ます。

Accept message support agreement [View Agreement]

右の 『View Agreement』 を ク リ ッ クする と以下のよ う な メ ッ セージを表示し ます。 許容する場合は 
チェ ッ ク マーク を入れます。

Lattice Semiconductor would like to collect data on what software messages are being generated for your               
design. This information is completely anonymous and only consists of program name generating the message,              
the message ID, and the number of times the message occurred. Allowing this data to be collected will allow                  
Lattice to better prioritize which messages need more content developed helping customers complete their             
designs easier and faster. Making checkbox "Accept message support agreement" be checked will allow this              
data to be collected.

23.3.2 Startup

　 本セ ク シ ョ ンでは主に起動時の設定ができ ます。

At Lattice Diamond Start up

メ ニューから、Lattice Diamond が起動し た際の振る舞いについて選択し ます。選択肢には以下の 3 つ 
があ り ます。

Open Previous Project : 最後に開いたプロ ジェ ク ト を開き ます

Show Start Page : ス ター ト ページ ・ ビ ューが表示されます

Start with New Project Wizard : 新しいプロ ジェ ク ト 作成ウ ィ ザード が起動し ます

図 23-13. Lattice Diamond 起動時の設定 （At Lattice Diamond startup）

Automatic check software update when Lattice Diamond launches

Lattice Diamond は起動時に、 自動的にア ッ プデー ト の有無を検出する機能があ り ます。 この機能を 
有効にする場合はチェ ッ ク を入れます。自動で検出させない場合はチェ ッ ク を外し ます （マニュ アルで
ア ッ プデー ト のチェ ッ クはでき ます）。 チェ ッ ク を入れた場合は、 さ らに以下の 3 つから ア ッ プデー ト
検出の周期を選択し てチェ ッ ク を入れます。

　 Every time : 起動ご と に検出を行います

　 Daily : 毎日最初の起動時に検出を行います

　 Weekly : 毎週最初の起動時に検出を行います

Tool startup as

各ツール （のウ ィ ン ド ウ） の起動時のア タ ッ チ設定です。 「Attached」 にチェ ッ ク が入っている と、
ツールは [task and tool specific view] 内のパネル と し てア タ ッチされて起動し ます。チェ ッ ク が入ってい    
ない場合は、 独立し たウ ィ ン ド ウ と し て （デタ ッチし て） 起動し ます。 ツールによ っては Diamond を
再起動し ない と設定が反映されないものがあ り ます。
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23.3.3 File Associations

　 本セ ク シ ョ ンでは、 各種フ ァ イル と それを開 く プロ グ ラ ムの関連付け設定を行います。 デフ ォル ト では全
て Lattice Diamond のプロ グ ラ ムが関連付け られていますが、例えばテキス ト エデ ィ ターなどは好みに応じ て 
常時使用し ている ものに変更する こ と ができ ます。 関連付けるプロ グ ラ ムを変更する場合は、 まず新しいプ
ロ グ ラ ムを登録する必要があ り ます。

図 23-14. 関連付けプロ グ ラ ムの追加

　 新 し いプ ロ グ ラ ム を登録す る には、 まず関連付け を変更 し たい フ ァ イ ルの拡張子を選択 し た状態で、
「External program for ‘xxx’ file extension:」 セルの 『Add』 ボタ ンを ク リ ッ ク し、 プロ グ ラ ムの追加ウ ィ ン ド ウ     
（図 23-14 左下） を立ち上げます （意図する行の 「Default Program」 セルを ク リ ッ ク し て ”<Add Program...>”   
を選択し て も同様）。

図 23-15. 関連付けプロ グ ラ ムの選択

　 このウ ィ ン ド ウの 「External Program」 セルで追加し たいプロ グ ラ ムの実行フ ァ イル （*.exe） をブラ ウズ後 
選択し、 「Display Name」 セルに Lattice Diamond 上での表示名を入力し ます。 『OK』 し て戻 り ます。 このウ ィ  
ン ド ウ内の 「Argument」 は、 プロ グ ラ ム起動時の引数の設定です。 例えば、 テキス ト エデ ィ ターの場合、 デ
フ ォル ト ではエデ ィ ター起動時にはフ ァ イル名のみが指定されていますが、 引数と し て行数の指定をサポー
ト し ているエデ ィ ターであれば適当な設定を行 う こ と によ り 、 エラー メ ッ セージ等をダブルク リ ッ クする と
問題の原因と なった行へカーソルが飛ぶよ う にな り ます （行数指定な しだ と カーソルはフ ァ イルの先頭）。

　 その後、 「Default Programs」 セルを ク リ ッ クする と、 登録し たプロ グ ラ ム名が表示されるので、 それを選 
択すれば関連付けが完了し ます （図 23-15）。

　 関連付けプ ロ グ ラ ムの追加は、 拡張子ご と に行 う 必要があ り ます。 過去に追加し たプ ロ グ ラ ムの履歴は
「External Program」 セルの右端の▼ア イ コ ンを ク リ ッ クする と表示されます。
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23.3.4 Directories

　 本セ ク シ ョ ンでは、 論理合成ツールやシ ミ ュ レータのパス設定を行います。 バン ド ルされている もの以外
のバージ ョ ンを使用する場合等に設定を行います。例えば正規版の Synplify Pro を使用する場合は、「UseOEM」 
のチェ ッ ク を外し、 右端の 『...』 ボタ ンを ク リ ッ ク し てブラ ウ ズ し て実行フ ァ イルのあ る フ ォルダーを指定
し ます ( 図 23-16)。

図 23-16. ツールのデ ィ レ ク ト リ 設定

　 同様に正規版の ModelSim や Active-HDL を使用するなどの場合、 同様に ”Simulation” セ ク シ ョ ンで右端の
『...』 ボタ ンを ク リ ッ ク し てブラ ウズ し、 実行フ ァ イルのあ る フ ォルダーを指定し ます。 第 10.2 節で記述し
ている Simlation Wizard によ るシ ミ ュ レーシ ョ ンで、 指定でき るシ ミ ュ レーターの候補表示に作用し ます。

23.3.5 Network Settings

　 Lattice Diamond では、ア ッ プデー ト 情報の検出や IP コ アのダウ ン ロード等でネ ッ ト ワーク接続が必要にな 
り ます。 社内ネ ッ ト ワーク などでネ ッ ト ワーク接続する際にプロ キシーサーバーを使用し ている場合は、 こ
のセ ク シ ョ ンでサーバー情報の設定を行います （ネ ッ ト ワーク管理者に確認し ます）。

23.4 レポー ト ・ メ ッ セージのカ ス タ ム化
　 Lattice Diamond 各プロセスでレポー ト される各種 メ ッ セージの表示に関する カス タマイ ズ機能が幾つかあ 
り ます。

23.4.1 メ ッ セージ ・ フ ィ ルタ リ ング

　 レポー ト ビ ュー ・ エ リ ア内の 「Design Summary」 に各レポー ト 種別を選択する枠があ り ます。 最下部にあ 
る [Messages] セ ク シ ョ ンには二つの項目があ り ます。 [User Defined Filters] では全プロセスからのレポー ト ・  
メ ッ セージをフ ィ ルタ リ ング し て確認する機能があ り ます。

　 [User Defined Filters] を選択する と、 右の枠に全ての メ ッ セージが一覧表示されますが、 それぞれには メ ッ  
セージ ID 番号と その生成されたプロセスが明示されています。通常はかな り の量の メ ッ セージが表示されま
すが、 殆どのものは無視し て も構わない Warning が少な く あ り ません。 このよ う な場合、 メ ッ セージ行を選
択後右ク リ ッ ク し て、 例えば [Filter Message with This ID] を選択する と （図 23-17）、 同一 ID の メ ッ セージが     
全てフ ィ ルタ リ ング されて非表示と な り ます。
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図 23-17. メ ッ セージ ・ フ ィ ルタ リ ング

　 基本的な推奨設計フ ローと し てエラー メ ッ セージは勿論、 全ての Warning を確認し て無視でき るかど う か
を吟味する こ と が期待されます。 本機能はその作業を格段に効率化し ます。

23.4.2 メ ッ セージ ・ シビ リ テ ィ 変更

　 特定の メ ッ セージ ID を Warning から Error に ” シビ リ テ ィ ” を上げたい場合があ るかも しれません。 その 
場合は ２ ステ ッ プの操作にな り ます。

　 まず前項同様に [User Defined Filters] を選択し ます。 右枠に表示される メ ッ セージから シビ リ テ ィ を上げ  
る （”Promote”） メ ッ セージを選択し て右ク リ ッ ク し、 ”Promote Message with This ID” を選択し ます （図 23-     
18 ： ツール と し てプロモー ト できない設定の場合はグレーアウ ト し て指定でき ません）。

　 次に メ ニューバーから [Project] → [Message Promotion ...] と選択する と、 ”Message Promotion” ウ ィ ン ド ウ   
が表示されます （図 23-19）。 このウ ィ ン ド ウで 「IDs」 セルに ID 番号を入力し て 『Promote』 ボタ ンを ク リ ッ 
ク し て、 指定が完了し ます。 それ以降のプロセス実行に適用されます。 複数の ID 番号があ る場合は ” ； ” で
区切って列記し ます。

図 23-18. 当該 メ ッ セージの抽出

　 『Promote』 ボタ ンを ク リ ッ ク し た際に、 ツール と し てプロモー ト でき ない設定になっている場合は、 ”The
ID:xxxxxxxx can’t be promoted” と の通知が表示されて、 指定でき ませんのでご留意 く ださい。
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図 23-19. シビ リ テ ィ を上げる指定

　 また、 『Export...』 ボタ ンを ク リ ッ クする と、 フ ァ イルブラ イザが表示されますので、 所望のフ ォルダーに
テキス ト ・ フ ァ イル ”xxx.pmt” と し て保存でき ます。 逆に 『Import...』 ボタ ンで既存の pmt フ ァ イルを取 り 込
むこ と ができ ます。 複数プロ ジェ ク ト 間で共有する場合などに活用でき ます。

23.4.3 メ ッ セージ と エデ ィ ターの リ ン ク

　 メ ッ セージによ っては、 該当箇所 （フ ァ イル） を特定するためにテキス ト エデ ィ ターにジ ャ ンプする こ と
ができ ます。

図 23-20. メ ッ セージの該当箇所をエデ ィ ターに リ ン ク し て起動

　 当該 メ ッ セージを選択後 （図 23-20）、 右ク リ ッ ク し て [Locate in] → [Text Editor] を選択し ます。 対象の   
フ ァ イルを表示し てエデ ィ ターが立ち上が り ます。非該当の メ ッ セージの場合は ”Locate in” はグレーア ウ ト 
し て選択でき ません。

--- *** ---
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