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論理シ ミ ュ レーシ ョ ン
註 ： 本 Lattice Diamond 日本語マニュ アルは、 日本語によ る理解のため一助と し て提供し ています。 作成にあたっては各 ト ピ ッ クについて可能な限 り 正確を期し てお 

第 10 章 　 論理シ ミ ュ レーシ ョ ン

10.1 Diamond 環境での論理シ ミ ュ レーシ ョ ン
　 Lattice Diamond 3.12 付属の ModelSim Lattice Edition” （以下 ModelSim LE） によ る論理シ ミ ュ レーシ ョ ンの     
実行には三通 り の方法があ り ます。 それぞれには長短があ り ます。

1. Simulation Wizard GUI ツールによ って ModelSim LE 方法 （第 10.2 節）

2. ModelSim LE を単独起動し て、 主にマウ ス操作によ って行 う 方法 （第 10.3 節）

3. ModelSim LE を単独起動し て、 ユーザーが記述 ・ 作成する ”DO マ ク ロ （TCL ス ク リ プ ト ） ” によ る
方法 （第 10.4 節）

　 以下、 各節でそれぞれの手順について記述し ます。

10.2 Simulation Wizard によ る シ ミ ュ レーシ ョ ン実行

10.2.1 Simulation Wizard の概要

　 ”Simulation Wizard” は Lattice Diamond から ModelSim LE を呼び出し て、 HDL ソースのコ ンパイルから シ   
ミ ュ レーシ ョ ン実行までを簡易的に自動実行する GUI ツールです。 ModelSim LE を単独起動し て GUI 操作に 
よ るシ ミ ュ レーシ ョ ン実行 （第 10.3 節） と、 基本的には等価な機能ですが、 ユーザー操作が極小化されてい
ます。

　 また、 Diamond 3.11 まで付属し ている Active-HDL について も Simulation Wizard は同様な手順で実行でき  
ますので、 本節記述をご参考 く ださい。

10.2.2 Simulation Wizard の起動と操作ステ ッ プ

　 Simulation Wizard は、 ツールバー上のア イ コ ン を ク リ ッ クするか （図 10-1）、 メ ニューバーから [Tools]  
→ [Simulation Wizard] を選択し て起動し ます。

図 10-1. Simulation Wizard の起動ア イ コ ン

　 Simulation Wizard を起動する と、 最初に ”Preparing the Simulator Interface” （Simulation Wizard の用途につい     
ての メ ッ セージ） が表示されます。 設定項目はないので、 ウ ィ ン ド ウ右下の 『Next>』 ボタ ンを ク リ ッ ク し次
へ進みます。

　 次に表示さ れる ウ ィ ン ド ウ （図 10-2） で、 適切なシ ミ ュ レーシ ョ ン ・ プロ ジ ェ ク ト 名を入力し、 フ ォル 
ダーパス を指定後に、 右下の 『Next>』 ボタ ンを ク リ ッ ク し ます （図 10-2 では非表示） 。 作業フ ォルダーを 
作成するかど う かを確認する メ ッ セージが出ますが、 『Yes』 を ク リ ッ ク し て先に進みます。

　 なお、 図 10-2 における シ ミ ュ レーターの選択について、 Diamond 3.12 では常に ModelSim (LE) がデフ ォル   
ト で選択されます。 グレーア ウ ト されている Active-HDL を イネーブルし て選択でき る よ う にするためには、
Active-HDL を イ ン ス ト ール後に Diamond 環境変数 Directories を設定し ておき ます （第 23.3.4 項参照）。
Macnica MacJUG_Di3.12_Simulation 10-1
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図 10-2. シ ミ ュ レーシ ョ ン ・ プロ ジェ ク ト の設定 １

　 次はシ ミ ュ レーシ ョ ン種別の選択です （図 10-3）。 選択肢と シ ミ ュ レーシ ョ ン内容は表 10-1 の通 り です。

図 10-3. シ ミ ュ レーシ ョ ン種別の選択

表 10-1. Process Stage と シ ミ ュ レーシ ョ ン内容

Process Stage シ ミ ュ レーシ ョ ン対象 遅延情報 （sdf）

RTL RTL ソースフ ァ イル な し

Post-Map Gate-Level マ ッ ピング後のネ ッ ト リ ス ト な し

Post-Route Gate-Level+Timing PAR 後ネ ッ ト リ ス ト （タ イ ミ ングシ ミ ュ レーシ ョ ン） あ り

　 ”Post-Map Gate-Level” と ”Post-Route Gate-Level+Timing” は、 シ ミ ュ レーシ ョ ン実行に必要なネ ッ ト リ ス  
ト が、 当該サブプロセス を実行し て生成されている場合のみ選択でき ます。 シ ミ ュ レーシ ョ ン内容を選択し
た ら、 右下の 『Next>』 ボタ ンを ク リ ッ ク し て先に進みます （図 10-3 では非表示）。

図 10-4. RTL フ ァ イル リ ス ト 表示

　 次はシ ミ ュ レーシ ョ ンに使用する ソース フ ァ イルの選択ウ ィ ン ド ウです （図 10-4） 。 デフ ォル ト 表示でシ 
ミ ュ レーシ ョ ン種別に対応し た ソース フ ァ イルが選択された状態になっています。 RTL シ ミ ュ レーシ ョ ンの
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場合はプロジェ ク ト にイ ンポー ト されている フ ァ イルが、 ネ ッ ト リ ス ト を使用する シ ミ ュ レーシ ョ ンの場合
は、 対応するネ ッ ト リ ス ト ・ フ ァ イル （と sdf フ ァ イル） が表示されます。

　 シ ミ ュ レーシ ョ ンの実行には、 これにテス ト ベンチを追加する必要があ り ます。 ウ ィ ン ド ウ上の ボタ

ンを ク リ ッ クする と、 HDL ソース を選択する ウ ィ ン ド ウが開き ますので、 必要なテス ト ベンチの HDL ソー
ス全てを選択し イ ンポー ト し ます。 テス ト ベンチなどシ ミ ュ レーシ ョ ンのみに用いる フ ァ イルは、 Diamond
のフ ァ イル リ ス ト ・ ビ ュー枠に ”simulation” 属性でイ ンポー ト する こ と ができ ます。 この場合、 図 10-4 に示 
すソース フ ァ イル一覧にはそ う し たシ ミ ュ レーシ ョ ン用フ ァ イル一式も含まれますので、 毎回新たに イ ン
ポー ト する手間が省けます。

　 VHDL の場合でユーザ定義パッ ケージがあ る場合は、当該ソース フ ァ イルが リ ス ト の上に く る（最初にコ ン

パイルする） よ う に、 フ ァ イルを選択し て や ボタ ンを ク リ ッ ク し てフ ァ イルの並び順を変えます。

　 ウ ィ ン ド ウ下部の 「Automatically set simulation compilation file order」 はチェ ッ ク されたま まにし ておき ま     
す。 「Copy Source to Simulation Directory」 のチェ ッ クサムは任意です。 『Next>』 ボタ ンで次に進みます。

　 "Parse HDL files for simulation" ウ ィ ン ド ウが表示されます （図 10-5）。 下部の 「Simulation Top Module」 に       
表示される、 自動認識された ト ッ プ ・ モジュール名が正しいこ と を確認し ます。 異なる場合はク リ ッ ク し て
プルダウ ン表示される候補から選択し ます。 意図するモジュールが選択でき ない場合は、 フ ァ イル構成や記
述に問題のあ る可能性があ り ます。 問題がなければ 『Next>』 ボタ ンを ク リ ッ ク し ます。

図 10-5. ト ッ プ ・ モジュールの確認

図 10-6. 設定確認のウ ィ ン ド ウ
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　 最後がこれまでの設定の確認画面です （図 10-6）。 問題がなければ 『Finish』 ボタ ンを ク リ ッ ク し ます。 変 
更の必要があれば 『<Back』 を ク リ ッ ク し て該当する ステ ッ プに戻って修正し ます。 デフ ォル ト では下部三
つのオプシ ョ ンにチェ ッ クが入っています。 「Run Simulation」 にチェ ッ クが入っている状態で 『Finish』 を ク 
リ ッ クする と ModelSim LE が起動し、 イ ンポー ト し た ソースのコ ンパイルが行われ、 そし てシ ミ ュ レーシ ョ 
ンが実行されます。 実行時間も自動的にツールが設定し ます。 「Add top-level signals to waveform display」 に     
チェ ッ ク が入っている と、 波形表示信号はテス ト ベンチの ト ッ プのみです。 こ のチェ ッ ク をはずす と 「Run
Simulation」 はチェ ッ ク （イネーブル） でき ません。

　 「Run Simulation」 にチェ ッ クが入っていない場合は、 コ ンパイルまでが行われます。 ユーザーが ModelSim 
LE 上でシ ミ ュ レーシ ョ ン初期化、 波形表示信号の指定、 シ ミ ュ レーシ ョ ン実行を行います。 GUI 起動後の操
作については第 10.3 節をご参照 く ださい。

　 作成されたシ ミ ュ レーシ ョ ン・プロ ジェ ク ト の ”Simulation Wizard ス ク リ プ ト ” フ ァ イル（*.spf）は、Diamond 
のフ ァ イル リ ス ト ・ ビ ュー下の ”Script Files” セ ク シ ョ ンに自動的にイ ンポー ト されます ( 図 10-7)。

図 10-7. 作成されたス ク リ プ ト ・ フ ァ イルのイ ンポー ト 例

　 *.spf が イ ンポー ト されていれば、 二回目以降はこれをダブルク リ ッ クする と、 各ウ ィ ン ド ウが初めのス
テ ッ プから設定された状態で表示されます。 複数の異なる *.spf を イ ンポー ト する こ と ができ ます。

10.3 GUI 起動 ・ 操作によ る シ ミ ュ レーシ ョ ン実行
　 Simulation Wizard ではな く 、ModelSim LE GUI 起動でシ ミ ュ レーシ ョ ンする場合、少な く と も本節で記述す   
る よ う な基本操作が必要と な り ます。 Simulation Wizard で最後のステ ッ プ （図 10-6） の左下オプシ ョ ン 3 つ  
の う ち、 「Run Simulator」 以外をチェ ッ ク し ていない状態で [Finish] を ク リ ッ クする場合には、 本節で記述す

る操作ステ ッ プの後半が必要 と な り ます （後述） 。 単独起動する場合は、 ア イ コ ン を ク リ ッ クするか、
Diamond メ ニ ューから [Tools] → [ModelSim Lattice-Edition] を選択し ます。

10.3.1 作成済みプロ ジェ ク ト のオープン

　 作成済みのプロジェ ク ト で再度シ ミ ュ レーシ ョ ンをする場合は、メ ニューから [File] → [Recent Projects] → 
[ プロジェ ク ト ・ リ ス ト ] から選択し ます。 リ ス ト には最大 8 つの履歴が表示されます （図 10-8）。 [File] → 
[Recent Directories] の操作でも同様ですが、 デ ィ レ ク ト リ の移動のみができ ます。

　 なお、Diamond と Radiant 両環境で ModelSim LE のシ ミ ュ レーシ ョ ンを行っている場合、環境は分別されず  
に、プロ ジェ ク ト 名が混在し て リ ス ト される こ と にご留意 く ださい。ツールが併存する環境下では、プロ ジェ
ク ト 名を工夫し て識別でき る よ う にする こ と を推奨し ます。

　 プロジェ ク ト ・ リ ス ト に含まれていない場合、 メ ニューバーの [File] → [Open...] を選択するか、 ア イ

コ ンを ク リ ッ ク し ます。 表示される “Open File” ウ ィ ン ド ウの右下フ ァ イルタ イプ “Project Files (*.mpf)” を       
指定し、 ブラ ウズ ・ 選択し て 『OK』 を ク リ ッ クする と、 プロ ジェ ク ト がオープン し ます。
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図 10-8. 作成済みプロ ジェ ク ト のオープン

　 なお、 この操作は ”Transcript” 枠に次のよ う にコマン ド を入力する こ と と等価です。 <location> は必ずフル
パスで入力し ます。

　 　 ModelSim> project open C:/<location>/<project_name>.mpf

10.3.2 新規プロ ジェ ク ト の作成

　 最初にシ ミ ュ レーシ ョ ン作業を行 う デ ィ レ ク ト リ に移動し ます。作業フ ォルダーを予め作成し ておき ます。
移動方法は二つあ り 、 第一の方法は メ ニュー [File] → [Change Directory...] と選択する と表れる フ ァ イル ・ ブ 
ラ ウザで所望のフ ォルダーを指定し ます。 第二の方法は GUI 下部 ”Transcript” 枠に ”CD” コマン ド を入力す
る こ と です。 例えば次のよ う にな り ます。 セパレータは ”\” （バッ ク ス ラ ッ シュ） ではな く 、 必ず ”/” （ス
ラ ッ シ ュ） にし て区切 り ます。

　 　 ModelSim> cd C:/xxx/yyy/zzz

　 次にシ ミ ュ レーシ ョ ン ・ プロ ジェ ク ト を作成し ます。 メ ニュー [File] → [New] → [Project...] と選択する と
表れる ウ ィ ン ド ウの 「Project Name」 セルにプロ ジェ ク ト 名を入力し ます （図 10-9） 。 「Project Location」 が   
意図する作業デ ィ レ ク ト リ であ る こ と を確認し ます。デフ ォル ト のシ ミ ュ レーシ ョ ン ・ ラ イブラ リ ー （Default
Library Name） は ”work” になっていますが、 敢えて変更する必要はあ り ません。

　 なお、 この操作は ”Transcript” 枠に次のよ う にコマン ド を入力する こ と と等価です。 <location> は作業デ ィ
レ ク ト リ です。 以降、 作業デ ィ レ ク ト リ がカレン ト ・ デ ィ レ ク ト リ にな り ます。

　 　 ModelSim> project new <location> <project_name>

図 10-9. シ ミ ュ レーシ ョ ン ・ プロ ジェ ク ト の作成
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10.3.3 RTL ソース フ ァ イルのイ ンポー ト

　 新規プロジェ ク ト を作成する と、 自動的に表示される ”Add items to the Project” ウ ィ ン ド ウでプロ ジェ ク    
ト にイ ンポー ト する RTL ソース フ ァ イルを指定し ます （図 10-10）。

　 ① ”Add Existing File” を ク リ ッ ク ② ”Add file to Project” ウ ィ ン ド ウで 『Browse』 を ク リ ッ ク

　 ③フ ァ イルを選択し て 『開 く 』 を ク リ ッ ク ④ ”File Name” を確認し て 『OK』 を ク リ ッ ク

すべてのフ ァ イルを指定する まで①～④を繰 り 返し、 最後に①のウ ィ ン ド ウで 『Close』 を ク リ ッ ク し ます。

図 10-10. RTL ソース フ ァ イルのイ ンポー ト

　 一旦ウ ィ ン ド ウ を閉じ た後や、 プロ ジェ ク ト を再オープン し てシ ミ ュ レーシ ョ ン作業する場合にフ ァ イル
の追加が必要な場合、 ”Project” ウ ィ ン ド ウ （””Project” タブを選択し た状態） で、 任意の表示がブラ ン ク な
ど こ かを右ク リ ッ ク し て、 [Add to Project] → [Existing File] と選択する と、 図 10-10 と同じ ウ ィ ン ド ウが現れ    
ます。 または メ ニューから [Project] → [Add to Project] → [Existing File] と選択し て も同様です。

　 なお、この操作は ”Transcript” 枠に次のよ う にコマン ド を入力する こ と と等価です。<file_name> は作業フ ォ
ルダー内に存在し ない場合は相対パス、 絶対パスいずれかの表記を伴 う 記述にし ます。

　 　 ModelSim> project addfile “<file_name>”

図 10-11. RTL ソース フ ァ イルの追加イ ンポー ト

10.3.4 コ ンパイル

　 次のス テ ッ プはソース フ ァ イルのコ ンパイルです。 ア イ コ ン メ ニ ューか ら ア イ コ ン を ク リ ッ クする
か、 または メ ニューから [Compile] → [Compile All] を選択し ます ( 図 10-12)。
10-6 Lattice Diamond 論理シ ミ ュ レーシ ョ ン
©2021 Macnica, Inc.



Rev.3.12
図 10-12. ソース フ ァ イルのコ ンパイル

　 ステータ スが のソース フ ァ イルのみを コ ンパイルする場合は、 ア イ コ ンを ク リ ッ ク し ます。

　 コ ンパイルエラーがあ る場合、 Transcript ウ ィ ン ド ウの当該ロ グが赤字表示にな り ます。 赤字行のど こ か
をダブルク リ ッ クする と、 別ウ ィ ン ド ウが開き （図 10-13 右） 、 エラーのよ り 詳細な理由がレポー ト されま 
すので、 参考にな り ます。

図 10-13. コ ンパイルエラーの詳細表示

　 Simulation Wizard 節でも記述し た とお り 、 VHDL でユーザ定義パッ ケージがあ り これを用いる場合は、 最 
初に （参照される他のソース フ ァ イルの前に） その定義フ ァ イルを コ ンパイルする必要があ り ます。 メ ニュー
から [Compile] → [Compile Order...] と選択する と表示される ウ ィ ン ド ウで、 コ ンパイルする フ ァ イル順を指 
定 ・ 変更でき ます。

　 なお、 コ ンパイルは ”Transcript” 枠に次のよ う にコマン ド を入力する こ と と 等価です。 以下の例 のよ う に 
<file_name> を複数列記 し て も 良いですが、 全ての RTL ソ ース フ ァ イ ルについて コ ンパ イ ルを行い ます。
<file_name> は作業フ ォルダー内に存在し ない場合は相対パス、絶対パスいずれかの表記を伴 う 記述と し ます。

　 Verilog ModelSim> vlog -work work <file_name> [<file_name>]

　 VHDL ModelSim> vcom -work work <file_name> [<file_name>]

10.3.5 シ ミ ュ レーシ ョ ンの初期化

　 次にシ ミ ュ レーシ ョ ンの初期化を行います。 ア イ コ ン を ク リ ッ クするか、 メ ニ ューバーで [Simulate]

→ [Start Simulation] を選択し ます。 ”Start Simulation” ウ ィ ン ド ウが表示されますので、 ”Design” タブで作業  
プロ ジェ ク ト のラ イブラ リ ー名 （デフ ォル ト ”work”） を展開し、 ト ッ プモジュール名＝テス ト ベンチ名を選
択し ます。 ”Type” カ ラ ム表示が Verilog では ”Module” （図 10-14 右例）、 VHDL では ”Entity” です。

　 ”Design” タブの次は ”Libraries” タブです。 「Search Libraries (-L)」 枠の右にあ る 『Add...』 ボタ ンを ク リ ッ  
クする と表示される ウ ィ ン ド ウ （図 10-15 中央） でターゲ ッ ト ・ デバイ スのラ イブラ リ ー名入力し て 『OK』 
ボタ ンを ク リ ッ ク し ます。 タ イプし始める と候補名が自動補間表示されます。 ラ イブラ リ ー名がわから ない
場合は第 10.6.1 項をご参照 く ださい。 或いは図 10-11 左図の下部にあ る [Library] タブを選択する と、 ツール 
にロード されている ラ イブラ リ ーの一覧が表示されていますので、 事前に確認でき ます。 ”ovi_” で始ま るの
が Verilog ラ イブラ リ ー、 ”ovi_” のないものが VHDL ラ イブラ リ ーです。
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図 10-14. シ ミ ュ レーシ ョ ンの初期化 １

　 ECP5 フ ァ ミ リ ーを ターゲ ッ ト と し て SERDES （PCS） が実装 さ れてい るデザ イ ンでは、 こ れに加えて
”pmi_work” と ”pscd_work” い う 名称のラ イブラ リ ーも必要です （第 10.5 節参照）。全てのラ イブラ リ ーを指定
し た ら、 『OK』 ボタ ンを ク リ ッ ク し て （図 10-15 右） 戻 り ます。

図 10-15. シ ミ ュ レーシ ョ ンの初期化 ２

　 なお、 この操作は ”Transcript” 枠に次のよ う にコマン ド を入力する こ と と等価です。 <TestBench_name> は
RTL 記述でのテス ト ベンチ名です。

　 ModelSim> vsim -L work -L ovi_machxo2 <TestBench_name> MachXO2 の場合

　 ModelSim> vsim -L work -L ovi_ecp5um -L pmi_work -L pcsd_work <TestBench_name> ECP5、 SERDES 有 り

図 10-16. シ ミ ュ レーシ ョ ン初期化後の表示例
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10.3.6 波形表示する信号の選択

　 シ ミ ュ レーシ ョ ンの初期化が問題な く 処理 さ れ る と、 初期表示は図 10-16 の よ う にな り ます。 まれに 
”Objects” 窓や ”Wave” 枠が表示されないこ と があ り ますが、 その場合は メ ニューバーでそれぞれ [View] →
[Objects]、 [View] → [Wave] を選択する と表示されます。

　 表示 （観測） する信号の指定方法は複数あ り ます。

図 10-17. ド ラ ッ グ＆ド ロ ッ プによ る表示波形の指定

　 ド ラ ッ グ＆ド ロ ッ プで行 う 場合 ( 図 10-17)、 ①最初に左側 ”Instance” 窓で対象信号を含むモジュール （エ 
ンテ ィ テ ィ ） を選択し、 ② ”Objects” 窓でオブジ ェ ク ト （信号名） を選択し、 ③選択し たオブジ ェ ク ト を
”Wave” 窓内に ド ラ ッ グ＆ド ロ ッ プし ます。 なお、 オブジェ ク ト と は、 Verilog ではポー ト および wire や reg
宣言されているネ ッ ト 、 VHDL ではポー ト および signal 宣言されているネ ッ ト （または ノード と呼ぶ） です。

　 別の指定方法では、 ア イ コ ン を用います。 ①左側 ”Instance” 窓で対象信号を含むモジ ュール （エンテ ィ
テ ィ ） を選択するか、 または ”Objects” 窓で対象信号を選択し （『Ctrl』 キーによ る複数選択も可）、 ②ア イ コ

ン を ク リ ッ ク し ます （図 10-18）。 ”Instance” の場合は、 選択されたモジュール （エンテ ィ テ ィ ） の全

オブジェ ク ト が追加される こ と にご留意 く だ さい。

図 10-18. ア イ コ ンによ る表示波形の指定例

　 これ以外の方法と し て、 ”Instance” 窓でモジュール （エンテ ィ テ ィ ） を選択し て メ ニ ューから [Add] → [To
Wave] → [All Items in region] を選択し た り 、 モジュール （エンテ ィ テ ィ ） を選択し てその上で右ク リ ッ クす   
る と表示される メ ニューで [Add to] → [Wave] → [All Items in region] を選択し ます。 モジ ュール （エンテ ィ
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テ ィ ） の全オブジェ ク ト が追加されます。

　 或いは ”Objects” 窓でオブジェ ク ト （複数可） を選択し、 その上で右ク リ ッ クする と表示される メ ニュー
で [Add to] → [Wave] → [Selected Signals] を選択し て も追加でき ます。

　 各信号 （オブジェ ク ト ） を ”Wave” ウ ィ ン ド ウに指定し終えた ら、 表示順を調整し ます。 ウ ィ ン ド ウ内で
変更する信号を選択し て ド ラ ッ グ＆ド ロ ッ プし ます。

　 なお、 この操作は ”Transcript” 枠に次のよ う にコマン ド を入力する こ と と等価です。 種々表示オプシ ョ ン
があ り ますが、 こ こ では割愛し ます （以下プロ ンプ ト の ”x” はコマン ド実行毎にイ ン ク リ メ ン ト する数字）。

　 VSIM x> add wave -noupdate /* テス ト ベンチ階層の全オブジェ ク ト

　 VSIM x> add wave -noupdate /<TestBench_name>/u_top/* テス ト ベンチ内イ ン ス タ ン ス u_top の全て

　 VSIM x> add wave -noupdate /<TestBench_name>/u_top/u_abc/nodex 　 　 イ ン ス タ ン ス u_abc の固有の信号

　 特定の複数オブジェ ク ト を指定する場合は、 全て三番目のよ う に与え る必要があ り ます。 通常、 波形表示
するオブジェ ク ト は多数にな り ます。 論理シ ミ ュ レーシ ョ ンは通常は繰 り 返し作業であ り 、 ”*” によ る指定
では順序や属性が制御でき ませんので、 ”DO” マ ク ロ を用いて実行する こ と が良 く 行われます。

　 ”Wave” ウ ィ ン ド ウでの表示波形 リ ス ト と順序 （および属性） が指定できた ら、 DO マ ク ロ と し て書き出し
てお く こ と を推奨し ます。 メ ニ ューから [File] → [Save Format...] と選択する と、”Save Format” ウ ィ ン ド ウが  
表示されます。 ”Pathname” セルにデ ィ レ ク ト リ とデフ ォル ト の DO マ ク ロ ・ フ ァ イル名がフ ィ ルされていま
すので、 適宜編集し て保存し ます。 次回以降は ”Transcript” 枠に次のよ う に入力する こ と で容易に波形表示
設定を再現でき ます （波形表示マ ク ロ をカレン ト ・ デ ィ レ ク ト リ に ”waves.do” と し て保存し た場合）。

　 VSIM x> do waves.do

10.3.7 シ ミ ュ レーシ ョ ンの実行

　 シ ミ ュ レーシ ョ ン実行は、 ツールバーの ”Run Length” セルに実行時間を単位と共に入力し て ア イ コ

ンを ク リ ッ ク し ます （図 10-19）。 これ以外にシ ミ ュ レーシ ョ ン実行関連ア イ コ ンは幾つかあ り 、 それぞれ以 
下のよ う な動作にな り ます。 シ ミ ュ レーシ ョ ン実行中は Break と Stop ア イ コ ンのみが有効です。

： Break （シ ミ ュ レーシ ョ ンを一時中断）

： Continue Run （中断し たシ ミ ュ レーシ ョ ンを再開）

： Run All （シ ミ ュ レーシ ョ ンをテス ト ベンチ記述の最後まで実行）

： Stop （シ ミ ュ レーシ ョ ン停止。 再開不可）

図 10-19. シ ミ ュ レーシ ョ ン実行

　 なお、 この操作は ”Transcript” 枠に次の例よ う なコマン ド を入力する こ と と同等です。

　 VSIM x> run 10 us 或いは

　 VSIM x> run -all など
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10.3.8 シ ミ ュ レーシ ョ ンの再実行

　 RTL ソース フ ァ イルの変更は一切な く 、 観測する波形の追加 ・ 削除や表示順の変更、 或いは表示属性 （2
進、 16 進など） や表示名のみを操作 ・ 編集する こ と は頻繁にあ り ます。 そのよ う な場合のシ ミ ュ レーシ ョ ン

再実行は、のよ う に行います。まず メ ニュー[Simulate] → [Restart...] を選択するか、ア イ コ ン を ク リ ッ ク

し ます。表示される ”Restart” ウ ィ ン ド ウで 『OK』 ボタ ンを ク リ ッ クする と、各ウ ィ ン ド ウがシ ミ ュ レーシ ョ
ン実行前の状態に更新されます ( 図 10-20)。

図 10-20. 波形表示のみを変更後のシ ミ ュ レーシ ョ ン再実行

　 RTL ソース フ ァ イルの追加 ・ 削除や記述の編集など、 何らかの変更があ る場合の再実行には、 一旦シ ミ ュ
レーシ ョ ン実行を終了し （第 10.3.9 項）、 ソース フ ァ イルの再コ ンパイル （第 10.3.4 項） から行います。

　 なお、 表示信号の属性変更は、 ”Wave” ウ ィ ン ド ウで当該信号を選択し て右ク リ ッ クする と 表示される メ
ニューから、 [Radix] などや [Properties...] を選択し て行います （16 進表記の指定は add wave コマン ド に - 
hexadecimal オプシ ョ ン指定でも可能です）。 また、 ”Wave” ウ ィ ン ド ウでの信号名は階層が深い と冗長にな り
ますので、 add wave コマン ド に -label オプシ ョ ンを追記し て表示名を指定でき ます。 また、 イ ン ス タ ン ス毎 
に分割表示する場合は、 メ ニュー [Add] → [To Wave] → [Divider...] と選択し てセパレータ行を追加し、 表示 
名を入力し ます。

　 再実行の操作は ”Transcript” 枠に次のよ う にコマン ド を入力する こ と と等価です。

　 VSIM x> restart 波形表示が変わら ない場合の再実行

　 VSIM x> restart -f -nowave 波形表示を変更し た後に再実行

10.3.9 シ ミ ュ レーシ ョ ンの終了

　 RTL ソース フ ァ イルの追加 ・ 削除や記述の編集など、 何らかの変更があ る場合のシ ミ ュ レーシ ョ ン再実行
には、 まず一旦シ ミ ュ レーシ ョ ンを終了し ます。 メ ニュー [Simulate] → [End Simulation] を選択し ます。

　 なお、 この操作は ”Transcript” 枠に次のよ う にコマン ド を入力する こ と と等価です。

　 　 VSIM x> quit -sim

　 ModelSim LE ではシ ミ ュ レーシ ョ ンの終了、 プロ ジェ ク ト のク ローズ （終了）、 そし て ModelSim LE のク  
ローズ （終了） を区別する必要があ り ます。 　 プロ ジェ ク ト の ク ローズは ”Transcript” 枠に次のコマン ド を
入力し ます。

　 　 VSIM x> project close

　 ModelSim LE の終了は、メ ニュー[File] → [Quit] を選択するか、”Transcript” 枠に次のコマン ド を入力し ます。

　 　 ModelSim > quit
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10.4 TCL ス ク リ プ ト によ る シ ミ ュ レーシ ョ ン実行
　 これまでに記述し た Simulation Wizard や GUI 起動後のマウ ス操作によ るシ ミ ュ レーシ ョ ンは、 簡易的に実 
行する場合は有用ですが、 やや煩雑な操作を伴います。 TCL ス ク リ プ ト （DO マ ク ロ） を用いた作業にする
と、 一連の操作の殆どを自動実行でき ます。 ユーザーが用意する ス ク リ プ ト の拡張子は任意ですが、 慣例的
に ”.do” と し ますので、 こ こ では ”DO マ ク ロ ” と呼びます。

10.4.1 ス ク リ プ ト の実行方法

　 既に DO マ ク ロが用意されていれば、 メ ニューから [Tools] → [Tcl] → [Execute Macro...] と選択し、 フ ァ イ 
ルブラ ウザーでフ ァ イルを選択後に 『開 く 』 を ク リ ッ ク し て実行でき ます （図 10-21）。

図 10-21. メ ニューからの DO マ ク ロの実行例

　 或いは ”Transcript” 枠にコマン ド入力する こ と でも実行でき ます。

　 　 ModelSim > cd <work_directory> まず DO マ ク ロのあ る作業デ ィ レ ク ト リ に移動

　 　 ModelSim > do init.do マ ク ロ ”init.do” を実行

　 作業デ ィ レ ク ト リ と は別の所に DO マ ク ロがあ る場合は、do コマン ド に続 く フ ァ イル名を相対パスや絶対
パス記述で指定し ます。 カ レ ン ト ・ デ ィ レ ク ト リ がど こ かを知 り たい場合は、 ”pwd” と 入力し ます （print
working directory）。

10.4.2 DO マ ク ロの典型的な記述例

　 こ こ での記述例に示す、 頻繁に用いる コマン ド の文法は、 前項で例示されている ものに相当し ます。 コマ
ン ド記述の順序 ・ 内容は、 概ね次のよ う にな り ます。 Simulation Wizard によ る シ ミ ュ レーシ ョ ンを実行する 
と、 そのフ ォルダーに拡張子 ”*.mdo” のテキス ト ・ フ ァ イルが生成されます。 これをガイ ド （参考） と し て
意図するプロジェ ク ト 用の DO マ ク ロ を作成する方法も あ り ます。

• マ ク ロ内で使用する変数の定義と新規プロ ジェ ク ト 作成

• RTL ソース フ ァ イルのイ ンポー ト

• RTL ソース フ ァ イルのコ ンパイル

• シ ミ ュ レーシ ョ ンの初期化

• 表示波形の指定

• シ ミ ュ レーシ ョ ン実行

　 マ ク ロ記述例です。 文頭は説明のための行番号 （マ ク ロ記述では不要）、 < > 印はユーザー固有の環境や名

称を意図し ています。 こ こ でのフ ァ イル名は例であ り 、 特に意味はあ り ません。
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1 # “init.do” コ メ ン ト 行は ”#” で始めます

2 set WORK_DIR C:/<work_directory> ” 作業デ ィ レ ク ト リ ” をマク ロ変数と し て定義し ます

3 set RTL_DIR C:/<RTL_source_directory> RTL ソースのあるデ ィ レ ク ト リ を変数と し て定義し ます

4 cd $WORK_DIR 作業デ ィ レ ク ト リ に ”Change Directory” で移動し ます

5 #

6 project new $WORK_DIR <project_name> 作業デ ィ レ ク ト リ に新規プロジ ェ ク ト を作成し ます

7 #

8 project addfile $RTL_DIR/jk.vhd 定義済み変数 RTL_DIR 下の VHDL ソースを イ ンポー ト し ます

9 project addfile $RTL_DIR/mn.v 同、 Verlog ソースを イ ンポー ト し ます

10 project addfile tb_zz.v カ レン ト （作業） デ ィ レ ク ト リ にあるテス ト ベンチを加えます

11 #

12 vlib work 作業ラ イブラ リ名を ”work” と し ます

13 vdel -lib work -all 念のため古い （前の作業時の） work ラ イブ ラ リ を削除し ます

14 vlib work 再度宣言し ます

15 #

16 # compile Verilog source files RTL ソースフ ァ イルのコ ンパイルです

17 vcom $RTL_DIR/jk.vhd VHDL ソースを コ ンパイルし ます

18 vlog $RTL_DIR/mn.v tb_zz.v Verilog ソース と テス ト ベンチを一緒にコ ンパイルし ます

19 #

20 # initialize simulation シ ミ ュ レーシ ョ ンを初期化し ます

21 vsim -L work -L ovi_machxo2 <tb_name> ターゲ ッ ト が MachXO2 の例です

22 #

23 # set up signals to display 表示波形の指定例です

24 add wave /<tb_name>/<instance_top_name>/* TB 内 DUT ト ッ プのイ ンス タ ンス下全オブジ ェ ク ト を追加

25 #do waves.do （該当時の例） 作業デ ィ レ ク ト リ にある波形表示指定のみの DO マク ロを実行

26 #

27 # run the simulation シ ミ ュ レーシ ョ ンを実行し ます

28 run 100 us 実行時間は 100us。 数値と単位の間にはスペースを入れます

　 以下に何点かコ メ ン ト を追記し ます。

8 ～ 10 行目 フ ァ イルのあ る フ ォルダー記述を伴 う 場合は、 相対パスか絶対パスで記述し ます

17 ～ 18 行目 同様です

21 行目 “-t” オプシ ョ ンで時間精度を指定する こ と があ り 得ます。遅延 （タ イ ミ ング） シ ミ ュ レー
シ ョ ンについては、 次項で追記し ます

25 行目 波形表示 DO マ ク ロについては、 次項で具体例を示し ます

4 ～ 12 行目 一度この DO マ ク ロ を実行し た後、繰 り 返し コ ンパイルから シ ミ ュ レーシ ョ ン実行まで行
う 場合に、 これら の行は不要です。 コ メ ン ト ア ウ ト し て別フ ァ イル と し て保存し、 それ
を繰 り 返し実行用 DO マ ク ロにする と便利です

　 なお、 各コマン ド に続 く オプシ ョ ンやフ ァ イル名などが長 く なる場合、 複数行に亘って記述する こ と も可
能です。 その場合は文末で改行する直前に ”\” 文字 （半角バッ ク ス ラ ッ シュ） を記述し ます。 この特殊文字
はコマン ド が次の行まで継続する こ と をツールに指示し ます。”\” 後は空白も何も付加し ないよ う にし ます。

　 繰 り 返し実行用 DO マ ク ロ を作成し て、これを実行する場合は ”Transcript” 枠で次のよ う に入力し ます（マ
ク ロ名を ”run.do” と し た場合の例）。

　 　 VSIM x> do run.do
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　 補足と し て、 ソース フ ァ イルを イ ンポー ト する と [Project] タブにフ ァ イルが リ ス ト されますが、 DO マ ク
ロの実行によ って コ ンパイルが成功し ている場合でも、 ”Status” カ ラ ムの記号は未コ ンパイル状態表示のま
まです ( 図 10-22)。しかし、”Transcript” 枠のロ グでエラー・ メ ッ セージが出ていなければ、問題はあ り ません。

図 10-22. DO マ ク ロによ る コ ンパイル ・ ステータ ス記号

10.4.3 波形表示 DO マ ク ロ

　 以下は波形表示 DO マ ク ロのご く 基本的な記述例です ：

1 add wave -noupdate /tb_lab/resetn

2 add wave -noupdate /tb_lab/clki

3 add wave -noupdate /tb_lab/dout

4 add wave -divider “u_ug_lab”

5 add wave -noupdate -label pll_lock /tb_lab/u_ug_lab/pll_lock

6 add wave -noupdate -label counter -hexadecimal /tb_lab/u_ug_lab/counter

　 以下に何点かコ メ ン ト を追記し ます。

1 ～ 3 行目 テス ト ベンチ直下の信号 resetn を表示、 等々

4 行目 波形の間にセパレータ行を挿入し、 次の行から続 く 信号のあ るモジ ュール名を明記

5 行目 表示名を短縮するために ”-label” オプシ ョ ンを使用し て表示名を指定

6 行目 -label オプシ ョ ン と共に、 -hexadecimal オプシ ョ ンで 16 進表記を指定

　 第 10.3.6 項で記述し た よ う な手順で波形表示 DO マ ク ロ を書き出し た場合は、 これをそのま ま用いるか、
これを編集し て使用する こ と にな り ます。

10.4.4 タ イ ミ ング ・ シ ミ ュ レーシ ョ ン

　 遅延付き タ イ ミ ング ・ シ ミ ュ レーシ ョ ンをする場合の初期化は、 以下のよ う にな り ます。 Diamond で生成
するネ ッ ト リ ス ト のシ ミ ュ レーシ ョ ン用 RTL （Verilog） を ”*.vo”、 その遅延フ ァ イルを ”*_vo.sdf” と し、 カ
レン ト （作業） デ ィ レ ク ト リ にコ ピーされている もの と仮定し ます。 *.vo/.sdf の生成方法については、 第 8
章をご参照 く ださい。

　 　 vsim -t 10ps -L ovi_machxo2 <tb_name> -sdfmax <dut_top>=<design_example>_vo.sdf

　 ”-t” は時間精度指定 （数値と単位の間にスペースな し）、 <tb_name> はテス ト ベンチ名、 -sdfmax は条件の 
指定（sdfmin/sdftyp/sdfmax のいずれか）、<dut_top> はテス ト ベンチでイ ン ス タ ン ス されている シ ミ ュ レーシ ョ
ン対象デザイ ンのイ ン ス タ ン ス名です。

　 なお、 タ イ ミ ング ・ シ ミ ュ レーシ ョ ンでコ ンパイルする RTL はテス ト ベンチ関連以外は唯一 ”*.vo” のみ
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です。 また、 *.vo/.sdf がカレ ン ト ・ デ ィ レ ク ト リ にない場合は、 相対 / 絶対パス記述を伴 う 指定にし ます。

10.5 PCS/SERDES のシ ミ ュ レーシ ョ ン
　 イ ンプ リ メ ンテーシ ョ ンで SERDES （PCS） を用いている場合のシ ミ ュ レーシ ョ ン実行について、 ECP5UM
ターゲ ッ ト を例にし て、 留意点を補足記述し ます。

　 ECP5 フ ァ ミ リ ーでは Clarity Designer で PCS モジュールを生成 ・ プラ ンニング し ますが、 リ セ ッ ト シーケ 
ン ス を実行する ソ フ ト ロジ ッ クのモジュール ”RSL” が必ず PCS と同時に生成されます（生成し ないオプシ ョ
ン も あ り ） 。 これは生成する （ ト ッ プ） モジ ュールの言語指定に拘わらず、 必ず Verilog で、 フ ァ イル名は
<PCS モジ ュール名 >_rsl.v です。 個の場合の RSL のコ ンパイル ・ コマン ド は以下のよ う にし ます。 リ セ ッ ト
シーケン スは実シ リ コ ンの動作と し ては数十 msec 以上の規定時間を待つためのカ ウ ン タが幾つか含まれて
います。 これらはシ ミ ュ レーシ ョ ン時間的には許容でき ない程度に長いため、 短縮するデ ィ レ ク テ ィ ブを明
示し ます。 二つの方法があ り ます。

　 ①コマン ド ラ イ ン （ス ク リ プ ト 内） ： vlog +define+RSL_SIM_MODE <WORK_DIR>/<PCS mod>_rsl.v

　 ②パラ メ ータ指定フ ァ イル等を用意し て ‘define RSL_SIM_MODE を記述

　 こ こ で、 <WORK_DIR> はス ク リ プ ト やコマン ド を実行する作業フ ォルダーからの相対パス、 或いはフルパ
ス指定です。 RSL 内記述は ”RSL_SIM_MODE” と い う パラ メ ータ定義があ る と短縮する動作になっています。

　 次に、シ ミ ュ レーシ ョ ン実行時のラ イブラ リ ー指定方法例です。<tb_top> はテス ト ベンチの ト ッ プモジュー
ル名を示すもの と し ます。 ECP5UM のデバイ ス内にあ るモジュール （マ ク ロ） の記述は全て Verilog ですの
で、 vsim コマン ド は次のよ う にな り ます。

　 　 VSIM x> vsim -L ovi_ecp5um -L pmi_work -L pcsd_work <tb_top>

10.6 シ ミ ュ レーシ ョ ン ・ ラ イブラ リ ー

10.6.1 ラ イブラ リ ー名

　 シ ミ ュ レーシ ョ ン初期化 （第 10.3.5 項など） において指定する ターゲ ッ ト ・ デバイ スのラ イブラ リ ー名は
表 10-2 の通 り です。

表 10-2. ラ イブラ リ ー名

デバイス Verilog ラ イブ ラ リー名 VHDL ラ イブ ラ リー名

MachXO2 ovi_machxo2 machxo2

MachXO3L, LF ovi_machxo3l machxo3l

MachXO3D ovi_machxo3d machxo3d

ECP5U ovi_ecp5u ecp5u

ECP5UM ovi_ecp5um ecp5um

Crosslink ovi_lifmd lifmd

Crosslink Plus ovi_lifmdf lifmdf

Mach-NX ovi_lfmnx lfmnx

10.6.2 VHDL のラ イブラ リ ー呼び出し記述

　 VHDL の RTL ソ ース フ ァ イ ル内では、 それぞれ冒頭で使用ラ イ ブ ラ リ ーを明記する必要があ り ます。
Simulation Wizard から シ ミ ュ レータ を起動する場合は必須ではあ り ません。

　 MachXO2 の場合の例を以下に示し ます。デバイ ス固有のマ ク ロ を イ ン ス タ ン スする場合は、必ず宣言する
必要があ り ます。 他のフ ァ ミ リ ーの場合も同様です。
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--VHDL 記述例 （合成対象のモジ ュール記述に含める場合）

-- synopsys translate_off

library MACHXO2;

use MACHXO2.components.all;

-- synopsys translate_on

　 また、 MachXO2/3 の EFB のよ う に、 Verilog ビヘービア記述のマ ク ロ ・ モジュールを呼び出す必要があ る
デザイ ンの場合は、 以下の Verilog ラ イブラ リ ーも含めます （MachXO2 の例）。

library ovi_machxo2;

use ovi_machxo2.all;

10.7 GSR/PUR のイ ン ス タ ン ス
　 MachXO2 など殆どのデバイ ス フ ァ ミ リ ーでは、 以下に示すデバイ ス初期化マ ク ロに相当する GSR （Global
Set/Reset） と PUR （Power-Up Reset） のイ ン ス タ ン ス記述を、 テス ト ベンチに含める必要があ り ます （コ ン 
パイルエラーが出なければ不要です）。特にイ ン ス タ ン ス名については、 こ この記述例の通 り でない と期待動
作し ません （エラーにな る） ので、 ご留意 く だ さい。

　 GSR の " リ セ ッ ト 信号名 " は実デザイ ンでの信号名です （有効極性は任意で、 ツールが自動判定し ます）。  
実装し ている特定デバイ スのマ ク ロ ・ モジュールによ っては リ セ ッ ト 信号ではな く 、 ”1’b1” とする必要があ
り ますので、 シ ミ ュ レーシ ョ ンで不可解な振る舞いが見られた場合は、 書き換えて試すこ と を推奨し ます。

// Verilog HDL 記述例 （テス ト ベンチ内）

PUR PUR_INST （1'b1） ;

GSR GSR_INST （< リ セ ッ ト 信号名 >） ; 問題がある場合は GSR_INST(1’b1) と記述変更し て試す

--VHDL 記述例 （テス ト ベンチ内）

-- コ ンポーネン ト 宣言部

COMPONENT GSR

　 PORT （ GSR: IN std_logic ） ;

END COMPONENT;

COMPONENT PUR

　 PORT （ PUR: IN std_logic ） ;

END COMPONENT;

…

Begin  -- モジュールボデ ィ 内

…

GSR_INST: GSR

  port map （ GSR => < リ セ ッ ト 信号名 >） ;

PUR_INST: PUR

  port map （ PUR => c_vcc ） ;

　 こ こ で、VHDL の場合、ECP5 以前のデバイ ス ・ フ ァ ミ リ ーではこ こに示す方法で問題あ り ませんが、ECP5 
と Crosslink フ ァ ミ リ ーでは VHDL の GSR/PUR プ リ ミ テ ィ ブがないため、 ラ イブラ リ ー宣言に留意する必要
があ り ます。 ECP5 の例を以下に示し ますが、 Verilog ラ イブラ リ の使用を追加する よ う にし ます。

library ovi_ecp5u;

use ovi_ecp5u.all;

　 なお、 GSR はどのデバイ スにも組み込まれているマ ク ロ （グ ローバル ・ バッ フ ァー） ですが、 PUR は実在
する訳ではな く 、 論理シ ミ ュ レーシ ョ ン用のみのマ ク ロです。

--- *** ---
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