
2021 年 12 月 Lattice Diamond 日本語ユーザーガイ ド

　

タ イ ミ ング解析ビ ュー
註 ： 本 Lattice Diamond 日本語マニュ アルは、 日本語によ る理解のため一助と し て提供し ています。 作成にあたっては各 ト ピ ッ クについて可能な限 り 正確を期し てお 

第 9 章 　 タ イ ミ ング解析ビ ュー （Timing Analysis View）

9.1 概要と起動
　 　 Lattice Diamond では静的タ イ ミ ング解析 （STA） の実行プロ グ ラ ムは TRACE と呼び、 タ イ ミ ング解析 
レポー ト を ”TRACE レポー ト ” と呼ぶ場合があ り ます。 従来のレポー ト は、 テキス ト や HTML 形式のため
（<proj_name>_<impl_name>.twr、 <proj_name>_<impl_name>_twr.html） 、 レポー ト の全容を確実に把握する こ と は、
規模の大きい回路実装ほど必ずし も容易ではあ り ませんでし た。

　 タ イ ミ ング解析ビ ューは、 タ イ ミ ング レポー ト を網羅的に、 かつ効率よ く レ ビ ューで き る表形式の GUI
ツールです。 特にパスの一覧と それぞれのパスに関する個々遅延エレ メ ン ト の遅延値、 起点と終点のク ロ ッ
ク遅延値など、視覚的にかつ直感的に把握する こ と を可能にし ます。また ソー ト （並び替え）機能も有用です。

　 また、 タ イ ミ ング解析ビ ューはフ ィ ジカル ・ ビ ューやフ ロ アプラ ン ・ ビ ューなど と の連携機能 （ク ロ スプ
ロービング） を備えています。 配置配線結果を踏まえた設計制約の妥当性の推敲やク リ テ ィ カルパスの特定
と、 第 16 章で記述する、 設計制約を編集 ・ 管理する ツールであ る スプレ ッ ド シー ト ・ ビ ュー （SSV） と の連
携を円滑に行 う こ と を可能にし ます。

　 付随する も う 一つの機能が ”TPF スプレ ッ ド シー ト ・ ビ ュー ” （第 9.6 節） で、 ウ ィ ン ド ウ表示自体は SSV
の簡易版です。 PAR プロセス を再実行せずに作成済ネ ッ ト リ ス ト に対し て、 LPF のタ イ ミ ング制約を変更し
た条件で静的タ イ ミ ング解析を実行し ます。制約変更の効果を短 TAT で予測し ますので、制約を推敲をする
際のベ－ス情報を得るために有用です。

　 タ イ ミ ング解析ビ ューの起動は、 Diamond ツールバーでア イ コ ン を ク リ ッ ク し ます ( 図 9-1)。 または

メ ニューバーの Tools から [Timing Analysis View] を選択し て も起動でき ます。 なお、 PAR （配置配線） まで  
完了し ていない と、 グレーア ウ ト し て起動でき ませんので、 ご注意 く ださい。

図 9-1. タ イ ミ ング解析ビ ューの起動

9.2 各ウ ィ ン ド ウのレ イ ア ウ ト と構成
　 起動する と タ イ ミ ング解析結果を自動的にロー ド し て立ち上が り ます。 初期画面をデタ ッ チする と 図 9-2 
のよ う になってお り 、デフ ォル ト では A から D の四つのウ ィ ン ド ウに分割されています。（デタ ッチ と ア タ ッ
チについては第 23.2.2 節をご参照下さい。）

　 A 左上部 ： グ ローバル設定と ス ト ラ テジー ・ オプシ ョ ンの関連項目 （Settings, Values） です

　 B 左下部 ： 設計制約 （Preference Name） ご と のレポー ト 項目一覧 （Preference Reports） 。 タ イ ミ ング違反  
（ネガテ ィ ブ ・ ス ラ ッ ク） があ る項目行は赤字で表示されます

　 C 右上部 ： パステーブル （Path Table）。 ス ラ ッ ク値で ソー ト されたパスのサマ リ 情報一覧です
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り ますが、 必ずし も網羅的あ るいは最新でない可能性や、 オ リ ジナル英語版オン ラ イ ンヘルプや各種ド キ ュ メ ン ト と不一致があ る可能性があ り 得ます。 疑義が生じ
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図 9-2. 初期表示例

　 D 右下部 ： 個々のパスの詳細遅延レポー ト です。 枠の下部に三つのタブがあ り 、 表示を切 り 替え られます

• 詳細パステーブル （Detailed Path Tables） ： 図 9-2 の表示はこの状態です。 デフ ォル ト で上部に三つの
タブが現れます

– データパス詳細 （Data Path Details）
– 起点ク ロ ッ ク遅延詳細 （Source Clock）
– 終点ク ロ ッ ク遅延詳細 （Destination Clock）

• パス接続図 （Schematic Path View） ～起点から終点までの リ ソース と遅延値を図示し た ものです

• レポー ト （Report: setup [hold]） ～ HTML 形式レポー ト です。 B 枠で選択する制約が ”setup” の場合は
タブ名が ”Report: setup” と な り 、 ”hold” が選択されている と タブ名は ”Report: hold” と表記されます。

　 図 9-2 の例では B 枠で制約レポー ト 項目が何も選択されていない状態のため、C 枠内と D 枠内の表示はブ 
ラ ン クになっています （レポー ト タブも名称は単純に ”Report” と い う 表記になっています）。

9.3 ク リ テ ィ カルパスの確認手順
　 タ イ ミ ングを満た さ ないパスや、 満た し ている ものの最も タ イ ミ ング ・ マージンの少ないパス （ク リ テ ィ
カルパス） を特定し、その遅延要素と値を解析するための、一般的な確認手順は次の通 り です。個々のステ ッ
プについては詳細を本節以降に記述し ます。

　 　 ステ ッ プ① ： B 枠 [Preference Name] で意図する制約項目を選択する

　 　 ステ ッ プ② ： 選択し た B 枠の制約項目にカバーされるバスが C 枠 [Path Table] に リ ス ト されるので、 そ 
の中で詳細に確認し たい、 いずれかのパス を選択する

　 　 ステ ッ プ③ ： 選択し た C 枠のパスに関する詳細遅延情報を D 枠 [Detailed Path Tables] で確認する

　 [Path Table] にレポー ト されるパスの本数は A 枠の項目 ”Worst-Case Paths” 値に従います （ス ト ラ テジー・  
オプシ ョ ンの一つ）。 また、 デフ ォル ト で [Path Table] 枠の リ ス ト 順序は ”Weighted Slack” 値で ソー ト されて  
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います。 すなわち、 ネガテ ィ ブ ・ ス ラ ッ ク （”Weighted Slack” セルが赤字） が大きい順序、 も し く はマージ 
ンの小さい順序で上から表示されます。

図 9-3. ク リ テ ィ カルパスの確認手順例

　 [Detailed Path Tables] 表示は、 図 9-2 に示すよ う に D 枠にあ る三つのタブの一つです。 また、 起動後の表   
示では図 9-4 の左にみられる よ う に、 各カ ラ ムの横幅が狭いため、 各セルの表示がフル名称にな り ませ

ん。 こ の場合はタ イ ミ ング解析ビ ューの左側にあ る ア イ コ ン列から を ク リ ッ クする こ と で、 自動的に
カ ラ ム幅調整が実行されて見やす く な り ます （図 9-4 内右）。

図 9-4. カ ラ ム幅自動調整 （Fit All Columns） 前後の例

9.4 タ イ ミ ング解析ビ ューのオプシ ョ ン変更
　 ビ ューを起動し た後に、解析オプシ ョ ンを変更する こ と ができ ます。 ビ ュー左側のア イ コ ン列から を

ク リ ッ クする と、 ”Settings” ウ ィ ン ド ウが表示されます。 または左上ウ ィ ン ド ウ [Settings] 内のど こかでダブ
ルク リ ッ ク し て も同様です。

　 ”Setting” ウ ィ ン ド ウは図 9-5 左側がデフ ォル ト 表示です。 ”Setup/Hold Performance Grade” は解析する ス   
ピード グレード指定です。プルダウ ンで変更でき ますが、特段の理由がない限 り は ”Default” のま まにし てお
き ます。 変更し た場合は、 ベス ト ケース （ホール ド側） やワース ト ケース （セ ッ ト ア ッ プ側） での解析では
な く 、 指定グレード のみでの解析にな り ます。

　 ”Report Style” もプルダウ ンから選択でき ます。 ”Worst-Case Paths” と ”Number of unconstrained paths” に
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は数値が入 り ます。それ以外はチェ ッ ク ボ ッ ク スが文頭にあ り 、チェ ッ ク印あ り がイネーブルを意味し ます。

図 9-5. オプシ ョ ン設定の変更例

9.4.1 パステーブル ・ ウ ィ ン ド ウ内の表示パス数

　 タ イ ミ ング解析ビ ュー起動時は図 9-6 のよ う になっています。 タ イ ミ ング解析ビ ュー左上枠の ”Settings” 
に表示されている ”Worst-Case Paths” の数値がパステーブル [Path Table] ウ ィ ン ド ウのレポー ト パス数にな  
り ます。 図 9-5 の左側はデフ ォル ト 値 10 です。 図 9-7 はオプシ ョ ン設定ウ ィ ン ド ウで図 9-5 右側のよ う に   
変更後の [Path Tables] ウ ィ ン ド ウの表示例 （一部） です。 パス数が変わっているのがわか り ます。

図 9-6. パステーブルの表示パス数オプシ ョ ン

図 9-7. レポー ト パス数の変更後の例

　 なお、タ イ ミ ング解析ビ ューは起動時にバッ ク グ ラ ン ド でそれぞれの制約項目について 30 本のパス まで解
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析し ています。 例えば、 デフ ォル ト の 10 から 30 までに変更し て も、 処理遅延を極小でレポー ト 表示を更新
でき る よ う にするためです。 仮に図 9-5 右の例のよ う に 30 以上にする と、 再度タ イ ミ ング解析処理が実行 
されますので、 特に大きなデザイ ンでは相応の処理時間が発生し ますので、 ご留意 く ださい。

9.4.2 未制約パスのレポー ト 指定

　 ”Number of unconstrained paths” （未制約パス） にも数値が入 り ます。デフ ォル ト では ”0” ですが、オプシ ョ   
ン設定ウ ィ ン ド ウで図 9-5 右側のよ う に値を指定し て イネーブルする と、 図 9-8 例のよ う にな り ます。

図 9-8. “Unconstrained Paths” 数値指定後の例

　 タ イ ミ ング解析ビ ューの左下ウ ィ ン ド ウ [Preference Name] にタブが二つあ り ます。”Preference Reports” は  
デフ ォル ト で表示される設計制約項目の リ ス ト ですが、 タブ ”Other Reports” に ”Unconstrained...” が四項目 
含まれて更新されます。 何れかを選択する と、 それに該当する 『未制約パス』 が [Path Table] ウ ィ ン ド ウに 
リ ス ト されます。 そのパス数がオプシ ョ ン設定で指定し た値に一致し ます。

　 なお、 全ての項目に対 し て該当す る パ ス が存在す る と は限 り ません。 デザ イ ン と 与え ら れた設計制約
（Timing Coverage） に依存し ます。 これは、 本来設計制約が与え られるべきパスが未制約で残っていないか 
ど う かを確認するための、 支援機能の一つです。

9.4.3 タ イ ミ ング解析ビ ューのオプシ ョ ン と ス ト ラ テジー設定

　 タ イ ミ ング解析ビ ューの各オプシ ョ ンは左上ウ ィ ン ド ウの [Settings] に表示されていますが、これはタ イ ミ
ング ・ レポー ト に関する ス ト ラ テジーのサブプロセス [Place & Route Trace] のオプシ ョ ン項目がそのま ま反   
映されています （図 9-9 橙枠） 。 タ イ ミ ング解析ビ ューを起動し た時に、 これらが反映された解析と レポー 
ト 表示が行われます。 ’Trace’ と は本章の冒頭で記述し た通 り STA を意味し ます。

図 9-9. 関連する ス ト ラ テジー ・ オプシ ョ ン項目
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　 タ イ ミ ング解析ビ ュー起動後に、 毎回その都度、 任意のオプシ ョ ン設定に変更する必要があ る よ う なケー
スでは、 あ らかじめス ト ラ テジー ・ オプシ ョ ンを所望の設定に変更し てお く こ と を推奨し ます。 毎回変更す
る手間と処理時間が省けます。

　 ただし、 ス ト ラ テジー ・ オプシ ョ ンを変更する際には留意が必要です。 変更する と、 そのオプシ ョ ンの該
当するプロセスやサブプロセスから再実行されます。 ”Place & Route Trace” であれはタ イ ミ ング解析 （STA）   
のみの再実行ですが、 ”Map Design” や ”Place & Route Design” のオプシ ョ ンを変更する と、 それぞれマ ッ ピ    
ング処理プロセス、 あ るいは配置配線処理プロセスからの再実行されます。

9.5 解析のための基本操作

9.5.1 設計制約項目の選択

　 ユーザーが与え る設計制約は基本的に全て LPF に記述されています。 タ イ ミ ング解析ビ ュー左下ウ ィ ン ド
ウの [Preference Name] には、 それら を ”Analysis Type” と し て ”setup” と ”hold” に分割し て リ ス ト し ます。 ま  
た、 これに加えてツールが自動的に抽出し た制約が存在すれば、 LPF にな く て も リ ス ト されます。 タ イ ミ ン
グ違反のあ る制約項目行は赤字で表示されます。 タ イ ミ ング違反が全 く 無ければ、 全て黒字です。

　 また、 デザイ ンや項目によ っては ”Analysis Type” に ”hold_window” が追加されます （図 9-10 例）。 これは  
” プロ ジェ ク ト で指定し たス ピード グレード に限定し てホール ド解析し た結果 ” を意味し ます。通常の ”hold”
はデフ ォル ト の解析対象であ る、 仮想最速ス ピード グレード ”M” に対し ての解析結果です。

図 9-10. ‘Preference Name‘ の リ ス ト と解析結果例

　 この リ ス ト の中から、 パステーブルで詳細を確認し たい制約項目を ク リ ッ ク し て選択し ます。

9.5.2 パステーブル と ソー ト 機能

　 パステーブルは Source、 Destination、 Weighted Slack、 Arrival、Required、 Data Delay、 Route %、Levels、 Clock   
Skew、 Setup/Hold の各項目 （カ ラ ム） が表形式でレポー ト されています ( 図 9-11)。 それぞれパス起点、 パ 
ス終点、 ス ラ ッ ク値、 パス遅延値、 許容される遅延値、 配線遅延の割合、 論理段数、 複数終点間のク ロ ッ ク
スキ ュー、 （FF の） セ ッ ト ア ッ プ / ホール ド要件、 を意味し ています。

図 9-11. パステーブルの表示例
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　 デフ ォル ト の リ ス ト 順序 ”Weighted Slack 値で ソー ト された ものです。 すなわち、 タ イ ミ ング違反があ る場 
合はネガテ ィ ブ ・ ス ラ ッ ク （”Weighted Slack” セルが赤字） が大きい順序、 も し く はタ イ ミ ング違反がない 
場合ではマージンの小さい順序で上から表示されます。

　 ソー ト 順を変更し たい場合、カ ラ ム最上位の項目名を ク リ ッ ク し ます。例えば ”Route %” 表記セルを ク リ ッ 
クする と、 配線遅延割合の昇順 （または降順） にパス表示が変更されます。 再度ク リ ッ クする と、 降順 （ま
たは昇順） が逆にな り ます。 また、 パステーブルが大きい場合などは、 ウ ィ ン ド ウ上部の ”Source Filter” や 
”Destination Filter” セルに何らかの文字を タ イプする と、 マ ッ チするパスのみがフ ィ ルタ されて表示されま 
す。 タ イプする一文字ご と、 直ちに不一致パスは除外されます。

　 パステーブルはタ イ ミ ング解析ビ ューの左端上にあ る ア イ コ ン を ク リ ッ クする と、 全カ ラ ムが表示

された状態にな り ます。 起動後では ”Source” や ”Destination” の階層表示のため、 殆どは全カ ラ ムが表示さ
れません。 ただし、 Source/Destination ノード名は一部の文字列しか表示でき ませんので、 再調整し ます。

9.5.3 詳細パステーブル

　 詳細パステーブル [Detailed Path Tables] には三つのテーブルがあ り ます （Data Path Details、 Source Clock、     
Destination Clock）。 デフ ォル ト ではこれらはタブで表示を切 り 替えて確認し ます ( 図 9-12)。

図 9-12. 詳細パステーブルの例

　 テーブルは遅延エレ メ ン ト が経路順に リ ス ト され、 エレ メ ン ト 名、 フ ァ ンア ウ ト 数、 遅延値、 起点 ・ 終点、
リ ソース名が示されます。 ”REG_DEL” はレジス タのク ロ ッ ク入力から Q 出力の遅延、 ”ROUTE” は配線遅
延、 ”CTOF_DEL” は LUT4 の遅延、 等々がわか り ます。 ”CTOF_DEL” にはこれ以外にも類似の名称が定義さ
れてます。

　 ク ロ ッ ク遅延テーブルは起点も終点も類似し ています。 図 9-13 は起点ク ロ ッ ク の例です。

図 9-13. 起点 ・ 終点ク ロ ッ ク遅延テーブル例

　 一般的に PLL を用いる こ と が少な く あ り ませんので、 この例のよ う にそれほど遅延エレ メ ン ト はあ り ませ
ん。 起点にし ろ終点にし ろ、 エレ メ ン ト が増え る と ク ロ ッ ク スキ ューの原因にな り 得ます。

　 詳細パステーブルの有用性の一つは、 特に遅延が大きい要因を探る上で、 従来のテキス ト や HTML 形式の
よ う にス ク ロールを何度も繰 り 返す必要な く 、 パステーブルで対象パス を選択し直すだけで多 く のパスに対
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し てレ ビ ューでき る こ と です。 例えば、 Fanout 数が想定以上に大き く ないか、 またはロ ジ ッ ク段数が多すぎ
ないか、 などが容易に把握でき ます。 Fanout 数が大きい と、 遅延も比例し て大き く な り ますし、 ロ ジ ッ ク段
数が多すぎ る と、 遅延要素 （エレ メ ン ト ） 数が多い こ と を意味し、 必然的に配線遅延も総じ て増大し ます。
一般的には設計制約やス ト ラ テジーで対処し ますが、 場合によ っては論理合成ツールへの制約が必要かも し
れませんし、 RTL 記述の修正が必要か と類推でき るかも しれません。

9.5.4 詳細パステーブル表示方法の切 り 替え

　 詳細データパス と起点 ・ 終点ク ロ ッ クの各表示は、 デフ ォル ト のタブ方式から同時表示にでき ます。

図 9-14. 詳細パステーブル表示 ： タブから スプ リ ッ タ

　 タブ方式から同時表示方式にするには、 図 9-14 のよ う にウ ィ ン ド ウのど こ かで右ク リ ッ クする と現れる 
小ウ ィ ン ド ウで [View with Splitters] を選択し ます。表示は図 9-15 のよ う に変わ り 、三つの領域に分割表示さ   
れます。 元の タ ブ方式に戻すには、 同様にウ ィ ン ド ウのど こ かで右 ク リ ッ クする と 現れる小ウ ィ ン ド ウ で
[View with Tabs] を選択し ます。

図 9-15. 詳細パステーブル表示 ： スプ リ ッ タから タブ

9.5.5 パス詳細図タブ と レポー ト タブ

　 タ イ ミ ング解析ビ ューの右下ウ ィ ン ド ウには、 パス詳細テーブル以外に、 パス詳細図と HTML レポー ト の
二つの表示機能があ り ます。

　 パス詳細図表示はウ ィ ン ド ウ下部の [Schematic Path View] タブを選択する こ と で、図 9-16 例のよ う に切 り   
替わ り ます。 [Detailed Path Tables] の表形式を図で置き換えた もので、 視覚的な理解の手助け と な り ます。 ク  
ロ ッ ク名、 ス ラ イ ス番号、 ネ ッ ト 名、 遅延値などが表示に含まれています。
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図 9-16. パス詳細図表示例

　 HTML レポー ト 表示はウ ィ ン ド ウ下部の [Report: <setup|hold>] タブを選択する こ と で、図 9-17 例のよ う に  
切 り 替わ り ます。 これは従来の HTML 形式レポー ト の中から、 選択し ているパスに該当する箇所を表示し て
います。

図 9-17. レポー ト 表示例

9.5.6 ク ロ スプロービング

　 パス情報に関し て視覚的な表示ツール と連携するのが、 ク ロ スプロービングです。 パステーブル内で確認
し たいパス を選択後右ク リ ッ クするか、 パス選択後に詳細パステーブル内のど こかを右ク リ ッ クする と表示
される メ ニュー窓で、 ”Show in” → “FloorPlan View” または ”Physical View” を選択し ます。 前者の例を図 9-      
18 に、 後者の例を図 9-19 に示し ます。 パス詳細図 （図 9-16） から も同様に呼び出すこ と ができ ます。

図 9-18. パステーブル内からの ク ロ スプロービング操作例

　 立ち上がったフ ロ アプラ ン ・ ビ ューの例を図 9-20 に、 フ ィ ジカル ・ ビ ューの例を図 9-21 に示し ます。
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図 9-19. 詳細パステーブル内からの ク ロ スプロービング操作例

　 フ ィ ジカル ・ ビ ューでは当該パスおよびネ ッ ト に対し て実際に使用されている配線 リ ソースが、 本ド キ ュ
メ ン ト ではやや判別しに く いですが、 黄色で表示されます。

図 9-20. 立ち上がったフ ロ アプラ ン ・ ビ ュー例

図 9-21. 立ち上がったフ ィ ジカル ・ ビ ュー例

　 他方、 フ ロ アプラ ン ・ ビ ューでは実配線ではな く 、 パスの経路で使用されているマ ク ロやス ラ イ ス間の論
理的な接続情報を結線し て折れ線表示し ます。 マウ ス を個々のマ ク ロ / ス ラ イ ス間の折れ線上に移動させる
と、 その折れ線の起点と終点のス ラ イ ス番号と そのポー ト 、 および遅延値がウ ィ ン ド ウの左下枠上に表示さ
れます。 いずれのビ ューの場合も、 想定以上に長い配線になっていないか、 などが容易に識別でき ます。
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9.5.7 詳細パス遅延データの csv フ ァ イルへの書き出し

　 図 9-3 のよ う に、 設計制約のいずれかが選択され、 パステーブルでいずれかのパスが選択されて、 詳細パ 
ステーブルにその詳細遅延データが表示されている状態で、そのパスデータについてcsvフ ァ イルに書き出す

こ と ができ ます。 タ イ ミ ング解析ビ ューの左端上部にあ る ア イ コ ン を ク リ ッ ク し ます。 またはデタ ッチ

し た状態で メ ニューバーから [File] → [Export] と選択し て も同じです。 全ての制約、 或いは全てのパスにつ
いて一度に書き出すこ と はでき ません。

9.6 TPF スプレ ッ ド シー ト ・ ビ ュー
　 TPF スプレ ッ ド シー ト ・ ビ ューは PAR プロセス を再実行せずに、 作成済ネ ッ ト リ ス ト に対し て静的タ イ ミ
ング解析を実行する機能です。

　 ユーザーの与え る設計制約は全て LPF 制約フ ァ イルに記述されています。LPF から タ イ ミ ングに関わる ア
イ テムのみを イ ンポー ト し、 修正し た ものを TPF フ ァ イルに一旦保存し ます。 タ イ ミ ング解析ビ ューは、 こ
の変更し た条件で作成済ネ ッ ト リ ス ト に対し て静的タ イ ミ ング解析を実行し ます。 TPF フ ァ イルは複数作成
でき ます。 また、 TPF から LPF に反映 （Export） させる こ と ができ ます。

　 留意すべきは、 この解析を元に LPF に遡って変更を与えた場合、 マ ッ ピングや配置配線結果のネ ッ ト リ ス
ト は修正前 と は異な る も のにな り ますので、 静的タ イ ミ ング解析結果も同一にはな ら ない と い う こ と です。
本機能はあ く まで設計制約を変更し た場合にど う なるかを予測し、 判断するためのベースにする機能です。

9.6.1 TPF フ ァ イルの作成と保存

　 まずタ イ ミ ング解析ビ ューのウ ィ ン ド ウ左端上にあ る ア イ コ ン を ク リ ッ ク し てビ ューを起動し ます。

タ イ ミ ング解析ビ ューをデタ ッチし た状態で、 メ ニューバーの [Edit] → [TPF Preferences...] を選択し て も起 
動でき ます （以降のステ ッ プでの操作上の都合で、 デタ ッチし てお く こ と を推奨し ます）。

　 起動する と、 図 9-22 のよ う にビ ュー下部にタブが三つあ り ます。 [Global Preferences] と [Group] タブの内  
容は一般的には変更せず、 主に [Timing Preferences] の制約値が変更の対象にな り ます。

図 9-22. 起動し た TPF スプレ ッ ド シー ト ・ ビ ューの例

　 まず通常のスプレ ッ ド シー ト ・ ビ ューと同様に意図する項目を変更し ます。 全ての変更が完了し た ら、 一
旦ウ ィ ン ド ウ を閉じ ます。その後 （タ イ ミ ング解析ビ ューをデタ ッチし て）、 メ ニューバーから [File] → [Save
Untitled As...] を選択し、 ポ ッ プア ッ プする ウ ィ ン ド ウでフ ァ イル名を入力し て保存し ます （図 9-23）。
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図 9-23. TPF フ ァ イルへの保存

　 保存し て も し ていな く て も、 その時点の該当する TPF フ ァ イル名は、 タ イ ミ ング解析ビ ューの最上部に表
示されていますので、 容易に識別でき ます （図 9-24）。 未保存の場合は ”Untitled” と表示されます。

図 9-24. 作業中の TPF フ ァ イル名表示

9.6.2 TPF での STA 再実行

　 次に変更後のタ イ ミ ング制約で STA を実行し ます。 タ イ ミ ング解析ビ ューのウ ィ ン ド ウ最左端のア イ コ ン

列から、 矢印が回転し ている ア イ コ ン を ク リ ッ ク し ます。 またはデタ ッチし た状態で メ ニューの [Edit]
→ [Update...] を選択し て も同じです。

　 STA 処理が再実行されて、 タ イ ミ ング解析ビ ューの各ウ ィ ン ド ウ内容が更新されます。

9.6.3 複数の TPF フ ァ イルの作成

　 場合によ っては異な る変更を別々に保持し ておきたいケースがあ り ます。その際は複数の TPF フ ァ イルを
作成し ておき ます。

図 9-25. 二回目以降の TPF フ ァ イル保存

　 図 9-22 のよ う にスプレ ッ ド シー ト ・ ビ ュー表示の状態で変更を加え、 一旦ウ ィ ン ド ウ を閉じ ます。 その
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後、 デタ ッチし た状態で メ ニュー [File] → [Save XXX.tpf As...] を選択し （図 9-25）、 ポ ッ プア ッ プする ウ ィ   
ン ド ウで保存フ ァ イル名を入力し ます。 こ こ で ’XXX’ は変更の元になったフ ァ イル名を意味し ます。

9.6.4 TPF から LPF への反映

　 TPF スプレ ッ ド シー ト ・ ビ ューの変更内容を通常のスプレ ッ ド シー ト ・ ビ ューに反映 （Export） する こ と
ができ ます。 まず TPF スプレ ッ ド シー ト ・ ビ ューで反映させる項目を選択し ます。 複数あ る場合は、 ’Ctrl’
キーを押し ながら全て選択し ます （図 9-26）。 そし て右ク リ ッ ク し て現れる メ ニューから ”Export to LPF” を   
選択し ます。

図 9-26. TPF から LPF への反映

　 する と通常のスプレ ッ ド シー ト ・ ビ ューが TPF の値を反映し た状態で立ち上が り ます。 未保存の状態を示
す 『＊』 印がスプレ ッ ド シー ト ・ ビ ュー ・ ウ ィ ン ド ウの左上端に表示されています。 当該イ ンプ リ メ ンテー
シ ョ ンでア ク テ ィ ブになっている LPF が元になっていますので、 そのま ま変更を受けて更新する場合は メ
ニューから File → Save XXX.lpf で保存し ます。別名で保存する場合は File → Save XXX.lpf As... で保存し ます。

9.6.5 編集後の TPF を元の LPF の値に戻す

　 種々検討を進めている と、 当初の LPF の値に戻し たいケースが生じ る こ と があ り ます。 その場合は、 デ
タ ッチし た状態で メ ニューから [File] → [Import] → [Copy LPF to TPF...] を選択し ます （図 9-27）。

図 9-27. LPF の TPF への取 り 込み

--- *** ---
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