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GUI カス タ マイズ

第 3 章 　 GUI カス タ マイズ
　 本章では Lattice Diamond Project Navigator の GUI のカス タマイ ズ方法や環境設定の方法について説明し ま   
す。 なお、 Lattice Diamond またはプロ ジェ ク ト ・ ナビゲータ （Project Navigator） と記述されている場合はど  
ち ら も Lattice Diamond Project Navigator を表すもの と し ます。

3.1 プロ ジェ ク ト ・ ナビゲータの構成 と各部の機能

3.1.1 プロ ジェ ク ト ・ ナビゲータの構成

　 本項では、 プロジェ ク ト ・ ナビゲータの基本的な構成や各ウ イ ン ド ウの名称等について説明し ます。 プロ
ジェ ク ト ・ ナビゲータは大き く 4 つのウ イ ン ド ウに分け られます （図 3-1）。

図 3-1. Lattice Diamond Project Navigator の構成

3.1.2 Menu and Toolbar エ リ ア

　 プロジェ ク ト ・ ナビゲータの最上段のエ リ アで、 プロ ジェ ク ト ・ ナビゲータの操作のための メ ニューバー
や、 各種ポイ ン ト ツールを起動するためのア イ コ ン等が配置されています。

Menu and Toolbarエリア

Output and Tcl Console エリア

Project Viewエリア

Tool Viewエリア
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3.1.3 Project View エ リ ア

　 Project View はプロジェ ク ト ・ナビゲータの中段左側のエ リ アで、主にプロ ジェ ク ト 管理に関わる ウ イ ン ド 
ウが配置されます。

File List ウイ ン ド ウ

プロジェ ク ト のイ ンプ リ メ ンテーシ ョ ンやイ ンポー ト し たデザイ ンフ ァ イル、制約フ ァ イル等が表示
される ウ イ ン ド ウです。

Process ウイ ン ド ウ

論理合成から配置配線までのプロセス フ ローと、 その実行状況を表示する ウ イ ン ド ウです。

Hierarchy ウイ ン ド ウ

[Generate Hierarchy] 機能で解析し たデザイ ンの階層構造を表示する ウ イ ン ド ウです。

3.1.4 Tool View エ リ ア

　 Tool View はプロ ジェ ク ト ・ナビゲータの中段右側のエ リ アで、Lattice Diamond 起動時に必要な情報を ま と  
めた [Start Page ウ イ ン ド ウ ]、 各種プロセスのレポー ト 等を表示する [Report ウ イ ン ド ウ ] のほかに起動し た 
各種ポイ ン ト ツール （テキス ト エデ ィ タや消費電力計算などの各種 GUI） 等が配置されます。 

図 3-2. Start Page ウ イ ン ド ウ

　 Start Page ウイ ン ド ウ

　 Start Page は Lattice Diamond 起動時に使用頻度の高い項目がま と めて表示されている ウ イ ン ド ウです。

• プロジェ ク ト の操作 メ ニュー （プロ ジェ ク ト の作成や open 等）

• Lattice Diamond のア ッ プデー ト 情報 （現行バージ ョ ン と ア ッ プデー ト 情報のチェ ッ ク日時）

• ユーザーガイ ドやチュー ト リ アル等の各種ド キ ュ メ ン ト への リ ン ク

　 Report ウイ ン ド ウ

　 プロジェ ク ト のサマ リ や実行し た各種プロセスのレポー ト が表示される ウ イ ン ド ウです。 レポー ト を表示
する イ ンプ リ メ ンテーシ ョ ンを タブで切 り 替え る こ と ができ ます。
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3.1.5 Output and Tcl console エ リ ア

　 プロジェ ク ト ・ ナビゲータのエ リ アで、 各種ロ グの表示や、 コマン ド ラ イ ンでプロセス を実行する際に使
用する [Tcl console] が配置されています。

3.2 各エ リ アのカ ス タマイ ズ

　 Lattice Diamond では、 エ リ アご と に表示方法等のカス タマイ ズが行え る よ う になっています。 本節では各 
エ リ アで可能なカ ス タマイ ズ内容と その方法について説明し ます。

3.2.1 Menu and Toolbar エ リ アのカス タマイ ズ

　 Menu and Toolbar エ リ アでは、 以下の内容についてカス タマイ ズする こ と ができ ます。

• Toolbar に表示する ア イ コ ンの選択

3.2.1.1 Toolbar に表示するアイ コ ンの選択

　 Menu and Toolbar エ リ アでは、 デフ ォル ト では全てのア イ コ ンが表示されていますが、 不要なア イ コ ンは  
非表示にする こ と ができ ます。 ア イ コ ンの表示／非表示切 り 替えは、 類似し た操作内容のグループご と に行
います。 メ ニューバーから [View] => [Toolbar] の順に選択する と表示される リ ス ト から、 グループ名を選択  
する と表示／非表示が切 り 替わ り ます。

図 3-3. Toolbar のア イ コ ン表示／非表示切 り 替え

　 表示される リ ス ト にチェ ッ クが入っている と、 そのグループは表示されている こ と を表し ます。 その状態
で リ ス ト から選択する と、 チェ ッ クが外れてア イ コ ンが非表示にな り ます。 リ ス ト のグループ名と対応する
ア イ コ ン と主な処理内容は図 3-4 および表 3-1 を参照し て く ださい。

図 3-4. リ ス ト のグループ名 と ア イ コ ンの対応

Tools

Process

Window Help

File Edit View
Project



JUG_D3.3GUI_v1.0 3-4

Lattice Diamond 日本語ユーザガイ ド

表 3-1. ア イ コ ンのグループの主な処理内容

3.2.2 Project View エ リ アのカス タマイ ズ

　 Project View エ リ アでは、 以下の内容についてカス タマイ ズする こ と ができ ます。

• ウ イ ン ド ウの表示／非表示切 り 替え

• ウ イ ン ド ウの多重／独立表示

• ウ イ ン ド ウのア タ ッチ／デタ ッチ

3.2.2.1 ウイ ン ド ウの表示／非表示切り替え

　 ウ イ ン ド ウ右上のボタ ン を ク リ ッ クする こ と でウ イ ン ド ウ を非表示にでき ます。 また、 メ ニ ューバー
から [View] => [Show Views] の順に選択する と現れる メ ニューで、表示／非表示を切 り 替え る こ と もでき ます   
（図 3-5）。

図 3-5. Project View エ リ アのウ イ ン ド ウ表示／非表示切 り 替え

　 リ ス ト には Project View エ リ ア と Output and Tcl console エ リ アのウ イ ン ド ウ名が表示され、 左側にチェ ッ    
ク マークが付いている ものが表示されている ウ イ ン ド ウです。 この メ ニュー上でウ イ ン ド ウ名を選択する と
ウ イ ン ド ウの表示／非表示が切 り 替わ り ます。

3.2.2.2 ウイ ン ド ウの多重／独立表示

　 Project View エ リ アのウ イ ン ド ウは、デフ ォル ト では多重し て表示されます。 これをエ リ ア内で独立し たウ 
イ ン ド ウ と し て表示させるには、 ウ イ ン ド ウのタ イ ト ルバーをつかんでエ リ ア内に ド ラ ッ グ し ます （エ リ ア
外に ド ラ ッ グ し た場合は 3.2.2.3 項参照）。 

グループ名 内 　 　 容

File フ ァ イルやプロジ ェ ク ト の open/close や保存関連のアイ コ ン

Edit テキス ト エデ ィ タや各種 GUI ツールの編集作業に使用するアイ コ ン （undo, redo 等）

View
Tool View エ リ アの特定ウイ ン ド ウの選択や、 GUI ツールの表示制御 （拡大、 縮小等）
に使用するアイ コ ン

Project Property ウイ ン ド ウの open やデバイス選択に使用するアイ コ ン

Process プロセスの実行や停止に使用するアイ コ ン

Tools 各種ポイ ン ト ツールを起動するアイ コ ン

Window Tool View エ リ アのウイ ン ド ウ表示カス タ マイズに使用するアイ コ ン

Help Lattice Diamond の update の有無を確認するアイ コ ン

Project Viewエリアの

ウインドウ
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図 3-6. Project View エ リ ア内での多重／独立表示の切 り 替え

Project View エ リ ア内で多重表示 Project View エ リ ア内で独立表示

　 ド ラ ッ グ し たウ イ ン ド ウの表示方法は、 ド ラ ッ グ されていないウ イ ン ド ウの表示で決ま り ます。 ウ イ ン ド
ウがエ リ ア内に ド ラ ッ グ される と、 ド ラ ッ グ されていないウ イ ン ド ウの周辺に空白が表示されます。 ド ラ ッ
グ されたウ イ ン ド ウはその空白部分に表示されます （図 3-7）。

図 3-7. 空白表示 と ウ イ ン ド ウの配置例

　 元の多重表示へ戻す場合は、 空白ができ ていない状態で ド ラ ッ グ し ます （図 3-8）。

空白

空白
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図 3-8. 多重表示へ戻す場合の例

　 Project View エ リ アの空白は、基本的に ド ラ ッ グ し て きたウ イ ン ド ウのあ る方向にでき ます。 ド ラ ッ グ し た 
ウ イ ン ド ウが Project View エ リ アの中心付近にあ る と、 空白はでき ません。

3.2.2.3 ウイ ン ド ウのア タ ッ チ／デタ ッ チ

　 Project View エ リ アのウ イ ン ド ウは、 デフ ォル ト ではプロ ジェ ク ト ・ ナビゲータに組み込まれた状態 （ア 
タ ッチ ： attach） になっていますが、 独立し たウ イ ン ド ウ （デタ ッチ ： detach） と し て表示させる こ と ができ
ます。 ア タ ッチされている ウ イ ン ド ウ をデタ ッチするには、 ウ イ ン ド ウのタ イ ト ルバーをつかんでエ リ ア外

に ド ラ ッ グするか、 ウ イ ン ド ウ右上にあ る  ア イ コ ンを ク リ ッ ク し ます。

図 3-9. ウ イ ン ド ウのア タ ッ チ とデタ ッチ

　 　 ア タ ッチ状態の File List ウ イ ン ド ウ デタ ッチ状態の File List ウ イ ン ド ウ

　 デタ ッチ状態のウ イ ン ド ウ をア タ ッチ状態に戻す場合は、 ウ イ ン ド ウのタ イ ト ルバーをつかんでエ リ ア内
に ド ラ ッ グ し ます。 ド ラ ッ グ されたウ イ ン ド ウは多重／独立表示切替え と同じで、 エ リ ア内の空白部分に配
置されます。

3.2.3 Tool View エ リ アのカス タマイ ズ

　 Tool View エ リ アでは、 以下の内容についてカス タマイ ズする こ と ができ ます。

• ウ イ ン ド ウの表示／非表示切 り 替え
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• ウ イ ン ド ウの分割表示と多重表示

• ウ イ ン ド ウのア タ ッチ／デタ ッチデタ ッチ

• レ イ ア ウ ト の保存と呼び出し

3.2.3.1 ウイ ン ド ウの表示／非表示切り替え

　 [Start Page] および [Report] ウ イ ン ド ウは、 プロ ジェ ク ト 作成時に自動的に表示されます。 その他のツール 
は メ ニューやア イ コ ンから起動する と Tool View エ リ アに表示されます。どのウ イ ン ド ウ も、ウ イ ン ド ウ右上

の ボタ ンか、 タブのウ イ ン ド ウ名の右側の ボタ ンを ク リ ッ クする と非表示にな り ます。

非表示にし た [Start Page] および [Report] ウ イ ン ド ウ を再度表示させるには、 メ ニ ューバーから [View] =>  
[Start Page] （または [Report]） の順に選択するか、 ツールバーから Start Page か Report ア イ コ ンを ク リ ッ ク  
し ます。

 Start Page  Report

3.2.3.2 ウイ ン ド ウの分割表示と多重表示

　 Tool View エ リ アのウ イ ン ド ウは、 デフ ォル ト では複数のウ イ ン ド ウが多重 （merge） されて表示されてい 
ます。この多重されたグループを Tab Group と呼びます。Tool view エ リ アに ２ つまで Tab Group を分割（split）   
する こ と ができ ます。

図 3-10. Tool View エ リ アでのウ イ ン ド ウ分割と マージ

マージ された状態 分割された状態

　 分割するには、 分割し たいウ イ ン ド ウのタブを選択し た状態で、 メ ニューバーから [Window] => [Split Tab

Group] の順に選択するか、 も し く はツールバーの ア イ コ ンを ク リ ッ ク し ます。

図 3-11. tab group の配置入れ替え例
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　 分割し たウ イ ン ド ウ を再度マージするには、 メ ニューバーから [Window] => [Merge Tab Group] の順に選択

するか、 も し く はツールバーの ア イ コ ンを ク リ ッ ク し ます。 2 つの tab group の配置を入れ替え る場合 
は、 メ ニューバーから [Window] => [Switch Tab Group position] の順に選択するか、 も し く はツールバーの

ア イ コ ンを ク リ ッ ク し ます。

　 Tool View エ リ アに 3 つ以上のウ イ ン ド ウが開いている場合、 分割された tab group 間を移動させる こ と も  
でき ます。 この場合は、 移動させたいウ イ ン ド ウ を選択し た状態で メ ニューバーから [Window] => [Move to

Another Tab Group] の順に選択するか、 も し く はツールバーの ア イ コ ンを ク リ ッ ク し ます。 また、 ウ イ  
ン ド ウの他の Tab Group に ド ラ ッ グする こ と でも移動させる こ と ができ ます。

3.2.3.3 ウイ ン ド ウのア タ ッ チ／デタ ッ チ

　 Tool View エ リ アのウ イ ン ド ウは、 デフ ォル ト ではプロ ジェ ク ト ・ ナビゲータに組み込まれた状態 （attach） 
になっていますが、 独立し たウ イ ン ド ウ （detach） と し て表示させる こ と ができ ます。 ア タ ッチされている

ウ イ ン ド ウ をデタ ッチするには、 ウ イ ン ド ウ右上の ア イ コ ンを ク リ ッ ク し ます。

図 3-12. ウ イ ン ド ウのア タ ッチ とデタ ッチ

ア タ ッチ状態のウ イ ン ド ウ デタ ッチ状態のウ イ ン ド ウ

　 個別にデタ ッチ状態のウ イ ン ド ウ をア タ ッチ状態に戻す場合は、 デタ ッチされている ウ イ ン ド ウ右上の

ア イ コ ンを ク リ ッ ク し ます。 Project View と は異な り 、 ウ イ ン ド ウ を ド ラ ッ グ し て も ア タ ッチ／デタ ッ 
チは切 り 替わ り ません。

　 デタ ッチされている ウ イ ン ド ウ全てをア タ ッチするには、メ ニ ューバーから [Window] => [Integrate all Tolls]

の順に選択するか、 ア イ コ ンを ク リ ッ ク し ます。 なお、 どち らの場合も Tool View エ リ アが分割されて 
いる場合は最後に ク リ ッ ク し たウ イ ン ド ウのあ る tab group にア タ ッチされます。

3.2.3.4 レ イアウ ト の保存と呼び出し

　 カ ス タマイ ズ し たウ イ ン ド ウのレ イ ア ウ ト を保存し、 必要に応じ て呼び出すこ と ができ ます。 カス タマイ
ズ し たレ イ ア ウ ト を保存するには、 適当なウ イ ン ド ウのレ イ ア ウ ト にし た状態で メ ニ ューバーから [Window]
=> [Save Layout] を選択し ます。 する と、 レ イ アウ ト 保存の設定ウ イ ン ド ウが起動し ます （図 3-13）。

　 [Name] 欄には、 保存する レ イ アウ ト 名を入力し ます。 この名称は、 後で呼び出す際に使用し ます。 ウ イ ン
ド ウの左下には [Launch view when loaded] チェ ッ ク ボ ッ ク スがあ り ます。 これにチェ ッ ク が入っている と、レ   
イ ア ウ ト を呼び出し た際に起動し ていないツールやウ イ ン ド ウがあった場合、 それら を自動的に起動し てレ
イ ア ウ ト を再現し ます。 チェ ッ クが入っていない場合は、 起動し ている ツールやウ イ ン ド ウだけでレ イ ア ウ
ト が再現されます。
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図 3-13. レ イ ア ウ ト 保存の設定ウ イ ン ド ウ

　 必要な部分の入力が完了し た ら ウ イ ン ド ウ右下の [OK] ボタ ンを ク リ ッ ク し ます。 保存し たレ イ ア ウ ト を
呼び出すには、 メ ニューバーから [Window] => [Manage Layout…] の順に選択し ます。 する と、 レ イ ア ウ ト の   
選択ウ イ ン ド ウが起動し ます （図 3-14） 。 ウ イ ン ド ウ左上には、 作成されたレ イ アウ ト 名の一覧が表示され 
ています。 こ の中か ら何かを選択する と、 ウ イ ン ド ウ左下にはレ イ ア ウ ト に含まれる ウ イ ン ド ウの一覧が、
ウ イ ン ド ウ右下にはレ イ ア ウ ト のイ メ ージが表示されます。

図 3-14. レ イ ア ウ ト 選択ウ イ ン ド ウ

　 レ イ ア ウ ト 名を選択し てウ イ ン ド ウ右上の [load] ボタ ンを ク リ ッ クする と、 保存し たレ イ ア ウ ト が再現さ
れます。 なお、 レ イ ア ウ ト を load し た際に起動し ている レ イ アウ ト に含まれないツールは閉じ られずそのま
ま残 り ます。

3.2.4 Output and Tcl console エ リ ア

　 Output and Tcl console エ リ アでは、 以下の内容についてカス タマイ ズする こ と ができ ます。

• ウ イ ン ド ウの表示／非表示切 り 替え

• ウ イ ン ド ウの多重／独立表示切 り 替え

• ウ イ ン ド ウのア タ ッチ／デタ ッチ
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• ステータ スバーの表示／非表示切 り 替え

3.2.4.1 ウイ ン ド ウの表示／非表示切り替え

　 不要な ウ イ ン ド ウ右上のボタ ン を ク リ ッ クする こ と でウ イ ン ド ウ を非表示にする こ と ができ ます。 ま
た、 メ ニューバーから [View] => [Show Views] の順に選択する と現れる メ ニ ューで、 表示／非表示を切 り 替え   
る こ と もでき ます （図 3-15）。

　 リ ス ト には Project View エ リ ア と Output and Tcl Console エ リ アのウ イ ン ド ウ名が表示され、左側にチェ ッ    
ク マークが付いている ものは、 表示されている ウ イ ン ド ウです。 この メ ニュー上でウ イ ン ド ウ名を選択する
と ウ イ ン ド ウの表示／非表示が切 り 替わ り ます。

図 3-15. Output and Tcl Console エ リ アのウ イ ン ド ウ表示／非表示切 り 替え

3.2.4.2 ウイ ン ド ウの多重／独立表示切り替え

　 Output and Tcl Console エ リ アのウ イ ン ド ウは、 デフ ォル ト では多重し て表示されます。 これをエ リ ア内で   
独立し たウ イ ン ド ウ と し て表示させるには、 ウ イ ン ド ウのタ イ ト ルバーをつかんでエ リ ア内に ド ラ ッ グ し ま
す （エ リ ア外に ド ラ ッ グ し た場合は 3.2.4.3 項参照）。

図 3-16. エ リ ア内での多重表示 と独立表示 ～ Output ウ イ ン ド ウの例

エ リ ア内で多重表示 エ リ ア内で独立表示

図 3-17. 空白表示 と ウ イ ン ド ウの配置例 1

Output and Tcl console
エリアのウインドウ

空白
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　 ド ラ ッ グ し たウ イ ン ド ウの表示方法は、 ド ラ ッ グ されていないウ イ ン ド ウの表示で決ま り ます。 ウ イ ン ド
ウがエ リ ア内に ド ラ ッ グ される と、 ド ラ ッ グ されていないウ イ ン ド ウの周辺に空白が表示されます。 ド ラ ッ
グ されたウ イ ン ド ウはその空白部分に表示されます （図 3-17、 図 3-18）。

図 3-18. 空白表示 と ウ イ ン ド ウの配置例 2

　 元の多重表示へ戻す場合は空白ができ ていない状態で ド ラ ッ グ し ます （図 3-19）。

図 3-19. 多重表示へ戻す場合の例

　 Output and Tcl Console エ リ アの空白は、 基本的に ド ラ ッ グ し て きたウ イ ン ド ウのあ る方向にでき ます。 ド   
ラ ッ グ し たウ イ ン ド ウがエ リ アの中心付近にあ る と、 空白はでき ません。

3.2.4.3 ウイ ン ド ウのア タ ッ チ／デタ ッ チ

　 Output and Tcl Console エ リ アのウ イ ン ド ウは、 デフ ォル ト ではプロ ジェ ク ト ・ ナビゲータに組み込まれた   
状態 （attach） になっていますが、 独立し たウ イ ン ド ウ （detach） と し て表示させる こ と ができ ます。 ア タ ッ

チされている ウ イ ン ド ウ をデタ ッチするには、 ウ イ ン ド ウの右上ア イ コ ン を ク リ ッ クするか、 ウ イ ン ド
ウのタ イ ト ルバーをつかんでエ リ ア外に ド ラ ッ グ し ます。

図 3-20. ウ イ ン ド ウのア タ ッチ とデタ ッチ

ア タ ッチ状態の Output ウ イ ン ド ウ デタ ッチ状態の Output ウ イ ン ド ウ

空白
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　 デタ ッチ状態のウ イ ン ド ウ をア タ ッチ状態に戻す場合は、 ウ イ ン ド ウのタ イ ト ルバーをつかんでエ リ ア内
に ド ラ ッ グ し ます。 ド ラ ッ グ されたウ イ ン ド ウは 3.2.4.2 項の多重／独立表示切替え と同じで、 エ リ ア内の空
白部分に配置されます。

3.2.4.4 ステータ スバーの表示／非表示切り替え

　 ウ イ ン ド ウ最下部にあ る ステータ スバーでは、 現在実行中のプロセスや メ モ リ の使用量が表示されます。

図 3-21. ステータ スバー

　 ステータ スバーはデフ ォル ト で表示されていますが、 これを非表示にする場合は メ ニューバーで [View] => 
[Status Bar] の順に選択し ます。 非表示の状態で再度同じ手順を行えば、 ステータ スバーが表示されます。

3.3 プロ ジェ ク ト ・ ナビゲータの環境設定

　 Lattice Diamond では、 ユーザが好みに合わせて環境設定ができ る よ う になっています。 メ ニ ューバーの 
[Tool] => [Options…] の順に選択する と開 く ウ イ ン ド ウ上で、[Environment] 以下の項目がプロ ジェ ク ト ・ナビ  
ゲータの環境設定です。

図 3-22. プロ ジェ ク ト ・ ナビゲータの環境設定



3-13 JUG_D3.3GUI_v1.0

GUI カス タ マイズ

　 なお、 このウ イ ン ド ウでは、 各種ツールの設定 （フ ォ ン ト や色設定） もでき ますが、 本節ではプロ ジェ ク
ト ・ ナビゲータの環境設定についてのみ説明し ます。 環境設定は、 大き く 以下の 5 項目に分かれています。

　 General : プロ ジェ ク ト ・ ナビゲータの全般的な設定

　 Startup : プロ ジェ ク ト ・ ナビゲータ を起動し た際の動作に関する設定

　 File Association : フ ァ イルの拡張子と、 それを開 く ツール （テキス ト エデ ィ タ等） の関連付け設定

　 Directories : 合成ツール と シ ミ ュ レータのフ ォルダ設定

　 Network Setting : ネ ッ ト ワーク接続 （プロ キシサーバ） の設定

3.3.1 General

　 General セ ク シ ョ ンでは主にプロジェ ク ト ・ ナビゲータの動作に関わる設定ができ ます。

Copy file to Implementation's Source Directory when adding existing file

既存のデザイ ンフ ァ イルをプロジェ ク ト にイ ンポー ト する方法のデフ ォル ト 値設定です（イ ンポー ト
の際に個別に選択する こ と もでき ます）。 チェ ッ クが入っている と、 デフ ォル ト が 「選択し たフ ァ イル
を イ ンプ リ メ ンテーシ ョ ン ・ フ ォルダにコ ピーし、 それを イ ンポー ト する」 設定にな り ます。 チェ ッ
クが入っていない と 「選択し たフ ァ イルを イ ンポー ト する」 設定にな り ます。

Archive all files under the Project Directory when archiving Project

フ ァ イル メ ニューから [Achieve Project] を実行し、 プロ ジェ ク ト を圧縮保存する場合の対象フ ァ イル 
の選択設定です。 チェ ッ ク が入っている と 、 当該プロ ジ ェ ク ト と の関連を問わずプロ ジ ェ ク ト フ ォル
ダ以下の全てのフ ァ イルおよびフ ォルダが圧縮されます。 チェ ッ ク が入っていない と、 当該プロ ジ ェ
ク ト に関連する フ ァ イルのみが圧縮されます。

Clear Output/Error/Warning window before running process

プロセス実行時の Output/Error/Warning ウ イ ン ド ウに関する設定です。 チェ ッ ク が入っている と プ
ロセス実行のたびに、以前の結果はク リ ア され新しい メ ッ セージのみが表示されます。チェ ッ ク が入っ
ていない と プロセス実行のたびに メ ッ セージが追記されていき ます。

Maximum items shown in Recent item lists （0~20）

Start Page に表示する Recent Project （最近開いたプロジェ ク ト ） の数の設定です。

Maximum number of implementation processes in run manager （1~32）

ラ ンマネージ ャで並列処理させる最大イ ンプ リ メ ンテーシ ョ ン数の設定です。使用する コ ンピ ュータ
の CPU コ ア数以下の値を設定する こ と を推奨し ます。

Maximum number of multi-par processes in run manager （1~32）

配置配線プロセスのス ト ラ テジ設定でマルチシード （Placement Iteration 値が 2 以上） 処理にし た場 
合、 ラ ンマネージャで並列処理させる最大数の設定です。 使用する コ ンピ ュータの CPU コ ア数以下の
値を設定する こ と を推奨し ます。

Accept message support agreement [View Agreement]

右の『View Agreement』を ク リ ッ クする と以下の様な メ ッ セージを表示し ます。許容する場合はチェ ッ 
ク マーク を入れます。

Lattice Semiconductor would like to collect data on what software messages are being generated for your               
design. This information is completely anonymous and only consists of program name generating the message,              
the message ID, and the number of times the message occurred. Allowing this data to be collected will allow                  
Lattice to better prioritize which messages need more content developed helping customers complete their             
designs easier and faster. Making checkbox "Accept message support agreement" be checked will allow this              
data to be collected.
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3.3.2 Startup

　 Startup セ ク シ ョ ンでは主にプロ ジェ ク ト ・ ナビゲータの起動時の設定ができ ます。

At Lattice Diamond Start up

メ ニューから、Lattice Diamond が起動し た際の振る舞いについて選択し ます。選択肢には以下の 3 つ 
があ り ます。

Open previous Project : 最後に開いたプロ ジェ ク ト を開き ます

Show Start Page : プロ ジェ ク ト が開かれず、 Start Page が表示されます

Start with New Project Wizard : 新しいプロ ジェ ク ト 作成ウ ィ ザード が起動し ます

図 3-23. Lattice Diamond 起動時の設定 ～ 起動時の表示設定

Automatic check software update when Lattice Diamond launches

Lattice Diamond は起動時に、 自動的にア ッ プデー ト の有無を検出する機能があ り ます。 この機能を 
有効にする場合はチェ ッ ク を入れます。 自動で検出させない場合はチェ ッ ク を外し ます （マニ ュ ア
ルでア ッ プデー ト のチェ ッ クはでき ます）。 チェ ッ ク を入れた場合は、 さ らに以下の 3 つから ア ッ プ
デー ト 検出の周期を選択し てチェ ッ ク を入れます。

　 Every time : 起動ご と に検出を行います

　 Daily : 毎日最初の起動時に検出を行います

　 Weekly : 毎週最初の起動時に検出を行います

Tool Startup as

各 Tool （のウ イ ン ド ウ） の起動時のア タ ッチ設定です。 Attached 欄にチェ ッ クが入っている と、 ツー
ルは [task and tool specific view] 内のパネル と し てア タ ッチされて起動し ます （図 3-24）。 チェ ッ ク が     
入っていない場合は、 独立し たウ イ ン ド ウ と し て起動し ます （図 3-25）。

図 3-24. Attached 欄にチェ ッ クが入っている場合 ～ パッ ケージ ・ ビ ューの例
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図 3-25. Attached 欄にチェ ッ クが入っていない場合 ～ パッ ケージ ・ ビ ューの例

　 ツールによ っては、 プロジェ ク ト ・ ナビゲータ を再起動し ない と設定が反映されないものがあ り ます。

3.3.3 File Associations

　 File Associations セ ク シ ョ ンでは、 各種フ ァ イル と それを開 く プロ グ ラ ムの関連付け設定を行います。 デ 
フ ォル ト では全て Lattice Diamond のプロ グ ラ ムが関連付け られていますが、テキス ト エデ ィ タ等は好みに応 
じ て常時使用し ている ものに変更する こ と ができ ます。 関連付けるプロ グ ラ ムを変更する場合は、 まず新し
いプロ グ ラ ムを登録する必要があ り ます。

　 新 し いプ ロ グ ラ ム を登録す る には、 まず関連付け を変更 し たい フ ァ イ ルの拡張子を選択 し た状態で、
External program for *** file extension 欄の Add ボタ ンを ク リ ッ ク し、 プロ グ ラ ムの追加ウ イ ン ド ウ を立ち上     
げます （意図する行の Default Program 欄を ク リ ッ ク し て ”Add Program ..” を選択し て も同様）。

図 3-26. 関連付けプロ グ ラ ムの追加

　 このウ イ ン ド ウの External Program 欄で追加し たいプロ グ ラ ムの実行フ ァ イル （*exe） を選択し、 Display 
Name 欄に Lattice Diamond 上での表示名を入力し ます。 Default Programs 欄を ク リ ッ クする と、 追加し たプロ  
グ ラ ムが表示されるので、 それを選択すれば関連付けが完了し ます （図 3-27）。
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図 3-27. 関連付けプロ グ ラ ムの選択

　 *****--------------------
• 関連付けプロ グ ラ ムの追加は、 拡張子ご と に行 う 必要があ り ます。 過去に追加し たプロ グ ラ ムの履歴
は External Program 欄の右側の▼ア イ コ ンを ク リ ッ クする と表示されます

　 *****--------------------

　 Argument 欄は、 プロ グ ラ ム （テキス ト エデ ィ タ） 起動時の引数の設定です。 デフ ォル ト ではエデ ィ タ起動
時にはフ ァ イル名のみが指定されていますが、 引数と し て行数の指定をサポー ト し ているエデ ィ タであれば
適当な設定を行 う こ と によ り 、 エラー メ ッ セージ等をダブルク リ ッ クする と問題の原因と なった行へカーソ
ルが飛ぶよ う にな り ます （行数指定な しだ と カーソルはフ ァ イルの先頭）。

3.3.4 Directories

　 Directories セ ク シ ョ ンでは、 論理合成ツールやシ ミ ュ レータのパス設定を行います。 バン ド ルされている
もの以外のバージ ョ ンを使用する場合等に設定を行います。

　 *****--------------------
• Synplify Pro はサポー ト し ていますが、 Synplify はサポー ト し ていません

• バン ド ル版でない Synplify Pro を使用する場合は、 UseOEM のチェ ッ ク を外し て く だ さい
　 *****--------------------

3.3.5 Network Settings

　 Lattice Diamond では、ア ッ プデー ト 情報の検出や IP コ アのダウ ン ロード等でネ ッ ト ワーク接続が必要にな 
り ます。 ネ ッ ト ワーク接続にプロ キシーサーバを使用し ている場合は、 このセ ク シ ョ ンでサーバ情報の設定
を行って く ださい。

3.4 レポー ト ・ メ ッ セージのカ ス タ ム化

　 Lattice Diamond では、 プロ ジェ ク ト ・ ナビゲータ内で表示する各プロセスでレポー ト される各種 メ ッ セー 
ジの表示に関し てカ ス タマイ ズ可能です。

　 ツールビ ュー ・ エ リ ア内の 「Design Summary」 に各プロセス毎のレポー ト を選択する枠があ り ます （図 3-  
28）。 最下段にあ る [Message] から [User Defined Filters] を選択後、 右の枠に表れる各 メ ッ セージに着目し ま  
す。 全てに メ ッ セージ ID 番号と その生成されたプロセス、 そし て メ ッ セージが一覧表示されます。 相当量の
ア イ テムが表示されますが、 殆どの場合は無視し て も構わない Warning が占める場合が少な く あ り ません。

　 こ のよ う な場合、 メ ッ セージ行を選択後右ク リ ッ ク し てア ク シ ョ ンを決定し ます。 例えば [Filter Message 
with This ID] を選択し た場合、 同一 ID の メ ッ セージは全てフ ィ ルタ リ ング されて非表示と な り ます。
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図 3-28. メ ッ セージの表示 と フ ィ ルタ リ ング設定

　 基本的な推奨設計フ ローと し てエラー メ ッ セージは勿論、 全ての Warning を確認し て無視でき るかど う か
を吟味する こ と が期待されます。 本機能はその作業を格段に効率化し ます。

　 メ ッ セージによ っては、 該当箇所 （フ ァ イル） を特定するためにテキス ト エデ ィ タにジ ャ ンプする こ と が
でき ます。 当該 メ ッ セージを選択後、 右ク リ ッ ク し て ”Text Editor” を選択し ます。 対象のフ ァ イルを表示し 
てエデ ィ タが立ち上が り ます。

図 3-29. メ ッ セージの該当箇所をエデ ィ タで リ ン ク表示
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3.5 改訂履歴

--- *** ---

Ver. Date page 内 　 容

2.3F June 30

3-2 ”Module Library / Dictionary ウ ィ ン ド ウ ” の記述削除

- 図 3-2 から図 3-5、 図 3-15、 図 3-22、 それぞれ差し替え更新

- 旧図 4-2 「HDL Diagram によ る構造解析」 削除

3.1
3-17 旧 3.4 節 「Lattice Diamond のア ッ プデー ト 」 を 1.7 節に移動

3-17 3.4 節 「レポー ト ・ メ ッ セージのカス タ ム化」 を追加

3.3 Mar.2015 --
一部の図を更新、 追加など。

3.3 節項目など内容を更新。
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