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・このマニュアルはispLEVERのオペレーションフローマニュアルです。

・簡単な回路図及びVHDLソースコードの作成からデバイスへのフィッティング、
波形シミュレーションまでの一連のフローを解説したものです。

・各項目の詳細については、別途ツール取り扱いマニュアルもしくは弊社技術
サポートまでお問い合わせください。

株式会社マクニカ
テクスター カンパニー
TEL：045-470-9841
lattice@macnica.co.jp

1. 1. はじめにはじめに
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Netlistをデバイス固有のcomponent
の形式に変換します。

デバイスに合わせて配置および配
線を行います。

汎用の論理合成ツールl又は
ispLEVER
に付属のOEM版論理構成ツールを使
用して論理合成を行います。

ispVM Syatemを使用しデバイスに書
き込みを行います。

Active-HDLまたはLattice専用波
形シミュレータを用いてFunction
シミュレーションを行います。

Active-HDLまたは、
Lattice専用波形シミュレータを
用いてTimingシミュレーションを
行います。

2. Lattice 2. Lattice ispisp LEVER Design FlowLEVER Design Flow
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◇ispLEVERを起動させます。
1. スタートメニューより、 [プログラム] → [Lattice Semiconductor] → [ispLEVER]を実行します。

2. [File]→[New Project]を選択して、新規プロジェクトを
作成します。

※新規以外のプロジェクトの場合は、Open Project を
選択してください。

デバイスの種類及び
設計ファイル

設計に対する
各種プロセスフロー

コンパイルログ及び
レポートファイル

Revision管理Tree

・右クリックでRevision管理をOn,Offできます。
・新しくコンパイルする度にRevisonが変わります
以前のRevisonに戻す際には該当するRevisonをハ
イライトさせて右クリックし、Set as Active Revisonを
クリックしてください。

Open Example を選択するとサンプルソースを
選択することが可能です。使い始めはこれを選択
して作業の流れを確認して頂く事も可能です。

New Projectを選択

3. ispLEVER3. ispLEVER起動起動
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◇新規プロジェクトの作成を行う前に、“新しいフォルダ”を必ず作成してください！

1. 任意のドライブを表示させ、フォルダの新規作成アイコンをクリックします。

※プロジェクト名には「日本語」を使用しないでください。 右図のようにプロジェク

ト名を“sample.syn”として、プロジェクトのタイプは“Schematic/VHDL”を選択し
てください（プロジェクトタイプはエントリー方法に応じてお選びください）

※プロジェクトフォルダの設定にはSchematicがございますがFPGAデバイスは
Schematicをサポートしておりません
※プロジェクトフォルダを配置する場所としてマイドキュメントやデスクトップを選

択しないで下さい（プロジェクトが保存されているパスに日本語や空白スペース

が入っていると問題になることがあります）。

②保存するロケーショ
ンを選択します。

⑤次へをクリック！！

①sampleと命名

③Schematic/VHDLを選択して下さい。
④論理合成ツールを
選択します。

3.1 3.1 新規プロジェクトの作成新規プロジェクトの作成

Design Entry Typeについて
Schematic/ABEL 回路図及びABELを用いたデザイン
Schematic/VHDL 回路図及びVHDLを用いたデザイン
VHDL VHDLを用いたデザイン
Schematic/Verilog HDL  回路図及びVerilog HDLを用いたデザイン
Verilog HDL Verilog HDLを用いたデザイン
EDIF EDIFを用いたデザイン
GDF GDFを用いたデザイン
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◇新規プロジェクトで用いるターゲットデバイスを選択します。

①デバイスファミリーの選択 ②デバイスの選択

③スピードグレードの選択

④温度グレードの選択

⑤パッケージタイプの選択

⑤次へをクリック

１．デバイスの情報を選択します。

２．元々あるソースをインポートします。
（必要なければしなくて良い）

①Add Sourceをクリック

②ソースを選択

③次へをクリック

３．完了をクリックします。

完了をクリック

プロジェクト情報
が表示

3.2 3.2 ターゲットデバイスの選択ターゲットデバイスの選択
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◇新規プロジェクトのエントリーをします(今回はVHDLで行ないます)

1. Project Navigatorから[Source]→[New]を選択します。 2. VHDL Moduleを選択し、OKをクリックします。

3. 表示されたダイアログボックスの各項目
を入力してOKをクリックします。

ABEL Test Vectors ABEL HDL のシミュレーション記述
ABEL HDL Module ABEL HDL のソース
User Document コメント等のオプション機能
Schematic 回路図エディタ
Waveform Stimulus 波形シミュレーション
Verilog Module Verilog HDL のソース
Verilog Test Fixture Verilog HDL のシミュレーション記述
VHDL Module VHDL のソース
VHDL Test Bench VHDL のシミュレーション記述
※選択できるファイルタイプは、プロジェクトタイプにより変わります。

新規作成時は[New]を選択して下さい。

既にソースが作成済みの場合は、
[Import…]を選択してください。

プロジェクトからソースを外したいときに
は[Remove]を選択してください。
※この作業ではフォルダ内からファイル
は削除されません。

VHDL Moduleを選択

※入力参考例
File Name ：counter
Entity ：counter
Architecture ：behavioral＊Importの場合は使用したいファイルを選択します。

3.3 3.3 デザインエントリーデザインエントリー
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◇ソースファイルを作成します(簡単な4ビットのアップ/ダウンカウンタを作成しましょう)
1.前ページで入力した項目が記載されたテキストエディタが開きます。
入力するサンプルソースは次ページ以降を参照してください。

Saveアイコンを選択
して保存してください

[File]→[Save]を選択
して保存してください

もしくはもしくは

3.4 VHDL3.4 VHDLソースの入力ソースの入力
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library ieee;
use ieee.std_logic_1164.all;
use ieee.std_logic_unsigned.all;

entity counter is
port( clk :in std_logic; --"port"でピン定義をします

rst :in std_logic;
c_en :in std_logic;
up_dw :in std_logic;
count :out std_logic_vector(3 downto 0));

end;

architecture behavioral of counter is --architecture以下にPLDの
--動作を記述します

signal n_count:std_logic_vector(3 downto 0); --内部ノードを設定します
begin

process(clk,rst)
begin

if(rst='1')then --リセット条件(High active)
n_count <= "0000";

elsif(clk 'event and clk ='1')then --クロックの立ち上がり動作
if (c_en = '1') then --クロックイネーブルで動作

if(up_dw ='1')then --アップ／ダウン信号で動作
n_count <= n_count + 1; --カウントアップ

elsif(up_dw ='0')then
n_count <= n_count - 1; --カウントダウン

end if;
end if;

end if;
end process;

count <= n_count; --ピンに出力します
end;

※入力が終了しましたら前ページを参考に保存して下さい。

3.4 3.4 サンプルソースサンプルソース(4bit(4bitアップダウンカウンタアップダウンカウンタ))
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◇前のページで作成したVHDLソースをトップの階層で回路図としてシンボル登録します
1. Project Navigatorから[Source]→[New]を選択します。 2. Schematicを選択し、OKをクリックします。

3.表示されたダイアログボックスのファイル
名を入力してOKをクリックします。

Schematic を選択

※今回は“top”と入力して下さい

4.以下のような回路図エディタが開きます。

Newを選択

既にソースが作成済みの場合の場合は、
[Import…]を選択してください。

3.5 3.5 回路図の作成回路図の作成①①((言語のみの設計の場合は言語のみの設計の場合は1616ページへページへ))



ispLEVER_ CLASIC Startup_for_MACH4000_Rev01.ppt     Page:  12
Sep. 2008

◇実際にシンボルブロックの登録作業を行ないます

1.メニューバーから[Add]→[New Block Symbol...]を選択します。

もしくはもしくは

アイコンを選択

2.以下のようなウィンドウが開きます。

ここをクリックすると、下図の
ようなウィンドウが開きます

プロジェクトフォルダ内にある
“counter.naf”を選択してOKをクリッ
クしてください。

3. VHDLソースで設計したモジュールの入出力
部分が各ボックスにインポートされてきます。

このダイアログはユーザー側で入力すること

も可能です。

※“*.naf”は、モジュールのI/F情報を含んだ
ファイルです。Runボタンをクリック！

[Add]→[New Block Symbol]
を選択してダイアログボック
スを開いてください

3.5 3.5 回路図の作成回路図の作成②②
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◇回路図エディタを使って回路設計を行ないます

1.前ページの方法で作ったシンボルがエディタ上に表示されます。 2.エディタでの作業に用いるツールバーの
説明を行ないます。ここでは今回の設計

に用いる操作のみを書きますので、詳細

については別途マニュアルを参照してく

ださい。

入力ピン 出力ピン

モジュール名

ツールバーが表示されていない場合、メ
ニューバーより[View]→[Drawing Toolbar]
を選択してください

今回は赤色で囲った部分のみの説明
をします

※Generate  Schematic Symbolを行うこと
でもシンボルを自動的に生成することも可能

です。

3.5 3.5 回路図の作成回路図の作成③③
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◇ツールバーの機能説明をします

1.ツールバーアイコンの各機能は以下の通りになります。

[Add Symbol]：ゲートやレジスタを
エディタ上に配置する際に選択します

このようなウィンドウが開きます。
ispM4Aシリーズの設計の場合には、
“Generic”ライブラリ及び“Vantis”マク
ロを選択して設計をしてください

[Add Wire]：配線する際に選択します

[Add Bus Tap]：バス信号の配線を
行う際に選択します

[Add Net Name]：信号名(I/Oピン)
及びネット名(内部ノード名)を付け
る際に選択します

[Delete]：消しゴムツールです

[Add Symbol Attribute]：シンボルに
アトリビュートを設定します。回路図
上でピン固定をする際に有効です

上図“Symbol Attribute Editor”が開きます。
このウィンドウ上で左図のようなI/Oパッ
ドのピン固定を行ないます。

[Add I/O Marker]：信号のモード(方
向)を設定します

※作成したシンボルはライブラリ
[Local]の中に保存されています

3.5  3.5  ツールバーの説明ツールバーの説明
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◇回路図作成作業を完了します
1.前ページで説明したツールバー機能を使って以下のように
設計を完成させます。

コンパイルのため、デバイス名
をハイライトします。

2.作成した回路図を保存し、エディタを閉じて
ください。

I/Oマーカーを忘れずに！

※ 回路図のみの設計を行ないたい場合には、ツール

バーより必要なゲートやレジスタを配置・配線して設

計を完了してください。

(回路図エディタのメニューアイコン) シートの移動

拡大
全体表示新規作成

シンボルエディット

シンボル作成

3.5 3.5 回路図の配線回路図の配線//信号名をつける信号名をつける((回路図設計の完了回路図設計の完了))

バス設定時は、バスの配線に
必ず名前をつけることに注意！
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◇ソースファイルをコンパイルします(ソースのチェックを行ないます)
1. Fit Designをダブルクリック。もしくはハイライト
表示して、Startボタンをクリックしてください。

※記述したソースに文法的な誤りがあるかどうかをチェックします。

※エラーが発生した場合はもう一度記述等を確認してください。

※文法エラーの場合は、ログのエラー勧告個所をダブルクリック

するとソース上のエラー個所にジャンプします。

2.コンパイルが始まります。

ダブルクリック！

右クリックで表示されるウィ
ンドウから[Start]を選択して
ください

もしくはもしくは

エラーがなければチェック
マークがつきますコンパイル成功です(エラーはありません)

コンパイル成功です(ワーニングがあります)

コンパイルエラーです(ログを確認して下さい)

(チェックマークの意味)

4. 4. コンパイル作業の開始コンパイル作業の開始

『Fit Design』により論理合成からFitting(書き込み用ファイル生成)まで完了します。
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１．Project NavigatorのPricesses for current source画面の『Synplify Synthesize VHDL File』
で論理合成を行えます。

4.1 4.1 論理合成ツール論理合成ツールについてについて

ダブルクリックした後、バックグランドでSynplifyが起動し論理合成を行います。
チェックがついたら論理合成は完了です。
記述ミスの場合はlogファイル内に赤字で表示されているエラーメッセージをダブルクリックすることで、
ソース内の該当箇所付近にとぶことが出来ます。

こちらをダブルクリックします。

※論理合成ツールはLattice社OEM版となっており、

選択したデバイスのアーキテクチャに最適な論理合成を提供致します。

※論理合成ツールは、単体での起動も可能です。

–Project Navigator画面のTools → Synplify

◇論理合成を行います。
Lattice社のispLEVERでは、Synplicity社の論理合成ツールSynplify proがバンドルされています。
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4.2. 4.2. 論理合成時のオプション設定について論理合成時のオプション設定について①①

ispLEVERのOptimization Constraintを
起動します。
Optimization Constraintで論理合成時の
オプション設定が可能です。

◇ 論理合成する前にオプション設定を行うことができます。
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4.2. 4.2. 論理合成時のオプション設定について論理合成時のオプション設定について②②

① Max_area
PT（プロダクトターム）の接続本数に制約をかけます。
数値を小さくするとPTの使用率が削減されますが、
Logic LEVELが増加しFmaxの特性が悪くなります。

② Logic_reduction (Yes / No)
冗長回路を削減し、インプリメントします。使用リソースの削減に効果が
あります。

③ Dt_synthesis (Yes / No)
D-FF、T-FFを使用し、積数項が最小になるようにインプリメントします。
使用リソースの削減に効果があります。"No"に設定した場合、D-FFの
みの使用となります。

④ Xor_synthesis (Yes / No)
マクロセル内のXORリソースを優先的に使用します。"No"の場合、積項
でXORを生成します。

⑤ Nodes_conllapse (Yes / No)
レジスタと出力ピン間の無駄なノードを削減し、Fmaxの向上、ロジック
リソースの削減を行います。 Node_collapsing_modeの設定によって論理
合成の結果が変わります。

⑥ Nodes_collapsing_mode (Speed / Area / Fmax)
Speed・・・設定された積項数の制限値までなら内部ノードを削減します。

Tpd、Tco、Fmaxが向上される傾向があります。
Area   ・・・ロジックリソース使用効率が向上されるように論理合成を行い

ます。リソース不足の際に効果がありますが、スピードの特性が
悪くなる傾向があります。

Fmax  ・・・⑦で設定されたロジックレベルに応じて論理合成を行います。

◇ 各項目で以下の設定を行うことができます。
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⑦ Fmax_logic_level
設定されたロジックレベルで論理合成を行います。ロジックレベルが大きく
なるとスピードの特性が悪くなります。(Nodes_collapsing_modeをFmaxに
設定した場合のみ有効）

⑧ Max_pterm_collapse
PTの接続本数制限を設定します。本数を増やすとマクロセルの使用率を
削減し、スピードを向上する傾向があります。(Nodes_collapsing_modeを
SpeedかAreaに設定した場合のみ有効)

⑨ Max_fanin
ノードの入力本数制限を設定します。本数を減らすとマクロセルの使用率、
スピード特性が共に悪くなる傾向があります。(Nodes_collapsing_modeを
SpeedかAreaに設定した場合のみ有効)

⑩ Max_pterm_split
PTの接続本数制限を設定します。制限本数を超えたPTに関しては別の
マクロセルに分割されます。(Nodes_collapsing_modeをSpeedかAreaに
設定した場合のみ有効)

⑪ Max_fanin_limit
ノードの入力本数制限を設定します。本数を減らすとマクロセルの使用率、
スピード特性が共に悪くなる傾向があります。(Nodes_collapsing_modeを
Fmaxに設定した場合のみ有効)

⑫ Max_pterm_limit
PTの接続本数制限を設定します。制限本数を超えたPTに関しては別の
マクロセルに分割されます。(Nodes_collapsing_modeをFmaxに設定した
場合のみ有効)

4.2. 4.2. 論理合成時のオプション設定について論理合成時のオプション設定について③③

◇ 各項目で以下の設定を行うことができます。
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⑬ Clock_enable_optimizations(Warp_all / Warp_all_opt / Keep_all /
Auto)
Warp_all ・・・CLK_ENをD入力ポートで生成します。
Warp_all_opt ・・・CLK_ENをD入力ポートに生成、もしくはD入力ポートに

最適化します。
Keep_all ・・・CLK_ENを保持します。
Auto ・・・CLK_ENの保持、最適化をツールが決定します。

⑭ Logic_optimization_effort
論理合成のレベルを設定します。数字を大きくするほど、内部ノードの削減が
見込めます。

4.2. 4.2. 論理合成時のオプション設定について論理合成時のオプション設定について④④

◇ 各項目で以下の設定を行うことができます。
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◇コンストレント・エディタを使ってピン固定を行ないます

1.デバイス名をハイライトして、画面右のConstraint Editorを
ダブルクリックしてください。

ダブルクリック！

デバイス名を
ハイライト

2.下のような画面が開いたら、アイコンメニューか
ら“Package View”を選択してください。

クリック！！

※ピン配置の方法※

１．右画面に信号名の一覧が表示されます。

２．配置したい信号をドラッグして、左画面の配置したい場所で

ドロップします。

３．配置が完了すると、左画面のピン位置に色がつきます。

入力ピン 双方向ピン出力ピン

（黄色） （ピンク）（青色）

5. 5. ピン固定ピン固定 (Package View(Package Viewを用いた設定を用いた設定))

ドラッグ＆ドロップします。
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◇メニューリストからLocation Assignmentを選択します

Location Assignment
を選択

Addをクリックして信号名をインポートします

信号がリストアップされます

良ければ“OK”をクリック

1．以下のようなウィンドウが開きます。

配置したい信号を
ハイライト

※ピン配置の修正・削除※

１．右図の最下部にあるウィンドウに表示された信号名をハイ
ライトした状態で、[Delete]を押せば信号を削除できます。

２．修正したい場合は、ハイライトした状態で[Modify]を押し、修
正後のピンを決定した後で[Update]を押してください。

削除 修正

5.1 5.1 ピン固定ピン固定 (Location Assignment(Location Assignmentを用いた設定を用いた設定))
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必ず[Apply]を押して下さい。

2. Backannotationタグにある[Pin Assignments]
にチェックをして[Apply] を押します。

3. Constraint Editorを開き(起動方法はP.18参照)、ピン番号が書かれている部分を
ハイライトもしくはダブルクリックして、固定したい番号を上書きします。

4. 割付したくないピンがある場合は、
右クリックで[Clear Selected]を選
択してください。

◇一度ピンフリーでコンパイルした結果を反映することが可能です
1. コンパイルが終了した段階で、[Tools]→

[Backannotate Project Assignment]を選
択して下さい。

[Backannotate Constraints..]を選択

「はい(Y)」を押して下さい。

ハイライトしてピン番号を上書き

“Pin Assignments” ⇒ピン配置のみを反映

“Pin and GLB Assignments”⇒ピン配置とGLBのアサインメントを反映

“Pin, GLB and Macrocell Assignments”

⇒ピン配置，GLBおよびマクロセルのアサインメントを反映

5.2 5.2 ピン固定ピン固定 (Compile(Compile後できる便利な設定後できる便利な設定))
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◇回路図エディタ上で実際にピンの配置を行います
1. I/Oパッドを用いてピン固定を行ないます。ツールバーより

[Edit Symbol Attribute]を選択して、ピンを固定したいI/O
パッドを選択してください。[Pin Number]という項目を選
択して固定したいピン番号を入力しウィンドウを閉じます。

I/Oパッドのボックス内に固定した
ピン番号が表示されます。

2.回路図エディタ上で固定したピンを実際のコンパ
イルに反映するためには、Project Navigator上で
以下のような設定を行なってください。

アトリビュートウィンドウ上で
[Pin Number]を選択して、ボック
スにピン番号を入力します。

[Tools]→[Import Source Constraint 
Option]を選択してください

チェックを付けてOKを選択することで、
回路図上で付加したアトリビュートを
コンパイル設定に反映することが可能
になります。

“Auto Import Source Constraints”

⇒確認のためのダイアログが表示されます。（デフォルト設定）

“Always Import Source Constraints”

⇒ソース式のコンストレイントをインポートします。※Constraint Editorの設定は反映されません。※

“Do Not Import Source Constraints”

⇒コンストレイント･エディタでの設定インポート。※ソース式のコンストレイントは反映されません。※

5.3 5.3 ピン固定ピン固定 ((回路図上での設定回路図上での設定))
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5.4. IO5.4. IOの詳細設定についての詳細設定について①①

①まず、ispLEVERのConstraint Editorを起動します。

②次に、 Global Constraintsを選択します。

◇IO周りの設定を行います。

以下の画面が表示されます。

※内部pull-up等の設定はCPLDの場合、
ピン毎ではなく、一括設定になることに
注意して下さい。
ただし、MACH4000ZEシリーズのみ、
ピン毎に設定することが可能です。
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① Pull (UP / DOWN / HOLD / OFF)
Pull UP       ・・・I/Oピンを内部Pull UPに設定します。
Pull DOWN ・・・I/Oピンを内部Pull DOWNに設定します。
Bus HOLD  ・・・I/Oピンを内部HOLDに設定します。最後の値が保持

されます。
OFF ・・・OFFに設定します。

※MACH4000ZEでは『Global Constraints』
ではPull設定項目は表示されません。
『Pin Attributes』シート内よりピン毎に設定を行います。
（資料内P.30～P.31『ピン属性の設定』をご覧下さい。）

② Security (ON / OFF)
書き込みデータの読み出しが出来ないようにセキュリティの設定をします。

③ Usercode
ユーザーコードをJEDECファイルに追加します。

④ Usercode_format (Hex / Bin / ASCII / Checksum)
ユーザーコードで使用するコード形式を設定します。

⑤ Balanced_partitioning (Yes / No)
デバイス内のパーテーションを設定します。有効の場合、設計回路の論理
合成がデバイスの一箇所に固まる事なく、効率のよい論理合成を行います。
デバイスの使用率が上がるとパーテーションに納まりきらずワーニングで
強制的にNoに変更されます。

⑥ Zero_hold_time (Yes / No)
入力レジスタにZero hold timeヒューズを設定します。入力レジスタのHold
が0になります。

◇ 各項目で以下の設定を行うことができます。

5.4. IO5.4. IOの詳細設定についての詳細設定について②②
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⑦ Auto_buffering_for_high_glb_fanin (ON / OFF)
自動バッファ追加の設定を行います。AND入力本数が制限値を超えた際
(GLBオーバー)にONに設定するとバッファを追加し、AND入力がGLBに
分散します。

⑧ Auto_buffering_for_low_bonded_io (ON / OFF)
自動バッファ追加の設定を行います。入力レジスタが一箇所のGLBに
固まっている際にONに設定するとバッファを追加し、入力レジスタを別の
GLBに分散させます。

⑨ Spread_placement (Yes / No)
論理合成時のデバイスへのリソースの分散を設定します。Yesの場合、
ロジックはデバイスに均等になるよう分散されます。またデバイスのFitting
率が向上します。Noの場合、ロジックは一箇所に固まり構成されるため、
スピードが向上します。

⑩ Max_macrocell_percent
論理合成時に使用するマクロセルの許容範囲を設定します。設定を超えた
場合はエラーが出ます。

⑪ Max_glb_input_percent
論理合成時に使用するGLBへの入力本数の許容範囲を設定します。

⑫ Fitter_effort_level (Low / Medium / High)
論理合成のレベルを設定します。Highに設定すると論理合成結果が向上
する事もあります。

◇ 各項目で以下の設定を行うことができます。

5.4. IO5.4. IOの詳細設定についての詳細設定について③③
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⑬ User_max_glb_fanin
GLBに入力出来る信号の最大数を設定します。

⑭ Adjust_input_assignments (ON / OFF)
GLBへの入力信号の分散を設定します。GLBへの入力本数が多い場合、
ONに設定すると固定されていない入力信号が別のGLBに分散されます。

⑮ Svf_erase_program_verify (ON / OFF)
SVFファイルにErase、Program、Verifyの設定を行います。JEDECファイル
生成時に生成されるSVFファイルに書き込みオペレーションを指定します。

⑯ Svf_erase_program_verify_secure (ON / OFF)
SVFファイルにErase、Program、Verify、Secureの設定を行います。JEDEC
ファイル生成時に生成されるSVFファイルに書き込みオペレーションを指定
します。

⑰ Svf_verify_only (ON / OFF)
SVFファイルにVerify onlyの設定を行います。JEDECファイル生成時に生成
されるSVFファイルに書き込みオペレーションを指定します。

◇ 各項目で以下の設定を行うことができます。

5.4. IO5.4. IOの詳細設定についての詳細設定について④④
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5.5.55. . ピンの属性の設定についてピンの属性の設定について①①

①まず、ispLEVERのConstraint Editorを起動します。

◇IOの属性設定を行います。

②次に、 PIN Attributesを選択します。
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5.5.55. . ピンの属性の設定についてピンの属性の設定について②②

◇この項目では以下の設定を行うことが可能です。

① Group Members ・・・ピンをグループ化させることが出来ます。
② GLB ・・・ピンフリーの際、ＧＬＢを指定することが出来ます。
③Macrocell ・・・ピンを設定するとマクロセルナンバーが表示されます。
④ Pin ・・・ピン番号を直接入力出来ます。
⑤ Bank ・・・バンクを指定出来ます。
⑥ IO Types ・・・Type IOレベルを決定することができます。
⑦ Pull ・・・MACH4000ZEでは、この項目によりピン毎にＵＰ/ＤＯＷＮ/ＨＯＬＤ/OFF

（プルアップ/プルダウン/前置保持/未設定）から選択出来ます。
※この設定はMACH4000ZEにだけ対応しています。

⑧ Slewrate ・・・スルーレートをFAST/SLOWから選択出来ます。
⑨ Input registers ・・・INREGを選択することで、マクロセルへの速い入力経路を設定できます。

これによりセットアップの時間を早く出来ます。

⑩ Register powerup ・・・NONE/RESET/SETから選択出来ます。
電源がONになったときに自動的にRESETやSETをかけることが出来ます。
ただし、電源の立ち上がり方等の条件によってはリセットされないことが
ありますので、必ず外部からリセットをかけれる構造をとることをお勧めします。
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◇ピン固定をした状態で再度コンパイルをしてレポートファイルを生成します

１．本資料16ページの要領で再度コンパイルをして下さい。

ダブルクリック！

2.コンパイルが終了後、
下図のようなHTML形式のレポートファイルが
開きます。コンテンツページにある項目をクリ

ックすることで該当するレポートが表示されま

す。デバック時などに有効になります。

コンテンツページ
レポートページ

※テキストベースのレポートの生成方法※

上図の説明にあるハイライト部分の上に、[Fitter Report]という
項目があります。こちらをダブルクリックしていただければ
Project Navigatorの最下部にレポートがテキストベースで表示
されます。

※信号名にもリンクが貼られて
いるため、デバッグ時には有効
なツールになります。

6. 6. 再コンパイルとレポートファイルの生成再コンパイルとレポートファイルの生成
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１．[Timing Analysis]をダブルクリックして下さい。

ダブルクリック！

fMAX ・・・クロック最大動作周波数
tSU/tH ・・・セットアップ/ホールドタイム
tPD ・・・TPD（ピン間の遅延時間）
tCO ・・・TCO（クロック to アウト）
tOE ・・・OE信号のタイミング（組み合わせOE)
tCOE ・・・OE信号のタイミング（クロックOE)
tP2P ・・・指定したピン間の遅延時間

製品グレード選択

２．[Performance Analyst]が起動します。

スピードグレード選択

タイミング解析結果

※タイミング解析ツールの優位点※

ispLEVERにバンドルされているタイミング解析ツールはスピー
ドグレードの異なる解析結果を再コンパイルすることなく表示
することができることにあります。是非お試しください。

Runボタンで解析スタート

7. 7. タイミング解析タイミング解析

ワースト値を表示

ワースパス
のDELAYを表示

◇タイミング解析を行います。
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◇最初にシミュレーションに用いる波形を作成します
1. Project Navigatorから[Source]→[New...]を選択します。続いて、
表示されたウィンドウから“Waveform Stimulus”を選択しクリッ
クします。

Newを選択

Waveform Stimulusを選択して
OKをクリック

デバイス名をハイライトして
OKをクリック

ファイル名に“test”と入力して
ください

※シミュレーションファイルの関連付けについて※

[Associate Waveform Stimulus]ウィンドウで、波形ファイルをデバイスに関
連付けすることによりタイミングシミュレーション(デバイス固有の遅延値を
含んだシミュレーション)も実行することが可能になります。ソース名に関連
付けをするとファンクションシミュレーション(ゲートレベルのシミュレーショ
ン)のみ実行可能になります。

8. 8. 波形シミュレーション波形シミュレーション①①
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◇ソースファイルから信号をインポートします

2. [Edit]→[Import Wave]を選択してソースファイルで
記述した信号をシミュレーターにインポートします。

ここを選択してください

表示したい信号を選択して“Add”
をクリックしてください。

選択が終わったら
“Show”をクリック！

1.トップソースをハイライトし、右ウインドに表示される
[Generate Schematic Symbol]を実行して下さい。
(※階層設計の場合、トップソースについてはモジュールのI/F部分を
管理している*.NAFファイルが自動生成されないため、上記作業によ

りファイルを生成する必要があります。下位階層のソース及びスタン

ドアローンで設計を行なっている場合にはこの作業は必要ありません)

8. 8. 波形シミュレーション波形シミュレーション②②
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◇信号をバスでまとめ、実際に波形を入力します
1. [Edit]→[New Wave]を選択して 入力信号をバスで

まとめます(入力バス化にはこの作業が必要です！！)。

ここを選択してください

信号の種類を選択してください

バスとしてまとめる際は、“count[3:0]”のように
記述して、“Add”をクリックしてください。

2.実際に波形を入力する際には、信号名をハイライト
(斜線が表示されます)して、必要なパルス幅の部分で
クリックします。すると、Selected Bit Pluseウィン
ドウに信号の極性と幅が表示されます。

クロックなどのパターンが連続す
る波形については、信号を選択し
てRepeatダイアログに数値を入力
してください。

8. 8. 波形シミュレーション波形シミュレーション③③
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◇それでは実際にシミュレーションをしてみましょう
1.シミュレーション波形ファイルをハイライトして右画面の

Function Simulationをダブルクリックしてください。

ダブルクリック！
波形ファイルを
ハイライト

2.下図のような画面が表示されたらアイコン “！”を
クリックしてください。

クリック！！

※シミュレーションには以下の2種類があります。

–Functional Simulation          →波形シミュレータが起動します

–Timing Simulation               →波形シミュレータが起動します

※プロジェクトのタイプによって表示されないものもあります。詳細については該当の各マニュア

ルを参照してください。また、上記波形シミュレーション以外(ActiveHDL)も使用可能ですが、

オペレーションについては別途マニュアルを参照してください。

シミュレーション結果の波形が表示されます

8. 8. 波形シミュレーション波形シミュレーション④④

※Functionalは論理レベルで早期に波形シミュレーション可能
Timing Simulationはfitting後遅延も考慮した波形シミュレーション可能
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◇表示されたシミュレーション結果を観察してみましょう(信号のバス化)
1. [Edit]→[Show]を選択して、“Show Waveform”という
ウィンドウを表示してください。

Showを選択してください ①AddNet(s)をクリック

②ShowBusをクリック

③Showをクリック

2.①②③の順番にボタンをクリックしてください。
[Save]を忘れずに。

出力バス化したい信号
を選択してください

選択したらクリック！

バス化された信号が
確認できます

上記ウィンドウ内の“D”とある部分ダブルクリックすると、内部の信号
(F/F、State-Machine等)を観察することができます。但し、内部の組み
合せ論理を観察することはできません。

⇒⇒

8. 8. 波形シミュレーション波形シミュレーション⑤⑤
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以上でispLEVER Clasic 1.2 Startup Manual for Mach 4000は終了です。

より詳細なお問合せ、ご質問等に関しましては、技術サポート貴社担当FAE
または下記技術サポート窓口までお気軽にお問い合わせ下さい。

株式会社 マクニカ テクスターカンパニー ラティス製品 技術サポート窓口
電話 045-470-9841/FAX 045-470-9844
Email lattice@macnica.co.jp
URL http://www.tecstar.macnica.co.jp/contact/index.html

9. 9. おわりにおわりに
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日付 Revision Old-page New-Page 変更内容の概要 更新担当者
2008/10/15 1.0 改訂版 高橋

10. Revision History10. Revision History
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