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® A—1—/\— Simulate > Start Simulation %3&iR
® [ Others ] #7 A " WLF File " IBBIZCTREEXRET7MILEZEIETE

Simulate  Add  Transcript

Madify, .

0 "IName |Value |O\rerride | | Add... |
'< a = | Dileke
e

Assertion

[ Disable PSL
[ Disable 5w

—Prafiler

[~ Enable assertion cover

I™ Enable memory profiing [" Enable assertion debug

Assert File
e | Wave ZIZEEEEMTHE

0-In Functional Yerification \

’7 ™ Enable 0-In CheckerWare
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WLF File
WIf 3
E\évj-\ Lo,)'gjii-fgbg\?t |7 |lngfcnmpare,fhase_sim Browse. .. |

QK Cancel

© Copyright ALTIMA Corporation & ELSENA Inc. 2013 - Official

10



A-2. HEBX{RDIIaL—3Y EISENA X
R EMEERER A

mO5-J74)L (\WIf) ZI85E
—FI#4)Lk: vsim.wif ABEE AR

DAL —Ya FETEIZ vsimwif T EEZEEENhEA. 77/ ILETRE
(51)

comp_sim.wif

—vsim v RETH
o-wif A7 3%
— vsim -wiIf A% -7 I)LA.WIf work. TR F-EDa1— )L A

w3im -wlf comp Sim.wlf work. Cest sm

© Copyright ALTIMA Corporation & ELSENA Inc. 2013 - Official 11



A-2. EBHNERDIZaL— 3y EISERA

faR BRI EERRE

~GUI ITTA T 3> %EN
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® [ Others ] #7 A " WLF File " IBBIZCTREEXRET7MILEZEIETE

Simulate  Add  Transcript

ALTIMA

X

Design ] WHDL ] Werilog ] Libraries ] SDF  Others I ﬂﬂ

Genetics{Paramel Ler

"IName |Value |Override | | Add... |

Modify...

[ ¥| _Delete
iCowerag —Assertion

I Enable code coverage [™ Disable PSL

—Profiler

[ Disable Swa

I Enable memary prafiing

" Enable assertion cove

[ Enable assertion deb

—WLF File

|:Assert File
‘| compare/conp_sim.wlf Browse..,

r0-In Functional Yerification \

Wave FICEFZEEMT HE
WIf 271IL B EIE R

I™ Enable 0-In Checker'Ware

\

WIf DILRFET
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'WLF File
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Browse, ., |

Ok Cancel
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A-3. Wizard DOERTE -E1T T D

BWizard THRI7MILZFEXTE

— AZ=a1—/\— Tools > Waveform
Compare ? Compilation Wizard %:#EiR

—- O - J7AILEIEE
®Reference Dataset: EH#¥O4-J74J)L
®Specify Dataset: B ZROT - T7AIL

x|
e step in creating a ~Reference Dataset
g = : :
T':":lls LEI_':."':lut EDkaarkE W|nd|:|W HEII:I e to Op::t, : et _compare/verilog/compare/base_sim.wlf !] Browse...

L r — - Test Dataset . N
ﬁ':ll"'l':h-lrr” L_ompare set can be a saved .wlf € Use Current Simulatic Eﬁ D 7 u 77/{}L

or a dataset that is already ¥ Update comparis

Code Coverage 5 Specify Dataset

. e Browse buttons to browse Impare/verilog/compare/comp_sim.wlf!] Browse. ..
Evrmcbimm sl T eversms aved dataset, or click the
lect a file from

lection history.
L »
HEBEXRAT -T74)L
Next > < Previous Cancel
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W R B R DR

Comparison Wizard 7 x|
With the reference and test ~| [ Comparison Method

datasets selected, the next ¢ Compare all Signals

step is to select a comparison

~
nethod. Compare Top Level Ports

" Specify Comparison by Signal
Compare All Signals - (" Specify Comparison by Region
compares all signals in the
test dataset against the
signals in the reference
dataset.

Compare Top Lewel Ports -
compares the top lewvel ports of
the selected datasets.

LE B 75 3K =

Compare All Signals EEDLIAL—LaBERICEFENESETDESZLLE
Compare Top Level Ports L EDR—rZLE
Soec . . 4>ZQDZ75\65§$RLT:1§%’EJ:|:$§
pecify Comparison by Signal Pi5 %A%
—I _\s‘
Specify Comparison by Region i?zf J vav () TH®
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— by Signal ZEREDFEIRIEHE

OLLEILI-LMEBZARIVAD) ARG ER

Comparison Wizard

Specify Comparison by Signal

This is the structure_browser
window, where you can specify the
signals to be used in the
comparison. Select a signal by
clicking with the left mouse
button; or, use 5hift-Click or
Control-Click to select multiple
signals.

Next > < Previous

M Instance

— addr
@ dat

— rd_

L wr_

i3
Cancel |
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— by Region ERFDER
®Structure Do FO i

il
Jn [
]

il

m' X Comparison Wizard 0 ]
izon by Region - ~Reference Region

lh ase_sim: /test_sm Browse... I

Reference Region -

This field allows you to ~Test Region
specify the reference region S : :
e AT he hsed 1o the [ Specify a different name For Test Region

comparison. You can type in the l
name of the region or use the
browser. ~Compare Signals of Type

vV In V out ¥ Inout :
Test Region - [V Recursive Search

Elicking the "Specifyia vV Internal vV Port
different name for Test Region™
box allows you to specify a L . = = e} . 1:
test region that might have a J:I:EX L/T-L\LE L] 0)9’(7 %Jg R
different name from that of the
;l reference region.

<] ] =l
T | = | Mext > < Previous Cancel I
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- Yes: P14 M ioR&EMNERTE Al e
-No: LHERETERET

x|
Click the Yes button and then Next Would you like to add more signals to the comparison?
to add more signals to the " Yes
comparison. ' No
Next = < Previous Cancel
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WK RS LB R AT
—“Compute Differences Now” 7R3>
—“Finish” R4~

Comparison Wizard

Click the button to compute the
differences.

@ O Il @ B

! L

Compute Differences Mow

Press Finish and proceed to the
Wave window where comparison

results are displayed.

Next > < Previous A
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> End Comparison %&E3R

Toole Layout Bookmarks 'Window Help

Code Coverage
Functional Coverage
Toggle Coverage
Coverage Save...

End Comparison #EELAWNVEE., 2aL—a FFH/EITTHE
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base sim.wlf

—vsim v RETH
o-wif A7 3%
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B-1. EED 3al—Ia R
R EERRTE ok
—- GUI [ZTH T av%Em

® A—1—/\— Simulate > Start Simulation %3&iR
® [ Others ] #7 A " WLF File " IBBIZCTREEXRET7MILEZEIETE

Simulate  Add  Transcript

x|
Design ] WHDL ] Werilog ] Libraries ] sD Cthers I 3]
Genetics/Parame ters
T‘IName |\n'alue |Override | | Add... |
Modify...
A il Delete
~Coverag iszerkion:
I Enable code coverage [ Disable PSL
I Disable S¥A

r~Prafiler

[~ Enable assertion cover

I™" Enable memary profiing [~ Enable assertion debug

e | Wave ZITEEEEMT 5L
/ "'D-In Functional Verification N W I f 77 /r } l/ 75‘\ g EJJ E E‘Z
I~ Enable 0-In Checkerware

YWLF File
WIf OEEFET {

= N |lngfcnmpare,fhase Sim Bru:uwse...|
B AL TL=SLy =

Cancel
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m\Wizard CTEEDOY - J7(ILZETE

— AZ=a—/\— Tools > Waveform
Compare ? Comparison Wizard #:&3R

—- O - J7AILEIEE
®Reference Dataset: EH#¥O4-J74J)L

Tools  Layout  Bookmarks  Window  Help

x|
Cade Coverage k
e - st step in creating a ~Reference Dataset
comparison is to open the _compare/verilog/coupare/base_sim.wlf !] Browse...
reference and test datasets (.wlf
=l ~Test Dataset s -
|}
ither dataset can be a saved .wlf % Use Current Simulation g& D 9_ 77’()b
file or a dataset that is already [V Update comparison STCEF ESCTTTON
opened.
" Specify Dataset
Use the Browse buttons to browse |
for a saved dataset, or click the

Update comparison after each run:
D2al—avFEERTTHUIC
HEEROEEICERN LEEETINET
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B-3. Wizard D& E -E1T
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Comparison Wizard

With the reference and test
datasets selected, the next
step is to select a comparison
nethod.

Compare &1l 5ignals -
compares all signals in the
test dataset against the
signals in the reference
dataset.

Compare Top Lewel Ports -
coupares the top lewel ports of
the selected datasets.

—Comparison Method
¢ Compare all Signals
(" Compare Top Level Ports
" Specify Comparison by Signal

(" Specify Comparison by Region

ALTIMA

B 75 ik B =

Compare All Signals

EEDL I — A AMERCATNLRTDIEEEILE

Compare Top Level Ports

LM DR—FZHER

Specify Comparison by Signal

AV RBI AMNGERLI-EBZLLER
P27 =58

Specify Comparison by Region

EIRLZ)—23) (BBE) THR
P28 &8
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— by Signal ZRFFDEIREHE
OLLELI-LMEBZ AV RIVAD AR GEIR

Comparison Wizard 3 x|
Specify Comparison by Signal |¥|Instance

This is the structure_browser _’ addr

window, where you can specify the _’ dat

signals to be used in the M’ o

comparison. Select a signal by =

clicking with the left mouse = wr_

button; or, use Shift-Click or
Control-Click to select multiple
sigmals.

<] | i3
Next > < Previous Cancel |
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— by Region ERFDL
®Structure VM ind
| structure_browseripd Comparison Wizard 8 x|

Y

il
Jn [
]

il

ify Comparison by Region o= ~Reference Region

Ibase_s im: /test_sm Browse. .. |

Reference Region -

This field allows you to ~Test Region
specify the reference region
tﬁat wgll he nsead 15 t.heg ™ Specify a different name for Test Region

comparison. You can type in the |
name of the region or use the

browser. ~Compare Signals of Type
Test Region - IV In V out [V InOut [V Recursive Search
Clicking the "Specify a IV Internal vV Port

different name for Test Region”
box allows you to specify a N R
test region that might have a 7 —[ V(=2 M
different name from that of the J:I:'EXL’T*L 1':_50)947 éﬁj:R
reference region.

- -
LI _>| Mext > < Previous Cancel |

Ok | Cancel |
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W LB R e 1R 3G E Al RE
- Yes: P26 i flikiE AN ek E AT &k
-No: LERETERTT

arison Wizard x|
Click the Yes button and then Next Would you like to add more signals to the comparison?
to add more signals to the " Yes
comparison. * No
Next = < Previous Cancel |
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B-3. Wizard OEE -ET

B LR ERT
—“Compute Differences Now” Ra>

— “Finish”

Comparison Wizard

Click the button to compute the
differences.

< Previous

R

x|

\—/ALTIMA

Compute Differences Now

© Copyright ALTIMA Corporati

Press Finish and proceed to the
Wave window where comparison
results are displayed.

18] Wave - Default

A compare:ftest_smj.

Now

Cursor 1

Msgs

2222222222222222. ..

750000ps |
749300 ps

< |

|«

[ lld 1 | B
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B-4. LEERDHE LB,

C J:l:$§%§%€5&"ﬁ2'@§ﬁ<
. ENELTLES
. EXNELGLER

[T wave - Default - i
- Msgs

B4 sim:ftest_sm/dat 2222222222222222, 1, {
o’ sim;: ftest_smfaddr 0000110011 -ZZ:I:Z:::: 0000010, /. J0000100... 0000 000 00010... 0... J0000110... J0O0OL10... J0000110...
< sim:ftest_smfrd_ St1 r | 7 il [ ki ; i [ l §
4 sim:ftest_smfwr_ Sti
o compare:ftest_sm/... |match
d:-4 base_sim:ftest_... |2zzzzz2222222222. .
ﬂ-‘-» sim:ftest_smfdat |zzzzzzzz22722222...
&-A compare:ftest_smf.., |match
-4 base_sim:ftest_,., |0000110011 00 00010... J0000100,., Jo000110.. .
=) < sim:ftest_smfaddr | 0000110011 0 L. 00 ::... l. 0 0000 000110...
<4 9] St0
[8] St0
[71 Sto
[6] 5t0
[5]
[4]
[3] Sto
[2] St0
[1] St1
[0] St1
A compare:ftest_smf... |match
A compare:ftest_smf... |match

tme Now geoopops |
mle Cursor 1 749300 ps

<« I ridd [ il 1 ] 1]

LN I N IS ¥
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B-6. RLLEDIET B

BRRLLE DR T
— A*Za—/\— Tools > Waveform Compare
> End Comparison %&E3R

Window Help

Start Comparisan.. .

Tools Layout Bookmarks

Way eform Com pare

3 - cormparison Wizard, .,
Code Coverage “

Functional Coverage
Toggle Coverage
Coverage Save...

End Compatison
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LB S R D RER LB,

B AR NS RER AT A
— Compare 12k

o FRHEN=T—3tvk: [WIf JPAILE] 2T
O LL B G R [compare] 47

LEEBREN =AMV REF AP =30 N AR T
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—Transcript D42 k™
e®Created # comparisons: Lb &R
®Found # Differences: MiER

# Created 4 compariszsons.

COLPAre rumn

# Computing waveform differences from time 0 ps to 750 ns
# Found 12 differences.

— Objects 12k
®Instance TEIRL-)—avVIZEFNBIES AR

| $a objects 5 Hd

]]II
S J

4

& base_sim - Default S i : ﬁ Objects X
Instance

-No Data- B A ¥addr<>addr¥

-No Data- A compare:ftest_sm/¥addr <>addr¥[:
-Mo Data- A compare:ftest_smi¥addr<>addr¥[’
Mo Data- A ¥addr<>addr¥

-Mo Data- A ¥rd_<>rd ¥

0000110011 4
zzzzzzzzezzez... ) 4
Skl 4

Skl 4 -No Data- A ¥rd_<srd ¥
-No Data- A For_<swr ¥

-Mo Data- A ¥or_<>wr ¥

»

»
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—Wave 42k

[T wave

2

e
ae

4
4

Lme
]

- Default -

ENELLES
ENELTSEHER

Msgs

sim:ftest_smjdat 0000000000000, . OH—5 D:D: (—O—C—0
sim:ftest_smfaddr  |0000110000 mmmj:):)@mmm@m (1000

sim:ftest_smjrd_

sim: ftest_smjwr_ L] | 1N

&+ compare:ftest_smf... [match : {3) :[D:):):: {13 N = — B B

-4 base_sim:{test_... |0000000000000. . 0 .:

B4 sim:ftest_sm{dat |000000000000O.., O—Tr- Cl—

B-A compare:jtest_smf... |match !:):]:J_D:D:)::):]:):):)
#14 base_simijtest_... |0000110000 m@—!ﬂ:ﬁ@mm}@@@
£5-4 sim:jtest_smfaddr |0000110000 o 000 Jpo00.._Jo0

-4 compareiftest_smf... |match f | [ —|

A compare:ftest_smf... |match

Cursor 1 298600 ps

5t1 1' | I
Sto ; L1

)
oo @ @ O G C ©

Mow 750000 ps

<

S I I [T
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FERRLR— DO 7 i

BEEREREZT XA ((txt)TH B

— A*Za—/\— Tools > Waveform Compare
> Differences > Write Report

@7 J4J)Lk: compare.txt

i Tools Layout Bookmarks Window Help
sacoero Loy 8] 63
) - LCOMparson yvizard,
Code Coverage L S
I Run Comparison A e ey
guncllzlozal Coverage : End Compparison S R % ot 3 .tXt w—ﬁlﬁﬁﬁ
cogqe ovserage Add N Total signals compared = 8
e s = Total primany differences = 6
Coverage Report Do Total secondary differences = 6
Coverage Configuration > Clear Murber of grirarny signals with differences = 2
Profile 4 l ¥ gh Oiff number 1, From time 171 ns delta 1 to time 191 ns delta 1.
Breakpaints. .. Rt i hasa_sim:/test_sm/dat = 0000000000000000000000001 (0101010
Dataset Snapshat. .. Relgad,.. sim:/test_smdat = QO0000000000000000000000T 01 01 011
— Oiff number 2, From time 171 ns delta 1 to time 191 ns delta 1.

base sim . test smAdat[0] = 510

sim: test_smdat[0] = 511

Oiff number 3, From time 171 ns delta 1 to time 191 ns delta 1.
base_sim. test_sm/dat = 00000000000000000000000C1 01 01 010
simtest_smdat = QO0000000000000000000000 01 & 011

Diff number 4, From time 171 ns delta 1 to time 191 ns delta 1.
base sim . test smAdat[0] = S0

sim: test_smdat[0] = 51

Diff number &, From time 409 ns delta 1 to time 411 ns delta 1.
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LETF—2DRE A,

BEEHERDO—FEICHE
~ HEESERFED)L—IL (.rul)
®Tools > Waveform Compare > Rules > Save
~- tHEFEATDT—4 (.dif)
®Tools > Waveform Compare > Differences
> Save

Toole Layout Bookmarks Window Help Toole Layout Bookmarks Window Help
Waveform Compare ;—ztart "Zrz.lrrxr.»-ari"orl‘ i : ;}" A Waveform Compare ‘%tart ':C.Irt'lgh_jﬂf‘.l:'rl. e l': o ﬁl J
e e LOMmpanson yvizar d,.. DS aE q Zomparison l"'_."ﬁf:_ﬂlj, e |
Gt Run Comparison B Ui ap SR s Run Comparison | i © i apil
Functional Coverage L4 A e Functional Coverage » ) b LG

End Comparison End Comparison
Toggle Coverage Toggle Coverage e[
Coverage Save... Add Coverage Save... Add ) R0 B
Coverage Report . Coverage Report .
5 A Options.., ) o Options...
Coverage Configuration Diff Coverage Conriguration Oiff
ifferences ifferences

Profile = Profile = =
Breakpoints... Breakpoints...

|_Dabacel Snanchab Dataset Snapshot...
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LeEfER D) O—k

WG RZTZBEO—~TOEE
- HEDOT-T74I)L (.wIf) ZBE<
® A= 1—/\— File > Open

~ g0 T - IJ74IL ((wIf) ZEE<
- B. DEBIIBEHYFEA
® A= 1—/\— File > Open

& comp_sim - Default -

Instance

(JOpen File § x|
’\;)\_} [ ~ Wolume (E?) ~ work ~ wave compare v verilog v compare ~ v & | compare(DiEF @
238 v HLOTALE - = v 0@

Q11 FUEL-%FIR
Quartus I Software_Perfect Course_

wave_compare
verilog

automation
basicSimulation
compare
k
il LT 2
27 AEN): |comp_sim,wlf L] ]Log Files (*.wif) _v_]

! base_sim

@ COMnp_sinm

B<(0) Frl
/4
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LESEEDYO—K oD,

—- HBREREDIL—ILEHEBERD I 74 ILERK
®Tools > Wave Compare > Reload %:&EiR
— HEEERTEDIL—IL-TF7AIL (.rul)
— MEEFRDT—%-774)L (.dif)

Tools Layout Bookmarks ‘Window Help Eij::j:'[’*‘”'ti EEEY
Start Comparison... B
Comparison Wizard. ..
< RumComparisan
Functional Coverage 4 Erd Compart
NaZomparison
Toggle Coverage | J—
Coverage Save... Add
Coverage Report ¥ I
~ PavT- : OPUOnS,
Coverage Configuration » DifF
-+ JITErENCES
Profile L] S cwe |
Breakpoints. .. q 0| & BRI TS
2 kp 5] base_sim | 4 & compare EEN K ¥] 3 (K] = ]

Mabacel Snand
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